import libuv-1.38.0-1.el8

This commit is contained in:
CentOS Sources 2020-07-28 04:13:01 -04:00 committed by Stepan Oksanichenko
parent 38645a3305
commit 58e97a8729
5 changed files with 109 additions and 3 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/libuv-v1.23.1.tar.gz
SOURCES/libuv-v1.38.0.tar.gz

View File

@ -1 +1 @@
394e088ff024e34bc4470e08a55e0eabe3209eae SOURCES/libuv-v1.23.1.tar.gz
ec045c2dfd29e1c6caab5886244fcb56a95b93f1 SOURCES/libuv-v1.38.0.tar.gz

View File

@ -0,0 +1,65 @@
diff --git a/Makefile.am b/Makefile.am
index d9d2f3d0..1d105806 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -254,7 +254,6 @@ test_run_tests_SOURCES = test/blackhole-server.c \
test/test-tcp-create-socket-early.c \
test/test-tcp-connect-error-after-write.c \
test/test-tcp-connect-error.c \
- test/test-tcp-connect-timeout.c \
test/test-tcp-connect6-error.c \
test/test-tcp-flags.c \
test/test-tcp-open.c \
@@ -288,8 +287,6 @@ test_run_tests_SOURCES = test/blackhole-server.c \
test/test-udp-ipv6.c \
test/test-udp-multicast-interface.c \
test/test-udp-multicast-interface6.c \
- test/test-udp-multicast-join.c \
- test/test-udp-multicast-join6.c \
test/test-udp-multicast-ttl.c \
test/test-udp-open.c \
test/test-udp-options.c \
diff --git a/test/test-list.h b/test/test-list.h
index 24a8a657..cb034076 100644
--- a/test/test-list.h
+++ b/test/test-list.h
@@ -126,7 +126,7 @@ TEST_DECLARE (tcp_bind_invalid_flags)
TEST_DECLARE (tcp_bind_writable_flags)
TEST_DECLARE (tcp_listen_without_bind)
TEST_DECLARE (tcp_connect_error_fault)
-TEST_DECLARE (tcp_connect_timeout)
+// TEST_DECLARE (tcp_connect_timeout)
TEST_DECLARE (tcp_close_while_connecting)
TEST_DECLARE (tcp_close)
TEST_DECLARE (tcp_close_reset_accepted)
@@ -162,8 +162,8 @@ TEST_DECLARE (udp_send_and_recv)
TEST_DECLARE (udp_send_hang_loop)
TEST_DECLARE (udp_send_immediate)
TEST_DECLARE (udp_send_unreachable)
-TEST_DECLARE (udp_multicast_join)
-TEST_DECLARE (udp_multicast_join6)
+// TEST_DECLARE (udp_multicast_join)
+// TEST_DECLARE (udp_multicast_join6)
TEST_DECLARE (udp_multicast_ttl)
TEST_DECLARE (udp_multicast_interface)
TEST_DECLARE (udp_multicast_interface6)
@@ -670,7 +670,7 @@ TASK_LIST_START
TEST_ENTRY (tcp_bind_writable_flags)
TEST_ENTRY (tcp_listen_without_bind)
TEST_ENTRY (tcp_connect_error_fault)
- TEST_ENTRY (tcp_connect_timeout)
+// TEST_ENTRY (tcp_connect_timeout)
TEST_ENTRY (tcp_close_while_connecting)
TEST_ENTRY (tcp_close)
TEST_ENTRY (tcp_close_reset_accepted)
@@ -717,8 +717,8 @@ TASK_LIST_START
TEST_ENTRY (udp_no_autobind)
TEST_ENTRY (udp_multicast_interface)
TEST_ENTRY (udp_multicast_interface6)
- TEST_ENTRY (udp_multicast_join)
- TEST_ENTRY (udp_multicast_join6)
+// TEST_ENTRY (udp_multicast_join)
+// TEST_ENTRY (udp_multicast_join6)
TEST_ENTRY (udp_multicast_ttl)
TEST_ENTRY (udp_try_send)

6
SOURCES/libuv.abignore Normal file
View File

@ -0,0 +1,6 @@
[suppress_function]
symbol_name_regexp = ^uv__.*
[suppress_function]
symbol_name_regexp = .*
change_kind = added-function

View File

@ -1,6 +1,11 @@
# Some of the tests do not work with the network-free environment in Koji
# The packager should run `fedpkg local --with tests` on their machine
# before pushing to Koji
%bcond_with tests
Name: libuv
Epoch: 1
Version: 1.23.1
Version: 1.38.0
Release: 1%{?dist}
Summary: Platform layer for node.js
@ -9,10 +14,18 @@ License: MIT and BSD and ISC
URL: http://libuv.org/
Source0: http://dist.libuv.org/dist/v%{version}/libuv-v%{version}.tar.gz
Source2: %{name}.pc.in
Source3: libuv.abignore
BuildRequires: autoconf automake libtool
BuildRequires: gcc
%if %{with tests}
# don't remove network tests
%else
# -- Patches -- #
Patch1: 0001-Disable-failing-network-tests.patch
%endif
%description
libuv is a new platform layer for Node. Its purpose is to abstract IOCP on
Windows and libev on Unix systems. We intend to eventually contain all platform
@ -32,6 +45,7 @@ Requires: %{name}-devel%{?_isa} = %{epoch}:%{version}-%{release}
%description static
Static library (.a) version of libuv.
%prep
%autosetup -n %{name}-v%{version} -p1
@ -44,12 +58,17 @@ Static library (.a) version of libuv.
%make_install
rm -f %{buildroot}%{_libdir}/libuv.la
mkdir -p %{buildroot}%{_libdir}/libuv/
install -Dm0644 -t %{buildroot}%{_libdir}/libuv/ %{SOURCE3}
%check
# Tests are currently disabled because some require network access
# Working with upstream to split these out
#./run-tests
#./run-benchmarks
make check
%ldconfig_scriptlets
%files
@ -57,6 +76,7 @@ rm -f %{buildroot}%{_libdir}/libuv.la
%doc ChangeLog
%license LICENSE
%{_libdir}/%{name}.so.*
%{_libdir}/libuv/libuv.abignore
%files devel
%{_libdir}/%{name}.so
@ -68,6 +88,21 @@ rm -f %{buildroot}%{_libdir}/libuv.la
%{_libdir}/%{name}.a
%changelog
* Tue Jun 09 2020 Zuzana Svetlikova <zsvetlik@redhat.com> - 1:1.38.0-1
- Update, disable failing tests
* Thu May 28 2020 Zuzana Svetlikova <zsvetlik@redhat.com> - 1:1.37.0-3
- Run tests
* Mon May 11 2020 Zuzana Svetlikova <zsvetlik@redhat.com> - 1:1.37.0-2
- Resolves: RHBZ#1817821
- bump for build
* Mon May 04 2020 Zuzana Svetlikova <zsvetlik@redhat.com> - 1:1.37.0-1
- Resolves: RHBZ#1817821
- Update to 1.37.0
- Add abidiff ignore file
* Mon Oct 08 2018 Jan Staněk <jstanek@redhat.com> - 1:1.23.1-1
- Update to 1.23.1
- Resolves: rhbz#1637000