Update to 1.33.1
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
bd8f350fdf
commit
0a7c06682b
1
.gitignore
vendored
1
.gitignore
vendored
@ -62,3 +62,4 @@
|
||||
/libuv-v1.31.0.tar.gz
|
||||
/libuv-v1.32.0.tar.gz
|
||||
/libuv-v1.33.0.tar.gz
|
||||
/libuv-v1.33.1.tar.gz
|
||||
|
36
2524.patch
36
2524.patch
@ -1,36 +0,0 @@
|
||||
From eb5552190000b9699bba33e1e419f500c7bd18b7 Mon Sep 17 00:00:00 2001
|
||||
From: Ben Noordhuis <info@bnoordhuis.nl>
|
||||
Date: Sat, 19 Oct 2019 09:54:46 +0200
|
||||
Subject: [PATCH] linux: fix arm64 SYS__sysctl build breakage
|
||||
|
||||
The arm64 architecture never had a _sysctl system call and therefore
|
||||
doesn't have a SYS__sysctl define either. Always return UV_ENOSYS.
|
||||
|
||||
Fixes: https://github.com/libuv/libuv/issues/2522
|
||||
---
|
||||
src/unix/random-sysctl.c | 9 +++++++++
|
||||
1 file changed, 9 insertions(+)
|
||||
|
||||
diff --git a/src/unix/random-sysctl.c b/src/unix/random-sysctl.c
|
||||
index 7af2e32070..fb182ded09 100644
|
||||
--- a/src/unix/random-sysctl.c
|
||||
+++ b/src/unix/random-sysctl.c
|
||||
@@ -65,9 +65,18 @@ int uv__random_sysctl(void* buf, size_t buflen) {
|
||||
* an okay trade-off for the fallback of the fallback: this function is
|
||||
* only called when neither getrandom(2) nor /dev/urandom are available.
|
||||
* Fails with ENOSYS on kernels configured without CONFIG_SYSCTL_SYSCALL.
|
||||
+ * At least arm64 never had a _sysctl system call and therefore doesn't
|
||||
+ * have a SYS__sysctl define either.
|
||||
*/
|
||||
+#ifdef SYS__sysctl
|
||||
if (syscall(SYS__sysctl, &args) == -1)
|
||||
return UV__ERR(errno);
|
||||
+#else
|
||||
+ {
|
||||
+ (void) &args;
|
||||
+ return UV_ENOSYS;
|
||||
+ }
|
||||
+#endif
|
||||
|
||||
if (n != sizeof(uuid))
|
||||
return UV_EIO; /* Can't happen. */
|
12
libuv.spec
12
libuv.spec
@ -1,7 +1,7 @@
|
||||
Name: libuv
|
||||
Epoch: 1
|
||||
Version: 1.33.0
|
||||
Release: 2%{?dist}
|
||||
Version: 1.33.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Platform layer for node.js
|
||||
|
||||
# the licensing breakdown is described in detail in the LICENSE file
|
||||
@ -14,9 +14,6 @@ BuildRequires: autoconf automake libtool
|
||||
BuildRequires: gcc
|
||||
|
||||
# -- Patches -- #
|
||||
# Upstream patch to fix builds on aarch64
|
||||
# https://github.com/libuv/libuv/pull/2524
|
||||
Patch0001: 2524.patch
|
||||
|
||||
|
||||
%description
|
||||
@ -75,6 +72,11 @@ rm -f %{buildroot}%{_libdir}/libuv.la
|
||||
%{_libdir}/%{name}.a
|
||||
|
||||
%changelog
|
||||
* Mon Dec 02 2019 Stephen Gallagher <sgallagh@redhat.com> - 1.33.1-1
|
||||
- Update to 1.33.1
|
||||
- Drop upstreamed patch
|
||||
- https://github.com/libuv/libuv/blob/v1.33.1/ChangeLog
|
||||
|
||||
* Mon Oct 21 2019 Stephen Gallagher <sgallagh@redhat.com> - 1.33.0-2
|
||||
- Add upstream patch to fix aarch64 builds
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libuv-v1.33.0.tar.gz) = 0fd846b8689890f3911d25ca55d9cd7e70b702279ff985787c5bc7d02c697f07b33a39bc0d43339d12838e4bb039cc1eb470181aa6b7b3106bd8f786594dd4e1
|
||||
SHA512 (libuv-v1.33.1.tar.gz) = 58d1568beaec42052a2c11efdae9f75f4bf5d3e428c863d48cdc73874083b9395b509dac8b187524a09f4ceae1659ea1dfceb9ffb621e9a7574bb12ac76051d4
|
||||
|
Loading…
Reference in New Issue
Block a user