- Add support for SHA256 and SHA512 in password hashes Related: #173583
- Fix file locking on some architectures - Rename sr@Latn.po to sr@latin.po Resolves: #426584 - Address issues from a review by Jason Tibbitts: - Remove default.-c, moving the provided functions to libuser proper - Remove the WITH_SELINUX build option - Move Python library test to %%check Resolves: #226054
This commit is contained in:
parent
a52cd57b3e
commit
aa3a61ee76
@ -1 +1 @@
|
|||||||
libuser-0.56.6.tar.bz2
|
libuser-0.56.7.tar.bz2
|
||||||
|
@ -1,42 +0,0 @@
|
|||||||
? build
|
|
||||||
Index: ChangeLog
|
|
||||||
===================================================================
|
|
||||||
RCS file: /usr/local/CVS/libuser/ChangeLog,v
|
|
||||||
retrieving revision 1.143
|
|
||||||
retrieving revision 1.144
|
|
||||||
diff -u -r1.143 -r1.144
|
|
||||||
--- ChangeLog 25 Oct 2007 06:36:56 -0000 1.143
|
|
||||||
+++ ChangeLog 30 Oct 2007 22:23:33 -0000 1.144
|
|
||||||
@@ -1,3 +1,8 @@
|
|
||||||
+2007-10-30 Miloslav Trmač <mitr@redhat.com>
|
|
||||||
+
|
|
||||||
+ * lib/util.c (lu_util_fscreate_restore) [WITH_SELINUX]: Fix use of
|
|
||||||
+ uninitialized data when SELinux is disabled.
|
|
||||||
+
|
|
||||||
2007-10-25 Miloslav Trmač <mitr@redhat.com>
|
|
||||||
|
|
||||||
* configure.in: Version 0.56.6.
|
|
||||||
Index: lib/util.c
|
|
||||||
===================================================================
|
|
||||||
RCS file: /usr/local/CVS/libuser/lib/util.c,v
|
|
||||||
retrieving revision 1.16
|
|
||||||
retrieving revision 1.17
|
|
||||||
diff -u -r1.16 -r1.17
|
|
||||||
--- lib/util.c 25 Oct 2007 05:48:04 -0000 1.16
|
|
||||||
+++ lib/util.c 30 Oct 2007 22:23:33 -0000 1.17
|
|
||||||
@@ -613,10 +613,11 @@
|
|
||||||
void
|
|
||||||
lu_util_fscreate_restore(security_context_t ctx)
|
|
||||||
{
|
|
||||||
- /* Don't check is_selinux_enabled(), we ignore errors anyway */
|
|
||||||
- (void)setfscreatecon(ctx);
|
|
||||||
- if (ctx)
|
|
||||||
- freecon(ctx);
|
|
||||||
+ if (is_selinux_enabled() > 0) {
|
|
||||||
+ (void)setfscreatecon(ctx);
|
|
||||||
+ if (ctx)
|
|
||||||
+ freecon(ctx);
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
|
|
||||||
/* Set fscreate context from context of file. */
|
|
45
libuser.spec
45
libuser.spec
@ -1,11 +1,8 @@
|
|||||||
%if %{?WITH_SELINUX:0}%{!?WITH_SELINUX:1}
|
|
||||||
%define WITH_SELINUX 1
|
|
||||||
%endif
|
|
||||||
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
||||||
|
|
||||||
Name: libuser
|
Name: libuser
|
||||||
Version: 0.56.6
|
Version: 0.56.7
|
||||||
Release: 4
|
Release: 1
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
|
|
||||||
@ -13,13 +10,9 @@ License: LGPLv2+
|
|||||||
# our distribution. Thus the source is only available from
|
# our distribution. Thus the source is only available from
|
||||||
# within this srpm.
|
# within this srpm.
|
||||||
Source: libuser-%{version}.tar.bz2
|
Source: libuser-%{version}.tar.bz2
|
||||||
Patch0: libuser-0.56.6-selinux.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-root
|
BuildRoot: %{_tmppath}/%{name}-root
|
||||||
BuildRequires: glib2-devel, linuxdoc-tools, pam-devel, popt-devel, python-devel
|
BuildRequires: glib2-devel, linuxdoc-tools, pam-devel, popt-devel, python-devel
|
||||||
BuildRequires: cyrus-sasl-devel, openldap-devel
|
BuildRequires: cyrus-sasl-devel, libselinux-devel, openldap-devel
|
||||||
%if %{WITH_SELINUX}
|
|
||||||
BuildRequires: libselinux-devel
|
|
||||||
%endif
|
|
||||||
Summary: A user and group account administration library
|
Summary: A user and group account administration library
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -53,15 +46,8 @@ administering user and group accounts.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch0 -p0 -b .selinux
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure --with-selinux --with-ldap --with-html-dir=%{_datadir}/gtk-doc/html
|
||||||
%if %{WITH_SELINUX}
|
|
||||||
--with-selinux \
|
|
||||||
%endif
|
|
||||||
--with-ldap \
|
|
||||||
--with-html-dir=%{_datadir}/gtk-doc/html
|
|
||||||
make
|
make
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
@ -74,13 +60,14 @@ make install DESTDIR=$RPM_BUILD_ROOT
|
|||||||
LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{_libdir}:${LD_LIBRARY_PATH}
|
LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{_libdir}:${LD_LIBRARY_PATH}
|
||||||
export LD_LIBRARY_PATH
|
export LD_LIBRARY_PATH
|
||||||
|
|
||||||
# Verify that all python modules load, just in case.
|
|
||||||
pushd $RPM_BUILD_ROOT/%{python_sitearch}
|
|
||||||
python -c "import libuser"
|
|
||||||
popd
|
|
||||||
|
|
||||||
%find_lang %{name}
|
%find_lang %{name}
|
||||||
|
|
||||||
|
%check
|
||||||
|
|
||||||
|
# Verify that all python modules load, just in case.
|
||||||
|
cd $RPM_BUILD_ROOT/%{python_sitearch}
|
||||||
|
python -c "import libuser"
|
||||||
|
|
||||||
%post -p /sbin/ldconfig
|
%post -p /sbin/ldconfig
|
||||||
|
|
||||||
%postun -p /sbin/ldconfig
|
%postun -p /sbin/ldconfig
|
||||||
@ -115,6 +102,18 @@ popd
|
|||||||
%{_datadir}/gtk-doc/html/*
|
%{_datadir}/gtk-doc/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jan 9 2008 Miloslav Trmač <mitr@volny.cz> - 0.56.7-1
|
||||||
|
- Add support for SHA256 and SHA512 in password hashes
|
||||||
|
Related: #173583
|
||||||
|
- Fix file locking on some architectures
|
||||||
|
- Rename sr@Latn.po to sr@latin.po
|
||||||
|
Resolves: #426584
|
||||||
|
- Address issues from a review by Jason Tibbitts:
|
||||||
|
- Remove default.-c, moving the provided functions to libuser proper
|
||||||
|
- Remove the WITH_SELINUX build option
|
||||||
|
- Move Python library test to %%check
|
||||||
|
Resolves: #226054
|
||||||
|
|
||||||
* Mon Jan 07 2008 Jason L Tibbitts III <tibbs@math.uh.edu> - 0.56.6-4
|
* Mon Jan 07 2008 Jason L Tibbitts III <tibbs@math.uh.edu> - 0.56.6-4
|
||||||
- Add the usual "there is no upstream" notice.
|
- Add the usual "there is no upstream" notice.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user