import liburing-1.0.7-3.el8

This commit is contained in:
CentOS Sources 2021-03-30 08:44:19 -04:00 committed by Stepan Oksanichenko
parent 3c5a59f337
commit 9b697b31da
7 changed files with 36 additions and 68 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/liburing-0.2.tar.bz2
SOURCES/liburing-1.0.7.tar.bz2

View File

@ -1 +1 @@
13b826f8eecbcd5d11b06b013b10c9ce74ddb4ed SOURCES/liburing-0.2.tar.bz2
cbd78fcc4fc43ec4c160a1b0d28c90d4b5779465 SOURCES/liburing-1.0.7.tar.bz2

View File

@ -1,26 +0,0 @@
Subject: [PATCH liburing v3 2/3] Makefile: add missing .pc dependency on .spec file
The version number is extracted from the .spec file. Make .pc depend on
.spec so that VERSION variable substitutions are always up-to-date.
Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com>
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index cc457bb..8af1c3a 100644
--- a/Makefile
+++ b/Makefile
@@ -31,7 +31,7 @@ ifneq ($(MAKECMDGOALS),clean)
include config-host.mak
endif
-%.pc: %.pc.in config-host.mak
+%.pc: %.pc.in config-host.mak $(SPECFILE)
sed -e "s%@prefix@%$(prefix)%g" \
-e "s%@libdir@%$(libdir)%g" \
-e "s%@includedir@%$(includedir)%g" \
--
2.23.0

View File

@ -1,12 +0,0 @@
diff --git a/src/include/liburing/barrier.h b/src/include/liburing/barrier.h
index fc40a8a..aca308a 100644
--- a/src/include/liburing/barrier.h
+++ b/src/include/liburing/barrier.h
@@ -76,6 +76,7 @@ do { \
* Add arch appropriate definitions. Be safe and use full barriers for
* archs we don't have support for.
*/
+#define io_uring_smp_mb() __sync_synchronize()
#define io_uring_smp_rmb() __sync_synchronize()
#define io_uring_smp_wmb() __sync_synchronize()
#endif /* defined(__x86_64__) || defined(__i386__) */

View File

@ -0,0 +1,16 @@
diff --git a/src/Makefile b/src/Makefile
index 44a95ad..6fd050d 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -4,9 +4,9 @@ libdir ?= $(prefix)/lib
libdevdir ?= $(prefix)/lib
CFLAGS ?= -g -fomit-frame-pointer -O2
-override CFLAGS += -Wall -Wextra -Wno-unused-parameter -Wno-sign-compare\
+override CFLAGS += -Wall -Wextra -Wno-unused-parameter -Wno-sign-compare -fPIC\
-Iinclude/ -include ../config-host.h
-SO_CFLAGS=-fPIC $(CFLAGS)
+SO_CFLAGS=$(CFLAGS)
L_CFLAGS=$(CFLAGS)
LINK_FLAGS=
LINK_FLAGS+=$(LDFLAGS)

View File

@ -1,21 +0,0 @@
Subject: [PATCH liburing v3 1/3] spec: update RPM version number to 0.2
Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com>
---
liburing.spec | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/liburing.spec b/liburing.spec
index 1337034..f9e9262 100644
--- a/liburing.spec
+++ b/liburing.spec
@@ -1,5 +1,5 @@
Name: liburing
-Version: 0.1
+Version: 0.2
Release: 1
Summary: Linux-native io_uring I/O access library
License: LGPLv2+
--
2.23.0

View File

@ -1,14 +1,12 @@
Name: liburing
Version: 0.2
Release: 2%{?dist}
Version: 1.0.7
Release: 3%{?dist}
Summary: Linux-native io_uring I/O access library
License: LGPLv2+
Source: %{name}-%{version}.tar.bz2
URL: http://brick.kernel.dk/snaps/%{name}-%{version}.tar.bz2
BuildRequires: gcc
Patch0: liburing-spec-update-RPM-version-number-to-0.2.patch
Patch1: liburing-Makefile-add-missing-pc-dependency-on-spec-file.patch
Patch2: liburing-add-missing-generic-implementation-of-smp_mb.patch
Patch0: liburing-always-build-with-fPIC.patch
%description
Provides native async IO for the Linux kernel, in a fast and efficient
@ -27,9 +25,9 @@ for the Linux-native io_uring.
%autosetup -p1
%build
./configure --prefix=%{_prefix} --libdir=/%{_libdir} --mandir=%{_mandir} --includedir=%{_includedir}
./configure --prefix=%{_prefix} --libdir=/%{_libdir} --libdevdir=/%{_libdir} --mandir=%{_mandir} --includedir=%{_includedir}
%make_build
%make_build V=1
%install
%make_install
@ -47,6 +45,19 @@ for the Linux-native io_uring.
%{_mandir}/man2/*
%changelog
* Thu Aug 20 2020 Jeff Moyer <jmoyer@redhat.com> - 1.0.7-3.el8
- Build with V=1 so that the build logs are useful.
- Related: rhbz#1862551
* Thu Aug 20 2020 Jeff Moyer <jmoyer@redhat.com> - 1.0.7-2.el8
- Fix versioning. The installed library is 1.0.7, make the rpm match.
- bump release number for build, which includes -fPIC fix
- Related: rhbz#1862551
* Fri Jul 31 2020 Jeff Moyer <jmoyer@redhat.com> - 0.7-1.el8
- Update to upstream version 0.7.
- Resolves: 1862551
* Wed Nov 6 2019 Jeff Moyer <jmoyer@redhat.com> - 0.2-2.el8
- bump release to trigger gating tests
- Related: bz#1724804