Update to 1.3.1

Signed-off-by: Zamir SUN <sztsian@gmail.com>
This commit is contained in:
Zamir SUN 2023-04-18 22:57:07 +08:00
parent 0113b3d40e
commit e676c4270e
4 changed files with 8 additions and 106 deletions

1
.gitignore vendored
View File

@ -1,3 +1,4 @@
/trace-cmd-libtracecmd-1.1.0.tar.gz /trace-cmd-libtracecmd-1.1.0.tar.gz
/trace-cmd-libtracecmd-1.1.3.tar.gz /trace-cmd-libtracecmd-1.1.3.tar.gz
/trace-cmd-libtracecmd-1.2.0.tar.gz /trace-cmd-libtracecmd-1.2.0.tar.gz
/trace-cmd-libtracecmd-1.3.1.tar.gz

View File

@ -1,12 +1,11 @@
Name: libtracecmd Name: libtracecmd
Version: 1.2.0 Version: 1.3.1
Release: 3%{?dist} Release: 1%{?dist}
License: LGPLv2 License: LGPLv2
Summary: A library for reading tracing instances stored in a trace file Summary: A library for reading tracing instances stored in a trace file
URL: https://git.kernel.org/pub/scm/utils/trace-cmd/trace-cmd.git/ URL: https://git.kernel.org/pub/scm/utils/trace-cmd/trace-cmd.git/
Source0: https://git.kernel.org/pub/scm/utils/trace-cmd/trace-cmd.git/snapshot/trace-cmd-libtracecmd-%{version}.tar.gz Source0: https://git.kernel.org/pub/scm/utils/trace-cmd/trace-cmd.git/snapshot/trace-cmd-libtracecmd-%{version}.tar.gz
Patch0: trace-cmd-Allow-building-with-GNU-Make-4.4.patch
ExcludeArch: %{ix86} %{arm} ExcludeArch: %{ix86} %{arm}
@ -59,7 +58,7 @@ chrpath --delete %{buildroot}/%{_libdir}/libtracecmd.so*
%license COPYING COPYING.LIB %license COPYING COPYING.LIB
%doc README %doc README
%{_libdir}/libtracecmd.so.1 %{_libdir}/libtracecmd.so.1
%{_libdir}/libtracecmd.so.1.2.0 %{_libdir}/libtracecmd.so.1.3.1
%{_docdir}/libtracecmd-doc %{_docdir}/libtracecmd-doc
%{_mandir}/man3/libtracecmd* %{_mandir}/man3/libtracecmd*
%{_mandir}/man3/tracecmd* %{_mandir}/man3/tracecmd*
@ -70,6 +69,9 @@ chrpath --delete %{buildroot}/%{_libdir}/libtracecmd.so*
%{_includedir}/trace-cmd %{_includedir}/trace-cmd
%changelog %changelog
* Tue Apr 18 2023 Zamir SUN <sztsian@gmail.com> - 1.3.1-1
- Update to 1.3.1
* Fri Mar 31 2023 Jerome Marchand <jmarchan@redhat.com> - 1.2.0-3 * Fri Mar 31 2023 Jerome Marchand <jmarchan@redhat.com> - 1.2.0-3
- Fix build: RHBZ#2171769 - Fix build: RHBZ#2171769

View File

@ -1 +1 @@
SHA512 (trace-cmd-libtracecmd-1.2.0.tar.gz) = 4ce1a83268587981d18bd24cf9fafecbed66555ef68807999c6a3735b5428424ee9a825f5de85c705c7ee1f926ae7fa728a2708b8e63a5c4a6c427c4ce7ce3df SHA512 (trace-cmd-libtracecmd-1.3.1.tar.gz) = 3c8ee0135d12b7c553de6903c1c3051f5ae83ec27edbcbc88d2ac80257dfd44da0ec12dd07f066684e6b5dfce60cbb1af8176643957534b3f582efb8e54ead04

View File

@ -1,101 +0,0 @@
From 5b87ceb33a33857a51aa52db092ad28e0510d00a Mon Sep 17 00:00:00 2001
From: Michal Sojka <michal.sojka@cvut.cz>
Date: Mon, 26 Dec 2022 17:49:51 +0100
Subject: [PATCH] trace-cmd: Allow building with GNU Make 4.4
Make 4.4 introduces several backward incompatibilities and the result
is that building trace-cmd with it never finishes. It seems that make
ends up in some kind of infinite recursion. The symptoms are:
$ make -d
GNU Make 4.4
Built for x86_64-pc-linux-gnu
Copyright (C) 1988-2022 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <https://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Reading makefiles...
Reading makefile 'Makefile'...
Makefile:79: not recursively expanding pkgconfig_dir to export to shell function
Makefile:79: not recursively expanding pkgconfig_dir to export to shell function
Makefile:224: not recursively expanding LIBTRACECMD_SHARED_VERSION to export to shell function
Makefile:79: not recursively expanding pkgconfig_dir to export to shell function
Makefile:224: not recursively expanding LIBTRACECMD_SHARED_VERSION to export to shell function
Makefile:225: not recursively expanding LIBTRACECMD_SHARED_SO to export to shell function
Makefile:79: not recursively expanding pkgconfig_dir to export to shell function
Makefile:79: not recursively expanding pkgconfig_dir to export to shell function
Build succeeds if recursively expanded variables (defined with '='),
which use $(shell ...) as its value, are replaced with simply expanded
variables (defined with ':=').
Link: https://lore.kernel.org/linux-trace-devel/20221226164951.2632069-1-michal.sojka@cvut.cz
Signed-off-by: Michal Sojka <michal.sojka@cvut.cz>
Tested-by: Daniel Wagner <dwagner@suse.de>
Signed-off-by: Steven Rostedt (Google) <rostedt@goodmis.org>
---
Makefile | 22 +++++++++++-----------
1 file changed, 11 insertions(+), 11 deletions(-)
diff --git a/Makefile b/Makefile
index b61b8951..e892a2ec 100644
--- a/Makefile
+++ b/Makefile
@@ -221,8 +221,8 @@ LIBS ?= -ldl
LIBTRACECMD_DIR = $(obj)/lib/trace-cmd
LIBTRACECMD_STATIC = $(LIBTRACECMD_DIR)/libtracecmd.a
LIBTRACECMD_SHARED = $(LIBTRACECMD_DIR)/libtracecmd.so.$(LIBTRACECMD_VERSION)
-LIBTRACECMD_SHARED_VERSION = $(shell echo $(LIBTRACECMD_SHARED) | sed -e 's/\(\.so\.[0-9]*\).*/\1/')
-LIBTRACECMD_SHARED_SO = $(shell echo $(LIBTRACECMD_SHARED) | sed -e 's/\(\.so\).*/\1/')
+LIBTRACECMD_SHARED_VERSION := $(shell echo $(LIBTRACECMD_SHARED) | sed -e 's/\(\.so\.[0-9]*\).*/\1/')
+LIBTRACECMD_SHARED_SO := $(shell echo $(LIBTRACECMD_SHARED) | sed -e 's/\(\.so\).*/\1/')
export LIBTRACECMD_STATIC LIBTRACECMD_SHARED
export LIBTRACECMD_SHARED_VERSION LIBTRACECMD_SHARED_SO
@@ -230,12 +230,12 @@ export LIBTRACECMD_SHARED_VERSION LIBTRACECMD_SHARED_SO
LIBTRACEEVENT=libtraceevent
LIBTRACEFS=libtracefs
-TEST_LIBTRACEEVENT = $(shell sh -c "$(PKG_CONFIG) --atleast-version $(LIBTRACEEVENT_MIN_VERSION) $(LIBTRACEEVENT) > /dev/null 2>&1 && echo y")
-TEST_LIBTRACEFS = $(shell sh -c "$(PKG_CONFIG) --atleast-version $(LIBTRACEFS_MIN_VERSION) $(LIBTRACEFS) > /dev/null 2>&1 && echo y")
+TEST_LIBTRACEEVENT := $(shell sh -c "$(PKG_CONFIG) --atleast-version $(LIBTRACEEVENT_MIN_VERSION) $(LIBTRACEEVENT) > /dev/null 2>&1 && echo y")
+TEST_LIBTRACEFS := $(shell sh -c "$(PKG_CONFIG) --atleast-version $(LIBTRACEFS_MIN_VERSION) $(LIBTRACEFS) > /dev/null 2>&1 && echo y")
ifeq ("$(TEST_LIBTRACEEVENT)", "y")
-LIBTRACEEVENT_CFLAGS = $(shell sh -c "$(PKG_CONFIG) --cflags $(LIBTRACEEVENT)")
-LIBTRACEEVENT_LDLAGS = $(shell sh -c "$(PKG_CONFIG) --libs $(LIBTRACEEVENT)")
+LIBTRACEEVENT_CFLAGS := $(shell sh -c "$(PKG_CONFIG) --cflags $(LIBTRACEEVENT)")
+LIBTRACEEVENT_LDLAGS := $(shell sh -c "$(PKG_CONFIG) --libs $(LIBTRACEEVENT)")
else
.PHONY: warning
warning:
@@ -253,8 +253,8 @@ endif
export LIBTRACEEVENT_CFLAGS LIBTRACEEVENT_LDLAGS
ifeq ("$(TEST_LIBTRACEFS)", "y")
-LIBTRACEFS_CFLAGS = $(shell sh -c "$(PKG_CONFIG) --cflags $(LIBTRACEFS)")
-LIBTRACEFS_LDLAGS = $(shell sh -c "$(PKG_CONFIG) --libs $(LIBTRACEFS)")
+LIBTRACEFS_CFLAGS := $(shell sh -c "$(PKG_CONFIG) --cflags $(LIBTRACEFS)")
+LIBTRACEFS_LDLAGS := $(shell sh -c "$(PKG_CONFIG) --libs $(LIBTRACEFS)")
else
.PHONY: warning
warning:
@@ -324,11 +324,11 @@ endif
export ZLIB_LDLAGS
ifndef NO_LIBZSTD
-TEST_LIBZSTD = $(shell sh -c "$(PKG_CONFIG) --atleast-version 1.4.0 libzstd > /dev/null 2>&1 && echo y")
+TEST_LIBZSTD := $(shell sh -c "$(PKG_CONFIG) --atleast-version 1.4.0 libzstd > /dev/null 2>&1 && echo y")
ifeq ("$(TEST_LIBZSTD)", "y")
-LIBZSTD_CFLAGS = $(shell sh -c "$(PKG_CONFIG) --cflags libzstd")
-LIBZSTD_LDLAGS = $(shell sh -c "$(PKG_CONFIG) --libs libzstd")
+LIBZSTD_CFLAGS := $(shell sh -c "$(PKG_CONFIG) --cflags libzstd")
+LIBZSTD_LDLAGS := $(shell sh -c "$(PKG_CONFIG) --libs libzstd")
CFLAGS += -DHAVE_ZSTD
ZSTD_INSTALLED=1
$(info Have ZSTD compression support)
--
2.39.2