- fix ltdl file open (#225116)
- fix lt_unset usage (#227454) - spec file cleanups for merge review
This commit is contained in:
parent
5cd18349bc
commit
f79ec8ce5e
@ -1,15 +1,15 @@
|
||||
--- libtool-1.5.22/libltdl/ltdl.c.rh2 2006-11-06 15:40:04.000000000 +0100
|
||||
+++ libtool-1.5.22/libltdl/ltdl.c 2006-11-06 15:40:26.000000000 +0100
|
||||
@@ -3203,10 +3203,12 @@
|
||||
--- libtool-1.5.22/libltdl/ltdl.c.relativepath 2007-02-08 09:20:54.000000000 -0500
|
||||
+++ libtool-1.5.22/libltdl/ltdl.c 2007-02-08 09:46:41.000000000 -0500
|
||||
@@ -3203,9 +3203,10 @@
|
||||
}
|
||||
#endif
|
||||
}
|
||||
+#if 0
|
||||
if (!file)
|
||||
- if (!file)
|
||||
+ if (!file)
|
||||
{
|
||||
file = fopen (filename, LT_READTEXT_MODE);
|
||||
- file = fopen (filename, LT_READTEXT_MODE);
|
||||
+ if(strstr(filename,"/") || strcmp((filename + strlen(filename) - 3), ".la") != 0)
|
||||
+ file = fopen (filename, LT_READTEXT_MODE);
|
||||
}
|
||||
+#endif
|
||||
|
||||
/* If we didn't find the file by now, it really isn't there. Set
|
||||
the status flag, and bail out. */
|
||||
|
20
libtool.spec
20
libtool.spec
@ -3,12 +3,14 @@
|
||||
Summary: The GNU Portable Library Tool
|
||||
Name: libtool
|
||||
Version: %{upstream_version}
|
||||
Release: 8
|
||||
Release: 9
|
||||
License: GPL
|
||||
Group: Development/Tools
|
||||
Source: http://ftp.gnu.org/gnu/libtool/libtool-%{upstream_version}.tar.gz
|
||||
URL: http://www.gnu.org/software/libtool/
|
||||
BuildRoot: %{_tmppath}/%{name}-root
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Requires(post): /sbin/install-info
|
||||
Requires(preun): /sbin/install-info
|
||||
Patch1: libtool-1.5.18-multilib.patch
|
||||
|
||||
# Remove in libtool-1.5.23:
|
||||
@ -24,7 +26,6 @@ Patch5: libtool-1.5.22-configupdate-217166.patch
|
||||
# don't read .la file in current working directory, root might get tricked
|
||||
# into running a prepared binary in that directory:
|
||||
Patch6: libtool-1.5.22-relativepath.patch
|
||||
PreReq: /sbin/install-info
|
||||
BuildRequires: autoconf >= 2.59, automake >= 1.9.2, texinfo
|
||||
# make sure we can configure all supported langs
|
||||
BuildRequires: gcc, gcc-c++, libstdc++-devel, gcc-gfortran, gcc-java
|
||||
@ -84,11 +85,11 @@ Static libraries and header files for development with ltdl.
|
||||
%prep
|
||||
%setup -n libtool-%{upstream_version} -q
|
||||
%patch1 -p1 -b .multilib
|
||||
%patch2 -p1
|
||||
%patch2 -p1 -b .misc
|
||||
%patch3 -p1 -b .anygcc
|
||||
%patch4 -p1 -b .rh1
|
||||
%patch5 -p1 -b .rh2
|
||||
%patch6 -p1 -b .automake110
|
||||
%patch4 -p1 -b .ldconfigvars
|
||||
%patch5 -p1 -b .automake110
|
||||
%patch6 -p1 -b .relativepath
|
||||
|
||||
%build
|
||||
|
||||
@ -158,6 +159,11 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Feb 08 2007 Karsten Hopp <karsten@redhat.com> 1.5.22-9
|
||||
- fix ltdl file open (#225116)
|
||||
- fix lt_unset usage (#227454)
|
||||
- spec file cleanups for merge review
|
||||
|
||||
* Mon Jan 22 2007 Karsten Hopp <karsten@redhat.com> 1.5.22-8
|
||||
- don't abort (un)install scriptlets when _excludedocs is set (#223708)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user