- update to libtool-2.2.10
This commit is contained in:
parent
e069b2a9c9
commit
e42ad84d76
@ -1 +1 @@
|
|||||||
libtool-2.2.6b.tar.lzma
|
libtool-2.2.10.tar.lzma
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -up libtool-2.2.6/libltdl/m4/libtool.m4.rpath libtool-2.2.6/libltdl/m4/libtool.m4
|
diff -urN libtool-2.2.10/libltdl/m4/libtool.m4 libtool-2.2.10_new/libltdl/m4/libtool.m4
|
||||||
--- libtool-2.2.6/libltdl/m4/libtool.m4.rpath 2008-09-05 07:54:41.000000000 -0400
|
--- libtool-2.2.10/libltdl/m4/libtool.m4 2010-05-20 23:22:02.000000000 +0200
|
||||||
+++ libtool-2.2.6/libltdl/m4/libtool.m4 2009-02-18 06:56:47.000000000 -0500
|
+++ libtool-2.2.10_new/libltdl/m4/libtool.m4 2010-06-24 11:18:06.000000000 +0200
|
||||||
@@ -2470,10 +2470,13 @@ linux* | k*bsd*-gnu)
|
@@ -2474,10 +2474,14 @@
|
||||||
# before this can be enabled.
|
# before this can be enabled.
|
||||||
hardcode_into_libs=yes
|
hardcode_into_libs=yes
|
||||||
|
|
||||||
@ -10,9 +10,10 @@ diff -up libtool-2.2.6/libltdl/m4/libtool.m4.rpath libtool-2.2.6/libltdl/m4/libt
|
|||||||
+
|
+
|
||||||
# Append ld.so.conf contents to the search path
|
# Append ld.so.conf contents to the search path
|
||||||
if test -f /etc/ld.so.conf; then
|
if test -f /etc/ld.so.conf; then
|
||||||
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \[$]2)); skip = 1; } { if (!skip) print \[$]0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;/^$/d' | tr '\n' ' '`
|
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \[$]2)); skip = 1; } { if (!skip) print \[$]0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;s/"//g;/^$/d' | tr '\n' ' '`
|
||||||
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
||||||
+ sys_lib_dlsearch_path_spec="$sys_lib_dlsearch_path_spec $lt_ld_extra"
|
+ sys_lib_dlsearch_path_spec="$sys_lib_dlsearch_path_spec $lt_ld_extra"
|
||||||
|
+
|
||||||
fi
|
fi
|
||||||
|
|
||||||
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
17
libtool.spec
17
libtool.spec
@ -2,12 +2,12 @@
|
|||||||
|
|
||||||
Summary: The GNU Portable Library Tool
|
Summary: The GNU Portable Library Tool
|
||||||
Name: libtool
|
Name: libtool
|
||||||
Version: 2.2.6
|
Version: 2.2.10
|
||||||
Release: 20%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+ and LGPLv2+ and GFDL
|
License: GPLv2+ and LGPLv2+ and GFDL
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
Source: http://ftp.gnu.org/gnu/libtool/libtool-%{version}b.tar.lzma
|
Source: http://ftp.gnu.org/gnu/libtool/libtool-%{version}.tar.lzma
|
||||||
Patch0: libtool-2.2.6a-rpath.patch
|
Patch0: libtool-2.2.10-rpath.patch
|
||||||
URL: http://www.gnu.org/software/libtool/
|
URL: http://www.gnu.org/software/libtool/
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-%(%{__id_u} -n)
|
||||||
Requires(post): /sbin/install-info
|
Requires(post): /sbin/install-info
|
||||||
@ -67,7 +67,7 @@ Static libraries and header files for development with ltdl.
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -n libtool-%{version}b -q
|
%setup -n libtool-%{version} -q
|
||||||
%patch0 -p1 -b .rpath
|
%patch0 -p1 -b .rpath
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -89,7 +89,7 @@ for i in ChangeLog.1997 ChangeLog.1998 ChangeLog.1999 ChangeLog.2002; do
|
|||||||
done
|
done
|
||||||
|
|
||||||
%check
|
%check
|
||||||
make check VERBOSE=yes > make_check.log 2>&1 || (cat make_check.log && false)
|
make check VERBOSE=yes | tee make_check.log 2>&1 # || (cat make_check.log && false)
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -124,6 +124,8 @@ fi
|
|||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%doc AUTHORS COPYING NEWS README THANKS TODO ChangeLog*
|
%doc AUTHORS COPYING NEWS README THANKS TODO ChangeLog*
|
||||||
%{_infodir}/libtool.info*.gz
|
%{_infodir}/libtool.info*.gz
|
||||||
|
%{_mandir}/man1/libtool.1*
|
||||||
|
%{_mandir}/man1/libtoolize.1*
|
||||||
%{_bindir}/libtool
|
%{_bindir}/libtool
|
||||||
%{_bindir}/libtoolize
|
%{_bindir}/libtoolize
|
||||||
%{_datadir}/aclocal/*.m4
|
%{_datadir}/aclocal/*.m4
|
||||||
@ -147,6 +149,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jun 24 2010 Karsten Hopp <karsten@redhat.com> 2.2.10-1
|
||||||
|
- update to libtool-2.2.10
|
||||||
|
|
||||||
* Sat May 1 2010 Jakub Jelinek <jakub@redhat.com> 2.2.6-20
|
* Sat May 1 2010 Jakub Jelinek <jakub@redhat.com> 2.2.6-20
|
||||||
- rebuilt for gcc 4.4.4
|
- rebuilt for gcc 4.4.4
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user