- detect gcc path at runtime instead of requiring one specific version
This commit is contained in:
parent
c91b906d20
commit
8c9526f773
44
libtool-1.5.22-anygcc.patch
Normal file
44
libtool-1.5.22-anygcc.patch
Normal file
@ -0,0 +1,44 @@
|
||||
--- libtool-1.5.22/libtool.m4.anygcc 2005-12-18 22:53:17.000000000 +0100
|
||||
+++ libtool-1.5.22/libtool.m4 2006-06-29 14:20:18.000000000 +0200
|
||||
@@ -4294,6 +4294,9 @@
|
||||
# Is the compiler the GNU C compiler?
|
||||
with_gcc=$_LT_AC_TAGVAR(GCC, $1)
|
||||
|
||||
+gcc_dir=\`gcc -print-file-name=. | $SED 's,/\.$,,'\`
|
||||
+gcc_ver=\`gcc -dumpversion\`
|
||||
+
|
||||
# An ERE matcher.
|
||||
EGREP=$lt_EGREP
|
||||
|
||||
@@ -4427,11 +4430,11 @@
|
||||
|
||||
# Dependencies to place before the objects being linked to create a
|
||||
# shared library.
|
||||
-predep_objects=$lt_[]_LT_AC_TAGVAR(predep_objects, $1)
|
||||
+predep_objects=\`echo $lt_[]_LT_AC_TAGVAR(predep_objects, $1) | \$SED -e "s@\${gcc_dir}@\\\${gcc_dir}@g;s@\${gcc_ver}@\\\${gcc_ver}@g"\`
|
||||
|
||||
# Dependencies to place after the objects being linked to create a
|
||||
# shared library.
|
||||
-postdep_objects=$lt_[]_LT_AC_TAGVAR(postdep_objects, $1)
|
||||
+postdep_objects=\`echo $lt_[]_LT_AC_TAGVAR(postdep_objects, $1) | \$SED -e "s@\${gcc_dir}@\\\${gcc_dir}@g;s@\${gcc_ver}@\\\${gcc_ver}@g"\`
|
||||
|
||||
# Dependencies to place before the objects being linked to create a
|
||||
# shared library.
|
||||
@@ -4443,7 +4446,7 @@
|
||||
|
||||
# The library search path used internally by the compiler when linking
|
||||
# a shared library.
|
||||
-compiler_lib_search_path=$lt_[]_LT_AC_TAGVAR(compiler_lib_search_path, $1)
|
||||
+compiler_lib_search_path=\`echo $lt_[]_LT_AC_TAGVAR(compiler_lib_search_path, $1) | \$SED -e "s@\${gcc_dir}@\\\${gcc_dir}@g;s@\${gcc_ver}@\\\${gcc_ver}@g"\`
|
||||
|
||||
# Method to check whether dependent libraries are shared objects.
|
||||
deplibs_check_method=$lt_deplibs_check_method
|
||||
@@ -4523,7 +4526,7 @@
|
||||
link_all_deplibs=$_LT_AC_TAGVAR(link_all_deplibs, $1)
|
||||
|
||||
# Compile-time system search path for libraries
|
||||
-sys_lib_search_path_spec=$lt_sys_lib_search_path_spec
|
||||
+sys_lib_search_path_spec=\`echo $lt_sys_lib_search_path_spec | \$SED -e "s@\${gcc_dir}@\\\${gcc_dir}@g;s@\${gcc_ver}@\\\${gcc_ver}@g"\`
|
||||
|
||||
# Run-time system search path for libraries
|
||||
sys_lib_dlsearch_path_spec=$lt_sys_lib_dlsearch_path_spec
|
10
libtool.spec
10
libtool.spec
@ -1,10 +1,9 @@
|
||||
%define upstream_version 1.5.22
|
||||
%define gcc_version %(gcc -dumpversion)
|
||||
|
||||
Summary: The GNU Portable Library Tool
|
||||
Name: libtool
|
||||
Version: %{upstream_version}
|
||||
Release: 5
|
||||
Release: 6
|
||||
License: GPL
|
||||
Group: Development/Tools
|
||||
Source: http://ftp.gnu.org/gnu/libtool/libtool-%{upstream_version}.tar.gz
|
||||
@ -15,13 +14,14 @@ Patch1: libtool-1.5.18-multilib.patch
|
||||
# Remove in libtool-1.5.23:
|
||||
Patch2: libtool-1.5.22-misc.patch
|
||||
|
||||
Patch3: libtool-1.5.22-anygcc.patch
|
||||
|
||||
PreReq: /sbin/install-info
|
||||
BuildRequires: autoconf >= 2.59, automake >= 1.9.2, texinfo
|
||||
# make sure we can configure all supported langs
|
||||
BuildRequires: gcc, gcc-c++, libstdc++-devel, gcc-gfortran, gcc-java
|
||||
# /usr/bin/libtool includes paths within gcc's versioned directories
|
||||
# Libtool must be rebuilt whenever a new upstream gcc is built
|
||||
Requires: gcc = %{gcc_version}
|
||||
Requires: autoconf >= 2.50, automake >= 1.4
|
||||
|
||||
%description
|
||||
@ -77,6 +77,7 @@ Static libraries and header files for development with ltdl.
|
||||
%setup -n libtool-%{upstream_version} -q
|
||||
%patch1 -p1 -b .multilib
|
||||
%patch2 -p1
|
||||
%patch3 -p1 -b .anygcc
|
||||
|
||||
%build
|
||||
|
||||
@ -146,6 +147,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Jun 29 2006 Karsten Hopp <karsten@redhat.de> 1.5.22-6
|
||||
- detect gcc path at runtime instead of requiring one specific version
|
||||
|
||||
* Thu Jun 29 2006 Karsten Hopp <karsten@redhat.de> 1.5.22-5
|
||||
- miscellaneous upstream fixes
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user