libtool,ltmain.sh: revert execute mode dd optimization
See the bug for more info. Version: 2.4.2-14 Resolves: #636045
This commit is contained in:
parent
b6164b7e35
commit
2e57b2d942
@ -1,43 +0,0 @@
|
||||
diff --git a/libltdl/config/ltmain.sh b/libltdl/config/ltmain.sh
|
||||
index 63ae69d..36625c7 100644
|
||||
--- a/libltdl/config/ltmain.sh
|
||||
+++ b/libltdl/config/ltmain.sh
|
||||
@@ -82,6 +82,7 @@ PROGRAM=libtool
|
||||
PACKAGE=libtool
|
||||
VERSION=2.4.2
|
||||
TIMESTAMP=""
|
||||
+: ${DD=dd}
|
||||
package_revision=1.3337
|
||||
|
||||
# Be Bourne compatible
|
||||
@@ -1224,6 +1225,21 @@ func_enable_tag "$optarg"
|
||||
## Main. ##
|
||||
## ----------- ##
|
||||
|
||||
+# func_try_sizelim file n
|
||||
+# try to write at most the first N bytes from FILE to the standard output when
|
||||
+# possible, otherwise put whole file
|
||||
+func_try_sizelim ()
|
||||
+{
|
||||
+ if test -n "$DD"; then
|
||||
+ $DD if="$1" bs=$2 count=1 2>/dev/null
|
||||
+ if test $? -eq 127; then
|
||||
+ cat "$1" 2>/dev/null
|
||||
+ fi
|
||||
+ else
|
||||
+ cat "$1" 2>/dev/null
|
||||
+ fi
|
||||
+}
|
||||
+
|
||||
# func_lalib_p file
|
||||
# True iff FILE is a libtool `.la' library or `.lo' object file.
|
||||
# This function is only a basic sanity check; it will hardly flush out
|
||||
@@ -1231,7 +1247,7 @@ func_enable_tag "$optarg"
|
||||
func_lalib_p ()
|
||||
{
|
||||
test -f "$1" &&
|
||||
- $SED -e 4q "$1" 2>/dev/null \
|
||||
+ func_try_sizelim "$1" 4096 | $SED -e 4q 2>/dev/null \
|
||||
| $GREP "^# Generated by .*$PACKAGE" > /dev/null 2>&1
|
||||
}
|
||||
|
12
libtool.spec
12
libtool.spec
@ -3,7 +3,7 @@
|
||||
Summary: The GNU Portable Library Tool
|
||||
Name: libtool
|
||||
Version: 2.4.2
|
||||
Release: 14%{?dist}
|
||||
Release: 15%{?dist}
|
||||
License: GPLv2+ and LGPLv2+ and GFDL
|
||||
URL: http://www.gnu.org/software/libtool/
|
||||
Group: Development/Tools
|
||||
@ -17,13 +17,6 @@ Patch1: libtool-2.4.2-TEMPORARY-disable-gcj-tests.patch
|
||||
# fixed in next release.
|
||||
Patch2: libtool-2.4.2-tar-no-owner.patch
|
||||
|
||||
# Do not hang too long on sed
|
||||
# ~> #636045
|
||||
# ~> Downstream (we don't care much about portability)
|
||||
# ~> upstream proposal:
|
||||
# http://lists.gnu.org/archive/html/bug-libtool/2013-04/msg00005.html
|
||||
Patch3: libtool-2.4.2-dd-execute-mode.patch
|
||||
|
||||
Requires(post): /sbin/install-info
|
||||
Requires(preun): /sbin/install-info
|
||||
|
||||
@ -167,6 +160,9 @@ fi
|
||||
%{_libdir}/libltdl.so
|
||||
|
||||
%changelog
|
||||
* Tue May 07 2013 Pavel Raiskup <praiskup@redhat.com> - 2.4.2-15
|
||||
- revert fix for #636045, thanks to Paolo Bonzini
|
||||
|
||||
* Fri Apr 26 2013 Pavel Raiskup <praiskup@redhat.com> - 2.4.2-14
|
||||
- allow root to copy files into NFS in libtoolize (#740079)
|
||||
- pre-filter sed's input by dd (#636045)
|
||||
|
Loading…
Reference in New Issue
Block a user