libtool: rebase back to 2.4.4
This reverts commit 1945f99711
.
Version: 2.4.4-1
Resolves: #1159497
This commit is contained in:
parent
e37df67fbd
commit
1421f339b7
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,3 +1 @@
|
|||||||
libtool-2.2.10.tar.lzma
|
/libtool-2.4.4.tar.xz
|
||||||
/libtool-2.4.tar.xz
|
|
||||||
/libtool-2.4.2.tar.xz
|
|
||||||
|
@ -1,44 +0,0 @@
|
|||||||
--- libtool-1.5.22/libtool.m4.anygcc 2005-12-18 22:53:17.000000000 +0100
|
|
||||||
+++ libtool-1.5.22/libtool.m4 2006-06-29 14:20:18.000000000 +0200
|
|
||||||
@@ -4294,6 +4294,9 @@
|
|
||||||
# Is the compiler the GNU C compiler?
|
|
||||||
with_gcc=$_LT_AC_TAGVAR(GCC, $1)
|
|
||||||
|
|
||||||
+gcc_dir=\`gcc -print-file-name=. | $SED 's,/\.$,,'\`
|
|
||||||
+gcc_ver=\`gcc -dumpversion\`
|
|
||||||
+
|
|
||||||
# An ERE matcher.
|
|
||||||
EGREP=$lt_EGREP
|
|
||||||
|
|
||||||
@@ -4427,11 +4430,11 @@
|
|
||||||
|
|
||||||
# Dependencies to place before the objects being linked to create a
|
|
||||||
# shared library.
|
|
||||||
-predep_objects=$lt_[]_LT_AC_TAGVAR(predep_objects, $1)
|
|
||||||
+predep_objects=\`echo $lt_[]_LT_AC_TAGVAR(predep_objects, $1) | \$SED -e "s@\${gcc_dir}@\\\${gcc_dir}@g;s@\${gcc_ver}@\\\${gcc_ver}@g"\`
|
|
||||||
|
|
||||||
# Dependencies to place after the objects being linked to create a
|
|
||||||
# shared library.
|
|
||||||
-postdep_objects=$lt_[]_LT_AC_TAGVAR(postdep_objects, $1)
|
|
||||||
+postdep_objects=\`echo $lt_[]_LT_AC_TAGVAR(postdep_objects, $1) | \$SED -e "s@\${gcc_dir}@\\\${gcc_dir}@g;s@\${gcc_ver}@\\\${gcc_ver}@g"\`
|
|
||||||
|
|
||||||
# Dependencies to place before the objects being linked to create a
|
|
||||||
# shared library.
|
|
||||||
@@ -4443,7 +4446,7 @@
|
|
||||||
|
|
||||||
# The library search path used internally by the compiler when linking
|
|
||||||
# a shared library.
|
|
||||||
-compiler_lib_search_path=$lt_[]_LT_AC_TAGVAR(compiler_lib_search_path, $1)
|
|
||||||
+compiler_lib_search_path=\`echo $lt_[]_LT_AC_TAGVAR(compiler_lib_search_path, $1) | \$SED -e "s@\${gcc_dir}@\\\${gcc_dir}@g;s@\${gcc_ver}@\\\${gcc_ver}@g"\`
|
|
||||||
|
|
||||||
# Method to check whether dependent libraries are shared objects.
|
|
||||||
deplibs_check_method=$lt_deplibs_check_method
|
|
||||||
@@ -4523,7 +4526,7 @@
|
|
||||||
link_all_deplibs=$_LT_AC_TAGVAR(link_all_deplibs, $1)
|
|
||||||
|
|
||||||
# Compile-time system search path for libraries
|
|
||||||
-sys_lib_search_path_spec=$lt_sys_lib_search_path_spec
|
|
||||||
+sys_lib_search_path_spec=\`echo $lt_sys_lib_search_path_spec | \$SED -e "s@\${gcc_dir}@\\\${gcc_dir}@g;s@\${gcc_ver}@\\\${gcc_ver}@g"\`
|
|
||||||
|
|
||||||
# Run-time system search path for libraries
|
|
||||||
sys_lib_dlsearch_path_spec=$lt_sys_lib_dlsearch_path_spec
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -up libtool-2.2.6/configure.echo libtool-2.2.6/configure
|
|
||||||
--- libtool-2.2.6/configure.echo 2008-12-03 09:26:03.000000000 -0500
|
|
||||||
+++ libtool-2.2.6/configure 2008-12-03 09:26:14.000000000 -0500
|
|
||||||
@@ -27606,7 +27606,7 @@ objdir=$objdir
|
|
||||||
SHELL=$lt_SHELL
|
|
||||||
|
|
||||||
# An echo program that does not interpret backslashes.
|
|
||||||
-ECHO=$lt_ECHO
|
|
||||||
+echo=$lt_ECHO
|
|
||||||
|
|
||||||
# Used to examine libraries when file_magic_cmd begins with "file".
|
|
||||||
MAGIC_CMD=$MAGIC_CMD
|
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/tests/convenience.at b/tests/convenience.at
|
|
||||||
index f076e61..b97b5f3 100644
|
|
||||||
--- a/tests/convenience.at
|
|
||||||
+++ b/tests/convenience.at
|
|
||||||
@@ -231,6 +231,8 @@ AT_SETUP([Java convenience archives])
|
|
||||||
LT_AT_EXEC_TAG([GCJ])
|
|
||||||
AT_KEYWORDS([libtool])
|
|
||||||
|
|
||||||
+AT_CHECK([exit 77])
|
|
||||||
+
|
|
||||||
cat >foo1.java <<EOF
|
|
||||||
public class foo1 {
|
|
||||||
public static void main(String[[]] argv) {
|
|
@ -1,37 +0,0 @@
|
|||||||
diff --git a/libltdl/m4/libtool.m4 b/libltdl/m4/libtool.m4
|
|
||||||
index 56666f0..126202f 100644
|
|
||||||
--- a/libltdl/m4/libtool.m4
|
|
||||||
+++ b/libltdl/m4/libtool.m4
|
|
||||||
@@ -1312,7 +1312,7 @@ ia64-*-hpux*)
|
|
||||||
rm -rf conftest*
|
|
||||||
;;
|
|
||||||
|
|
||||||
-x86_64-*kfreebsd*-gnu|x86_64-*linux*|ppc*-*linux*|powerpc*-*linux*| \
|
|
||||||
+x86_64-*kfreebsd*-gnu|x86_64-*linux*|powerpc*-*linux*| \
|
|
||||||
s390*-*linux*|s390*-*tpf*|sparc*-*linux*)
|
|
||||||
# Find out which ABI we are using.
|
|
||||||
echo 'int i;' > conftest.$ac_ext
|
|
||||||
@@ -1326,7 +1326,10 @@ s390*-*linux*|s390*-*tpf*|sparc*-*linux*)
|
|
||||||
x86_64-*linux*)
|
|
||||||
LD="${LD-ld} -m elf_i386"
|
|
||||||
;;
|
|
||||||
- ppc64-*linux*|powerpc64-*linux*)
|
|
||||||
+ powerpc64le-*linux*)
|
|
||||||
+ LD="${LD-ld} -m elf32lppclinux"
|
|
||||||
+ ;;
|
|
||||||
+ powerpc64-*linux*)
|
|
||||||
LD="${LD-ld} -m elf32ppclinux"
|
|
||||||
;;
|
|
||||||
s390x-*linux*)
|
|
||||||
@@ -1345,7 +1348,10 @@ s390*-*linux*|s390*-*tpf*|sparc*-*linux*)
|
|
||||||
x86_64-*linux*)
|
|
||||||
LD="${LD-ld} -m elf_x86_64"
|
|
||||||
;;
|
|
||||||
- ppc*-*linux*|powerpc*-*linux*)
|
|
||||||
+ powerpcle-*linux*)
|
|
||||||
+ LD="${LD-ld} -m elf64lppc"
|
|
||||||
+ ;;
|
|
||||||
+ powerpc-*linux*)
|
|
||||||
LD="${LD-ld} -m elf64ppc"
|
|
||||||
;;
|
|
||||||
s390*-*linux*|s390*-*tpf*)
|
|
@ -1,30 +0,0 @@
|
|||||||
diff --git a/libtoolize.in b/libtoolize.in
|
|
||||||
index 2bce172..16b764d 100644
|
|
||||||
--- a/libtoolize.in
|
|
||||||
+++ b/libtoolize.in
|
|
||||||
@@ -69,6 +69,7 @@
|
|
||||||
# General help using GNU software: <http://www.gnu.org/gethelp/>.
|
|
||||||
|
|
||||||
: ${TAR=tar}
|
|
||||||
+test "$TAR" = "tar" && : ${TAR_NO_OWNER=--no-same-owner}
|
|
||||||
|
|
||||||
PROGRAM=libtoolize
|
|
||||||
|
|
||||||
@@ -1279,7 +1280,7 @@ func_copy_cb ()
|
|
||||||
$RM "$my_destdir/$my_file"
|
|
||||||
if $opt_copy; then
|
|
||||||
if { ( cd "$my_srcdir" && $TAR chf - "$my_file" ) 2>/dev/null \
|
|
||||||
- | ( umask 0 && cd "$my_destdir" && $TAR xf - ) >/dev/null 2>&1; } \
|
|
||||||
+ | ( umask 0 && cd "$my_destdir" && $TAR xf - $TAR_NO_OWNER) >/dev/null 2>&1; } \
|
|
||||||
&& touch "$my_destdir/$my_file"; then
|
|
||||||
$opt_quiet || func_echo_once "$my_msg_var"
|
|
||||||
$opt_quiet || func_echo "copying $my_copy_msg"
|
|
||||||
@@ -1288,7 +1289,7 @@ func_copy_cb ()
|
|
||||||
else
|
|
||||||
if test "$my_file" = "aclocal.m4"; then
|
|
||||||
if { ( cd "$my_srcdir" && $TAR chf - "$my_file" ) 2>/dev/null \
|
|
||||||
- | ( umask 0 && cd "$my_destdir" && $TAR xf - ) >/dev/null 2>&1 ; }
|
|
||||||
+ | ( umask 0 && cd "$my_destdir" && $TAR xf - $TAR_NO_OWNER) >/dev/null 2>&1 ; }
|
|
||||||
then
|
|
||||||
$opt_quiet || func_echo_once "$my_msg_var"
|
|
||||||
$opt_quiet || func_echo "copying $my_copy_msg"
|
|
@ -1,7 +1,17 @@
|
|||||||
diff -urN libtool-2.2.10/libltdl/m4/libtool.m4 libtool-2.2.10_new/libltdl/m4/libtool.m4
|
From 78f1c485fa9833c2b02f0bb5b1a630ee67251a01 Mon Sep 17 00:00:00 2001
|
||||||
--- libtool-2.2.10/libltdl/m4/libtool.m4 2010-05-20 23:22:02.000000000 +0200
|
From: Karsten Hopp <karsten@fedoraproject.org>
|
||||||
+++ libtool-2.2.10_new/libltdl/m4/libtool.m4 2010-06-24 11:18:06.000000000 +0200
|
Date: Wed, 29 Oct 2014 13:27:27 +0100
|
||||||
@@ -2474,10 +2474,14 @@
|
Subject: [PATCH] remove /lib64 and /usr/lib64 rpath
|
||||||
|
|
||||||
|
---
|
||||||
|
m4/libtool.m4 | 5 ++++-
|
||||||
|
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/m4/libtool.m4 b/m4/libtool.m4
|
||||||
|
index 068f0d8..bb87360 100644
|
||||||
|
--- a/m4/libtool.m4
|
||||||
|
+++ b/m4/libtool.m4
|
||||||
|
@@ -2739,10 +2739,13 @@ linux* | k*bsd*-gnu | kopensolaris*-gnu | gnu*)
|
||||||
# before this can be enabled.
|
# before this can be enabled.
|
||||||
hardcode_into_libs=yes
|
hardcode_into_libs=yes
|
||||||
|
|
||||||
@ -13,7 +23,9 @@ diff -urN libtool-2.2.10/libltdl/m4/libtool.m4 libtool-2.2.10_new/libltdl/m4/lib
|
|||||||
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \[$]2)); skip = 1; } { if (!skip) print \[$]0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;s/"//g;/^$/d' | tr '\n' ' '`
|
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \[$]2)); skip = 1; } { if (!skip) print \[$]0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;s/"//g;/^$/d' | tr '\n' ' '`
|
||||||
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
||||||
+ sys_lib_dlsearch_path_spec="$sys_lib_dlsearch_path_spec $lt_ld_extra"
|
+ sys_lib_dlsearch_path_spec="$sys_lib_dlsearch_path_spec $lt_ld_extra"
|
||||||
+
|
|
||||||
fi
|
fi
|
||||||
|
|
||||||
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
||||||
|
--
|
||||||
|
1.9.3
|
||||||
|
|
33
libtool-2.4.4-race-in-aclocal-autoheader-calls.patch
Normal file
33
libtool-2.4.4-race-in-aclocal-autoheader-calls.patch
Normal file
@ -0,0 +1,33 @@
|
|||||||
|
From 2ad0598f0d8cd8c8532a2c34ea1b06c71901047d Mon Sep 17 00:00:00 2001
|
||||||
|
From: Pavel Raiskup <praiskup@redhat.com>
|
||||||
|
Date: Mon, 15 Dec 2014 13:42:25 +0100
|
||||||
|
Subject: [PATCH] tests: fix race in aclocal/autoheader calls
|
||||||
|
|
||||||
|
Put the sleep 1 after aclocal run, same as autoreconf does. This
|
||||||
|
guarantees that 'aclocal.m4' will have smaller timestamp than
|
||||||
|
'config.h.in' and avoids re-running autoheader later on.
|
||||||
|
|
||||||
|
* tests/testsuite.at (LT_AT_ACLOCAL): Sleep sec after aclocal run.
|
||||||
|
---
|
||||||
|
tests/testsuite.at | 5 +++++
|
||||||
|
1 file changed, 5 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/tests/testsuite.at b/tests/testsuite.at
|
||||||
|
index 76ed722..2a359a3 100644
|
||||||
|
--- a/tests/testsuite.at
|
||||||
|
+++ b/tests/testsuite.at
|
||||||
|
@@ -123,6 +123,11 @@ AT_DATA([acinclude.m4],
|
||||||
|
[m4_define([AC_CONFIG_MACRO_DIRS], m4_defn([AC_CONFIG_MACRO_DIR]))])
|
||||||
|
]])
|
||||||
|
LT_AT_CHECK([$ACLOCAL $1$macro_dir], [0], [ignore], [ignore])
|
||||||
|
+# After the 'aclocal' run sleep 1 second to guarantee that aclocal.m4 is going
|
||||||
|
+# to have older timestamp than other autotools later-generated files (concretely
|
||||||
|
+# for libtool case, we speak about config.h.in generated autoheader).
|
||||||
|
+# Autoreconf does the same (after the first aclocal run).
|
||||||
|
+sleep 1
|
||||||
|
AT_XFAIL_IF([test no = "$ACLOCAL"])
|
||||||
|
AT_KEYWORDS([automake])
|
||||||
|
])
|
||||||
|
--
|
||||||
|
1.9.3
|
||||||
|
|
53
libtool.spec
53
libtool.spec
@ -1,10 +1,12 @@
|
|||||||
# See the bug #429880
|
# See the bug #429880
|
||||||
%global gcc_version %(gcc -dumpversion || echo "666")
|
%global gcc_version %(gcc -dumpversion || echo "666")
|
||||||
|
|
||||||
|
%{!?runselftest:%global runselftest 1}
|
||||||
|
|
||||||
Summary: The GNU Portable Library Tool
|
Summary: The GNU Portable Library Tool
|
||||||
Name: libtool
|
Name: libtool
|
||||||
Version: 2.4.2
|
Version: 2.4.4
|
||||||
Release: 32%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+ and LGPLv2+ and GFDL
|
License: GPLv2+ and LGPLv2+ and GFDL
|
||||||
URL: http://www.gnu.org/software/libtool/
|
URL: http://www.gnu.org/software/libtool/
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
@ -12,22 +14,12 @@ Group: Development/Tools
|
|||||||
Source: http://ftp.gnu.org/gnu/libtool/libtool-%{version}.tar.xz
|
Source: http://ftp.gnu.org/gnu/libtool/libtool-%{version}.tar.xz
|
||||||
|
|
||||||
# ~> downstream
|
# ~> downstream
|
||||||
Patch0: libtool-2.2.10-rpath.patch
|
# ~> remove possibly once #1158915 gets fixed somehow
|
||||||
|
Patch0: libtool-2.4.3-rpath.patch
|
||||||
|
|
||||||
# Disable buggy tests for features we don't support.
|
# ~> downstream (proposed)
|
||||||
# ~> downstream
|
# ~> http://permalink.gmane.org/gmane.comp.gnu.libtool.patches/11808
|
||||||
Patch1: libtool-2.4.2-TEMPORARY-disable-gcj-tests.patch
|
Patch1: libtool-2.4.4-race-in-aclocal-autoheader-calls.patch
|
||||||
|
|
||||||
# Run the 'tar --no-same-owner -xf' instead of 'tar -xf'
|
|
||||||
# ~> #740079
|
|
||||||
# ~> Downstream - tar is not used in upstream 'master' branch anymore, will be
|
|
||||||
# fixed in next release.
|
|
||||||
Patch2: libtool-2.4.2-tar-no-owner.patch
|
|
||||||
|
|
||||||
# powerpc*le-linux support
|
|
||||||
# ~> upstream
|
|
||||||
# ~> `git diff c37bc1a3..8a8dfaec m4/libtool.m4`
|
|
||||||
Patch3: libtool-2.4.2-powerpcle-linux.patch
|
|
||||||
|
|
||||||
# /usr/bin/libtool includes paths within gcc's versioned directories
|
# /usr/bin/libtool includes paths within gcc's versioned directories
|
||||||
# Libtool must be rebuilt whenever a new upstream gcc is built
|
# Libtool must be rebuilt whenever a new upstream gcc is built
|
||||||
@ -95,10 +87,9 @@ Static libraries and header files for development with ltdl.
|
|||||||
%prep
|
%prep
|
||||||
%setup -n libtool-%{version} -q
|
%setup -n libtool-%{version} -q
|
||||||
%patch0 -p1 -b .rpath
|
%patch0 -p1 -b .rpath
|
||||||
%patch1 -p1 -b .temp-disable-gcj-test
|
%patch1 -p1 -b .racy-testsuite
|
||||||
%patch2 -p1 -b .tar-no-same-owner
|
|
||||||
%patch3 -p1 -b .ppc-le-support
|
|
||||||
|
|
||||||
|
autoreconf -v
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export CC=gcc
|
export CC=gcc
|
||||||
@ -121,14 +112,11 @@ export CFLAGS="$RPM_OPT_FLAGS -fPIC"
|
|||||||
|
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
for i in ChangeLog.1997 ChangeLog.1998 ChangeLog.1999 ChangeLog.2002; do
|
|
||||||
iconv -f ISO_8859-15 -t UTF8 $i > $i.tmp
|
|
||||||
mv -f $i.tmp $i
|
|
||||||
done
|
|
||||||
|
|
||||||
|
|
||||||
%check
|
%check
|
||||||
make check VERBOSE=yes
|
%if 0%{?runselftest}
|
||||||
|
make check VERBOSE=yes || { cat testsuite.log ; false ; }
|
||||||
|
%endif
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -157,7 +145,6 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
|
||||||
%doc AUTHORS COPYING NEWS README THANKS TODO ChangeLog*
|
%doc AUTHORS COPYING NEWS README THANKS TODO ChangeLog*
|
||||||
%{_infodir}/libtool.info*.gz
|
%{_infodir}/libtool.info*.gz
|
||||||
%{_mandir}/man1/libtool.1*
|
%{_mandir}/man1/libtool.1*
|
||||||
@ -165,20 +152,19 @@ fi
|
|||||||
%{_bindir}/libtool
|
%{_bindir}/libtool
|
||||||
%{_bindir}/libtoolize
|
%{_bindir}/libtoolize
|
||||||
%{_datadir}/aclocal/*.m4
|
%{_datadir}/aclocal/*.m4
|
||||||
%exclude %{_datadir}/libtool/libltdl
|
%dir %{_datadir}/libtool
|
||||||
%{_datadir}/libtool
|
%{_datadir}/libtool/build-aux
|
||||||
|
|
||||||
|
|
||||||
%files ltdl
|
%files ltdl
|
||||||
%defattr(-,root,root)
|
|
||||||
%doc libltdl/COPYING.LIB
|
%doc libltdl/COPYING.LIB
|
||||||
%{_libdir}/libltdl.so.*
|
%{_libdir}/libltdl.so.*
|
||||||
|
|
||||||
|
|
||||||
%files ltdl-devel
|
%files ltdl-devel
|
||||||
%defattr(-,root,root)
|
|
||||||
%doc libltdl/README
|
%doc libltdl/README
|
||||||
%{_datadir}/libtool/libltdl
|
%{_datadir}/libtool
|
||||||
|
%exclude %{_datadir}/libtool/build-aux
|
||||||
%{_includedir}/ltdl.h
|
%{_includedir}/ltdl.h
|
||||||
%{_includedir}/libltdl
|
%{_includedir}/libltdl
|
||||||
# .so files without version must be in -devel subpackage
|
# .so files without version must be in -devel subpackage
|
||||||
@ -186,6 +172,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 17 2015 Pavel Raiskup <praiskup@redhat.com> - 2.4.4-1
|
||||||
|
- rebase again to 2.4.4
|
||||||
|
|
||||||
* Fri Feb 06 2015 Jakub Jelinek <jakub@redhat.com> - 2.4.2-32
|
* Fri Feb 06 2015 Jakub Jelinek <jakub@redhat.com> - 2.4.2-32
|
||||||
- rebuilt for gcc 5.0.0
|
- rebuilt for gcc 5.0.0
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user