libtirpc/libtirpc-0.1.7-gssglue.patch

29 lines
1.2 KiB
Diff

diff -up libtirpc-0.1.7/configure.in.orig libtirpc-0.1.7/configure.in
--- libtirpc-0.1.7/configure.in.orig 2007-10-17 12:03:25.000000000 -0400
+++ libtirpc-0.1.7/configure.in 2007-10-17 12:07:18.000000000 -0400
@@ -10,6 +10,10 @@ AC_ARG_ENABLE(gss,[ --enable-gss
*) AC_MSG_ERROR(bad value ${enableval} for --enable-gss) ;;
esac],[gss=false])
AM_CONDITIONAL(GSS, test x$gss = xtrue)
+if test x$gss = xtrue; then
+ PKG_CHECK_MODULES(GSSGLUE, libgssglue, [],
+ AC_MSG_ERROR([Unable to locate information required to use libgssglue.]))
+fi
AC_PROG_CC
diff -up libtirpc-0.1.7/src/Makefile.am.orig libtirpc-0.1.7/src/Makefile.am
--- libtirpc-0.1.7/src/Makefile.am.orig 2007-10-17 12:03:25.000000000 -0400
+++ libtirpc-0.1.7/src/Makefile.am 2007-10-17 12:06:19.000000000 -0400
@@ -29,8 +29,8 @@ libtirpc_la_SOURCES += xdr.c xdr_rec.c x
## Secure-RPC
if GSS
libtirpc_la_SOURCES += auth_gss.c authgss_prot.c svc_auth_gss.c
- libtirpc_la_LDFLAGS += -lgssapi
- libtirpc_la_CFLAGS = -DHAVE_RPCSEC_GSS
+ libtirpc_la_LDFLAGS += $(GSSGLUE_LIBS)
+ libtirpc_la_CFLAGS = -DHAVE_RPCSEC_GSS -I/usr/include/gssglue $(GSSGLUE_LIBS)
endif
## libtirpc_a_SOURCES += key_call.c key_prot_xdr.c getpublickey.c