Updated to latest upstream version: 0.2.0
This commit is contained in:
parent
93755a9824
commit
f56c333ccf
@ -3,3 +3,4 @@ libtirpc-0.1.8.tar.bz2
|
|||||||
libtirpc-0.1.9.tar.bz2
|
libtirpc-0.1.9.tar.bz2
|
||||||
libtirpc-0.1.10.tar.bz2
|
libtirpc-0.1.10.tar.bz2
|
||||||
libtirpc-0.1.11.tar.bz2
|
libtirpc-0.1.11.tar.bz2
|
||||||
|
libtirpc-0.2.0.tar.bz2
|
||||||
|
@ -1,65 +0,0 @@
|
|||||||
diff --git a/src/svc.c b/src/svc.c
|
|
||||||
commit 8f840586d9ceba6d682ab424ae48a0cf08f7ea41
|
|
||||||
Author: Jeff Layton <jlayton@redhat.com>
|
|
||||||
Date: Mon Apr 20 12:23:25 2009 -0400
|
|
||||||
|
|
||||||
http://web.mit.edu/kerberos/advisories/MITKRB5-SA-2006-002-rpc.txt
|
|
||||||
|
|
||||||
Signed-off-by: Jeff Layton <jlayton@redhat.com>
|
|
||||||
Signed-off-by: Steve Dickson <steved@redhat.com>
|
|
||||||
|
|
||||||
commit 54ad86c29bcd40dbb6b9f1f9e611778add4227ea
|
|
||||||
Author: Jeff Layton <jlayton@redhat.com>
|
|
||||||
Date: Mon Apr 20 12:22:22 2009 -0400
|
|
||||||
|
|
||||||
[PATCH] port fix for CVE-2008-0947
|
|
||||||
|
|
||||||
Adds bounds checking of fd passed into makefd_xprt against FD_SETSIZE.
|
|
||||||
|
|
||||||
http://web.mit.edu/kerberos/advisories/MITKRB5-SA-2008-002.txt
|
|
||||||
|
|
||||||
This was reported against MIT krb5 code, but it looks like libtirpc
|
|
||||||
has a similar problem.
|
|
||||||
|
|
||||||
Signed-off-by: Jeff Layton <jlayton@redhat.com>
|
|
||||||
Signed-off-by: Steve Dickson <steved@redhat.com>
|
|
||||||
-----------------------------------------------------
|
|
||||||
--- a/src/svc.c
|
|
||||||
+++ b/src/svc.c
|
|
||||||
@@ -78,6 +78,7 @@ static struct svc_callout
|
|
||||||
|
|
||||||
extern rwlock_t svc_lock;
|
|
||||||
extern rwlock_t svc_fd_lock;
|
|
||||||
+extern struct svc_auth_ops svc_auth_gss_ops;
|
|
||||||
|
|
||||||
static struct svc_callout *svc_find (rpcprog_t, rpcvers_t,
|
|
||||||
struct svc_callout **, char *);
|
|
||||||
@@ -715,6 +716,11 @@ svc_getreq_common (fd)
|
|
||||||
SVC_DESTROY (xprt);
|
|
||||||
break;
|
|
||||||
}
|
|
||||||
+ else if ((xprt->xp_auth != NULL) &&
|
|
||||||
+ (xprt->xp_auth->svc_ah_ops != &svc_auth_gss_ops))
|
|
||||||
+ {
|
|
||||||
+ xprt->xp_auth = NULL;
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
while (stat == XPRT_MOREREQS);
|
|
||||||
}
|
|
||||||
diff --git a/src/svc_vc.c b/src/svc_vc.c
|
|
||||||
index 44d3497..7a1f5c3 100644
|
|
||||||
--- a/src/svc_vc.c
|
|
||||||
+++ b/src/svc_vc.c
|
|
||||||
@@ -261,6 +261,12 @@ makefd_xprt(fd, sendsize, recvsize)
|
|
||||||
|
|
||||||
assert(fd != -1);
|
|
||||||
|
|
||||||
+ if (fd >= FD_SETSIZE) {
|
|
||||||
+ warnx("svc_vc: makefd_xprt: fd too high\n");
|
|
||||||
+ xprt = NULL;
|
|
||||||
+ goto done;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
xprt = mem_alloc(sizeof(SVCXPRT));
|
|
||||||
if (xprt == NULL) {
|
|
||||||
warnx("svc_vc: makefd_xprt: out of memory");
|
|
@ -1,11 +0,0 @@
|
|||||||
--- libtirpc-0.1.7/src/Makefile.am.orig 2005-05-18 01:10:50.000000000 -0400
|
|
||||||
+++ libtirpc-0.1.7/src/Makefile.am 2006-08-09 15:15:31.000000000 -0400
|
|
||||||
@@ -11,7 +11,7 @@ INCLUDES = -I../tirpc -DPORTMAP -DINET6
|
|
||||||
|
|
||||||
lib_LTLIBRARIES = libtirpc.la
|
|
||||||
|
|
||||||
-libtirpc_la_LDFLAGS = -lnsl -lpthread -version-info 1:9:0
|
|
||||||
+libtirpc_la_LDFLAGS = -lnsl -lpthread -version-info 1:11:0
|
|
||||||
|
|
||||||
libtirpc_la_SOURCES = auth_none.c auth_unix.c authunix_prot.c bindresvport.c clnt_bcast.c \
|
|
||||||
clnt_dg.c clnt_generic.c clnt_perror.c clnt_raw.c clnt_simple.c \
|
|
10
libtirpc-0.2.0-rc1.patch
Normal file
10
libtirpc-0.2.0-rc1.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
diff --git a/Makefile.am b/Makefile.am
|
||||||
|
index 3e50d3c..7f5f37b 100644
|
||||||
|
--- a/Makefile.am
|
||||||
|
+++ b/Makefile.am
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-SUBDIRS = src man
|
||||||
|
+SUBDIRS = src man doc
|
||||||
|
|
||||||
|
nobase_include_HEADERS = tirpc/netconfig.h \
|
||||||
|
tirpc/rpcsvc/crypt.x \
|
File diff suppressed because it is too large
Load Diff
@ -1,6 +1,6 @@
|
|||||||
Name: libtirpc
|
Name: libtirpc
|
||||||
Version: 0.1.11
|
Version: 0.2.0
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Transport Independent RPC Library
|
Summary: Transport Independent RPC Library
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
License: SISSL and BSD
|
License: SISSL and BSD
|
||||||
@ -30,10 +30,7 @@ Group: Development/Libraries
|
|||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Requires(devel): pkgconfig man
|
Requires(devel): pkgconfig man
|
||||||
|
|
||||||
Patch1: libtirpc-0.1.12-rc1.patch
|
Patch1: libtirpc-0.2.0-rc1.patch
|
||||||
|
|
||||||
Patch100: libtirpc-0.1.7-compile.patch
|
|
||||||
Patch101: libtirpc-changetoBSDlicense.patch
|
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
This package includes header files and libraries necessary for
|
This package includes header files and libraries necessary for
|
||||||
@ -44,9 +41,6 @@ developing programs which use the tirpc library.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
|
||||||
%patch100 -p1
|
|
||||||
%patch101 -p1
|
|
||||||
|
|
||||||
# Remove .orig files
|
# Remove .orig files
|
||||||
find . -name "*.orig" | xargs rm -f
|
find . -name "*.orig" | xargs rm -f
|
||||||
|
|
||||||
@ -92,21 +86,11 @@ rm -rf %{buildroot}
|
|||||||
%files devel
|
%files devel
|
||||||
%defattr(0644,root,root,755)
|
%defattr(0644,root,root,755)
|
||||||
%dir %{_includedir}/tirpc
|
%dir %{_includedir}/tirpc
|
||||||
%dir %{_includedir}/tirpc/misc
|
|
||||||
%dir %{_includedir}/tirpc/rpc
|
%dir %{_includedir}/tirpc/rpc
|
||||||
%dir %{_includedir}/tirpc/rpcsvc
|
%dir %{_includedir}/tirpc/rpcsvc
|
||||||
%{_libdir}/libtirpc.so
|
%{_libdir}/libtirpc.so
|
||||||
%{_libdir}/pkgconfig/libtirpc.pc
|
%{_libdir}/pkgconfig/libtirpc.pc
|
||||||
%{_includedir}/tirpc/fpmath.h
|
|
||||||
%{_includedir}/tirpc/getpeereid.h
|
|
||||||
%{_includedir}/tirpc/libc_private.h
|
|
||||||
%{_includedir}/tirpc/misc/event.h
|
|
||||||
%{_includedir}/tirpc/misc/queue.h
|
|
||||||
%{_includedir}/tirpc/misc/socket.h
|
|
||||||
%{_includedir}/tirpc/namespace.h
|
|
||||||
%{_includedir}/tirpc/netconfig.h
|
%{_includedir}/tirpc/netconfig.h
|
||||||
%{_includedir}/tirpc/nss_tls.h
|
|
||||||
%{_includedir}/tirpc/reentrant.h
|
|
||||||
%{_includedir}/tirpc/rpc/auth.h
|
%{_includedir}/tirpc/rpc/auth.h
|
||||||
%{_includedir}/tirpc/rpc/auth_des.h
|
%{_includedir}/tirpc/rpc/auth_des.h
|
||||||
%{_includedir}/tirpc/rpc/auth_gss.h
|
%{_includedir}/tirpc/rpc/auth_gss.h
|
||||||
@ -137,11 +121,12 @@ rm -rf %{buildroot}
|
|||||||
%{_includedir}/tirpc/rpc/xdr.h
|
%{_includedir}/tirpc/rpc/xdr.h
|
||||||
%{_includedir}/tirpc/rpcsvc/crypt.h
|
%{_includedir}/tirpc/rpcsvc/crypt.h
|
||||||
%{_includedir}/tirpc/rpcsvc/crypt.x
|
%{_includedir}/tirpc/rpcsvc/crypt.x
|
||||||
%{_includedir}/tirpc/spinlock.h
|
|
||||||
%{_includedir}/tirpc/un-namespace.h
|
|
||||||
%{_mandir}/*/*
|
%{_mandir}/*/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 29 2009 Steve Dickson <steved@redhat.com> 0.2.0-1
|
||||||
|
- Updated to latest upstream version: 0.2.0
|
||||||
|
|
||||||
* Tue May 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> 0.1.11-3
|
* Tue May 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> 0.1.11-3
|
||||||
- Replace the Sun RPC license with the BSD license, with the explicit permission of Sun Microsystems
|
- Replace the Sun RPC license with the BSD license, with the explicit permission of Sun Microsystems
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user