Update to latest upstream version 0.1.9
This commit is contained in:
parent
7d886e50ca
commit
e7c6e1b122
@ -1,19 +0,0 @@
|
|||||||
--- libtirpc-0.1.7/src/svc_run.c.orig 2005-05-18 01:10:50.000000000 -0400
|
|
||||||
+++ libtirpc-0.1.7/src/svc_run.c 2007-07-09 12:52:23.000000000 -0400
|
|
||||||
@@ -51,14 +51,14 @@ svc_run()
|
|
||||||
struct timeval timeout;
|
|
||||||
extern rwlock_t svc_fd_lock;
|
|
||||||
|
|
||||||
- timeout.tv_sec = 30;
|
|
||||||
- timeout.tv_usec = 0;
|
|
||||||
|
|
||||||
for (;;) {
|
|
||||||
rwlock_rdlock(&svc_fd_lock);
|
|
||||||
readfds = svc_fdset;
|
|
||||||
cleanfds = svc_fdset;
|
|
||||||
rwlock_unlock(&svc_fd_lock);
|
|
||||||
+ timeout.tv_sec = 30;
|
|
||||||
+ timeout.tv_usec = 0;
|
|
||||||
switch (select(svc_maxfd+1, &readfds, NULL, NULL, &timeout)) {
|
|
||||||
case -1:
|
|
||||||
FD_ZERO(&readfds);
|
|
@ -1,97 +0,0 @@
|
|||||||
--- libtirpc-0.1.7/src/svc_auth_none.c.orig 2006-08-14 11:52:49.000000000 -0400
|
|
||||||
+++ libtirpc-0.1.7/src/svc_auth_none.c 2006-08-14 11:52:53.000000000 -0400
|
|
||||||
@@ -0,0 +1,73 @@
|
|
||||||
+/*
|
|
||||||
+ svc_auth_none.c
|
|
||||||
+
|
|
||||||
+ Copyright (c) 2000 The Regents of the University of Michigan.
|
|
||||||
+ All rights reserved.
|
|
||||||
+
|
|
||||||
+ Copyright (c) 2000 Dug Song <dugsong@UMICH.EDU>.
|
|
||||||
+ All rights reserved, all wrongs reversed.
|
|
||||||
+
|
|
||||||
+ Redistribution and use in source and binary forms, with or without
|
|
||||||
+ modification, are permitted provided that the following conditions
|
|
||||||
+ are met:
|
|
||||||
+
|
|
||||||
+ 1. Redistributions of source code must retain the above copyright
|
|
||||||
+ notice, this list of conditions and the following disclaimer.
|
|
||||||
+ 2. Redistributions in binary form must reproduce the above copyright
|
|
||||||
+ notice, this list of conditions and the following disclaimer in the
|
|
||||||
+ documentation and/or other materials provided with the distribution.
|
|
||||||
+ 3. Neither the name of the University nor the names of its
|
|
||||||
+ contributors may be used to endorse or promote products derived
|
|
||||||
+ from this software without specific prior written permission.
|
|
||||||
+
|
|
||||||
+ THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
||||||
+ WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
||||||
+ MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
|
|
||||||
+ DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
|
|
||||||
+ FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
|
|
||||||
+ CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
|
|
||||||
+ SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
|
|
||||||
+ BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
|
|
||||||
+ LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
|
|
||||||
+ NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
|
|
||||||
+ SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
||||||
+
|
|
||||||
+ $Id: svc_auth_none.c,v 1.1 2004/10/22 17:24:30 bfields Exp $
|
|
||||||
+ */
|
|
||||||
+
|
|
||||||
+#include <rpc/rpc.h>
|
|
||||||
+
|
|
||||||
+static bool_t svcauth_none_destroy();
|
|
||||||
+static bool_t svcauth_none_wrap();
|
|
||||||
+
|
|
||||||
+struct svc_auth_ops svc_auth_none_ops = {
|
|
||||||
+ svcauth_none_wrap,
|
|
||||||
+ svcauth_none_wrap,
|
|
||||||
+ svcauth_none_destroy
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+SVCAUTH svc_auth_none = {
|
|
||||||
+ &svc_auth_none_ops,
|
|
||||||
+ NULL,
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+static bool_t
|
|
||||||
+svcauth_none_destroy(SVCAUTH *auth)
|
|
||||||
+{
|
|
||||||
+ return (TRUE);
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static bool_t
|
|
||||||
+svcauth_none_wrap(SVCAUTH *auth, XDR *xdrs, xdrproc_t xdr_func,
|
|
||||||
+ caddr_t xdr_ptr)
|
|
||||||
+{
|
|
||||||
+ return ((*xdr_func)(xdrs, xdr_ptr));
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+enum auth_stat
|
|
||||||
+_svcauth_none(struct svc_req *rqst, struct rpc_msg *msg)
|
|
||||||
+{
|
|
||||||
+ rqst->rq_xprt->xp_auth = &svc_auth_none;
|
|
||||||
+
|
|
||||||
+ return (AUTH_OK);
|
|
||||||
+}
|
|
||||||
--- libtirpc-0.1.7/src/Makefile.am.orig 2006-08-11 12:58:28.000000000 -0400
|
|
||||||
+++ libtirpc-0.1.7/src/Makefile.am 2006-08-14 11:54:20.000000000 -0400
|
|
||||||
@@ -28,7 +28,8 @@ libtirpc_la_SOURCES += xdr.c xdr_rec.c x
|
|
||||||
|
|
||||||
## Secure-RPC
|
|
||||||
if GSS
|
|
||||||
- libtirpc_la_SOURCES += auth_gss.c authgss_prot.c svc_auth_gss.c
|
|
||||||
+ libtirpc_la_SOURCES += auth_gss.c authgss_prot.c svc_auth_gss.c \
|
|
||||||
+ svc_auth_none.c
|
|
||||||
libtirpc_la_LDFLAGS += $(GSSGLUE_LIBS)
|
|
||||||
libtirpc_la_CFLAGS = -DHAVE_RPCSEC_GSS $(GSSGLUE_CFLAGS)
|
|
||||||
endif
|
|
||||||
@@ -49,7 +50,7 @@ $(libtirpc_la_OBJECTS) :auth_none.c auth
|
|
||||||
svc_raw.c svc_run.c svc_simple.c svc_vc.c \
|
|
||||||
xdr.c xdr_rec.c xdr_array.c xdr_float.c xdr_mem.c xdr_reference.c xdr_stdio.c \
|
|
||||||
auth_gss.c authgss_prot.c svc_auth_gss.c getpeereid.c \
|
|
||||||
- auth_time.c auth_des.c authdes_prot.c
|
|
||||||
+ auth_time.c auth_des.c authdes_prot.c svc_auth_none.c
|
|
||||||
|
|
||||||
else
|
|
||||||
$(libtirpc_la_OBJECTS) :auth_none.c auth_unix.c authunix_prot.c bindresvport.c clnt_bcast.c \
|
|
@ -1,23 +0,0 @@
|
|||||||
commit 276e782ef9bb9b7c647edb91707c382e5a38c7c8
|
|
||||||
Author: CHIKAMA Masaki <masaki.chikama@gmail.com>
|
|
||||||
Date: Fri Jun 27 14:08:55 2008 -0400
|
|
||||||
|
|
||||||
Added super-H(sh3,sh4) architecture support
|
|
||||||
|
|
||||||
Signed-off-by: CHIKAMA Masaki <masaki.chikama@gmail.com>
|
|
||||||
Signed-off-by: Steve Dickson <steved@redhat.com>
|
|
||||||
|
|
||||||
diff --git a/src/xdr_float.c b/src/xdr_float.c
|
|
||||||
index d8b22e6..4693ef0 100644
|
|
||||||
--- a/src/xdr_float.c
|
|
||||||
+++ b/src/xdr_float.c
|
|
||||||
@@ -59,7 +59,8 @@
|
|
||||||
defined(__mips__) || defined(__ns32k__) || defined(__alpha__) || \
|
|
||||||
defined(__arm32__) || defined(__ppc__) || defined(__ia64__) || \
|
|
||||||
defined(__arm26__) || defined(__sparc64__) || defined(__amd64__) || \
|
|
||||||
- defined(__powerpc__) || defined(__s390__) || defined(__arm__)
|
|
||||||
+ defined(__powerpc__) || defined(__s390__) || defined(__arm__) || \
|
|
||||||
+ defined(__sh__)
|
|
||||||
#include <bits/endian.h>
|
|
||||||
#define IEEEFP
|
|
||||||
#endif
|
|
@ -1,5 +1,5 @@
|
|||||||
Name: libtirpc
|
Name: libtirpc
|
||||||
Version: 0.1.8
|
Version: 0.1.9
|
||||||
Release: 2%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Transport Independent RPC Library
|
Summary: Transport Independent RPC Library
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -30,10 +30,6 @@ Group: Development/Libraries
|
|||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Requires(devel): pkgconfig man
|
Requires(devel): pkgconfig man
|
||||||
|
|
||||||
Patch1: libtirpc-0.1.7-svcauthnone.patch
|
|
||||||
Patch2: libtirpc-0.1.7-svc-run.patch
|
|
||||||
Patch3: libtirpc-0.1.8-superH-support.patch
|
|
||||||
|
|
||||||
Patch100: libtirpc-0.1.7-compile.patch
|
Patch100: libtirpc-0.1.7-compile.patch
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
@ -43,10 +39,6 @@ developing programs which use the tirpc library.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1
|
|
||||||
%patch2 -p1
|
|
||||||
# 446559: Add super-H(sh3,4) architecture support.
|
|
||||||
%patch3 -p1
|
|
||||||
|
|
||||||
%patch100 -p1
|
%patch100 -p1
|
||||||
|
|
||||||
@ -145,6 +137,9 @@ rm -rf %{buildroot}
|
|||||||
%{_mandir}/*/*
|
%{_mandir}/*/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 9 2008 Steve Dickson <steved@redhat.com> 0.1.9-1
|
||||||
|
- Update to latest upstream version 0.1.9
|
||||||
|
|
||||||
* Fri Jun 27 2008 Steve Dickson <steved@redhat.com> 0.1.8-2
|
* Fri Jun 27 2008 Steve Dickson <steved@redhat.com> 0.1.8-2
|
||||||
- Added super-H(sh3,4) architecture support (bz 446559)
|
- Added super-H(sh3,4) architecture support (bz 446559)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user