Updated to latest upstream RC release: libtirpc-0.2.3-rc3
Signed-off-by: Steve Dickson <steved@redhat.com>
This commit is contained in:
parent
09cd081d59
commit
d1e6fefd83
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,4 @@
|
|||||||
cscope*
|
cscope*
|
||||||
/libtirpc-0.2.2.tar.bz2
|
/libtirpc-0.2.2.tar.bz2
|
||||||
|
libtirpc-0.2.2/
|
||||||
|
x86_64/
|
||||||
|
@ -1,21 +0,0 @@
|
|||||||
commit 9a00d8b6adef347619ab13b15303b523d78ca02f
|
|
||||||
Author: Peter Simons <simons@cryp.to>
|
|
||||||
Date: Mon Mar 19 15:54:54 2012 -0400
|
|
||||||
|
|
||||||
Makefile.am: install target in doc/Makefile.am doesn't honor sysconfdir
|
|
||||||
|
|
||||||
Signed-off-by: Steve Dickson <steved@redhat.com>
|
|
||||||
|
|
||||||
diff --git a/doc/Makefile.am b/doc/Makefile.am
|
|
||||||
index cc4fa76..f8c88b5 100644
|
|
||||||
--- a/doc/Makefile.am
|
|
||||||
+++ b/doc/Makefile.am
|
|
||||||
@@ -1,5 +1,5 @@
|
|
||||||
|
|
||||||
install: install-am
|
|
||||||
- $(mkinstalldirs) $(DESTDIR)/etc
|
|
||||||
- cp -p ./etc_netconfig $(DESTDIR)/etc/netconfig
|
|
||||||
- chmod 0644 $(DESTDIR)/etc/netconfig
|
|
||||||
+ $(mkinstalldirs) $(DESTDIR)/$(sysconfdir)
|
|
||||||
+ cp -p ./etc_netconfig $(DESTDIR)/$(sysconfdir)/netconfig
|
|
||||||
+ chmod 0644 $(DESTDIR)/$(sysconfdir)/netconfig
|
|
@ -1,28 +0,0 @@
|
|||||||
diff -up libtirpc-0.2.2/src/svc_dg.c.orig libtirpc-0.2.2/src/svc_dg.c
|
|
||||||
--- libtirpc-0.2.2/src/svc_dg.c.orig 2011-07-19 15:02:41.087631000 -0400
|
|
||||||
+++ libtirpc-0.2.2/src/svc_dg.c 2011-07-19 15:04:43.154243000 -0400
|
|
||||||
@@ -254,8 +254,8 @@ svc_dg_reply(xprt, msg)
|
|
||||||
XDR_SETPOS(xdrs, 0);
|
|
||||||
msg->rm_xid = su->su_xid;
|
|
||||||
if (xdr_replymsg(xdrs, msg) &&
|
|
||||||
- (!has_args ||
|
|
||||||
- (SVCAUTH_WRAP(xprt->xp_auth, xdrs, xdr_results, xdr_location)))) {
|
|
||||||
+ (!has_args || (xprt->xp_auth &&
|
|
||||||
+ SVCAUTH_WRAP(xprt->xp_auth, xdrs, xdr_results, xdr_location)))) {
|
|
||||||
struct msghdr *msg = &su->su_msghdr;
|
|
||||||
struct iovec iov;
|
|
||||||
|
|
||||||
diff -up libtirpc-0.2.2/src/svc_vc.c.orig libtirpc-0.2.2/src/svc_vc.c
|
|
||||||
--- libtirpc-0.2.2/src/svc_vc.c.orig 2011-07-19 15:05:28.577588000 -0400
|
|
||||||
+++ libtirpc-0.2.2/src/svc_vc.c 2011-07-19 15:05:40.058928000 -0400
|
|
||||||
@@ -698,8 +698,8 @@ svc_vc_reply(xprt, msg)
|
|
||||||
msg->rm_xid = cd->x_id;
|
|
||||||
rstat = FALSE;
|
|
||||||
if (xdr_replymsg(xdrs, msg) &&
|
|
||||||
- (!has_args ||
|
|
||||||
- (SVCAUTH_WRAP(xprt->xp_auth, xdrs, xdr_results, xdr_location)))) {
|
|
||||||
+ (!has_args || (xprt->xp_auth &&
|
|
||||||
+ SVCAUTH_WRAP(xprt->xp_auth, xdrs, xdr_results, xdr_location)))) {
|
|
||||||
rstat = TRUE;
|
|
||||||
}
|
|
||||||
(void)xdrrec_endofrecord(xdrs, TRUE);
|
|
1312
libtirpc-0.2.3-rc3.patch
Normal file
1312
libtirpc-0.2.3-rc3.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Name: libtirpc
|
Name: libtirpc
|
||||||
Version: 0.2.2
|
Version: 0.2.2
|
||||||
Release: 31%{?dist}
|
Release: 41%{?dist}
|
||||||
Summary: Transport Independent RPC Library
|
Summary: Transport Independent RPC Library
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
License: SISSL and BSD
|
License: SISSL and BSD
|
||||||
@ -11,9 +11,7 @@ URL: http://nfsv4.bullopensource.org/
|
|||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Source0: http://downloads.sourceforge.net/libtirpc/libtirpc-%{version}.tar.bz2
|
Source0: http://downloads.sourceforge.net/libtirpc/libtirpc-%{version}.tar.bz2
|
||||||
|
|
||||||
Patch001: libtirpc-0.2.3-rc1.patch
|
Patch001: libtirpc-0.2.3-rc3.patch
|
||||||
Patch002: libtirpc-0.2.2-wrap-segfault.patch
|
|
||||||
Patch003: libtirpc-0.2.2-doc-Makefile.patch
|
|
||||||
|
|
||||||
BuildRequires: automake, autoconf, libtool, pkgconfig
|
BuildRequires: automake, autoconf, libtool, pkgconfig
|
||||||
BuildRequires: libgssglue-devel
|
BuildRequires: libgssglue-devel
|
||||||
@ -45,8 +43,6 @@ developing programs which use the tirpc library.
|
|||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch001 -p1
|
%patch001 -p1
|
||||||
%patch002 -p1
|
|
||||||
%patch003 -p1
|
|
||||||
|
|
||||||
# Remove .orig files
|
# Remove .orig files
|
||||||
find . -name "*.orig" | xargs rm -f
|
find . -name "*.orig" | xargs rm -f
|
||||||
@ -135,7 +131,10 @@ rm -rf %{buildroot}
|
|||||||
%{_mandir}/*/*
|
%{_mandir}/*/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Mon Mar 19 2012 Steve Dickson <steved@redhat.com> 0.2.1-3
|
* Thu Apr 26 2012 Steve Dickson <steved@redhat.com> 0.2.1-4.1
|
||||||
|
- Updated to latest upstream RC release: libtirpc-0.2.3-rc3
|
||||||
|
|
||||||
|
* Mon Mar 19 2012 Steve Dickson <steved@redhat.com> 0.2.1-3.1
|
||||||
- Fixed the install path in doc/Makefile.am
|
- Fixed the install path in doc/Makefile.am
|
||||||
|
|
||||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.2-2.1
|
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.2-2.1
|
||||||
|
Loading…
Reference in New Issue
Block a user