Install man pages

This commit is contained in:
Steve Dickson 2008-03-13 09:59:17 +00:00
parent e27db56a92
commit d09e210b3d
2 changed files with 58 additions and 2 deletions

View File

@ -0,0 +1,32 @@
diff -up /dev/null libtirpc-0.1.7/man/Makefile.am
--- /dev/null 2008-03-07 09:39:09.380146390 -0500
+++ libtirpc-0.1.7/man/Makefile.am 2008-03-12 14:44:01.000000000 -0400
@@ -0,0 +1,9 @@
+
+man5_MANS = netconfig.5
+man_MANS = bindresvport.3t des_crypt.3t getnetconfig.3t getnetpath.3t \
+ getrpcent.3t getrpcport.3t rpc.3t rpc_clnt_auth.3t rpc_clnt_calls.3t \
+ rpc_clnt_create.3t rpc_secure.3t rpc_soc.3t rpc_svc_calls.3t \
+ rpc_svc_create.3t rpc_svc_err.3t rpc_svc_reg.3t rpc_xdr.3t rtime.3t
+
+EXTRA_DIST = $(man5t_MANS) $(man3t_MANS)
+
diff -up libtirpc-0.1.7/configure.in.orig libtirpc-0.1.7/configure.in
--- libtirpc-0.1.7/configure.in.orig 2008-03-12 14:42:30.000000000 -0400
+++ libtirpc-0.1.7/configure.in 2008-03-12 14:43:15.000000000 -0400
@@ -26,5 +26,5 @@ AC_CHECK_HEADERS([arpa/inet.h fcntl.h li
AC_CHECK_LIB([pthread], [pthread_create])
-AC_CONFIG_FILES([Makefile src/Makefile])
+AC_CONFIG_FILES([Makefile src/Makefile man/Makefile])
AC_OUTPUT(libtirpc.pc)
diff -up libtirpc-0.1.7/Makefile.am.orig libtirpc-0.1.7/Makefile.am
--- libtirpc-0.1.7/Makefile.am.orig 2008-03-12 14:42:30.000000000 -0400
+++ libtirpc-0.1.7/Makefile.am 2008-03-12 14:43:15.000000000 -0400
@@ -1,4 +1,4 @@
-SUBDIRS = src
+SUBDIRS = src man
nobase_include_HEADERS = tirpc/un-namespace.h \
tirpc/spinlock.h \

View File

@ -1,6 +1,6 @@
Name: libtirpc
Version: 0.1.7
Release: 17%{?dist}
Release: 18%{?dist}
Summary: Transport Independent RPC Library
Group: System Environment/Libraries
License: GPL
@ -28,7 +28,7 @@ by almost 70 vendors on all major operating systems. TS-RPC source code
Summary: Development files for the libtirpc library
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Requires: pkgconfig
Requires(devel): pkgconfig man
Patch1: libtirpc-0.1.7-netconfig.patch
Patch2: libtirpc-0.1.7-gssglue.patch
@ -46,6 +46,7 @@ Patch13: libtirpc-0.1.7-svc-rtaddr.patch
Patch14: libtirpc-0.1.7-arm.patch
Patch15: libtirpc-0.1.7-bufoverflow.patch
Patch16: libtirpc-0.1.7-libtirpc-pc.patch
Patch17: libtirpc-0.1.7-man-install.patch
Patch100: libtirpc-0.1.7-compile.patch
@ -72,6 +73,7 @@ developing programs which use the tirpc library.
%patch14 -p1
%patch15 -p1
%patch16 -p1
%patch17 -p1
%patch100 -p1
@ -81,6 +83,10 @@ find . -name "*.orig" | xargs rm -f
%build
autoreconf -fisv
%configure --enable-gss
for i in man/*.3; do
mv $i "$i"t
done
exit
make all
%install
@ -90,10 +96,24 @@ make install DESTDIR=%{buildroot}
# Don't package .a or .la files
rm -f %{buildroot}%{_libdir}/*.{a,la}
# Creat the man diretory
mv %{buildroot}%{_mandir}/man3 %{buildroot}%{_mandir}/man3t
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%post devel
# Register the new man section
#if [ "$1" -eq 1 ]; then
# makewhatis -s 3t
#fi
%postun devel
# Remove the existance of the man section
#makewhatis -s 3
%clean
rm -rf %{buildroot}
@ -153,8 +173,12 @@ rm -rf %{buildroot}
%{_includedir}/tirpc/rpcsvc/crypt.x
%{_includedir}/tirpc/spinlock.h
%{_includedir}/tirpc/un-namespace.h
%{_mandir}/*/*
%changelog
* Wed Mar 12 2008 Steve Dickson <steved@redhat.com> 0.1.7-18
- Install man pages
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.7-17
- Autorebuild for GCC 4.3