Switch the libgssapi dependency to libgssglue

This commit is contained in:
Steve Dickson 2007-10-17 18:27:04 +00:00
parent cd95ac93ca
commit cb948a3f79
3 changed files with 27 additions and 22 deletions

View File

@ -1,26 +1,28 @@
--- libtirpc-0.1.7/src/Makefile.am.orig 2006-08-11 11:50:28.000000000 -0400 diff -up libtirpc-0.1.7/configure.in.orig libtirpc-0.1.7/configure.in
+++ libtirpc-0.1.7/src/Makefile.am 2006-08-11 12:48:29.000000000 -0400 --- libtirpc-0.1.7/configure.in.orig 2007-10-17 12:03:25.000000000 -0400
+++ libtirpc-0.1.7/configure.in 2007-10-17 12:07:18.000000000 -0400
@@ -10,6 +10,10 @@ AC_ARG_ENABLE(gss,[ --enable-gss
*) AC_MSG_ERROR(bad value ${enableval} for --enable-gss) ;;
esac],[gss=false])
AM_CONDITIONAL(GSS, test x$gss = xtrue)
+if test x$gss = xtrue; then
+ PKG_CHECK_MODULES(GSSGLUE, libgssglue, [],
+ AC_MSG_ERROR([Unable to locate information required to use libgssglue.]))
+fi
AC_PROG_CC
diff -up libtirpc-0.1.7/src/Makefile.am.orig libtirpc-0.1.7/src/Makefile.am
--- libtirpc-0.1.7/src/Makefile.am.orig 2007-10-17 12:03:25.000000000 -0400
+++ libtirpc-0.1.7/src/Makefile.am 2007-10-17 12:06:19.000000000 -0400
@@ -29,8 +29,8 @@ libtirpc_la_SOURCES += xdr.c xdr_rec.c x @@ -29,8 +29,8 @@ libtirpc_la_SOURCES += xdr.c xdr_rec.c x
## Secure-RPC ## Secure-RPC
if GSS if GSS
libtirpc_la_SOURCES += auth_gss.c authgss_prot.c svc_auth_gss.c libtirpc_la_SOURCES += auth_gss.c authgss_prot.c svc_auth_gss.c
- libtirpc_la_LDFLAGS += -lgssapi - libtirpc_la_LDFLAGS += -lgssapi
- libtirpc_la_CFLAGS = -DHAVE_RPCSEC_GSS - libtirpc_la_CFLAGS = -DHAVE_RPCSEC_GSS
+ libtirpc_la_LDFLAGS += $(GSSAPI_LIBS) + libtirpc_la_LDFLAGS += $(GSSGLUE_LIBS)
+ libtirpc_la_CFLAGS = -DHAVE_RPCSEC_GSS $(GSSAPI_CFLAGS) + libtirpc_la_CFLAGS = -DHAVE_RPCSEC_GSS -I/usr/include/gssglue $(GSSGLUE_LIBS)
endif endif
## libtirpc_a_SOURCES += key_call.c key_prot_xdr.c getpublickey.c ## libtirpc_a_SOURCES += key_call.c key_prot_xdr.c getpublickey.c
--- libtirpc-0.1.7/configure.in.orig 2006-08-11 11:48:36.000000000 -0400
+++ libtirpc-0.1.7/configure.in 2006-08-11 12:07:15.000000000 -0400
@@ -10,6 +10,10 @@ AC_ARG_ENABLE(gss,[ --enable-gss
*) AC_MSG_ERROR(bad value ${enableval} for --enable-gss) ;;
esac],[gss=false])
AM_CONDITIONAL(GSS, test x$gss = xtrue)
+if test x$gss = xtrue; then
+ PKG_CHECK_MODULES(GSSAPI, libgssapi >= 0.10, [],
+ AC_MSG_ERROR([Unable to locate information required to use libgssapi.]))
+fi
AC_PROG_CC

View File

@ -83,8 +83,8 @@
- libtirpc_la_SOURCES += auth_gss.c authgss_prot.c svc_auth_gss.c - libtirpc_la_SOURCES += auth_gss.c authgss_prot.c svc_auth_gss.c
+ libtirpc_la_SOURCES += auth_gss.c authgss_prot.c svc_auth_gss.c \ + libtirpc_la_SOURCES += auth_gss.c authgss_prot.c svc_auth_gss.c \
+ svc_auth_none.c + svc_auth_none.c
libtirpc_la_LDFLAGS += $(GSSAPI_LIBS) libtirpc_la_LDFLAGS += $(GSSGLUE_LIBS)
libtirpc_la_CFLAGS = -DHAVE_RPCSEC_GSS $(GSSAPI_CFLAGS) libtirpc_la_CFLAGS = -DHAVE_RPCSEC_GSS $(GSSGLUE_CFLAGS)
endif endif
@@ -49,7 +50,7 @@ $(libtirpc_la_OBJECTS) :auth_none.c auth @@ -49,7 +50,7 @@ $(libtirpc_la_OBJECTS) :auth_none.c auth
svc_raw.c svc_run.c svc_simple.c svc_vc.c \ svc_raw.c svc_run.c svc_simple.c svc_vc.c \

View File

@ -1,6 +1,6 @@
Name: libtirpc Name: libtirpc
Version: 0.1.7 Version: 0.1.7
Release: 11%{?dist} Release: 12%{?dist}
Summary: Transport Independent RPC Library Summary: Transport Independent RPC Library
Group: System Environment/Libraries Group: System Environment/Libraries
License: GPL License: GPL
@ -10,7 +10,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: http://nfsv4.bullopensource.org/tarballs/tirpc/%{name}-%{version}.tar.bz2 Source0: http://nfsv4.bullopensource.org/tarballs/tirpc/%{name}-%{version}.tar.bz2
BuildRequires: automake, autoconf, libtool, pkgconfig BuildRequires: automake, autoconf, libtool, pkgconfig
BuildRequires: libgssapi-devel BuildRequires: libgssglue-devel
%description %description
This package contains SunLib's implementation of transport-independent This package contains SunLib's implementation of transport-independent
@ -31,7 +31,7 @@ Requires: %{name} = %{version}-%{release}
Requires: pkgconfig Requires: pkgconfig
Patch1: libtirpc-0.1.7-netconfig.patch Patch1: libtirpc-0.1.7-netconfig.patch
Patch2: libtirpc-0.1.7-gssapi.patch Patch2: libtirpc-0.1.7-gssglue.patch
Patch3: libtirpc-0.1.7-svcauthnone.patch Patch3: libtirpc-0.1.7-svcauthnone.patch
Patch4: libtirpc-0.1.7-ppc64.patch Patch4: libtirpc-0.1.7-ppc64.patch
Patch5: libtirpc-0.1.7-svcauthdestroy.patch Patch5: libtirpc-0.1.7-svcauthdestroy.patch
@ -145,6 +145,9 @@ rm -rf %{buildroot}
%{_includedir}/tirpc/un-namespace.h %{_includedir}/tirpc/un-namespace.h
%changelog %changelog
* Wed Oct 17 2007 Steve Dickson <steved@redhat.com> 0.1.7-12
- Switch the libgssapi dependency to libgssglue
* Mon Oct 15 2007 Steve Dickson <steved@redhat.com> 0.1.7-11 * Mon Oct 15 2007 Steve Dickson <steved@redhat.com> 0.1.7-11
- Made tcp6/udp6 network ids no longer visible in the netconfig - Made tcp6/udp6 network ids no longer visible in the netconfig
file since the ipv6 code is not fully baked yet in rpcbind. (bz 249121) file since the ipv6 code is not fully baked yet in rpcbind. (bz 249121)