Added in spec file and a patch file that makes things compile
This commit is contained in:
parent
8ac6473a57
commit
c144093431
43
libtirpc-0.1.7-compile.patch
Normal file
43
libtirpc-0.1.7-compile.patch
Normal file
@ -0,0 +1,43 @@
|
|||||||
|
--- libtirpc-0.1.7/src/Makefile.am.orig 2005-05-18 01:10:50.000000000 -0400
|
||||||
|
+++ libtirpc-0.1.7/src/Makefile.am 2006-08-09 14:35:10.000000000 -0400
|
||||||
|
@@ -11,7 +11,7 @@
|
||||||
|
|
||||||
|
lib_LTLIBRARIES = libtirpc.la
|
||||||
|
|
||||||
|
-libtirpc_la_LDFLAGS = -lnsl -lpthread
|
||||||
|
+libtirpc_la_LDFLAGS = -lnsl -lpthread -version-info 1:7:0
|
||||||
|
|
||||||
|
libtirpc_la_SOURCES = auth_none.c auth_unix.c authunix_prot.c bindresvport.c clnt_bcast.c \
|
||||||
|
clnt_dg.c clnt_generic.c clnt_perror.c clnt_raw.c clnt_simple.c \
|
||||||
|
--- libtirpc-0.1.7/src/svc_auth_gss.c.orig 2005-05-18 01:10:50.000000000 -0400
|
||||||
|
+++ libtirpc-0.1.7/src/svc_auth_gss.c 2006-08-09 14:35:51.000000000 -0400
|
||||||
|
@@ -382,7 +382,7 @@
|
||||||
|
return (AUTH_FAILED);
|
||||||
|
}
|
||||||
|
auth->svc_ah_ops = &svc_auth_gss_ops;
|
||||||
|
- SVCAUTH_PRIVATE(auth) = gd;
|
||||||
|
+ auth->svc_ah_private = (caddr_t) gd;
|
||||||
|
rqst->rq_xprt->xp_auth = auth;
|
||||||
|
}
|
||||||
|
else gd = SVCAUTH_PRIVATE(rqst->rq_xprt->xp_auth);
|
||||||
|
--- libtirpc-0.1.7/configure.in.orig 2005-05-18 01:10:50.000000000 -0400
|
||||||
|
+++ libtirpc-0.1.7/configure.in 2006-08-09 14:35:10.000000000 -0400
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
|
||||||
|
-AC_INIT(libtirpc, 0.1.5)
|
||||||
|
-AM_INIT_AUTOMAKE(libtirpc, 0.1.5)
|
||||||
|
+AC_INIT(libtirpc, 0.1.7)
|
||||||
|
+AM_INIT_AUTOMAKE(libtirpc, 0.1.7)
|
||||||
|
AM_MAINTAINER_MODE
|
||||||
|
AC_CONFIG_SRCDIR([src/auth_des.c])
|
||||||
|
|
||||||
|
--- libtirpc-0.1.7/Makefile.am.orig 2005-05-18 01:10:50.000000000 -0400
|
||||||
|
+++ libtirpc-0.1.7/Makefile.am 2006-08-09 14:35:10.000000000 -0400
|
||||||
|
@@ -44,5 +44,5 @@
|
||||||
|
tirpc/rpc/auth_des.h
|
||||||
|
|
||||||
|
install-exec-local:
|
||||||
|
- cp -p ./doc/etc_netconfig /etc/netconfig
|
||||||
|
- chmod 0644 /etc/netconfig
|
||||||
|
+ cp -p ./doc/etc_netconfig ${sysconfdir}/netconfig
|
||||||
|
+ chmod 0644 ${sysconfdir}/netconfig
|
117
libtirpc.spec
Normal file
117
libtirpc.spec
Normal file
@ -0,0 +1,117 @@
|
|||||||
|
Name: libtirpc
|
||||||
|
Version: 0.1.7
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Transport Independent RPC Library
|
||||||
|
Group: System Environment/Libraries
|
||||||
|
License: GPL
|
||||||
|
URL: http://nfsv4.bullopensource.org/
|
||||||
|
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root-%(%{__id_u} -n)
|
||||||
|
Source0: http://nfsv4.bullopensource.org/tarballs/tirpc/libtirpc-0.1.7.tar.bz2
|
||||||
|
BuildRequires: automake, autoconf, libtool
|
||||||
|
Requires(postun): /sbin/ldconfig
|
||||||
|
Requires(pre): /sbin/ldconfig
|
||||||
|
|
||||||
|
%description
|
||||||
|
This package contains SunLib's implementation of transport-independent
|
||||||
|
RPC (TI-RPC) documentation. This library forms a piece of the base of
|
||||||
|
Open Network Computing (ONC), and is derived directly from the
|
||||||
|
Solaris 2.3 source.
|
||||||
|
|
||||||
|
TI-RPC is an enhanced version of TS-RPC that requires the UNIX System V
|
||||||
|
Transport Layer Interface (TLI) or an equivalent X/Open Transport Interface
|
||||||
|
(XTI). TI-RPC is on-the-wire compatible with the TS-RPC, which is supported
|
||||||
|
by almost 70 vendors on all major operating systems. TS-RPC source code
|
||||||
|
(RPCSRC 4.0) remains available from several internet sites.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for the libtirpc library
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: pkgconfig
|
||||||
|
|
||||||
|
Patch1: libtirpc-0.1.7-compile.patch
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
This package includes header files and libraries necessary for
|
||||||
|
developing programs which use the tirpc library.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
autoreconf -fisv
|
||||||
|
%configure --enable-gss --prefix=%{buildroot}
|
||||||
|
make all
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf %{buildroot}
|
||||||
|
mkdir -p %{buildroot}/etc
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%clean
|
||||||
|
rm -rf %{buildroot}
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%doc AUTHORS ChangeLog NEWS README
|
||||||
|
%{_libdir}/libtirpc.so.*
|
||||||
|
%{_libdir}/libtirpc.la
|
||||||
|
%{_sysconfdir}/netconfig
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(0644,root,root,755)
|
||||||
|
%{_libdir}/libtirpc.so
|
||||||
|
%{_libdir}/libtirpc.a
|
||||||
|
%{_includedir}/tirpc/fpmath.h
|
||||||
|
%{_includedir}/tirpc/getpeereid.h
|
||||||
|
%{_includedir}/tirpc/libc_private.h
|
||||||
|
%{_includedir}/tirpc/misc/event.h
|
||||||
|
%{_includedir}/tirpc/misc/queue.h
|
||||||
|
%{_includedir}/tirpc/misc/socket.h
|
||||||
|
%{_includedir}/tirpc/namespace.h
|
||||||
|
%{_includedir}/tirpc/netconfig.h
|
||||||
|
%{_includedir}/tirpc/nss_tls.h
|
||||||
|
%{_includedir}/tirpc/reentrant.h
|
||||||
|
%{_includedir}/tirpc/rpc/auth.h
|
||||||
|
%{_includedir}/tirpc/rpc/auth_des.h
|
||||||
|
%{_includedir}/tirpc/rpc/auth_gss.h
|
||||||
|
%{_includedir}/tirpc/rpc/auth_kerb.h
|
||||||
|
%{_includedir}/tirpc/rpc/auth_unix.h
|
||||||
|
%{_includedir}/tirpc/rpc/clnt.h
|
||||||
|
%{_includedir}/tirpc/rpc/clnt_soc.h
|
||||||
|
%{_includedir}/tirpc/rpc/clnt_stat.h
|
||||||
|
%{_includedir}/tirpc/rpc/des.h
|
||||||
|
%{_includedir}/tirpc/rpc/des_crypt.h
|
||||||
|
%{_includedir}/tirpc/rpc/nettype.h
|
||||||
|
%{_includedir}/tirpc/rpc/pmap_clnt.h
|
||||||
|
%{_includedir}/tirpc/rpc/pmap_prot.h
|
||||||
|
%{_includedir}/tirpc/rpc/pmap_rmt.h
|
||||||
|
%{_includedir}/tirpc/rpc/raw.h
|
||||||
|
%{_includedir}/tirpc/rpc/rpc.h
|
||||||
|
%{_includedir}/tirpc/rpc/rpc_com.h
|
||||||
|
%{_includedir}/tirpc/rpc/rpc_msg.h
|
||||||
|
%{_includedir}/tirpc/rpc/rpcb_clnt.h
|
||||||
|
%{_includedir}/tirpc/rpc/rpcb_prot.h
|
||||||
|
%{_includedir}/tirpc/rpc/rpcb_prot.x
|
||||||
|
%{_includedir}/tirpc/rpc/rpcent.h
|
||||||
|
%{_includedir}/tirpc/rpc/svc.h
|
||||||
|
%{_includedir}/tirpc/rpc/svc_auth.h
|
||||||
|
%{_includedir}/tirpc/rpc/svc_dg.h
|
||||||
|
%{_includedir}/tirpc/rpc/svc_soc.h
|
||||||
|
%{_includedir}/tirpc/rpc/types.h
|
||||||
|
%{_includedir}/tirpc/rpc/xdr.h
|
||||||
|
%{_includedir}/tirpc/rpcsvc/crypt.h
|
||||||
|
%{_includedir}/tirpc/rpcsvc/crypt.x
|
||||||
|
%{_includedir}/tirpc/spinlock.h
|
||||||
|
%{_includedir}/tirpc/un-namespace.h
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Aug 4 2006 Steve Dickson <steved@redhat.com> 0.1.7-1
|
||||||
|
- Initial commit
|
Loading…
Reference in New Issue
Block a user