Updated to latest upstream RC release: libtirpc-1-1-5-rc3
Signed-off-by: Steve Dickson <steved@redhat.com>
This commit is contained in:
parent
3559cc6539
commit
8b29e8d563
@ -1,3 +1,42 @@
|
||||
diff --git a/man/rpc_secure.3t b/man/rpc_secure.3t
|
||||
index 4a1ad93..404df0b 100644
|
||||
--- a/man/rpc_secure.3t
|
||||
+++ b/man/rpc_secure.3t
|
||||
@@ -19,7 +19,7 @@
|
||||
.Ft AUTH *
|
||||
.Fo authdes_pk_create
|
||||
.Fa "char *name"
|
||||
-.FA "netobj *publickey"
|
||||
+.Fa "netobj *publickey"
|
||||
.Fa "unsigned window"
|
||||
.Fa "struct sockaddr *addr"
|
||||
.Fa "des_block *ckey"
|
||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||
index 932414d..b40a6b4 100644
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -38,7 +38,7 @@ endif
|
||||
if GSS
|
||||
libtirpc_la_SOURCES += auth_gss.c authgss_prot.c svc_auth_gss.c \
|
||||
rpc_gss_utils.c
|
||||
- libtirpc_la_LDFLAGS += $(GSSAPI_LIBS)
|
||||
+ libtirpc_la_LIBADD = $(GSSAPI_LIBS)
|
||||
libtirpc_la_CFLAGS = -DHAVE_RPCSEC_GSS $(GSSAPI_CFLAGS)
|
||||
endif
|
||||
|
||||
diff --git a/src/auth_des.c b/src/auth_des.c
|
||||
index af2f61f..c9af2e9 100644
|
||||
--- a/src/auth_des.c
|
||||
+++ b/src/auth_des.c
|
||||
@@ -396,7 +396,7 @@ authdes_validate(AUTH *auth, struct opaque_auth *rverf)
|
||||
/*
|
||||
* validate
|
||||
*/
|
||||
- if (bcmp((char *)&ad->ad_timestamp, (char *)&verf.adv_timestamp,
|
||||
+ if (memcmp((char *)&ad->ad_timestamp, (char *)&verf.adv_timestamp,
|
||||
sizeof(struct timeval)) != 0) {
|
||||
LIBTIRPC_DEBUG(1, ("authdes_validate: verifier mismatch"));
|
||||
return (FALSE);
|
||||
diff --git a/src/auth_gss.c b/src/auth_gss.c
|
||||
index 5959893..7d08262 100644
|
||||
--- a/src/auth_gss.c
|
||||
@ -19,6 +58,19 @@ index 5959893..7d08262 100644
|
||||
}
|
||||
|
||||
gd->established = TRUE;
|
||||
diff --git a/src/auth_time.c b/src/auth_time.c
|
||||
index 69400bc..936dd76 100644
|
||||
--- a/src/auth_time.c
|
||||
+++ b/src/auth_time.c
|
||||
@@ -104,7 +104,7 @@ static int uaddr_to_sockaddr(uaddr, sin)
|
||||
p_bytes[1] = (unsigned char)a[5] & 0x000000FF;
|
||||
|
||||
sin->sin_family = AF_INET; /* always */
|
||||
- bcopy((char *)&p_bytes, (char *)&sin->sin_port, 2);
|
||||
+ memcpy((char *)&sin->sin_port, (char *)&p_bytes, 2);
|
||||
|
||||
return (0);
|
||||
}
|
||||
diff --git a/src/clnt_bcast.c b/src/clnt_bcast.c
|
||||
index 98cf061..2ad6c89 100644
|
||||
--- a/src/clnt_bcast.c
|
||||
@ -31,6 +83,32 @@ index 98cf061..2ad6c89 100644
|
||||
return (RPC_UNKNOWNPROTO);
|
||||
}
|
||||
while ((nconf = __rpc_getconf(handle)) != NULL) {
|
||||
diff --git a/src/crypt_client.c b/src/crypt_client.c
|
||||
index f393926..cd6f7de 100644
|
||||
--- a/src/crypt_client.c
|
||||
+++ b/src/crypt_client.c
|
||||
@@ -75,8 +75,8 @@ _des_crypt_call(buf, len, dparms)
|
||||
des_crypt_1_arg.desbuf.desbuf_val = buf;
|
||||
des_crypt_1_arg.des_dir = dparms->des_dir;
|
||||
des_crypt_1_arg.des_mode = dparms->des_mode;
|
||||
- bcopy(dparms->des_ivec, des_crypt_1_arg.des_ivec, 8);
|
||||
- bcopy(dparms->des_key, des_crypt_1_arg.des_key, 8);
|
||||
+ memcpy(des_crypt_1_arg.des_ivec, dparms->des_ivec, 8);
|
||||
+ memcpy(des_crypt_1_arg.des_key, dparms->des_key, 8);
|
||||
|
||||
result_1 = des_crypt_1(&des_crypt_1_arg, clnt);
|
||||
if (result_1 == (desresp *) NULL) {
|
||||
@@ -88,8 +88,8 @@ _des_crypt_call(buf, len, dparms)
|
||||
|
||||
if (result_1->stat == DESERR_NONE ||
|
||||
result_1->stat == DESERR_NOHWDEVICE) {
|
||||
- bcopy(result_1->desbuf.desbuf_val, buf, len);
|
||||
- bcopy(result_1->des_ivec, dparms->des_ivec, 8);
|
||||
+ memcpy(buf, result_1->desbuf.desbuf_val, len);
|
||||
+ memcpy(dparms->des_ivec, result_1->des_ivec, 8);
|
||||
}
|
||||
|
||||
clnt_freeres(clnt, (xdrproc_t)xdr_desresp, result_1);
|
||||
diff --git a/src/getnetconfig.c b/src/getnetconfig.c
|
||||
index 92e7c43..cfd33c2 100644
|
||||
--- a/src/getnetconfig.c
|
||||
@ -181,6 +259,28 @@ index b642840..29fbf0a 100644
|
||||
return(-1);
|
||||
}
|
||||
|
||||
diff --git a/src/svc_auth_des.c b/src/svc_auth_des.c
|
||||
index 19a7c60..b096e08 100644
|
||||
--- a/src/svc_auth_des.c
|
||||
+++ b/src/svc_auth_des.c
|
||||
@@ -145,7 +145,7 @@ _svcauth_des(rqst, msg)
|
||||
return (AUTH_BADCRED);
|
||||
}
|
||||
cred->adc_fullname.name = area->area_netname;
|
||||
- bcopy((char *)ixdr, cred->adc_fullname.name,
|
||||
+ memcpy(cred->adc_fullname.name, (char *)ixdr,
|
||||
(u_int)namelen);
|
||||
cred->adc_fullname.name[namelen] = 0;
|
||||
ixdr += (RNDUP(namelen) / BYTES_PER_XDR_UNIT);
|
||||
@@ -419,7 +419,7 @@ cache_spot(key, name, timestamp)
|
||||
if (cp->key.key.high == hi &&
|
||||
cp->key.key.low == key->key.low &&
|
||||
cp->rname != NULL &&
|
||||
- bcmp(cp->rname, name, strlen(name) + 1) == 0) {
|
||||
+ memcmp(cp->rname, name, strlen(name) + 1) == 0) {
|
||||
if (BEFORE(timestamp, &cp->laststamp)) {
|
||||
svcauthdes_stats.ncachereplays++;
|
||||
return (-1); /* replay */
|
||||
diff --git a/src/svc_generic.c b/src/svc_generic.c
|
||||
index 52a56c2..20abaa2 100644
|
||||
--- a/src/svc_generic.c
|
||||
@ -225,6 +325,30 @@ index 97a76a3..c23cd36 100644
|
||||
len = 0;
|
||||
else
|
||||
goto fatal_err;
|
||||
diff --git a/src/xdr.c b/src/xdr.c
|
||||
index b9a1558..28d1382 100644
|
||||
--- a/src/xdr.c
|
||||
+++ b/src/xdr.c
|
||||
@@ -877,7 +877,8 @@ xdr_int64_t(xdrs, llp)
|
||||
if (XDR_GETLONG(xdrs, (long *)&ul[1]) == FALSE)
|
||||
return (FALSE);
|
||||
*llp = (int64_t)
|
||||
- (((u_int64_t)ul[0] << 32) | ((u_int64_t)ul[1]));
|
||||
+ (((u_int64_t)ul[0] << 32) |
|
||||
+ ((u_int64_t)(ul[1]) & 0xffffffff));
|
||||
return (TRUE);
|
||||
case XDR_FREE:
|
||||
return (TRUE);
|
||||
@@ -910,7 +911,8 @@ xdr_u_int64_t(xdrs, ullp)
|
||||
if (XDR_GETLONG(xdrs, (long *)&ul[1]) == FALSE)
|
||||
return (FALSE);
|
||||
*ullp = (u_int64_t)
|
||||
- (((u_int64_t)ul[0] << 32) | ((u_int64_t)ul[1]));
|
||||
+ (((u_int64_t)ul[0] << 32) |
|
||||
+ ((u_int64_t)(ul[1]) & 0xffffffff));
|
||||
return (TRUE);
|
||||
case XDR_FREE:
|
||||
return (TRUE);
|
||||
diff --git a/src/xdr_rec.c b/src/xdr_rec.c
|
||||
index 7d535cf..676cc82 100644
|
||||
--- a/src/xdr_rec.c
|
||||
@ -275,3 +399,19 @@ index 7d535cf..676cc82 100644
|
||||
return FALSE;
|
||||
}
|
||||
|
||||
diff --git a/tirpc/rpc/rpcent.h b/tirpc/rpc/rpcent.h
|
||||
index 9d3ef9c..5bff876 100644
|
||||
--- a/tirpc/rpc/rpcent.h
|
||||
+++ b/tirpc/rpc/rpcent.h
|
||||
@@ -48,8 +48,9 @@
|
||||
extern "C" {
|
||||
#endif
|
||||
|
||||
-/* These are defined in /usr/include/rpc/netdb.h */
|
||||
-#if !defined(__GLIBC__) || defined(__UCLIBC__)
|
||||
+/* These are defined in /usr/include/rpc/netdb.h, unless we are using
|
||||
+ the C library without RPC support. */
|
||||
+#if defined(__UCLIBC__) && !defined(__UCLIBC_HAS_RPC__) || !defined(__GLIBC__)
|
||||
struct rpcent {
|
||||
char *r_name; /* name of server for this rpc program */
|
||||
char **r_aliases; /* alias list */
|
@ -2,13 +2,13 @@
|
||||
|
||||
Name: libtirpc
|
||||
Version: 1.1.4
|
||||
Release: 2.rc2%{?dist}.2
|
||||
Release: 2.rc3%{?dist}
|
||||
Summary: Transport Independent RPC Library
|
||||
License: SISSL and BSD
|
||||
URL: http://git.linux-nfs.org/?p=steved/libtirpc.git;a=summary
|
||||
Source0: http://downloads.sourceforge.net/libtirpc/libtirpc-%{version}.tar.bz2
|
||||
|
||||
Patch001: libtirpc-1.1.5-rc2.patch
|
||||
Patch001: libtirpc-1.1.5-rc3.patch
|
||||
|
||||
BuildRequires: automake, autoconf, libtool, pkgconfig
|
||||
BuildRequires: krb5-devel
|
||||
@ -122,6 +122,9 @@ mv %{buildroot}%{_mandir}/man3 %{buildroot}%{_mandir}/man3t
|
||||
%{_mandir}/*/*
|
||||
|
||||
%changelog
|
||||
* Thu Sep 05 2019 Steve Dickson <steved@redhat.com> 1.0.4-2.rc3
|
||||
- Updated to latest upstream RC release: libtirpc-1-1-5-rc3
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.4-2.rc2.2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user