Added hooks to used the libgssapi library.

This commit is contained in:
Steve Dickson 2006-08-11 16:57:18 +00:00
parent 285ec3c6ac
commit 54ab0f1e43
2 changed files with 35 additions and 2 deletions

View File

@ -0,0 +1,26 @@
--- libtirpc-0.1.7/src/Makefile.am.orig 2006-08-11 11:50:28.000000000 -0400
+++ libtirpc-0.1.7/src/Makefile.am 2006-08-11 12:48:29.000000000 -0400
@@ -29,8 +29,8 @@ libtirpc_la_SOURCES += xdr.c xdr_rec.c x
## Secure-RPC
if GSS
libtirpc_la_SOURCES += auth_gss.c authgss_prot.c svc_auth_gss.c
- libtirpc_la_LDFLAGS += -lgssapi
- libtirpc_la_CFLAGS = -DHAVE_RPCSEC_GSS
+ libtirpc_la_LDFLAGS += $(GSSAPI_LIBS)
+ libtirpc_la_CFLAGS = -DHAVE_RPCSEC_GSS $(GSSAPI_CFLAGS)
endif
## libtirpc_a_SOURCES += key_call.c key_prot_xdr.c getpublickey.c
--- libtirpc-0.1.7/configure.in.orig 2006-08-11 11:48:36.000000000 -0400
+++ libtirpc-0.1.7/configure.in 2006-08-11 12:07:15.000000000 -0400
@@ -10,6 +10,10 @@ AC_ARG_ENABLE(gss,[ --enable-gss
*) AC_MSG_ERROR(bad value ${enableval} for --enable-gss) ;;
esac],[gss=false])
AM_CONDITIONAL(GSS, test x$gss = xtrue)
+if test x$gss = xtrue; then
+ PKG_CHECK_MODULES(GSSAPI, libgssapi >= 0.10, [],
+ AC_MSG_ERROR([Unable to locate information required to use libgssapi.]))
+fi
AC_PROG_CC

View File

@ -8,9 +8,13 @@ URL: http://nfsv4.bullopensource.org/
BuildRoot: %{_tmppath}/%{name}-%{version}-root-%(%{__id_u} -n)
Source0: http://nfsv4.bullopensource.org/tarballs/tirpc/libtirpc-0.1.7.tar.bz2
BuildRequires: automake, autoconf, libtool
BuildRequires: automake, autoconf, libtool, pkgconfig
BuildRequires: libgssapi-devel
Requires(postun): /sbin/ldconfig
Requires(pre): /sbin/ldconfig
Requires: libgssapi
%description
This package contains SunLib's implementation of transport-independent
@ -31,6 +35,7 @@ Requires: %{name} = %{version}-%{release}
Requires: pkgconfig
Patch1: libtirpc-0.1.7-netconfig.patch
Patch2: libtirpc-0.1.7-gssapi.patch
Patch100: libtirpc-0.1.7-compile.patch
@ -42,6 +47,7 @@ developing programs which use the tirpc library.
%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch100 -p1
@ -117,8 +123,9 @@ rm -rf %{buildroot}
%{_includedir}/tirpc/un-namespace.h
%changelog
* Fri Aug 11 2006 Steve Dickson <steved@redhat.com> 0.1.7-1
* Fri Aug 11 2006 Steve Dickson <steved@redhat.com> 0.1.7-2
- Uncommented tcp6 and udp6 in the default /etc/netconfig file.
- Added hooks to used the libgssapi library.
* Fri Aug 4 2006 Steve Dickson <steved@redhat.com> 0.1.7-1
- Initial commit