Updated to the latest upstream release: libtirpc-1_3_5 (RHEL-50728)

Signed-off-by: Steve Dickson <steved@redhat.com>
Resolves: RHEL-50728
This commit is contained in:
Steve Dickson 2024-07-27 12:35:02 -04:00
parent a8edd78557
commit 3723ac44c2
4 changed files with 8 additions and 125 deletions

4
.gitignore vendored
View File

@ -1,4 +1,4 @@
Makefile Makefile
x86_64/ x86_64/
/libtirpc-1.3.4.tar.bz2 /libtirpc-1.3.5.tar.bz2
libtirpc-1.3.4 libtirpc-1.3.5

View File

@ -1,118 +0,0 @@
diff --git a/configure.ac b/configure.ac
index f1f4f23..d763afc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,7 +64,7 @@ fi
AC_ARG_ENABLE(ipv6,
[AC_HELP_STRING([--disable-ipv6], [Disable IPv6 support @<:@default=no@:>@])],
[],[enable_ipv6=yes])
-AM_CONDITIONAL(INET6, test "x$disable_ipv6" != xno)
+AM_CONDITIONAL(INET6, test "x$enable_ipv6" != xno)
if test "x$enable_ipv6" != xno; then
AC_DEFINE(INET6, 1, [Define to 1 if IPv6 is available])
fi
diff --git a/doc/Makefile.am b/doc/Makefile.am
index d42ab90..b9678f6 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -2,3 +2,8 @@ dist_sysconf_DATA = netconfig bindresvport.blacklist
CLEANFILES = cscope.* *~
DISTCLEANFILES = Makefile.in
+
+if ! INET6
+install-exec-hook:
+ $(SED) -i '/^tcp6\|^udp6/d' "$(DESTDIR)$(sysconfdir)"/netconfig
+endif
diff --git a/src/auth_gss.c b/src/auth_gss.c
index 3127b92..9d18f96 100644
--- a/src/auth_gss.c
+++ b/src/auth_gss.c
@@ -184,7 +184,6 @@ authgss_create(CLIENT *clnt, gss_name_t name, struct rpc_gss_sec *sec)
AUTH *auth, *save_auth;
struct rpc_gss_data *gd;
OM_uint32 min_stat = 0;
- rpc_gss_options_ret_t ret;
gss_log_debug("in authgss_create()");
@@ -230,12 +229,8 @@ authgss_create(CLIENT *clnt, gss_name_t name, struct rpc_gss_sec *sec)
save_auth = clnt->cl_auth;
clnt->cl_auth = auth;
- memset(&ret, 0, sizeof(rpc_gss_options_ret_t));
- if (!authgss_refresh(auth, &ret)) {
+ if (!authgss_refresh(auth, NULL))
auth = NULL;
- sec->major_status = ret.major_status;
- sec->minor_status = ret.minor_status;
- }
else
authgss_auth_get(auth); /* Reference for caller */
@@ -624,9 +619,12 @@ _rpc_gss_refresh(AUTH *auth, rpc_gss_options_ret_t *options_ret)
}
static bool_t
-authgss_refresh(AUTH *auth, void *ret)
+authgss_refresh(AUTH *auth, void *dummy)
{
- return _rpc_gss_refresh(auth, (rpc_gss_options_ret_t *)ret);
+ rpc_gss_options_ret_t ret;
+
+ memset(&ret, 0, sizeof(ret));
+ return _rpc_gss_refresh(auth, &ret);
}
bool_t
@@ -844,9 +842,9 @@ rpc_gss_seccreate(CLIENT *clnt, char *principal, char *mechanism,
gd->sec = sec;
if (req) {
- sec.req_flags = req->req_flags;
+ gd->sec.req_flags = req->req_flags;
gd->time_req = req->time_req;
- sec.cred = req->my_cred;
+ gd->sec.cred = req->my_cred;
gd->icb = req->input_channel_bindings;
}
diff --git a/src/rpc_dtablesize.c b/src/rpc_dtablesize.c
index bce97e8..e88698f 100644
--- a/src/rpc_dtablesize.c
+++ b/src/rpc_dtablesize.c
@@ -42,6 +42,8 @@ _rpc_dtablesize(void)
if (size == 0) {
size = sysconf(_SC_OPEN_MAX);
+ if (size > FD_SETSIZE)
+ size = FD_SETSIZE;
}
return (size);
}
diff --git a/src/svc.c b/src/svc.c
index 3a8709f..9b932a5 100644
--- a/src/svc.c
+++ b/src/svc.c
@@ -657,8 +657,6 @@ svc_getreqset (readfds)
assert (readfds != NULL);
setsize = _rpc_dtablesize ();
- if (setsize > FD_SETSIZE)
- setsize = FD_SETSIZE;
maskp = readfds->fds_bits;
for (sock = 0; sock < setsize; sock += NFDBITS)
{
diff --git a/tirpc/rpc/auth_gss.h b/tirpc/rpc/auth_gss.h
index a530d42..f2af6e9 100644
--- a/tirpc/rpc/auth_gss.h
+++ b/tirpc/rpc/auth_gss.h
@@ -64,8 +64,6 @@ struct rpc_gss_sec {
rpc_gss_svc_t svc; /* service */
gss_cred_id_t cred; /* cred handle */
u_int req_flags; /* req flags for init_sec_context */
- int major_status;
- int minor_status;
};
/* Private data required for kernel implementation */

View File

@ -1,15 +1,13 @@
%define _root_libdir /%{_lib} %define _root_libdir /%{_lib}
Name: libtirpc Name: libtirpc
Version: 1.3.4 Version: 1.3.5
Release: 1.rc2%{?dist}.3 Release: 0%{?dist}
Summary: Transport Independent RPC Library Summary: Transport Independent RPC Library
License: SISSL AND BSD-3-Clause License: SISSL AND BSD-3-Clause
URL: http://git.linux-nfs.org/?p=steved/libtirpc.git;a=summary URL: http://git.linux-nfs.org/?p=steved/libtirpc.git;a=summary
Source0: http://downloads.sourceforge.net/libtirpc/libtirpc-%{version}.tar.bz2 Source0: http://downloads.sourceforge.net/libtirpc/libtirpc-%{version}.tar.bz2
Patch001: libtirpc.1.3.5-rc2.patch
BuildRequires: automake, autoconf, libtool, pkgconfig BuildRequires: automake, autoconf, libtool, pkgconfig
BuildRequires: krb5-devel BuildRequires: krb5-devel
BuildRequires: gcc BuildRequires: gcc
@ -114,6 +112,9 @@ mv %{buildroot}%{_mandir}/man3 %{buildroot}%{_mandir}/man3t
%{_mandir}/*/* %{_mandir}/*/*
%changelog %changelog
* Sat Jul 27 2024 Steve Dickson <steved@redhat.com> - 1.3.5-0
- Updated to the latest upstream release: libtirpc-1_3_5 (RHEL-50728)
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 1.3.4-1.rc2.3 * Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 1.3.4-1.rc2.3
- Bump release for June 2024 mass rebuild - Bump release for June 2024 mass rebuild

View File

@ -1 +1 @@
SHA512 (libtirpc-1.3.4.tar.bz2) = 004e61b5853717324790c46cda5ff227d525909f189194ae72a1ec8f476ca35d7f4c1f03c0fbc690c1696d60a212675b09246dbe627fdbf1a9a47f5664e82b00 SHA512 (libtirpc-1.3.5.tar.bz2) = c80a953671c5692294efe7425e41c7f12bd4c430f473f9ea71883168cb4a69111f0018122bd0e7982e18f4576e45d4977ce0790743382faae006c446813d2a4f