Updated to the latest upstream RC release: libtirpc-1-3-5-rc2

Signed-off-by: Steve Dickson <steved@redhat.com>
This commit is contained in:
Steve Dickson 2024-01-05 15:34:20 -05:00
parent bc6c487357
commit 04a726dfa4
3 changed files with 57 additions and 1758 deletions

File diff suppressed because it is too large Load Diff

View File

@ -1,3 +1,29 @@
diff --git a/configure.ac b/configure.ac
index f1f4f23..d763afc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,7 +64,7 @@ fi
AC_ARG_ENABLE(ipv6,
[AC_HELP_STRING([--disable-ipv6], [Disable IPv6 support @<:@default=no@:>@])],
[],[enable_ipv6=yes])
-AM_CONDITIONAL(INET6, test "x$disable_ipv6" != xno)
+AM_CONDITIONAL(INET6, test "x$enable_ipv6" != xno)
if test "x$enable_ipv6" != xno; then
AC_DEFINE(INET6, 1, [Define to 1 if IPv6 is available])
fi
diff --git a/doc/Makefile.am b/doc/Makefile.am
index d42ab90..b9678f6 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -2,3 +2,8 @@ dist_sysconf_DATA = netconfig bindresvport.blacklist
CLEANFILES = cscope.* *~
DISTCLEANFILES = Makefile.in
+
+if ! INET6
+install-exec-hook:
+ $(SED) -i '/^tcp6\|^udp6/d' "$(DESTDIR)$(sysconfdir)"/netconfig
+endif
diff --git a/src/auth_gss.c b/src/auth_gss.c
index 3127b92..9d18f96 100644
--- a/src/auth_gss.c
@ -51,6 +77,32 @@ index 3127b92..9d18f96 100644
gd->icb = req->input_channel_bindings;
}
diff --git a/src/rpc_dtablesize.c b/src/rpc_dtablesize.c
index bce97e8..e88698f 100644
--- a/src/rpc_dtablesize.c
+++ b/src/rpc_dtablesize.c
@@ -42,6 +42,8 @@ _rpc_dtablesize(void)
if (size == 0) {
size = sysconf(_SC_OPEN_MAX);
+ if (size > FD_SETSIZE)
+ size = FD_SETSIZE;
}
return (size);
}
diff --git a/src/svc.c b/src/svc.c
index 3a8709f..9b932a5 100644
--- a/src/svc.c
+++ b/src/svc.c
@@ -657,8 +657,6 @@ svc_getreqset (readfds)
assert (readfds != NULL);
setsize = _rpc_dtablesize ();
- if (setsize > FD_SETSIZE)
- setsize = FD_SETSIZE;
maskp = readfds->fds_bits;
for (sock = 0; sock < setsize; sock += NFDBITS)
{
diff --git a/tirpc/rpc/auth_gss.h b/tirpc/rpc/auth_gss.h
index a530d42..f2af6e9 100644
--- a/tirpc/rpc/auth_gss.h

View File

@ -2,13 +2,13 @@
Name: libtirpc
Version: 1.3.4
Release: 1.rc1%{?dist}
Release: 1.rc2%{?dist}
Summary: Transport Independent RPC Library
License: SISSL AND BSD-3-Clause
URL: http://git.linux-nfs.org/?p=steved/libtirpc.git;a=summary
Source0: http://downloads.sourceforge.net/libtirpc/libtirpc-%{version}.tar.bz2
Patch001: libtirpc.1.3.5-rc1.patch
Patch001: libtirpc.1.3.5-rc2.patch
BuildRequires: automake, autoconf, libtool, pkgconfig
BuildRequires: krb5-devel
@ -114,6 +114,9 @@ mv %{buildroot}%{_mandir}/man3 %{buildroot}%{_mandir}/man3t
%{_mandir}/*/*
%changelog
* Fri Jan 5 2024 Steve Dickson <steved@redhat.com> - 1.3.4-1.rc2
- Updated to the latest upstream RC release: libtirpc-1-3-5-rc2
* Wed Jan 3 2024 Steve Dickson <steved@redhat.com> - 1.3.4-1.rc1
- Updated to the latest upstream RC release: libtirpc-1-3-5-rc1