51a02b6c80
- Render the map directly from SVG (#1335158) - Fix memory leaks in tz.c - Fix an invalid memory access - Do not modify TZ in the process environment - Move all data files to /usr/share/libtimezonemap from .../libtimezonemap/ui - Add extra city data so all timezone offsets are clickable - Move Venezuela from -04:30 to -04:00 - Fix the conversion of points just west of 180 longitude - Remove the out-of-date Olson map data - Update the "backward" file - Improve the location selected when setting the timezone by name (#1322648) - Remove an extra line in the +10:00 layer - Move Chile back an hour
40 lines
1.2 KiB
Diff
40 lines
1.2 KiB
Diff
From b7714717a6073e7d8696737b1366aa2628182bc5 Mon Sep 17 00:00:00 2001
|
|
From: David Shea <dshea@redhat.com>
|
|
Date: Wed, 29 Jun 2016 14:30:04 -0400
|
|
Subject: [PATCH 24/24] Fix issues with 'make distcheck'
|
|
|
|
Ensure that citiesInfo is written to, read from, and cleaned from
|
|
$builddir.
|
|
---
|
|
src/Makefile.am | 7 +++++--
|
|
1 file changed, 5 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/src/Makefile.am b/src/Makefile.am
|
|
index 570b828..40a1f0b 100644
|
|
--- a/src/Makefile.am
|
|
+++ b/src/Makefile.am
|
|
@@ -15,7 +15,10 @@ dist_noinst_DATA = \
|
|
data/citiesExtra.txt
|
|
|
|
data/citiesInfo.txt: data/cities15000.txt data/citiesExtra.txt
|
|
- cat data/cities15000.txt data/citiesExtra.txt > $@
|
|
+ @$(MKDIR_P) $(builddir)/data
|
|
+ $(AM_V_GEN)cat $(srcdir)/data/cities15000.txt $(srcdir)/data/citiesExtra.txt > $@
|
|
+
|
|
+CLEANFILES = data/citiesInfo.txt
|
|
|
|
tzdatadir = $(pkgdatadir)/
|
|
dist_tzdata_DATA = data/backward
|
|
@@ -31,7 +34,7 @@ AM_CPPFLAGS = \
|
|
noinst_PROGRAMS = test-timezone
|
|
|
|
|
|
-AM_TESTS_ENVIRONMENT = TZ_DATA_FILE=$(srcdir)/data/citiesInfo.txt ; \
|
|
+AM_TESTS_ENVIRONMENT = TZ_DATA_FILE=$(builddir)/data/citiesInfo.txt ; \
|
|
ADMIN1_FILE=$(srcdir)/data/admin1Codes.txt ; \
|
|
COUNTRY_FILE=$(srcdir)/data/countryInfo.txt ; \
|
|
DATADIR=$(srcdir)/data ; \
|
|
--
|
|
2.5.5
|
|
|