65 lines
2.2 KiB
Diff
65 lines
2.2 KiB
Diff
From 7e33322d16f78ab613ffdd284274be580034023a Mon Sep 17 00:00:00 2001
|
|
From: David Shea <dshea@redhat.com>
|
|
Date: Thu, 14 Nov 2013 10:50:49 -0500
|
|
Subject: [PATCH 06/10] Turn on and fix g-ir-scanner warnings.
|
|
|
|
A comment in timezone-completion opened with /** but did not include
|
|
gtk-doc data. Removed the extra asterisk.
|
|
|
|
cc_timezone_map_get_location needed transfer information since it
|
|
returns a non-const object. Added a doc comment with transfer none.
|
|
---
|
|
src/Makefile.am | 2 +-
|
|
src/cc-timezone-map.c | 8 ++++++++
|
|
src/timezone-completion.c | 2 +-
|
|
3 files changed, 10 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/src/Makefile.am b/src/Makefile.am
|
|
index b4461cd..8b00c16 100644
|
|
--- a/src/Makefile.am
|
|
+++ b/src/Makefile.am
|
|
@@ -109,7 +109,7 @@ introspection_sources = $(libtimezonemap_GISOURCES)
|
|
TimezoneMap-1.0.gir: libtimezonemap.la
|
|
TimezoneMap_1_0_gir_INCLUDES = GObject-2.0 Gtk-3.0 Json-1.0
|
|
TimezoneMap_1_0_gir_CFLAGS = $(INCLUDES)
|
|
-TimezoneMap_1_0_gir_SCANNERFLAGS = --identifier-prefix=Cc
|
|
+TimezoneMap_1_0_gir_SCANNERFLAGS = --identifier-prefix=Cc --warn-all
|
|
TimezoneMap_1_0_gir_LIBS = libtimezonemap.la
|
|
TimezoneMap_1_0_gir_FILES = $(introspection_sources)
|
|
|
|
diff --git a/src/cc-timezone-map.c b/src/cc-timezone-map.c
|
|
index a782089..7fd7b08 100644
|
|
--- a/src/cc-timezone-map.c
|
|
+++ b/src/cc-timezone-map.c
|
|
@@ -1195,6 +1195,14 @@ cc_timezone_map_set_watermark (CcTimezoneMap *map, const gchar * watermark)
|
|
gtk_widget_queue_draw (GTK_WIDGET (map));
|
|
}
|
|
|
|
+/**
|
|
+ * cc_timezone_map_get_location:
|
|
+ * @map: A #CcTimezoneMap
|
|
+ *
|
|
+ * Returns the current location set for the map.
|
|
+ *
|
|
+ * Returns: (transfer none): the map location.
|
|
+ */
|
|
CcTimezoneLocation *
|
|
cc_timezone_map_get_location (CcTimezoneMap *map)
|
|
{
|
|
diff --git a/src/timezone-completion.c b/src/timezone-completion.c
|
|
index f6ca8c8..e7f88db 100644
|
|
--- a/src/timezone-completion.c
|
|
+++ b/src/timezone-completion.c
|
|
@@ -442,7 +442,7 @@ get_descendent (GtkWidget * parent, GType type)
|
|
return NULL;
|
|
}
|
|
|
|
-/**
|
|
+/*
|
|
* The popup window and its GtkTreeView are private to our parent completion
|
|
* object. We can't get access to discover if there is a highlighted item or
|
|
* even if the window is showing right now. So this is a super hack to find
|
|
--
|
|
1.8.4.2
|
|
|