import libtiff-4.4.0-5.el9_1
This commit is contained in:
parent
ef5d5b1b6d
commit
892b60cf82
@ -0,0 +1,40 @@
|
|||||||
|
From b2e3171e935be3c4b79657aebf4175ef3be403b1 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Matej=20Mu=C5=BEila?= <mmuzila@redhat.com>
|
||||||
|
Date: Mon, 18 Jul 2022 13:40:10 +0200
|
||||||
|
Subject: [PATCH] Back off the minimum required automake version to 1.11.
|
||||||
|
There isn't anything in libtiff currently that actually requires 1.12, and
|
||||||
|
changing this allows the package to be built on pre-F18 machines for easier
|
||||||
|
testing.
|
||||||
|
|
||||||
|
This patch can go away once we no longer care about testing on pre-F18.
|
||||||
|
---
|
||||||
|
Makefile.am | 2 +-
|
||||||
|
test/Makefile.am | 2 +-
|
||||||
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile.am b/Makefile.am
|
||||||
|
index aaabf4d1..66e13dd8 100644
|
||||||
|
--- a/Makefile.am
|
||||||
|
+++ b/Makefile.am
|
||||||
|
@@ -25,7 +25,7 @@
|
||||||
|
|
||||||
|
docdir = $(LIBTIFF_DOCDIR)
|
||||||
|
|
||||||
|
-AUTOMAKE_OPTIONS = 1.12 dist-zip foreign
|
||||||
|
+AUTOMAKE_OPTIONS = 1.11 dist-zip foreign
|
||||||
|
ACLOCAL_AMFLAGS = -I m4
|
||||||
|
|
||||||
|
docfiles = \
|
||||||
|
diff --git a/test/Makefile.am b/test/Makefile.am
|
||||||
|
index b5823198..949667ee 100644
|
||||||
|
--- a/test/Makefile.am
|
||||||
|
+++ b/test/Makefile.am
|
||||||
|
@@ -23,7 +23,7 @@
|
||||||
|
|
||||||
|
# Process this file with automake to produce Makefile.in.
|
||||||
|
|
||||||
|
-AUTOMAKE_OPTIONS = 1.12 color-tests parallel-tests foreign
|
||||||
|
+AUTOMAKE_OPTIONS = 1.11 color-tests parallel-tests foreign
|
||||||
|
|
||||||
|
LIBTIFF = $(top_builddir)/libtiff/libtiff.la
|
||||||
|
|
21
SOURCES/0002-Fix-Makefile.patch
Normal file
21
SOURCES/0002-Fix-Makefile.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
From ab8a25b78922ba0e93fc4264d15c3e796a6f4c34 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Matej=20Mu=C5=BEila?= <mmuzila@redhat.com>
|
||||||
|
Date: Thu, 5 May 2022 14:42:52 +0200
|
||||||
|
Subject: [PATCH] Fix Makefile
|
||||||
|
|
||||||
|
---
|
||||||
|
html/man/Makefile.am | 1 -
|
||||||
|
1 file changed, 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/html/man/Makefile.am b/html/man/Makefile.am
|
||||||
|
index 3ed00d44..8a64925a 100644
|
||||||
|
--- a/html/man/Makefile.am
|
||||||
|
+++ b/html/man/Makefile.am
|
||||||
|
@@ -90,7 +90,6 @@ docfiles = \
|
||||||
|
tiffcrop.1.html \
|
||||||
|
tiffdither.1.html \
|
||||||
|
tiffdump.1.html \
|
||||||
|
- tiffgt.1.html \
|
||||||
|
tiffinfo.1.html \
|
||||||
|
tiffmedian.1.html \
|
||||||
|
tiffset.1.html \
|
@ -0,0 +1,179 @@
|
|||||||
|
From eda0ab31e15edbb6ddee96f5c87d52888d68872c Mon Sep 17 00:00:00 2001
|
||||||
|
From: 4ugustus <wangdw.augustus@qq.com>
|
||||||
|
Date: Sat, 11 Jun 2022 09:31:43 +0000
|
||||||
|
Subject: [PATCH] (CVE-2022-2056 CVE-2022-2057 CVE-2022-2058) fix the FPE in
|
||||||
|
tiffcrop (#415, #427, and #428)
|
||||||
|
|
||||||
|
(cherry picked from commit dd1bcc7abb26094e93636e85520f0d8f81ab0fab)
|
||||||
|
---
|
||||||
|
libtiff/tif_aux.c | 9 +++++++
|
||||||
|
libtiff/tiffiop.h | 1 +
|
||||||
|
tools/tiffcrop.c | 62 ++++++++++++++++++++++++++---------------------
|
||||||
|
3 files changed, 44 insertions(+), 28 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/libtiff/tif_aux.c b/libtiff/tif_aux.c
|
||||||
|
index 140f26c7..5b88c8d0 100644
|
||||||
|
--- a/libtiff/tif_aux.c
|
||||||
|
+++ b/libtiff/tif_aux.c
|
||||||
|
@@ -402,6 +402,15 @@ float _TIFFClampDoubleToFloat( double val )
|
||||||
|
return (float)val;
|
||||||
|
}
|
||||||
|
|
||||||
|
+uint32_t _TIFFClampDoubleToUInt32(double val)
|
||||||
|
+{
|
||||||
|
+ if( val < 0 )
|
||||||
|
+ return 0;
|
||||||
|
+ if( val > 0xFFFFFFFFU || val != val )
|
||||||
|
+ return 0xFFFFFFFFU;
|
||||||
|
+ return (uint32_t)val;
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
int _TIFFSeekOK(TIFF* tif, toff_t off)
|
||||||
|
{
|
||||||
|
/* Huge offsets, especially -1 / UINT64_MAX, can cause issues */
|
||||||
|
diff --git a/libtiff/tiffiop.h b/libtiff/tiffiop.h
|
||||||
|
index e3af461d..4e8bdac2 100644
|
||||||
|
--- a/libtiff/tiffiop.h
|
||||||
|
+++ b/libtiff/tiffiop.h
|
||||||
|
@@ -365,6 +365,7 @@ extern double _TIFFUInt64ToDouble(uint64_t);
|
||||||
|
extern float _TIFFUInt64ToFloat(uint64_t);
|
||||||
|
|
||||||
|
extern float _TIFFClampDoubleToFloat(double);
|
||||||
|
+extern uint32_t _TIFFClampDoubleToUInt32(double);
|
||||||
|
|
||||||
|
extern tmsize_t
|
||||||
|
_TIFFReadEncodedStripAndAllocBuffer(TIFF* tif, uint32_t strip,
|
||||||
|
diff --git a/tools/tiffcrop.c b/tools/tiffcrop.c
|
||||||
|
index 1f827b2b..90286a5e 100644
|
||||||
|
--- a/tools/tiffcrop.c
|
||||||
|
+++ b/tools/tiffcrop.c
|
||||||
|
@@ -5268,17 +5268,17 @@ computeInputPixelOffsets(struct crop_mask *crop, struct image_data *image,
|
||||||
|
{
|
||||||
|
if ((crop->res_unit == RESUNIT_INCH) || (crop->res_unit == RESUNIT_CENTIMETER))
|
||||||
|
{
|
||||||
|
- x1 = (uint32_t) (crop->corners[i].X1 * scale * xres);
|
||||||
|
- x2 = (uint32_t) (crop->corners[i].X2 * scale * xres);
|
||||||
|
- y1 = (uint32_t) (crop->corners[i].Y1 * scale * yres);
|
||||||
|
- y2 = (uint32_t) (crop->corners[i].Y2 * scale * yres);
|
||||||
|
+ x1 = _TIFFClampDoubleToUInt32(crop->corners[i].X1 * scale * xres);
|
||||||
|
+ x2 = _TIFFClampDoubleToUInt32(crop->corners[i].X2 * scale * xres);
|
||||||
|
+ y1 = _TIFFClampDoubleToUInt32(crop->corners[i].Y1 * scale * yres);
|
||||||
|
+ y2 = _TIFFClampDoubleToUInt32(crop->corners[i].Y2 * scale * yres);
|
||||||
|
}
|
||||||
|
else
|
||||||
|
{
|
||||||
|
- x1 = (uint32_t) (crop->corners[i].X1);
|
||||||
|
- x2 = (uint32_t) (crop->corners[i].X2);
|
||||||
|
- y1 = (uint32_t) (crop->corners[i].Y1);
|
||||||
|
- y2 = (uint32_t) (crop->corners[i].Y2);
|
||||||
|
+ x1 = _TIFFClampDoubleToUInt32(crop->corners[i].X1);
|
||||||
|
+ x2 = _TIFFClampDoubleToUInt32(crop->corners[i].X2);
|
||||||
|
+ y1 = _TIFFClampDoubleToUInt32(crop->corners[i].Y1);
|
||||||
|
+ y2 = _TIFFClampDoubleToUInt32(crop->corners[i].Y2);
|
||||||
|
}
|
||||||
|
/* a) Region needs to be within image sizes 0.. width-1; 0..length-1
|
||||||
|
* b) Corners are expected to be submitted as top-left to bottom-right.
|
||||||
|
@@ -5357,17 +5357,17 @@ computeInputPixelOffsets(struct crop_mask *crop, struct image_data *image,
|
||||||
|
{
|
||||||
|
if (crop->res_unit != RESUNIT_INCH && crop->res_unit != RESUNIT_CENTIMETER)
|
||||||
|
{ /* User has specified pixels as reference unit */
|
||||||
|
- tmargin = (uint32_t)(crop->margins[0]);
|
||||||
|
- lmargin = (uint32_t)(crop->margins[1]);
|
||||||
|
- bmargin = (uint32_t)(crop->margins[2]);
|
||||||
|
- rmargin = (uint32_t)(crop->margins[3]);
|
||||||
|
+ tmargin = _TIFFClampDoubleToUInt32(crop->margins[0]);
|
||||||
|
+ lmargin = _TIFFClampDoubleToUInt32(crop->margins[1]);
|
||||||
|
+ bmargin = _TIFFClampDoubleToUInt32(crop->margins[2]);
|
||||||
|
+ rmargin = _TIFFClampDoubleToUInt32(crop->margins[3]);
|
||||||
|
}
|
||||||
|
else
|
||||||
|
{ /* inches or centimeters specified */
|
||||||
|
- tmargin = (uint32_t)(crop->margins[0] * scale * yres);
|
||||||
|
- lmargin = (uint32_t)(crop->margins[1] * scale * xres);
|
||||||
|
- bmargin = (uint32_t)(crop->margins[2] * scale * yres);
|
||||||
|
- rmargin = (uint32_t)(crop->margins[3] * scale * xres);
|
||||||
|
+ tmargin = _TIFFClampDoubleToUInt32(crop->margins[0] * scale * yres);
|
||||||
|
+ lmargin = _TIFFClampDoubleToUInt32(crop->margins[1] * scale * xres);
|
||||||
|
+ bmargin = _TIFFClampDoubleToUInt32(crop->margins[2] * scale * yres);
|
||||||
|
+ rmargin = _TIFFClampDoubleToUInt32(crop->margins[3] * scale * xres);
|
||||||
|
}
|
||||||
|
|
||||||
|
if ((lmargin + rmargin) > image->width)
|
||||||
|
@@ -5397,24 +5397,24 @@ computeInputPixelOffsets(struct crop_mask *crop, struct image_data *image,
|
||||||
|
if (crop->res_unit != RESUNIT_INCH && crop->res_unit != RESUNIT_CENTIMETER)
|
||||||
|
{
|
||||||
|
if (crop->crop_mode & CROP_WIDTH)
|
||||||
|
- width = (uint32_t)crop->width;
|
||||||
|
+ width = _TIFFClampDoubleToUInt32(crop->width);
|
||||||
|
else
|
||||||
|
width = image->width - lmargin - rmargin;
|
||||||
|
|
||||||
|
if (crop->crop_mode & CROP_LENGTH)
|
||||||
|
- length = (uint32_t)crop->length;
|
||||||
|
+ length = _TIFFClampDoubleToUInt32(crop->length);
|
||||||
|
else
|
||||||
|
length = image->length - tmargin - bmargin;
|
||||||
|
}
|
||||||
|
else
|
||||||
|
{
|
||||||
|
if (crop->crop_mode & CROP_WIDTH)
|
||||||
|
- width = (uint32_t)(crop->width * scale * image->xres);
|
||||||
|
+ width = _TIFFClampDoubleToUInt32(crop->width * scale * image->xres);
|
||||||
|
else
|
||||||
|
width = image->width - lmargin - rmargin;
|
||||||
|
|
||||||
|
if (crop->crop_mode & CROP_LENGTH)
|
||||||
|
- length = (uint32_t)(crop->length * scale * image->yres);
|
||||||
|
+ length = _TIFFClampDoubleToUInt32(crop->length * scale * image->yres);
|
||||||
|
else
|
||||||
|
length = image->length - tmargin - bmargin;
|
||||||
|
}
|
||||||
|
@@ -5868,13 +5868,13 @@ computeOutputPixelOffsets (struct crop_mask *crop, struct image_data *image,
|
||||||
|
{
|
||||||
|
if (page->res_unit == RESUNIT_INCH || page->res_unit == RESUNIT_CENTIMETER)
|
||||||
|
{ /* inches or centimeters specified */
|
||||||
|
- hmargin = (uint32_t)(page->hmargin * scale * page->hres * ((image->bps + 7) / 8));
|
||||||
|
- vmargin = (uint32_t)(page->vmargin * scale * page->vres * ((image->bps + 7) / 8));
|
||||||
|
+ hmargin = _TIFFClampDoubleToUInt32(page->hmargin * scale * page->hres * ((image->bps + 7) / 8));
|
||||||
|
+ vmargin = _TIFFClampDoubleToUInt32(page->vmargin * scale * page->vres * ((image->bps + 7) / 8));
|
||||||
|
}
|
||||||
|
else
|
||||||
|
{ /* Otherwise user has specified pixels as reference unit */
|
||||||
|
- hmargin = (uint32_t)(page->hmargin * scale * ((image->bps + 7) / 8));
|
||||||
|
- vmargin = (uint32_t)(page->vmargin * scale * ((image->bps + 7) / 8));
|
||||||
|
+ hmargin = _TIFFClampDoubleToUInt32(page->hmargin * scale * ((image->bps + 7) / 8));
|
||||||
|
+ vmargin = _TIFFClampDoubleToUInt32(page->vmargin * scale * ((image->bps + 7) / 8));
|
||||||
|
}
|
||||||
|
|
||||||
|
if ((hmargin * 2.0) > (pwidth * page->hres))
|
||||||
|
@@ -5912,13 +5912,13 @@ computeOutputPixelOffsets (struct crop_mask *crop, struct image_data *image,
|
||||||
|
{
|
||||||
|
if (page->mode & PAGE_MODE_PAPERSIZE )
|
||||||
|
{
|
||||||
|
- owidth = (uint32_t)((pwidth * page->hres) - (hmargin * 2));
|
||||||
|
- olength = (uint32_t)((plength * page->vres) - (vmargin * 2));
|
||||||
|
+ owidth = _TIFFClampDoubleToUInt32((pwidth * page->hres) - (hmargin * 2));
|
||||||
|
+ olength = _TIFFClampDoubleToUInt32((plength * page->vres) - (vmargin * 2));
|
||||||
|
}
|
||||||
|
else
|
||||||
|
{
|
||||||
|
- owidth = (uint32_t)(iwidth - (hmargin * 2 * page->hres));
|
||||||
|
- olength = (uint32_t)(ilength - (vmargin * 2 * page->vres));
|
||||||
|
+ owidth = _TIFFClampDoubleToUInt32(iwidth - (hmargin * 2 * page->hres));
|
||||||
|
+ olength = _TIFFClampDoubleToUInt32(ilength - (vmargin * 2 * page->vres));
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -5927,6 +5927,12 @@ computeOutputPixelOffsets (struct crop_mask *crop, struct image_data *image,
|
||||||
|
if (olength > ilength)
|
||||||
|
olength = ilength;
|
||||||
|
|
||||||
|
+ if (owidth == 0 || olength == 0)
|
||||||
|
+ {
|
||||||
|
+ TIFFError("computeOutputPixelOffsets", "Integer overflow when calculating the number of pages");
|
||||||
|
+ exit(EXIT_FAILURE);
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
/* Compute the number of pages required for Portrait or Landscape */
|
||||||
|
switch (page->orient)
|
||||||
|
{
|
@ -0,0 +1,90 @@
|
|||||||
|
From ecd9216e574039b8fba893314bdfc6edbdd6bf20 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Su_Laus <sulau@freenet.de>
|
||||||
|
Date: Mon, 15 Aug 2022 22:11:03 +0200
|
||||||
|
Subject: [PATCH] =?UTF-8?q?(CVE-2022-2519=20CVE-2022-2520=20CVE-2022-2521)?=
|
||||||
|
=?UTF-8?q?=20According=20to=20Richard=20Nolde=20https://gitlab.com/libtif?=
|
||||||
|
=?UTF-8?q?f/libtiff/-/issues/401#note=5F877637400=20the=20tiffcrop=20opti?=
|
||||||
|
=?UTF-8?q?on=20=E2=80=9E-S=E2=80=9C=20is=20also=20mutually=20exclusive=20?=
|
||||||
|
=?UTF-8?q?to=20the=20other=20crop=20options=20(-X|-Y),=20-Z=20and=20-z.?=
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
This is now checked and ends tiffcrop if those arguments are not mutually exclusive.
|
||||||
|
|
||||||
|
This MR will fix the following tiffcrop issues: #349, #414, #422, #423, #424
|
||||||
|
|
||||||
|
(cherry picked from commit 8fe3735942ea1d90d8cef843b55b3efe8ab6feaf)
|
||||||
|
---
|
||||||
|
tools/tiffcrop.c | 27 ++++++++++++++-------------
|
||||||
|
1 file changed, 14 insertions(+), 13 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/tools/tiffcrop.c b/tools/tiffcrop.c
|
||||||
|
index 90286a5e..d9213ecb 100644
|
||||||
|
--- a/tools/tiffcrop.c
|
||||||
|
+++ b/tools/tiffcrop.c
|
||||||
|
@@ -108,7 +108,7 @@
|
||||||
|
* lower level, scanline level routines. Debug reports a limited set
|
||||||
|
* of messages to monitor progress without enabling dump logs.
|
||||||
|
*
|
||||||
|
- * Note: The (-X|-Y), -Z and -z options are mutually exclusive.
|
||||||
|
+ * Note: The (-X|-Y), -Z, -z and -S options are mutually exclusive.
|
||||||
|
* In no case should the options be applied to a given selection successively.
|
||||||
|
*/
|
||||||
|
|
||||||
|
@@ -173,12 +173,12 @@ static char tiffcrop_rev_date[] = "02-09-2022";
|
||||||
|
#define ROTATECW_270 32
|
||||||
|
#define ROTATE_ANY (ROTATECW_90 | ROTATECW_180 | ROTATECW_270)
|
||||||
|
|
||||||
|
-#define CROP_NONE 0
|
||||||
|
-#define CROP_MARGINS 1
|
||||||
|
-#define CROP_WIDTH 2
|
||||||
|
-#define CROP_LENGTH 4
|
||||||
|
-#define CROP_ZONES 8
|
||||||
|
-#define CROP_REGIONS 16
|
||||||
|
+#define CROP_NONE 0 /* "-S" -> Page_MODE_ROWSCOLS and page->rows/->cols != 0 */
|
||||||
|
+#define CROP_MARGINS 1 /* "-m" */
|
||||||
|
+#define CROP_WIDTH 2 /* "-X" */
|
||||||
|
+#define CROP_LENGTH 4 /* "-Y" */
|
||||||
|
+#define CROP_ZONES 8 /* "-Z" */
|
||||||
|
+#define CROP_REGIONS 16 /* "-z" */
|
||||||
|
#define CROP_ROTATE 32
|
||||||
|
#define CROP_MIRROR 64
|
||||||
|
#define CROP_INVERT 128
|
||||||
|
@@ -316,7 +316,7 @@ struct crop_mask {
|
||||||
|
#define PAGE_MODE_RESOLUTION 1
|
||||||
|
#define PAGE_MODE_PAPERSIZE 2
|
||||||
|
#define PAGE_MODE_MARGINS 4
|
||||||
|
-#define PAGE_MODE_ROWSCOLS 8
|
||||||
|
+#define PAGE_MODE_ROWSCOLS 8 /* for -S option */
|
||||||
|
|
||||||
|
#define INVERT_DATA_ONLY 10
|
||||||
|
#define INVERT_DATA_AND_TAG 11
|
||||||
|
@@ -781,7 +781,7 @@ static const char usage_info[] =
|
||||||
|
" The four debug/dump options are independent, though it makes little sense to\n"
|
||||||
|
" specify a dump file without specifying a detail level.\n"
|
||||||
|
"\n"
|
||||||
|
-"Note: The (-X|-Y), -Z and -z options are mutually exclusive.\n"
|
||||||
|
+"Note: The (-X|-Y), -Z, -z and -S options are mutually exclusive.\n"
|
||||||
|
" In no case should the options be applied to a given selection successively.\n"
|
||||||
|
"\n"
|
||||||
|
;
|
||||||
|
@@ -2131,13 +2131,14 @@ void process_command_opts (int argc, char *argv[], char *mp, char *mode, uint32
|
||||||
|
/*NOTREACHED*/
|
||||||
|
}
|
||||||
|
}
|
||||||
|
- /*-- Check for not allowed combinations (e.g. -X, -Y and -Z and -z are mutually exclusive) --*/
|
||||||
|
- char XY, Z, R;
|
||||||
|
+ /*-- Check for not allowed combinations (e.g. -X, -Y and -Z, -z and -S are mutually exclusive) --*/
|
||||||
|
+ char XY, Z, R, S;
|
||||||
|
XY = ((crop_data->crop_mode & CROP_WIDTH) || (crop_data->crop_mode & CROP_LENGTH));
|
||||||
|
Z = (crop_data->crop_mode & CROP_ZONES);
|
||||||
|
R = (crop_data->crop_mode & CROP_REGIONS);
|
||||||
|
- if ((XY && Z) || (XY && R) || (Z && R)) {
|
||||||
|
- TIFFError("tiffcrop input error", "The crop options(-X|-Y), -Z and -z are mutually exclusive.->Exit");
|
||||||
|
+ S = (page->mode & PAGE_MODE_ROWSCOLS);
|
||||||
|
+ if ((XY && Z) || (XY && R) || (XY && S) || (Z && R) || (Z && S) || (R && S)) {
|
||||||
|
+ TIFFError("tiffcrop input error", "The crop options(-X|-Y), -Z, -z and -S are mutually exclusive.->Exit");
|
||||||
|
exit(EXIT_FAILURE);
|
||||||
|
}
|
||||||
|
} /* end process_command_opts */
|
@ -0,0 +1,32 @@
|
|||||||
|
From 670117c3a76bc0f995bfdb6c293ab2ce9af18273 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Su_Laus <sulau@freenet.de>
|
||||||
|
Date: Sat, 20 Aug 2022 23:35:26 +0200
|
||||||
|
Subject: [PATCH] (CVE-2022-2519 CVE-2022-2520 CVE-2022-2521) tiffcrop -S
|
||||||
|
option: Make decision simpler.
|
||||||
|
|
||||||
|
(cherry picked from commit bad48e90b410df32172006c7876da449ba62cdba)
|
||||||
|
---
|
||||||
|
tools/tiffcrop.c | 10 +++++-----
|
||||||
|
1 file changed, 5 insertions(+), 5 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/tools/tiffcrop.c b/tools/tiffcrop.c
|
||||||
|
index d9213ecb..0551a01c 100644
|
||||||
|
--- a/tools/tiffcrop.c
|
||||||
|
+++ b/tools/tiffcrop.c
|
||||||
|
@@ -2133,11 +2133,11 @@ void process_command_opts (int argc, char *argv[], char *mp, char *mode, uint32
|
||||||
|
}
|
||||||
|
/*-- Check for not allowed combinations (e.g. -X, -Y and -Z, -z and -S are mutually exclusive) --*/
|
||||||
|
char XY, Z, R, S;
|
||||||
|
- XY = ((crop_data->crop_mode & CROP_WIDTH) || (crop_data->crop_mode & CROP_LENGTH));
|
||||||
|
- Z = (crop_data->crop_mode & CROP_ZONES);
|
||||||
|
- R = (crop_data->crop_mode & CROP_REGIONS);
|
||||||
|
- S = (page->mode & PAGE_MODE_ROWSCOLS);
|
||||||
|
- if ((XY && Z) || (XY && R) || (XY && S) || (Z && R) || (Z && S) || (R && S)) {
|
||||||
|
+ XY = ((crop_data->crop_mode & CROP_WIDTH) || (crop_data->crop_mode & CROP_LENGTH)) ? 1 : 0;
|
||||||
|
+ Z = (crop_data->crop_mode & CROP_ZONES) ? 1 : 0;
|
||||||
|
+ R = (crop_data->crop_mode & CROP_REGIONS) ? 1 : 0;
|
||||||
|
+ S = (page->mode & PAGE_MODE_ROWSCOLS) ? 1 : 0;
|
||||||
|
+ if (XY + Z + R + S > 1) {
|
||||||
|
TIFFError("tiffcrop input error", "The crop options(-X|-Y), -Z, -z and -S are mutually exclusive.->Exit");
|
||||||
|
exit(EXIT_FAILURE);
|
||||||
|
}
|
@ -1,31 +0,0 @@
|
|||||||
Back off the minimum required automake version to 1.11. There isn't
|
|
||||||
anything in libtiff currently that actually requires 1.12, and changing
|
|
||||||
this allows the package to be built on pre-F18 machines for easier testing.
|
|
||||||
|
|
||||||
This patch can go away once we no longer care about testing on pre-F18.
|
|
||||||
|
|
||||||
|
|
||||||
diff -Naur tiff-4.0.3.orig/Makefile.am tiff-4.0.3/Makefile.am
|
|
||||||
--- tiff-4.0.3.orig/Makefile.am 2012-09-20 09:22:47.000000000 -0400
|
|
||||||
+++ tiff-4.0.3/Makefile.am 2012-10-30 11:33:30.312823564 -0400
|
|
||||||
@@ -25,7 +25,7 @@
|
|
||||||
|
|
||||||
docdir = $(LIBTIFF_DOCDIR)
|
|
||||||
|
|
||||||
-AUTOMAKE_OPTIONS = 1.12 dist-zip foreign
|
|
||||||
+AUTOMAKE_OPTIONS = 1.11 dist-zip foreign
|
|
||||||
ACLOCAL_AMFLAGS = -I m4
|
|
||||||
|
|
||||||
docfiles = \
|
|
||||||
diff -Naur tiff-4.0.3.orig/test/Makefile.am tiff-4.0.3/test/Makefile.am
|
|
||||||
--- tiff-4.0.3.orig/test/Makefile.am 2012-09-20 09:22:28.000000000 -0400
|
|
||||||
+++ tiff-4.0.3/test/Makefile.am 2012-10-30 11:33:17.109696812 -0400
|
|
||||||
@@ -23,7 +23,7 @@
|
|
||||||
|
|
||||||
# Process this file with automake to produce Makefile.in.
|
|
||||||
|
|
||||||
-AUTOMAKE_OPTIONS = 1.12 color-tests parallel-tests foreign
|
|
||||||
+AUTOMAKE_OPTIONS = 1.11 color-tests parallel-tests foreign
|
|
||||||
|
|
||||||
LIBTIFF = $(top_builddir)/libtiff/libtiff.la
|
|
||||||
|
|
@ -1,12 +0,0 @@
|
|||||||
diff --git a/html/man/Makefile.am b/html/man/Makefile.am
|
|
||||||
index 587296c..696005e 100644
|
|
||||||
--- a/html/man/Makefile.am
|
|
||||||
+++ b/html/man/Makefile.am
|
|
||||||
@@ -92,7 +92,6 @@ docfiles = \
|
|
||||||
tiffcrop.1.html \
|
|
||||||
tiffdither.1.html \
|
|
||||||
tiffdump.1.html \
|
|
||||||
- tiffgt.1.html \
|
|
||||||
tiffinfo.1.html \
|
|
||||||
tiffmedian.1.html \
|
|
||||||
tiffset.1.html \
|
|
@ -1,14 +1,19 @@
|
|||||||
Summary: Library of functions for manipulating TIFF format image files
|
Summary: Library of functions for manipulating TIFF format image files
|
||||||
Name: libtiff
|
Name: libtiff
|
||||||
Version: 4.4.0
|
Version: 4.4.0
|
||||||
Release: 2%{?dist}
|
Release: 5%{?dist}
|
||||||
License: libtiff
|
License: libtiff
|
||||||
URL: http://www.simplesystems.org/libtiff/
|
URL: http://www.simplesystems.org/libtiff/
|
||||||
|
|
||||||
Source: ftp://ftp.simplesystems.org/pub/libtiff/tiff-%{version}.tar.gz
|
Source: ftp://ftp.simplesystems.org/pub/libtiff/tiff-%{version}.tar.gz
|
||||||
|
|
||||||
Patch0: libtiff-am-version.patch
|
# Patches generated from https://gitlab.cee.redhat.com/mmuzila/libtiff/-/tree/c9s
|
||||||
Patch1: libtiff-make-check.patch
|
# Patches were generated by: git format-patch -N ...
|
||||||
|
Patch0001: 0001-Back-off-the-minimum-required-automake-version-to-1..patch
|
||||||
|
Patch0002: 0002-Fix-Makefile.patch
|
||||||
|
Patch0003: 0003-CVE-2022-2056-CVE-2022-2057-CVE-2022-2058-fix-the-FP.patch
|
||||||
|
Patch0004: 0004-CVE-2022-2519-CVE-2022-2520-CVE-2022-2521-According-.patch
|
||||||
|
Patch0005: 0005-CVE-2022-2519-CVE-2022-2520-CVE-2022-2521-tiffcrop-S.patch
|
||||||
|
|
||||||
BuildRequires: gcc, gcc-c++
|
BuildRequires: gcc, gcc-c++
|
||||||
BuildRequires: zlib-devel libjpeg-devel jbigkit-devel libzstd-devel libwebp-devel
|
BuildRequires: zlib-devel libjpeg-devel jbigkit-devel libzstd-devel libwebp-devel
|
||||||
@ -56,10 +61,7 @@ This package contains command-line programs for manipulating TIFF format
|
|||||||
image files using the libtiff library.
|
image files using the libtiff library.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n tiff-%{version}
|
%autosetup -p1 -n tiff-%{version}
|
||||||
|
|
||||||
%patch0 -p1
|
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
# Use build system's libtool.m4, not the one in the package.
|
# Use build system's libtool.m4, not the one in the package.
|
||||||
rm -f libtool.m4
|
rm -f libtool.m4
|
||||||
@ -164,6 +166,17 @@ find html -name 'Makefile*' | xargs rm
|
|||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 24 2022 Matej Mužila <mmuzila@redhat.com> - 4.4.0-5
|
||||||
|
- Bump release
|
||||||
|
- Resolves: CVE-2022-2953
|
||||||
|
|
||||||
|
* Tue Oct 11 2022 Matej Mužila <mmuzila@redhat.com> - 4.4.0-4
|
||||||
|
- Resolves: CVE-2022-2519 CVE-2022-2520 CVE-2022-2521
|
||||||
|
|
||||||
|
* Mon Jul 18 2022 Matej Mužila <mmuzila@redhat.com> 4.4.0-3
|
||||||
|
- Fix CVE-2022-2056 CVE-2022-2057 CVE-2022-2058
|
||||||
|
- Resolves: #2106768
|
||||||
|
|
||||||
* Wed Jun 15 2022 Matej Mužila <mmuzila@redhat.com> 4.4.0-2
|
* Wed Jun 15 2022 Matej Mužila <mmuzila@redhat.com> 4.4.0-2
|
||||||
- Update to version 4.4.0
|
- Update to version 4.4.0
|
||||||
- Resolves: CVE-2022-0561 CVE-2022-0562 CVE-2022-22844 CVE-2022-0865
|
- Resolves: CVE-2022-0561 CVE-2022-0562 CVE-2022-22844 CVE-2022-0865
|
||||||
|
Loading…
Reference in New Issue
Block a user