Update to libtiff 4.0.3
This commit is contained in:
parent
b6f0d3e539
commit
78445b68d5
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
/tiff-4.0.2.tar.gz
|
||||
/tiff-4.0.3.tar.gz
|
||||
|
@ -1,15 +0,0 @@
|
||||
diff -up tiff-4.0.2/test/raw_decode.c.bigendian tiff-4.0.2/test/raw_decode.c
|
||||
--- tiff-4.0.2/test/raw_decode.c.bigendian 2012-07-03 15:27:37.168543695 +0200
|
||||
+++ tiff-4.0.2/test/raw_decode.c 2012-07-03 15:28:47.795051599 +0200
|
||||
@@ -85,9 +85,9 @@ static int check_rgb_pixel( int pixel, i
|
||||
static int check_rgba_pixel( int pixel, int red, int green, int blue, int alpha, unsigned char *buffer ) {
|
||||
/* RGBA images are upside down - adjust for normal ordering */
|
||||
int adjusted_pixel = pixel % 128 + (127 - (pixel/128)) * 128;
|
||||
- unsigned char *rgba = buffer + 4 * adjusted_pixel;
|
||||
+ unsigned int *rgba = (unsigned int*)(buffer + 4 * adjusted_pixel);
|
||||
|
||||
- if( rgba[0] == red && rgba[1] == green && rgba[2] == blue && rgba[3] == alpha ) {
|
||||
+ if( TIFFGetR(*rgba) == red && TIFFGetG(*rgba) == green && TIFFGetB(*rgba) == blue && TIFFGetA(*rgba) == alpha ) {
|
||||
return 0;
|
||||
}
|
||||
|
@ -1,11 +0,0 @@
|
||||
diff -Naur tiff-4.0.2.orig/tools/tiff2pdf.c tiff-4.0.2/tools/tiff2pdf.c
|
||||
--- tiff-4.0.2.orig/tools/tiff2pdf.c 2012-06-15 17:51:54.000000000 -0400
|
||||
+++ tiff-4.0.2/tools/tiff2pdf.c 2012-07-05 13:34:36.569691068 -0400
|
||||
@@ -1066,6 +1066,7 @@
|
||||
"Can't set directory %u of input file %s",
|
||||
i,
|
||||
TIFFFileName(input));
|
||||
+ t2p->t2p_error = T2P_ERR_ERROR;
|
||||
return;
|
||||
}
|
||||
if(TIFFGetField(input, TIFFTAG_PAGENUMBER, &pagen, &paged)){
|
File diff suppressed because it is too large
Load Diff
15
libtiff.spec
15
libtiff.spec
@ -1,7 +1,7 @@
|
||||
Summary: Library of functions for manipulating TIFF format image files
|
||||
Name: libtiff
|
||||
Version: 4.0.2
|
||||
Release: 6%{?dist}
|
||||
Version: 4.0.3
|
||||
Release: 1%{?dist}
|
||||
|
||||
License: libtiff
|
||||
Group: System Environment/Libraries
|
||||
@ -9,10 +9,6 @@ URL: http://www.remotesensing.org/libtiff/
|
||||
|
||||
Source: ftp://ftp.remotesensing.org/pub/libtiff/tiff-%{version}.tar.gz
|
||||
|
||||
Patch1: libtiff-4.0.2-bigendian.patch
|
||||
Patch2: libtiff-CVE-2012-3401.patch
|
||||
Patch3: libtiff-accessors.patch
|
||||
|
||||
BuildRequires: zlib-devel libjpeg-devel jbigkit-devel
|
||||
BuildRequires: libtool automake autoconf pkgconfig
|
||||
|
||||
@ -62,10 +58,6 @@ image files using the libtiff library.
|
||||
%prep
|
||||
%setup -q -n tiff-%{version}
|
||||
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
# Use build system's libtool.m4, not the one in the package.
|
||||
rm -f libtool.m4
|
||||
|
||||
@ -168,6 +160,9 @@ find html -name 'Makefile*' | xargs rm
|
||||
%{_mandir}/man1/*
|
||||
|
||||
%changelog
|
||||
* Thu Oct 4 2012 Tom Lane <tgl@redhat.com> 4.0.3-1
|
||||
- Update to libtiff 4.0.3
|
||||
|
||||
* Fri Aug 3 2012 Tom Lane <tgl@redhat.com> 4.0.2-6
|
||||
- Remove compat subpackage; no longer needed
|
||||
- Minor specfile cleanup per suggestions from Tom Callaway
|
||||
|
Loading…
Reference in New Issue
Block a user