- New upstream release 1.0beta3
This commit is contained in:
parent
cdec552bcd
commit
fd88dafbee
@ -1 +1 @@
|
|||||||
libtheora-1.0beta2.tar.gz
|
libtheora-1.0beta3.tar.gz
|
||||||
|
@ -1,70 +0,0 @@
|
|||||||
--- libtheora-1.0beta2/examples/png2theora.c 2007-10-04 20:37:00.000000000 +0200
|
|
||||||
+++ libtheora-1.0beta2/examples/png2theora.c.new 2007-11-29 21:30:56.000000000 +0100
|
|
||||||
@@ -12,7 +12,7 @@
|
|
||||||
|
|
||||||
function: example encoder application; makes an Ogg Theora
|
|
||||||
file from a sequence of png images
|
|
||||||
- last mod: $Id: png2theora.c 13925 2007-10-03 18:51:06Z sping $
|
|
||||||
+ last mod: $Id$
|
|
||||||
based on code from Vegard Nossum
|
|
||||||
|
|
||||||
********************************************************************/
|
|
||||||
@@ -132,22 +132,24 @@
|
|
||||||
fwrite(og.header, og.header_len, 1, ogg_fp);
|
|
||||||
fwrite(og.body, og.body_len, 1, ogg_fp);
|
|
||||||
}
|
|
||||||
+ /* libogg flushes automatically after the first header */
|
|
||||||
|
|
||||||
theora_comment_init(&tc);
|
|
||||||
theora_encode_comment(&tc, &op);
|
|
||||||
ogg_stream_packetin(&ogg_os, &op);
|
|
||||||
- if(ogg_stream_pageout(&ogg_os, &og)) {
|
|
||||||
+ while(ogg_stream_pageout(&ogg_os, &og)) {
|
|
||||||
fwrite(og.header, og.header_len, 1, ogg_fp);
|
|
||||||
fwrite(og.body, og.body_len, 1, ogg_fp);
|
|
||||||
}
|
|
||||||
|
|
||||||
theora_encode_tables(&theora_td, &op);
|
|
||||||
ogg_stream_packetin(&ogg_os, &op);
|
|
||||||
- if(ogg_stream_pageout(&ogg_os, &og)) {
|
|
||||||
+ while(ogg_stream_pageout(&ogg_os, &og)) {
|
|
||||||
fwrite(og.header, og.header_len, 1, ogg_fp);
|
|
||||||
fwrite(og.body, og.body_len, 1, ogg_fp);
|
|
||||||
}
|
|
||||||
|
|
||||||
+ /* flush at the end of the headers */
|
|
||||||
if(ogg_stream_flush(&ogg_os, &og)) {
|
|
||||||
fwrite(og.header, og.header_len, 1, ogg_fp);
|
|
||||||
fwrite(og.body, og.body_len, 1, ogg_fp);
|
|
||||||
@@ -234,7 +236,7 @@
|
|
||||||
}
|
|
||||||
|
|
||||||
ogg_stream_packetin(&ogg_os, &op);
|
|
||||||
- if(ogg_stream_pageout(&ogg_os, &og)) {
|
|
||||||
+ while(ogg_stream_pageout(&ogg_os, &og)) {
|
|
||||||
fwrite(og.header, og.header_len, 1, ogg_fp);
|
|
||||||
fwrite(og.body, og.body_len, 1, ogg_fp);
|
|
||||||
}
|
|
||||||
@@ -254,7 +256,11 @@
|
|
||||||
|
|
||||||
if (theora_initialized) {
|
|
||||||
theora_encode_packetout(&theora_td, 1, &op);
|
|
||||||
- if(ogg_stream_pageout(&ogg_os, &og)) {
|
|
||||||
+ while(ogg_stream_pageout(&ogg_os, &og)) {
|
|
||||||
+ fwrite(og.header, og.header_len, 1, ogg_fp);
|
|
||||||
+ fwrite(og.body, og.body_len, 1, ogg_fp);
|
|
||||||
+ }
|
|
||||||
+ if(ogg_stream_flush(&ogg_os, &og)) {
|
|
||||||
fwrite(og.header, og.header_len, 1, ogg_fp);
|
|
||||||
fwrite(og.body, og.body_len, 1, ogg_fp);
|
|
||||||
}
|
|
||||||
@@ -369,7 +375,8 @@
|
|
||||||
png_init_io(png_ptr, fp);
|
|
||||||
png_set_sig_bytes(png_ptr, 8);
|
|
||||||
|
|
||||||
- png_read_png(png_ptr, info_ptr, PNG_TRANSFORM_STRIP_16, NULL);
|
|
||||||
+ png_read_png(png_ptr, info_ptr, PNG_TRANSFORM_STRIP_16 |
|
|
||||||
+ PNG_TRANSFORM_STRIP_ALPHA | PNG_TRANSFORM_PACKING, NULL);
|
|
||||||
|
|
||||||
row_pointers = png_get_rows(png_ptr, info_ptr);
|
|
||||||
|
|
24
libtheora-1.0beta3-undef-nonweak-symbols.patch
Normal file
24
libtheora-1.0beta3-undef-nonweak-symbols.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff -up libtheora-1.0beta3/lib/Makefile.am.foo libtheora-1.0beta3/lib/Makefile.am
|
||||||
|
--- libtheora-1.0beta3/lib/Makefile.am.foo 2008-04-16 22:25:54.000000000 +0200
|
||||||
|
+++ libtheora-1.0beta3/lib/Makefile.am 2008-04-19 10:29:14.000000000 +0200
|
||||||
|
@@ -144,6 +144,7 @@ libtheoraenc_la_SOURCES = \
|
||||||
|
libtheoraenc_la_LDFLAGS = \
|
||||||
|
-version-info @THENC_LIB_CURRENT@:@THENC_LIB_REVISION@:@THENC_LIB_AGE@ \
|
||||||
|
@THEORAENC_LDFLAGS@ $(OGG_LIBS)
|
||||||
|
+libtheoraenc_la_LIBADD = libtheora.la
|
||||||
|
|
||||||
|
libtheora_la_SOURCES = \
|
||||||
|
cpu.c \
|
||||||
|
diff -up libtheora-1.0beta3/lib/Makefile.in.foo libtheora-1.0beta3/lib/Makefile.in
|
||||||
|
--- libtheora-1.0beta3/lib/Makefile.in.foo 2008-04-16 22:26:15.000000000 +0200
|
||||||
|
+++ libtheora-1.0beta3/lib/Makefile.in 2008-04-19 10:32:32.000000000 +0200
|
||||||
|
@@ -119,7 +119,8 @@ libtheoradec_la_OBJECTS = $(am_libtheora
|
||||||
|
libtheoradec_la_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) \
|
||||||
|
$(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
|
||||||
|
$(libtheoradec_la_LDFLAGS) $(LDFLAGS) -o $@
|
||||||
|
-libtheoraenc_la_LIBADD =
|
||||||
|
+libtheoraenc_la_LIBADD = libtheora.la
|
||||||
|
+libtheoraenc_la_DEPENDENCIES = libtheora.la
|
||||||
|
am__libtheoraenc_la_SOURCES_DIST = cpu.c \
|
||||||
|
$(enc_arch_dir)/dct_decode_mmx.c $(enc_arch_dir)/dsp_mmx.c \
|
||||||
|
$(enc_arch_dir)/dsp_mmxext.c $(enc_arch_dir)/recon_mmx.c \
|
@ -1,14 +1,14 @@
|
|||||||
Summary: Theora Video Compression Codec
|
Summary: Theora Video Compression Codec
|
||||||
Name: libtheora
|
Name: libtheora
|
||||||
Version: 1.0beta2
|
Version: 1.0beta3
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 0
|
Epoch: 0
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://www.theora.org
|
URL: http://www.theora.org
|
||||||
Source0: http://downloads.xiph.org/releases/theora/%{name}-%{version}.tar.gz
|
Source0: http://downloads.xiph.org/releases/theora/%{name}-%{version}.tar.gz
|
||||||
Patch1: libtheora-1.0alpha8-textreloc.patch
|
Patch1: libtheora-1.0alpha8-textreloc.patch
|
||||||
Patch2: libtheora-1.0beta2-png2theora.patch
|
Patch2: libtheora-1.0beta3-undef-nonweak-symbols.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: libogg-devel >= 2:1.1
|
BuildRequires: libogg-devel >= 2:1.1
|
||||||
BuildRequires: libvorbis-devel
|
BuildRequires: libvorbis-devel
|
||||||
@ -57,19 +57,24 @@ with theora bitstreams.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
|
# no custom CFLAGS please
|
||||||
|
sed -i 's/CFLAGS="$CFLAGS $cflags_save"/CFLAGS="$cflags_save"/g' configure
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --enable-shared --disable-static
|
%configure --enable-shared --disable-static
|
||||||
|
# Don't use rpath!
|
||||||
|
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||||
|
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||||
make
|
make
|
||||||
make -C doc/spec
|
make -C doc/spec
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
%makeinstall
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
|
|
||||||
rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
|
rm $RPM_BUILD_ROOT/%{_libdir}/*.la
|
||||||
rm -r $RPM_BUILD_ROOT/%{_docdir}/%{name}-%{version}
|
rm -r $RPM_BUILD_ROOT/%{_docdir}/%{name}-%{version}
|
||||||
|
|
||||||
mkdir -p $RPM_BUILD_ROOT/%{_bindir}
|
mkdir -p $RPM_BUILD_ROOT/%{_bindir}
|
||||||
@ -95,11 +100,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc doc/libtheora/html doc/vp3-format.txt doc/spec/Theora_spec.pdf
|
%doc doc/libtheora/html doc/vp3-format.txt doc/spec/Theora.pdf
|
||||||
%doc doc/color.html doc/draft-ietf-avt-rtp-theora-00.txt
|
%doc doc/color.html doc/draft-ietf-avt-rtp-theora-00.txt
|
||||||
%{_includedir}/theora
|
%{_includedir}/theora
|
||||||
%{_libdir}/*.so
|
%{_libdir}/*.so
|
||||||
%{_libdir}/pkgconfig/theora.pc
|
%{_libdir}/pkgconfig/theora*.pc
|
||||||
|
|
||||||
%files -n theora-tools
|
%files -n theora-tools
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
@ -107,6 +112,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 17 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 1.0beta3-1
|
||||||
|
- New upstream release 1.0beta3
|
||||||
|
|
||||||
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:1.0beta2-4
|
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:1.0beta2-4
|
||||||
- Autorebuild for GCC 4.3
|
- Autorebuild for GCC 4.3
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user