- libtheora 1.1alpha1. Woo Thusnelda!
This commit is contained in:
parent
a1a17ebd9d
commit
e481380f49
@ -1 +1,2 @@
|
||||
libtheora-1.0.tar.bz2
|
||||
libtheora-1.1alpha1.tar.bz2
|
||||
|
@ -1,31 +0,0 @@
|
||||
diff -up libtheora-1.0alpha8/lib/enc/x86_32/dct_decode_mmx.c~ libtheora-1.0alpha8/lib/enc/x86_32/dct_decode_mmx.c
|
||||
--- libtheora-1.0alpha8/lib/enc/x86_32/dct_decode_mmx.c~ 2007-09-14 19:27:07.000000000 +0200
|
||||
+++ libtheora-1.0alpha8/lib/enc/x86_32/dct_decode_mmx.c 2007-09-14 19:27:07.000000000 +0200
|
||||
@@ -21,6 +21,9 @@
|
||||
|
||||
#if defined(USE_ASM)
|
||||
|
||||
+/* Disabled as this asm results in text relocations, which is BAD */
|
||||
+#if 0
|
||||
+
|
||||
static const __attribute__((aligned(8),used)) ogg_int64_t V3= 0x0003000300030003LL;
|
||||
static const __attribute__((aligned(8),used)) ogg_int64_t V804= 0x0804080408040804LL;
|
||||
|
||||
@@ -173,12 +176,17 @@ static void FilterVert__mmx(unsigned cha
|
||||
);
|
||||
}
|
||||
|
||||
+#endif
|
||||
+
|
||||
/* install our implementation in the function table */
|
||||
void dsp_mmx_dct_decode_init(DspFunctions *funcs)
|
||||
{
|
||||
+/* Disabled as this asm results in text relocations, which is BAD */
|
||||
+#if 0
|
||||
TH_DEBUG("enabling accelerated x86_32 mmx dct decode functions.\n");
|
||||
funcs->FilterVert = FilterVert__mmx;
|
||||
funcs->FilterHoriz = FilterHoriz__mmx;
|
||||
+#endif
|
||||
}
|
||||
|
||||
#endif /* USE_ASM */
|
@ -1,24 +0,0 @@
|
||||
diff -up libtheora-1.0/lib/Makefile.am.orig libtheora-1.0/lib/Makefile.am
|
||||
--- libtheora-1.0/lib/Makefile.am.orig 2008-10-24 06:07:31.000000000 +0200
|
||||
+++ libtheora-1.0/lib/Makefile.am 2008-12-16 21:06:12.000000000 +0100
|
||||
@@ -144,6 +144,7 @@ libtheoraenc_la_SOURCES = \
|
||||
libtheoraenc_la_LDFLAGS = \
|
||||
-version-info @THENC_LIB_CURRENT@:@THENC_LIB_REVISION@:@THENC_LIB_AGE@ \
|
||||
@THEORAENC_LDFLAGS@ $(OGG_LIBS)
|
||||
+libtheoraenc_la_LIBADD = libtheoradec.la
|
||||
|
||||
libtheora_la_SOURCES = \
|
||||
$(decoder_arch_sources) \
|
||||
diff -up libtheora-1.0/lib/Makefile.in.orig libtheora-1.0/lib/Makefile.in
|
||||
--- libtheora-1.0/lib/Makefile.in.orig 2008-10-29 11:36:47.000000000 +0100
|
||||
+++ libtheora-1.0/lib/Makefile.in 2008-12-16 21:06:08.000000000 +0100
|
||||
@@ -116,7 +116,8 @@ am__libtheoradec_la_SOURCES_DIST = dec/x
|
||||
Version_script-dec
|
||||
am_libtheoradec_la_OBJECTS = $(am__objects_2) $(am__objects_3)
|
||||
libtheoradec_la_OBJECTS = $(am_libtheoradec_la_OBJECTS)
|
||||
-libtheoraenc_la_LIBADD =
|
||||
+libtheoraenc_la_LIBADD = libtheoradec.la
|
||||
+libtheoraenc_la_DEPENDENCIES = libtheoradec.la
|
||||
am__libtheoraenc_la_SOURCES_DIST = $(enc_arch_dir)/dct_decode_mmx.c \
|
||||
$(enc_arch_dir)/dsp_mmx.c $(enc_arch_dir)/dsp_mmxext.c \
|
||||
$(enc_arch_dir)/recon_mmx.c $(enc_arch_dir)/idct_mmx.c \
|
@ -1,13 +1,12 @@
|
||||
Summary: Theora Video Compression Codec
|
||||
Name: libtheora
|
||||
Version: 1.0
|
||||
Release: 3%{?dist}
|
||||
Version: 1.1alpha1
|
||||
Release: 1%{?dist}
|
||||
Epoch: 1
|
||||
License: BSD
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.theora.org
|
||||
Source0: http://downloads.xiph.org/releases/theora/libtheora-1.0.tar.bz2
|
||||
Patch2: libtheora-1.0beta3-undef-nonweak-symbols.patch
|
||||
Source0: http://downloads.xiph.org/releases/theora/%{name}-%{version}.tar.bz2
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: libogg-devel >= 2:1.1
|
||||
BuildRequires: libvorbis-devel
|
||||
@ -66,7 +65,6 @@ with theora bitstreams.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch2 -p1
|
||||
# no custom CFLAGS please
|
||||
sed -i 's/CFLAGS="$CFLAGS $cflags_save"/CFLAGS="$cflags_save"/g' configure
|
||||
|
||||
@ -125,6 +123,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jun 02 2009 Adam Jackson <ajax@redhat.com> 1:1.1alpha1-1
|
||||
- libtheora 1.1alpha1. Woo Thusnelda!
|
||||
|
||||
* Tue Feb 24 2009 Matthias Clasen <mclasen@redhat.com> 1:1.0-3
|
||||
- Make -devel-docs noarch
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user