Update to 0.1.24-1
This commit is contained in:
parent
e87e4c0b77
commit
da10158c38
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@ libdatrie-0.2.2.tar.gz
|
|||||||
/libdatrie-0.2.8.tar.xz
|
/libdatrie-0.2.8.tar.xz
|
||||||
/libthai-0.1.20.tar.xz
|
/libthai-0.1.20.tar.xz
|
||||||
/libthai-0.1.21.tar.xz
|
/libthai-0.1.21.tar.xz
|
||||||
|
/libthai-0.1.24.tar.xz
|
||||||
|
36
libthai-0.1.24-gcc6.patch
Normal file
36
libthai-0.1.24-gcc6.patch
Normal file
@ -0,0 +1,36 @@
|
|||||||
|
Index: ChangeLog
|
||||||
|
===================================================================
|
||||||
|
--- ChangeLog.orig
|
||||||
|
+++ ChangeLog
|
||||||
|
@@ -28,6 +28,18 @@
|
||||||
|
|
||||||
|
2015-11-22 Theppitak Karoonboonyanan <theppitak@gmail.com>
|
||||||
|
|
||||||
|
+ Fix compilation error with GCC 6
|
||||||
|
+
|
||||||
|
+ * include/thai/thctype.h (_th_bitmsk):
|
||||||
|
+ - Use unsigned int instead of unsigned short for bitmask base,
|
||||||
|
+ as GCC 6 takes ~0 as -1 for unsigned short,
|
||||||
|
+ and causes compilation error for scim-thai.
|
||||||
|
+
|
||||||
|
+ Thanks Martin Michlmayr for the report via Debian #811690
|
||||||
|
+ http://bugs.debian.org/811690
|
||||||
|
+
|
||||||
|
+2016-01-20 Theppitak Karoonboonyanan <theppitak@gmail.com>
|
||||||
|
+
|
||||||
|
* configure.ac: Post-release version suffix added.
|
||||||
|
|
||||||
|
2015-10-22 Theppitak Karoonboonyanan <theppitak@gmail.com>
|
||||||
|
Index: include/thai/thctype.h
|
||||||
|
===================================================================
|
||||||
|
--- include/thai/thctype.h.orig
|
||||||
|
+++ include/thai/thctype.h
|
||||||
|
@@ -363,7 +363,7 @@ extern int th_iscombchar(thchar_t c);
|
||||||
|
#include <ctype.h>
|
||||||
|
#define _th_ISbit(bit) (1 << (bit))
|
||||||
|
#define _th_bitfld(base, val) ((val) << (base))
|
||||||
|
-#define _th_bitmsk(base, bits) (~((~(unsigned short)0) << (bits)) << (base))
|
||||||
|
+#define _th_bitmsk(base, bits) (~((~(unsigned)0) << (bits)) << (base))
|
||||||
|
|
||||||
|
enum {
|
||||||
|
_th_IStis = _th_ISbit(0), /* TIS-620 char */
|
@ -1,20 +1,20 @@
|
|||||||
Index: libthai-0.1.19/doc/Doxyfile.in
|
Index: libthai-0.1.24/doc/Doxyfile.in
|
||||||
===================================================================
|
===================================================================
|
||||||
--- libthai-0.1.19.orig/doc/Doxyfile.in
|
--- libthai-0.1.24.orig/doc/Doxyfile.in
|
||||||
+++ libthai-0.1.19/doc/Doxyfile.in
|
+++ libthai-0.1.24/doc/Doxyfile.in
|
||||||
@@ -940,7 +940,7 @@ HTML_HEADER =
|
@@ -1124,7 +1124,7 @@ HTML_HEADER =
|
||||||
# each generated HTML page. If it is left blank doxygen will generate a
|
# that doxygen normally uses.
|
||||||
# standard footer.
|
# This tag requires that the tag GENERATE_HTML is set to YES.
|
||||||
|
|
||||||
-HTML_FOOTER =
|
-HTML_FOOTER =
|
||||||
+HTML_FOOTER = no_date_footer.html
|
+HTML_FOOTER = no_date_footer.html
|
||||||
|
|
||||||
# The HTML_STYLESHEET tag can be used to specify a user-defined cascading
|
# The HTML_STYLESHEET tag can be used to specify a user-defined cascading style
|
||||||
# style sheet that is used by each HTML page. It can be used to
|
# sheet that is used by each HTML page. It can be used to fine-tune the look of
|
||||||
Index: libthai-0.1.19/doc/no_date_footer.html
|
Index: libthai-0.1.24/doc/no_date_footer.html
|
||||||
===================================================================
|
===================================================================
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ libthai-0.1.19/doc/no_date_footer.html
|
+++ libthai-0.1.24/doc/no_date_footer.html
|
||||||
@@ -0,0 +1,7 @@
|
@@ -0,0 +1,7 @@
|
||||||
+<hr size="1"><address style="text-align: right;"><small>
|
+<hr size="1"><address style="text-align: right;"><small>
|
||||||
+Generated for $projectname by <a href="http://www.doxygen.org/
|
+Generated for $projectname by <a href="http://www.doxygen.org/
|
||||||
|
14
libthai.spec
14
libthai.spec
@ -1,11 +1,12 @@
|
|||||||
Summary: Thai language support routines
|
Summary: Thai language support routines
|
||||||
Name: libthai
|
Name: libthai
|
||||||
Version: 0.1.21
|
Version: 0.1.24
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: ftp://linux.thai.net/pub/thailinux/software/libthai/libthai-%{version}.tar.xz
|
Source: ftp://linux.thai.net/pub/thailinux/software/libthai/libthai-%{version}.tar.xz
|
||||||
Patch: libthai-0.1.9-multilib.patch
|
Patch0: libthai-0.1.9-multilib.patch
|
||||||
|
Patch1: libthai-0.1.24-gcc6.patch
|
||||||
URL: http://linux.thai.net
|
URL: http://linux.thai.net
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
@ -33,7 +34,8 @@ libthai.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch -p1 -b .multilib
|
%patch0 -p1 -b .multilib
|
||||||
|
%patch1 -p0 -b .gcc6
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --disable-static
|
%configure --disable-static
|
||||||
@ -73,6 +75,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/pkgconfig/*
|
%{_libdir}/pkgconfig/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 16 2016 Daiki Ueno <dueno@redhat.com> - 0.1.24-1
|
||||||
|
- Update to 0.1.24
|
||||||
|
- Apply patch from upstream, which fixes scim-thai FTBFS with GCC6 (Closes: #1308117)
|
||||||
|
|
||||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.21-3
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.21-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user