Update to 0.1.20-1
This commit is contained in:
parent
7a6b2b6503
commit
b3779da11e
2
.gitignore
vendored
2
.gitignore
vendored
@ -2,3 +2,5 @@ libthai-0.1.12.tar.gz
|
|||||||
libdatrie-0.2.2.tar.gz
|
libdatrie-0.2.2.tar.gz
|
||||||
/libdatrie-0.2.6.tar.xz
|
/libdatrie-0.2.6.tar.xz
|
||||||
/libthai-0.1.19.tar.xz
|
/libthai-0.1.19.tar.xz
|
||||||
|
/libdatrie-0.2.8.tar.xz
|
||||||
|
/libthai-0.1.20.tar.xz
|
||||||
|
@ -1,18 +1,20 @@
|
|||||||
diff -up libthai-0.1.12/libdatrie-0.2.2/datrie/Makefile.am.static-build libthai-0.1.12/libdatrie-0.2.2/datrie/Makefile.am
|
Index: libthai-0.1.20/libdatrie/datrie/Makefile.am
|
||||||
--- libthai-0.1.12/libdatrie/datrie/Makefile.am.static-build 2009-04-13 05:18:20.000000000 -0400
|
===================================================================
|
||||||
+++ libthai-0.1.12/libdatrie/datrie/Makefile.am 2009-06-27 17:58:06.813631702 -0400
|
--- libthai-0.1.20.orig/libdatrie/datrie/Makefile.am
|
||||||
|
+++ libthai-0.1.20/libdatrie/datrie/Makefile.am
|
||||||
@@ -10,7 +10,7 @@ EXTRA_DIST = libdatrie.map libdatrie.def
|
@@ -10,7 +10,7 @@ EXTRA_DIST = libdatrie.map libdatrie.def
|
||||||
|
|
||||||
INCLUDES = -I$(top_srcdir)
|
AM_CPPFLAGS = -I$(top_srcdir)
|
||||||
|
|
||||||
-lib_LTLIBRARIES = libdatrie.la
|
-lib_LTLIBRARIES = libdatrie.la
|
||||||
+noinst_LTLIBRARIES = libdatrie.la
|
+noinst_LTLIBRARIES = libdatrie.la
|
||||||
|
|
||||||
libdatrie_la_SOURCES = \
|
libdatrie_la_SOURCES = \
|
||||||
typedefs.h \
|
typedefs.h \
|
||||||
diff -up libthai-0.1.12/libthai.pc.in.static-build libthai-0.1.12/libthai.pc.in
|
Index: libthai-0.1.20/libthai.pc.in
|
||||||
--- libthai-0.1.12/libthai.pc.in.static-build 2009-03-31 00:25:23.000000000 -0400
|
===================================================================
|
||||||
+++ libthai-0.1.12/libthai.pc.in 2009-06-27 17:58:06.814631492 -0400
|
--- libthai-0.1.20.orig/libthai.pc.in
|
||||||
|
+++ libthai-0.1.20/libthai.pc.in
|
||||||
@@ -6,6 +6,5 @@ includedir=@includedir@
|
@@ -6,6 +6,5 @@ includedir=@includedir@
|
||||||
Name: libthai
|
Name: libthai
|
||||||
Description: Thai support library
|
Description: Thai support library
|
||||||
@ -20,10 +22,11 @@ diff -up libthai-0.1.12/libthai.pc.in.static-build libthai-0.1.12/libthai.pc.in
|
|||||||
-Requires.private: datrie-0.2
|
-Requires.private: datrie-0.2
|
||||||
Libs: -L${libdir} -lthai
|
Libs: -L${libdir} -lthai
|
||||||
Cflags: -I${includedir}
|
Cflags: -I${includedir}
|
||||||
diff -up libthai-0.1.12/src/Makefile.am.static-build libthai-0.1.12/src/Makefile.am
|
Index: libthai-0.1.20/src/Makefile.am
|
||||||
--- libthai-0.1.12/src/Makefile.am.static-build 2009-06-07 03:20:15.000000000 -0400
|
===================================================================
|
||||||
+++ libthai-0.1.12/src/Makefile.am 2009-06-27 17:59:20.060630864 -0400
|
--- libthai-0.1.20.orig/src/Makefile.am
|
||||||
@@ -19,7 +19,8 @@ libthai_sublibs = \
|
+++ libthai-0.1.20/src/Makefile.am
|
||||||
|
@@ -18,7 +18,8 @@ libthai_sublibs = \
|
||||||
$(top_builddir)/src/thwchar/libthwchar.la \
|
$(top_builddir)/src/thwchar/libthwchar.la \
|
||||||
$(top_builddir)/src/thwctype/libthwctype.la \
|
$(top_builddir)/src/thwctype/libthwctype.la \
|
||||||
$(top_builddir)/src/thwstr/libthwstr.la \
|
$(top_builddir)/src/thwstr/libthwstr.la \
|
||||||
@ -33,10 +36,11 @@ diff -up libthai-0.1.12/src/Makefile.am.static-build libthai-0.1.12/src/Makefile
|
|||||||
|
|
||||||
if LD_HAS_VERSION_SCRIPT
|
if LD_HAS_VERSION_SCRIPT
|
||||||
EXPORTS_FLAGS = -Wl,-version-script -Wl,$(srcdir)/libthai.map
|
EXPORTS_FLAGS = -Wl,-version-script -Wl,$(srcdir)/libthai.map
|
||||||
diff -up libthai-0.1.12/src/thbrk/Makefile.am.static-build libthai-0.1.12/src/thbrk/Makefile.am
|
Index: libthai-0.1.20/src/thbrk/Makefile.am
|
||||||
--- libthai-0.1.12/src/thbrk/Makefile.am.static-build 2009-01-19 08:32:50.000000000 -0500
|
===================================================================
|
||||||
+++ libthai-0.1.12/src/thbrk/Makefile.am 2009-06-27 17:58:06.812632123 -0400
|
--- libthai-0.1.20.orig/src/thbrk/Makefile.am
|
||||||
@@ -16,5 +16,4 @@ libthbrk_la_SOURCES = \
|
+++ libthai-0.1.20/src/thbrk/Makefile.am
|
||||||
|
@@ -15,5 +15,4 @@ libthbrk_la_SOURCES = \
|
||||||
brk-maximal.c \
|
brk-maximal.c \
|
||||||
brk-maximal.h
|
brk-maximal.h
|
||||||
|
|
||||||
|
11
libthai.spec
11
libthai.spec
@ -1,9 +1,9 @@
|
|||||||
%define datrie_version 0.2.6
|
%define datrie_version 0.2.8
|
||||||
|
|
||||||
Summary: Thai language support routines
|
Summary: Thai language support routines
|
||||||
Name: libthai
|
Name: libthai
|
||||||
Version: 0.1.19
|
Version: 0.1.20
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: ftp://linux.thai.net/pub/thailinux/software/libthai/libthai-%{version}.tar.xz
|
Source: ftp://linux.thai.net/pub/thailinux/software/libthai/libthai-%{version}.tar.xz
|
||||||
@ -61,7 +61,6 @@ mv libdatrie-%{datrie_version} libdatrie
|
|||||||
|
|
||||||
{
|
{
|
||||||
pushd libdatrie
|
pushd libdatrie
|
||||||
mkdir m4
|
|
||||||
autoreconf -i -f
|
autoreconf -i -f
|
||||||
%configure
|
%configure
|
||||||
make
|
make
|
||||||
@ -111,6 +110,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/pkgconfig/*
|
%{_libdir}/pkgconfig/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Apr 23 2014 Daiki Ueno <dueno@redhat.com> - 0.1.20-1
|
||||||
|
- Update to 0.1.20
|
||||||
|
- Update bundled libdatrie to 0.2.8
|
||||||
|
|
||||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.19-2
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.19-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user