re-import sources as agreed with the maintainer

This commit is contained in:
Adam Samalik 2023-07-18 12:02:08 +02:00
parent ff13d9fcbe
commit 879364e1fc
4 changed files with 83 additions and 1 deletions

10
.gitignore vendored
View File

@ -1,2 +1,10 @@
SOURCES/libthai-0.1.27.tar.xz
libthai-0.1.12.tar.gz
libdatrie-0.2.2.tar.gz
/libdatrie-0.2.6.tar.xz
/libthai-0.1.19.tar.xz
/libdatrie-0.2.8.tar.xz
/libthai-0.1.20.tar.xz
/libthai-0.1.21.tar.xz
/libthai-0.1.24.tar.xz
/libthai-0.1.25.tar.xz
/libthai-0.1.27.tar.xz

36
libthai-0.1.24-gcc6.patch Normal file
View File

@ -0,0 +1,36 @@
Index: ChangeLog
===================================================================
--- ChangeLog.orig
+++ ChangeLog
@@ -28,6 +28,18 @@
2015-11-22 Theppitak Karoonboonyanan <theppitak@gmail.com>
+ Fix compilation error with GCC 6
+
+ * include/thai/thctype.h (_th_bitmsk):
+ - Use unsigned int instead of unsigned short for bitmask base,
+ as GCC 6 takes ~0 as -1 for unsigned short,
+ and causes compilation error for scim-thai.
+
+ Thanks Martin Michlmayr for the report via Debian #811690
+ http://bugs.debian.org/811690
+
+2016-01-20 Theppitak Karoonboonyanan <theppitak@gmail.com>
+
* configure.ac: Post-release version suffix added.
2015-10-22 Theppitak Karoonboonyanan <theppitak@gmail.com>
Index: include/thai/thctype.h
===================================================================
--- include/thai/thctype.h.orig
+++ include/thai/thctype.h
@@ -363,7 +363,7 @@ extern int th_iscombchar(thchar_t c);
#include <ctype.h>
#define _th_ISbit(bit) (1 << (bit))
#define _th_bitfld(base, val) ((val) << (base))
-#define _th_bitmsk(base, bits) (~((~(unsigned short)0) << (bits)) << (base))
+#define _th_bitmsk(base, bits) (~((~(unsigned)0) << (bits)) << (base))
enum {
_th_IStis = _th_ISbit(0), /* TIS-620 char */

17
tests/make_check.sh Normal file
View File

@ -0,0 +1,17 @@
#!/bin/bash
set -x
check_return_value () {
if [ $1 != 0 ] ; then
exit $1
fi
}
cd $1
./configure --prefix=/usr
check_return_value $?
make
check_return_value $?
make check
exit $?

21
tests/tests.yml Normal file
View File

@ -0,0 +1,21 @@
- hosts: localhost
vars:
- artifacts: "{{ lookup('env', 'TEST_ARTIFACTS')|default('./artifacts', true) }}"
tags:
- classic
remote_user: root
roles:
- role: standard-test-source # to get the source tar ball to do “make check”
- role: standard-test-basic
required_packages:
- make
- gcc
- autoconf
- automake
- libtool
- doxygen
- libdatrie-devel
tests:
- make-check:
dir: ./
run: bash ./make_check.sh ./source