Update to 0.1.20-3
This commit is contained in:
parent
f0d717b684
commit
5d202f47a7
@ -1,48 +0,0 @@
|
|||||||
Index: libthai-0.1.20/libdatrie/datrie/Makefile.am
|
|
||||||
===================================================================
|
|
||||||
--- libthai-0.1.20.orig/libdatrie/datrie/Makefile.am
|
|
||||||
+++ libthai-0.1.20/libdatrie/datrie/Makefile.am
|
|
||||||
@@ -10,7 +10,7 @@ EXTRA_DIST = libdatrie.map libdatrie.def
|
|
||||||
|
|
||||||
AM_CPPFLAGS = -I$(top_srcdir)
|
|
||||||
|
|
||||||
-lib_LTLIBRARIES = libdatrie.la
|
|
||||||
+noinst_LTLIBRARIES = libdatrie.la
|
|
||||||
|
|
||||||
libdatrie_la_SOURCES = \
|
|
||||||
typedefs.h \
|
|
||||||
Index: libthai-0.1.20/libthai.pc.in
|
|
||||||
===================================================================
|
|
||||||
--- libthai-0.1.20.orig/libthai.pc.in
|
|
||||||
+++ libthai-0.1.20/libthai.pc.in
|
|
||||||
@@ -6,6 +6,5 @@ includedir=@includedir@
|
|
||||||
Name: libthai
|
|
||||||
Description: Thai support library
|
|
||||||
Version: @VERSION@
|
|
||||||
-Requires.private: datrie-0.2
|
|
||||||
Libs: -L${libdir} -lthai
|
|
||||||
Cflags: -I${includedir}
|
|
||||||
Index: libthai-0.1.20/src/Makefile.am
|
|
||||||
===================================================================
|
|
||||||
--- libthai-0.1.20.orig/src/Makefile.am
|
|
||||||
+++ libthai-0.1.20/src/Makefile.am
|
|
||||||
@@ -18,7 +18,8 @@ libthai_sublibs = \
|
|
||||||
$(top_builddir)/src/thwchar/libthwchar.la \
|
|
||||||
$(top_builddir)/src/thwctype/libthwctype.la \
|
|
||||||
$(top_builddir)/src/thwstr/libthwstr.la \
|
|
||||||
- $(top_builddir)/src/thwbrk/libthwbrk.la
|
|
||||||
+ $(top_builddir)/src/thwbrk/libthwbrk.la \
|
|
||||||
+ $(DATRIE_LIBS)
|
|
||||||
|
|
||||||
if LD_HAS_VERSION_SCRIPT
|
|
||||||
EXPORTS_FLAGS = -Wl,-version-script -Wl,$(srcdir)/libthai.map
|
|
||||||
Index: libthai-0.1.20/src/thbrk/Makefile.am
|
|
||||||
===================================================================
|
|
||||||
--- libthai-0.1.20.orig/src/thbrk/Makefile.am
|
|
||||||
+++ libthai-0.1.20/src/thbrk/Makefile.am
|
|
||||||
@@ -15,5 +15,4 @@ libthbrk_la_SOURCES = \
|
|
||||||
brk-maximal.c \
|
|
||||||
brk-maximal.h
|
|
||||||
|
|
||||||
-libthbrk_la_LIBADD = $(DATRIE_LIBS)
|
|
||||||
|
|
48
libthai.spec
48
libthai.spec
@ -3,22 +3,16 @@
|
|||||||
Summary: Thai language support routines
|
Summary: Thai language support routines
|
||||||
Name: libthai
|
Name: libthai
|
||||||
Version: 0.1.20
|
Version: 0.1.20
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: ftp://linux.thai.net/pub/thailinux/software/libthai/libthai-%{version}.tar.xz
|
Source: ftp://linux.thai.net/pub/thailinux/software/libthai/libthai-%{version}.tar.xz
|
||||||
Source1: ftp://linux.thai.net/pub/thailinux/software/libthai/libdatrie-%{datrie_version}.tar.xz
|
Patch: libthai-0.1.9-multilib.patch
|
||||||
Patch: libthai-libdatrie-static-build.patch
|
|
||||||
Patch1: libthai-0.1.9-multilib.patch
|
|
||||||
URL: http://linux.thai.net
|
URL: http://linux.thai.net
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: pkgconfig
|
BuildRequires: pkgconfig(datrie-0.2)
|
||||||
BuildRequires: doxygen
|
BuildRequires: doxygen
|
||||||
# we edit the Makefile.am's
|
|
||||||
BuildRequires: automake
|
|
||||||
BuildRequires: autoconf
|
|
||||||
BuildRequires: libtool
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
LibThai is a set of Thai language support routines aimed to ease
|
LibThai is a set of Thai language support routines aimed to ease
|
||||||
@ -40,39 +34,10 @@ Install libthai-devel if you want to develop programs which will use
|
|||||||
libthai.
|
libthai.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version} -a 1
|
%setup -q
|
||||||
mv libdatrie-%{datrie_version} libdatrie
|
%patch -p1 -b .multilib
|
||||||
%patch -p1 -b .static-build
|
|
||||||
%patch1 -p1 -b .multilib
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
# libthai depends on this library called libdatrie. libdatrie is a
|
|
||||||
# data-structure implementaiton that the author of libthai ripped out of it.
|
|
||||||
# However, since libthai is the only user of that code, there's no reason to
|
|
||||||
# 1) package it separately, 2) use it as a shared library.
|
|
||||||
# So, we compile it as a libtool convenience library and include in libthai.so,
|
|
||||||
# and use symbol hiding to hide them (and other internal symbols).
|
|
||||||
#
|
|
||||||
# The patch takes care of making datrie into a convenience lib and making sure
|
|
||||||
# libthai will include it (and hide its symbols), and the exports make sure
|
|
||||||
# libthai finds the uninstalled libdatrie. We need to call automake, since
|
|
||||||
# the patch modifies a few Makefile.am's.
|
|
||||||
|
|
||||||
{
|
|
||||||
pushd libdatrie
|
|
||||||
autoreconf -i -f
|
|
||||||
%configure
|
|
||||||
make
|
|
||||||
popd
|
|
||||||
}
|
|
||||||
|
|
||||||
export DATRIE_CFLAGS="-I$PWD/libdatrie"
|
|
||||||
export DATRIE_LIBS="$PWD/libdatrie/datrie/libdatrie.la"
|
|
||||||
export PATH="$PWD/libdatrie/tools:$PATH"
|
|
||||||
|
|
||||||
autoreconf -i -f
|
|
||||||
|
|
||||||
%configure --disable-static
|
%configure --disable-static
|
||||||
make
|
make
|
||||||
|
|
||||||
@ -110,6 +75,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/pkgconfig/*
|
%{_libdir}/pkgconfig/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 4 2014 Daiki Ueno <dueno@redhat.com> - 0.1.20-3
|
||||||
|
- Unbundle libdatrie (Closes: #1062540)
|
||||||
|
|
||||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.20-2
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.20-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user