rhbz#1691299 - libtdb-1.4.2 is available
This commit is contained in:
parent
bbde7fc49c
commit
e5a3e1daa3
1
.gitignore
vendored
1
.gitignore
vendored
@ -21,3 +21,4 @@
|
||||
/tdb-1.3.16.tar.gz
|
||||
/tdb-1.3.17.tar.gz
|
||||
/tdb-1.3.18.tar.gz
|
||||
/tdb-1.4.2.tar.gz
|
||||
|
@ -1,110 +0,0 @@
|
||||
From 8970020e20689db9a93bfcc33e71c312d1488309 Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Slebodnik <lslebodn@fedoraproject.org>
|
||||
Date: Wed, 12 Jun 2019 12:27:04 +0200
|
||||
Subject: [PATCH] wafsamba: Use native waf timer
|
||||
|
||||
__main__:1: DeprecationWarning: time.clock has been deprecated in Python 3.3
|
||||
and will be removed from Python 3.8: use time.perf_counter
|
||||
or time.process_time instead
|
||||
|
||||
Signed-off-by: Lukas Slebodnik <lslebodn@fedoraproject.org>
|
||||
---
|
||||
buildtools/wafsamba/samba_deps.py | 25 ++++++++++++-------------
|
||||
1 file changed, 12 insertions(+), 13 deletions(-)
|
||||
|
||||
diff --git a/buildtools/wafsamba/samba_deps.py b/buildtools/wafsamba/samba_deps.py
|
||||
index f8c38809bd2296288374cd66788cdd8fdb2c7538..03c37079a8c435628e058a6d00c0f942a06f3bd9 100644
|
||||
--- a/buildtools/wafsamba/samba_deps.py
|
||||
+++ b/buildtools/wafsamba/samba_deps.py
|
||||
@@ -1,6 +1,6 @@
|
||||
# Samba automatic dependency handling and project rules
|
||||
|
||||
-import os, sys, re, time
|
||||
+import os, sys, re
|
||||
|
||||
from waflib import Build, Options, Logs, Utils, Errors
|
||||
from waflib.Logs import debug
|
||||
@@ -1102,8 +1102,7 @@ def check_project_rules(bld):
|
||||
if not force_project_rules and load_samba_deps(bld, tgt_list):
|
||||
return
|
||||
|
||||
- global tstart
|
||||
- tstart = time.clock()
|
||||
+ timer = Utils.Timer()
|
||||
|
||||
bld.new_rules = True
|
||||
Logs.info("Checking project rules ...")
|
||||
@@ -1112,26 +1111,26 @@ def check_project_rules(bld):
|
||||
|
||||
expand_subsystem_deps(bld)
|
||||
|
||||
- debug("deps: expand_subsystem_deps: %f" % (time.clock() - tstart))
|
||||
+ debug("deps: expand_subsystem_deps: %s" % str(timer))
|
||||
|
||||
replace_grouping_libraries(bld, tgt_list)
|
||||
|
||||
- debug("deps: replace_grouping_libraries: %f" % (time.clock() - tstart))
|
||||
+ debug("deps: replace_grouping_libraries: %s" % str(timer))
|
||||
|
||||
build_direct_deps(bld, tgt_list)
|
||||
|
||||
- debug("deps: build_direct_deps: %f" % (time.clock() - tstart))
|
||||
+ debug("deps: build_direct_deps: %s" % str(timer))
|
||||
|
||||
break_dependency_loops(bld, tgt_list)
|
||||
|
||||
- debug("deps: break_dependency_loops: %f" % (time.clock() - tstart))
|
||||
+ debug("deps: break_dependency_loops: %s" % str(timer))
|
||||
|
||||
if Options.options.SHOWDEPS:
|
||||
show_dependencies(bld, Options.options.SHOWDEPS, set())
|
||||
|
||||
calculate_final_deps(bld, tgt_list, loops)
|
||||
|
||||
- debug("deps: calculate_final_deps: %f" % (time.clock() - tstart))
|
||||
+ debug("deps: calculate_final_deps: %s" % str(timer))
|
||||
|
||||
if Options.options.SHOW_DUPLICATES:
|
||||
show_object_duplicates(bld, tgt_list)
|
||||
@@ -1140,7 +1139,7 @@ def check_project_rules(bld):
|
||||
for f in [ build_dependencies, build_includes, add_init_functions ]:
|
||||
debug('deps: project rules checking %s', f)
|
||||
for t in tgt_list: f(t)
|
||||
- debug("deps: %s: %f" % (f, time.clock() - tstart))
|
||||
+ debug("deps: %s: %s" % (f, str(timer)))
|
||||
|
||||
debug('deps: project rules stage1 completed')
|
||||
|
||||
@@ -1148,17 +1147,17 @@ def check_project_rules(bld):
|
||||
Logs.error("Duplicate sources present - aborting")
|
||||
sys.exit(1)
|
||||
|
||||
- debug("deps: check_duplicate_sources: %f" % (time.clock() - tstart))
|
||||
+ debug("deps: check_duplicate_sources: %s" % str(timer))
|
||||
|
||||
if not bld.check_group_ordering(tgt_list):
|
||||
Logs.error("Bad group ordering - aborting")
|
||||
sys.exit(1)
|
||||
|
||||
- debug("deps: check_group_ordering: %f" % (time.clock() - tstart))
|
||||
+ debug("deps: check_group_ordering: %s" % str(timer))
|
||||
|
||||
show_final_deps(bld, tgt_list)
|
||||
|
||||
- debug("deps: show_final_deps: %f" % (time.clock() - tstart))
|
||||
+ debug("deps: show_final_deps: %s" % str(timer))
|
||||
|
||||
debug('deps: project rules checking completed - %u targets checked',
|
||||
len(tgt_list))
|
||||
@@ -1166,7 +1165,7 @@ def check_project_rules(bld):
|
||||
if not bld.is_install:
|
||||
save_samba_deps(bld, tgt_list)
|
||||
|
||||
- debug("deps: save_samba_deps: %f" % (time.clock() - tstart))
|
||||
+ debug("deps: save_samba_deps: %s" % str(timer))
|
||||
|
||||
Logs.info("Project rules pass")
|
||||
|
||||
--
|
||||
2.22.0
|
||||
|
12
libtdb.spec
12
libtdb.spec
@ -3,17 +3,15 @@
|
||||
%endif
|
||||
|
||||
Name: libtdb
|
||||
Version: 1.3.18
|
||||
Release: 5%{?dist}
|
||||
Version: 1.4.2
|
||||
Release: 1%{?dist}
|
||||
Summary: The tdb library
|
||||
License: LGPLv3+
|
||||
URL: http://tdb.samba.org/
|
||||
Source: http://samba.org/ftp/tdb/tdb-%{version}.tar.gz
|
||||
|
||||
# Patches
|
||||
Patch0001: waflib-python38-pyembed.diff
|
||||
Patch0002: 0002-wafsamba-Use-native-waf-timer.patch
|
||||
Patch0003: 0003-wafsamba-Fix-few-SyntaxWarnings-caused-by-regular-ex.patch
|
||||
Patch0001: 0003-wafsamba-Fix-few-SyntaxWarnings-caused-by-regular-ex.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: libxslt
|
||||
@ -97,6 +95,10 @@ make install DESTDIR=$RPM_BUILD_ROOT
|
||||
%ldconfig_scriptlets
|
||||
|
||||
%changelog
|
||||
* Mon Aug 26 2019 Lukas Slebodnik <lslebodn@fedoraproject.org> - 1.4.2-1
|
||||
- rhbz#1691299 - libtdb-1.4.2 is available
|
||||
- rhbz#1737644 - libldb, libtalloc, libtevent, libtdb: Remove Python 2 subpackages from Fedora 31+
|
||||
|
||||
* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 1.3.18-5
|
||||
- Rebuilt for Python 3.8
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (tdb-1.3.18.tar.gz) = 9b856b2a5b2d852ff0048ba7b1700ea46b8dad5d4e94027472fdce9f1db4b5afba9aec127b7a4c2a38d4722c8e0ea78c1734d102fa134ac802eace6b24358034
|
||||
SHA512 (tdb-1.4.2.tar.gz) = 1d1f83e1b79cc6ea2b5cbc755de4a370fb95ef0f592f3bd2b6d23b1be18555cd417a9254fdf276dc6bd7f3368af82a4569c1f1cdde13d98405a5d38f1291d832
|
||||
|
@ -1,17 +0,0 @@
|
||||
diff --git a/third_party/waf/waflib/Tools/python.py b/third_party/waf/waflib/Tools/python.py
|
||||
index 52a05c6..79836bb 100644
|
||||
--- a/third_party/waf/waflib/Tools/python.py
|
||||
+++ b/third_party/waf/waflib/Tools/python.py
|
||||
@@ -338,7 +338,11 @@ def check_python_headers(conf, features='pyembed pyext'):
|
||||
|
||||
if 'pyembed' in features:
|
||||
for flags in all_flags:
|
||||
- conf.check_cfg(msg='Asking python-config for pyembed %r flags' % ' '.join(flags), path=env.PYTHON_CONFIG, package='', uselib_store='PYEMBED', args=flags)
|
||||
+ embedflags = flags + ['--embed']
|
||||
+ try:
|
||||
+ conf.check_cfg(msg='Asking python-config for pyembed %r flags' % ' '.join(embedflags), path=env.PYTHON_CONFIG, package='', uselib_store='PYEMBED', args=embedflags)
|
||||
+ except conf.errors.ConfigurationError:
|
||||
+ conf.check_cfg(msg='Asking python-config for pyembed %r flags' % ' '.join(flags), path=env.PYTHON_CONFIG, package='', uselib_store='PYEMBED', args=flags)
|
||||
|
||||
try:
|
||||
conf.test_pyembed(xx)
|
Loading…
Reference in New Issue
Block a user