RHEL 9.0.0 Alpha bootstrap
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/libtdb#720f40e86b50f6be5234724122664be0fc051197
This commit is contained in:
parent
07b4454e89
commit
529dc4a1cc
27
.gitignore
vendored
27
.gitignore
vendored
@ -0,0 +1,27 @@
|
|||||||
|
/tdb-1.2.9.tar.gz
|
||||||
|
/tdb-1.2.10.tar.gz
|
||||||
|
/tdb-1.2.11.tar.gz
|
||||||
|
/tdb-1.2.12.tar.gz
|
||||||
|
/tdb-1.2.13.tar.gz
|
||||||
|
/tdb-1.3.0.tar.gz
|
||||||
|
/tdb-1.3.1.tar.gz
|
||||||
|
/tdb-1.3.3.tar.gz
|
||||||
|
/tdb-1.3.4.tar.gz
|
||||||
|
/tdb-1.3.5.tar.gz
|
||||||
|
/tdb-1.3.6.tar.gz
|
||||||
|
/tdb-1.3.7.tar.gz
|
||||||
|
/tdb-1.3.8.tar.gz
|
||||||
|
/tdb-1.3.9.tar.gz
|
||||||
|
/tdb-1.3.10.tar.gz
|
||||||
|
/tdb-1.3.11.tar.gz
|
||||||
|
/tdb-1.3.12.tar.gz
|
||||||
|
/tdb-1.3.13.tar.gz
|
||||||
|
/tdb-1.3.14.tar.gz
|
||||||
|
/tdb-1.3.15.tar.gz
|
||||||
|
/tdb-1.3.16.tar.gz
|
||||||
|
/tdb-1.3.17.tar.gz
|
||||||
|
/tdb-1.3.18.tar.gz
|
||||||
|
/tdb-1.4.2.tar.gz
|
||||||
|
/tdb.keyring
|
||||||
|
/tdb-1.4.3.tar.asc
|
||||||
|
/tdb-1.4.3.tar.gz
|
195
0003-wafsamba-Fix-few-SyntaxWarnings-caused-by-regular-ex.patch
Normal file
195
0003-wafsamba-Fix-few-SyntaxWarnings-caused-by-regular-ex.patch
Normal file
@ -0,0 +1,195 @@
|
|||||||
|
From 87dfb0ce329447625050771fd83dae1841ece1b8 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Lukas Slebodnik <lslebodn@fedoraproject.org>
|
||||||
|
Date: Wed, 12 Jun 2019 13:38:17 +0200
|
||||||
|
Subject: [PATCH] wafsamba: Fix few SyntaxWarnings caused by regular
|
||||||
|
expressions
|
||||||
|
|
||||||
|
./buildtools/wafsamba/samba_utils.py:258: SyntaxWarning: invalid escape sequence \$
|
||||||
|
lst = re.split('(\$\{\w+\})', string)
|
||||||
|
./buildtools/wafsamba/samba_utils.py:261: SyntaxWarning: invalid escape sequence \$
|
||||||
|
if re.match('\$\{\w+\}', v):
|
||||||
|
./buildtools/wafsamba/samba_cross.py:80: SyntaxWarning: invalid escape sequence \(
|
||||||
|
m = re.match('\(\s*(-?\d+)\s*,\s*\"(.*)\"\s*\)', ans)
|
||||||
|
./buildtools/wafsamba/samba_conftests.py:400: SyntaxWarning: invalid escape sequence \s
|
||||||
|
m = re.search('MAN%sEXT\s+=\s+(\w+)' % section, man)
|
||||||
|
./buildtools/wafsamba/samba_abi.py:24: SyntaxWarning: invalid escape sequence \$
|
||||||
|
sig = re.sub('^\$[0-9]+\s=\s\{(.+)\}$', r'\1', sig)
|
||||||
|
./buildtools/wafsamba/samba_abi.py:25: SyntaxWarning: invalid escape sequence \$
|
||||||
|
sig = re.sub('^\$[0-9]+\s=\s\{(.+)\}(\s0x[0-9a-f]+\s<\w+>)+$', r'\1', sig)
|
||||||
|
./buildtools/wafsamba/samba_abi.py:26: SyntaxWarning: invalid escape sequence \$
|
||||||
|
sig = re.sub('^\$[0-9]+\s=\s(0x[0-9a-f]+)\s?(<\w+>)?$', r'\1', sig)
|
||||||
|
./buildtools/wafsamba/samba_abi.py:33: SyntaxWarning: invalid escape sequence \*
|
||||||
|
m = m.replace('*', '\*')
|
||||||
|
./buildtools/wafsamba/samba_abi.py:44: SyntaxWarning: invalid escape sequence \s
|
||||||
|
sig = re.sub(',\s\.\.\.', '', sig)
|
||||||
|
./buildtools/wafsamba/samba_headers.py:22: SyntaxWarning: invalid escape sequence \s
|
||||||
|
re_header = re.compile('^\s*#\s*include[ \t]*"([^"]+)"', re.I | re.M)
|
||||||
|
./buildtools/wafsamba/symbols.py:122: SyntaxWarning: invalid escape sequence \[
|
||||||
|
re_sharedlib = re.compile(b'Shared library: \[(.*)\]')
|
||||||
|
./buildtools/wafsamba/symbols.py:124: SyntaxWarning: invalid escape sequence \[
|
||||||
|
re_rpath = re.compile(b'Library (rpath|runpath): \[(.*)\]')
|
||||||
|
./buildtools/wafsamba/pkgconfig.py:12: SyntaxWarning: invalid escape sequence \w
|
||||||
|
a = re.split('(@\w+@)', s)
|
||||||
|
./buildtools/wafsamba/pkgconfig.py:17: SyntaxWarning: invalid escape sequence \w
|
||||||
|
if re.match('@\w+@', v):
|
||||||
|
./buildtools/wafsamba/configure_file.py:16: SyntaxWarning: invalid escape sequence \w
|
||||||
|
a = re.split('(@\w+@)', s)
|
||||||
|
./buildtools/wafsamba/configure_file.py:19: SyntaxWarning: invalid escape sequence \w
|
||||||
|
if re.match('@\w+@', v):
|
||||||
|
---
|
||||||
|
buildtools/wafsamba/configure_file.py | 4 ++--
|
||||||
|
buildtools/wafsamba/pkgconfig.py | 4 ++--
|
||||||
|
buildtools/wafsamba/samba_abi.py | 12 ++++++------
|
||||||
|
buildtools/wafsamba/samba_conftests.py | 2 +-
|
||||||
|
buildtools/wafsamba/samba_cross.py | 2 +-
|
||||||
|
buildtools/wafsamba/samba_headers.py | 2 +-
|
||||||
|
buildtools/wafsamba/samba_utils.py | 4 ++--
|
||||||
|
buildtools/wafsamba/symbols.py | 4 ++--
|
||||||
|
8 files changed, 17 insertions(+), 17 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/buildtools/wafsamba/configure_file.py b/buildtools/wafsamba/configure_file.py
|
||||||
|
index 6ad43546249fba7b4c0a037035e8574e7a9d2753..98a58a4604513e3633317e73299c1c9280c250d2 100644
|
||||||
|
--- a/buildtools/wafsamba/configure_file.py
|
||||||
|
+++ b/buildtools/wafsamba/configure_file.py
|
||||||
|
@@ -13,10 +13,10 @@ def subst_at_vars(task):
|
||||||
|
s = task.inputs[0].read()
|
||||||
|
|
||||||
|
# split on the vars
|
||||||
|
- a = re.split('(@\w+@)', s)
|
||||||
|
+ a = re.split(r'(@\w+@)', s)
|
||||||
|
out = []
|
||||||
|
for v in a:
|
||||||
|
- if re.match('@\w+@', v):
|
||||||
|
+ if re.match(r'@\w+@', v):
|
||||||
|
vname = v[1:-1]
|
||||||
|
if not vname in task.env and vname.upper() in task.env:
|
||||||
|
vname = vname.upper()
|
||||||
|
diff --git a/buildtools/wafsamba/pkgconfig.py b/buildtools/wafsamba/pkgconfig.py
|
||||||
|
index b83d5f382a58352bb3318b594aa2b45fc02d87d5..b77bd618c8903789c7ba9e64a6972a4e080f1821 100644
|
||||||
|
--- a/buildtools/wafsamba/pkgconfig.py
|
||||||
|
+++ b/buildtools/wafsamba/pkgconfig.py
|
||||||
|
@@ -9,12 +9,12 @@ def subst_at_vars(task):
|
||||||
|
|
||||||
|
s = task.inputs[0].read()
|
||||||
|
# split on the vars
|
||||||
|
- a = re.split('(@\w+@)', s)
|
||||||
|
+ a = re.split(r'(@\w+@)', s)
|
||||||
|
out = []
|
||||||
|
done_var = {}
|
||||||
|
back_sub = [ ('PREFIX', '${prefix}'), ('EXEC_PREFIX', '${exec_prefix}')]
|
||||||
|
for v in a:
|
||||||
|
- if re.match('@\w+@', v):
|
||||||
|
+ if re.match(r'@\w+@', v):
|
||||||
|
vname = v[1:-1]
|
||||||
|
if not vname in task.env and vname.upper() in task.env:
|
||||||
|
vname = vname.upper()
|
||||||
|
diff --git a/buildtools/wafsamba/samba_abi.py b/buildtools/wafsamba/samba_abi.py
|
||||||
|
index 5e7686da3d68b1ebcd842b8a319a5997fa9cf600..761667fcfe1f3937be22c8261b45dcb3979ae4cd 100644
|
||||||
|
--- a/buildtools/wafsamba/samba_abi.py
|
||||||
|
+++ b/buildtools/wafsamba/samba_abi.py
|
||||||
|
@@ -21,16 +21,16 @@ version_key = lambda x: list(map(int, x.split(".")))
|
||||||
|
def normalise_signature(sig):
|
||||||
|
'''normalise a signature from gdb'''
|
||||||
|
sig = sig.strip()
|
||||||
|
- sig = re.sub('^\$[0-9]+\s=\s\{(.+)\}$', r'\1', sig)
|
||||||
|
- sig = re.sub('^\$[0-9]+\s=\s\{(.+)\}(\s0x[0-9a-f]+\s<\w+>)+$', r'\1', sig)
|
||||||
|
- sig = re.sub('^\$[0-9]+\s=\s(0x[0-9a-f]+)\s?(<\w+>)?$', r'\1', sig)
|
||||||
|
- sig = re.sub('0x[0-9a-f]+', '0xXXXX', sig)
|
||||||
|
+ sig = re.sub(r'^\$[0-9]+\s=\s\{(.+)\}$', r'\1', sig)
|
||||||
|
+ sig = re.sub(r'^\$[0-9]+\s=\s\{(.+)\}(\s0x[0-9a-f]+\s<\w+>)+$', r'\1', sig)
|
||||||
|
+ sig = re.sub(r'^\$[0-9]+\s=\s(0x[0-9a-f]+)\s?(<\w+>)?$', r'\1', sig)
|
||||||
|
+ sig = re.sub(r'0x[0-9a-f]+', '0xXXXX', sig)
|
||||||
|
sig = re.sub('", <incomplete sequence (\\\\[a-z0-9]+)>', r'\1"', sig)
|
||||||
|
|
||||||
|
for t in abi_type_maps:
|
||||||
|
# we need to cope with non-word characters in mapped types
|
||||||
|
m = t
|
||||||
|
- m = m.replace('*', '\*')
|
||||||
|
+ m = m.replace('*', r'\*')
|
||||||
|
if m[-1].isalnum() or m[-1] == '_':
|
||||||
|
m += '\\b'
|
||||||
|
if m[0].isalnum() or m[0] == '_':
|
||||||
|
@@ -41,7 +41,7 @@ def normalise_signature(sig):
|
||||||
|
|
||||||
|
def normalise_varargs(sig):
|
||||||
|
'''cope with older versions of gdb'''
|
||||||
|
- sig = re.sub(',\s\.\.\.', '', sig)
|
||||||
|
+ sig = re.sub(r',\s\.\.\.', '', sig)
|
||||||
|
return sig
|
||||||
|
|
||||||
|
|
||||||
|
diff --git a/buildtools/wafsamba/samba_conftests.py b/buildtools/wafsamba/samba_conftests.py
|
||||||
|
index ef632ba903369e4211991f17a3b204bcd96c3a2f..63e50567860ff890b00b0ce6c7607c917b7329d1 100644
|
||||||
|
--- a/buildtools/wafsamba/samba_conftests.py
|
||||||
|
+++ b/buildtools/wafsamba/samba_conftests.py
|
||||||
|
@@ -397,7 +397,7 @@ WriteMakefile(
|
||||||
|
|
||||||
|
if section:
|
||||||
|
man = Utils.readf(os.path.join(bdir,'Makefile'))
|
||||||
|
- m = re.search('MAN%sEXT\s+=\s+(\w+)' % section, man)
|
||||||
|
+ m = re.search(r'MAN%sEXT\s+=\s+(\w+)' % section, man)
|
||||||
|
if not m:
|
||||||
|
conf.end_msg('not found', color='YELLOW')
|
||||||
|
return
|
||||||
|
diff --git a/buildtools/wafsamba/samba_cross.py b/buildtools/wafsamba/samba_cross.py
|
||||||
|
index 8863c2c53e7d7dd9317c9233f0085ffd0eea6b2f..34793902fba884cf2d8358bf4315dc98027266b6 100644
|
||||||
|
--- a/buildtools/wafsamba/samba_cross.py
|
||||||
|
+++ b/buildtools/wafsamba/samba_cross.py
|
||||||
|
@@ -77,7 +77,7 @@ def cross_answer(ca_file, msg):
|
||||||
|
f.close()
|
||||||
|
return (0, ans.strip("'"))
|
||||||
|
else:
|
||||||
|
- m = re.match('\(\s*(-?\d+)\s*,\s*\"(.*)\"\s*\)', ans)
|
||||||
|
+ m = re.match(r'\(\s*(-?\d+)\s*,\s*\"(.*)\"\s*\)', ans)
|
||||||
|
if m:
|
||||||
|
f.close()
|
||||||
|
return (int(m.group(1)), m.group(2))
|
||||||
|
diff --git a/buildtools/wafsamba/samba_headers.py b/buildtools/wafsamba/samba_headers.py
|
||||||
|
index a268c011c5d8e406e0d763554c55668cfb5388bc..c8bee19010978a04460b0637fcc8fd484a699ea8 100644
|
||||||
|
--- a/buildtools/wafsamba/samba_headers.py
|
||||||
|
+++ b/buildtools/wafsamba/samba_headers.py
|
||||||
|
@@ -19,7 +19,7 @@ def header_install_path(header, header_path):
|
||||||
|
return ''
|
||||||
|
|
||||||
|
|
||||||
|
-re_header = re.compile('^\s*#\s*include[ \t]*"([^"]+)"', re.I | re.M)
|
||||||
|
+re_header = re.compile(r'^\s*#\s*include[ \t]*"([^"]+)"', re.I | re.M)
|
||||||
|
|
||||||
|
# a dictionary mapping source header paths to public header paths
|
||||||
|
header_map = {}
|
||||||
|
diff --git a/buildtools/wafsamba/samba_utils.py b/buildtools/wafsamba/samba_utils.py
|
||||||
|
index ad97de1859ba24c4afd5106b4f9694b0dc855643..75c9794ec40f327ef8ccf9aa33fafd6ed6181e3b 100644
|
||||||
|
--- a/buildtools/wafsamba/samba_utils.py
|
||||||
|
+++ b/buildtools/wafsamba/samba_utils.py
|
||||||
|
@@ -255,10 +255,10 @@ def TO_LIST(str, delimiter=None):
|
||||||
|
|
||||||
|
def subst_vars_error(string, env):
|
||||||
|
'''substitute vars, throw an error if a variable is not defined'''
|
||||||
|
- lst = re.split('(\$\{\w+\})', string)
|
||||||
|
+ lst = re.split(r'(\$\{\w+\})', string)
|
||||||
|
out = []
|
||||||
|
for v in lst:
|
||||||
|
- if re.match('\$\{\w+\}', v):
|
||||||
|
+ if re.match(r'\$\{\w+\}', v):
|
||||||
|
vname = v[2:-1]
|
||||||
|
if not vname in env:
|
||||||
|
raise KeyError("Failed to find variable %s in %s in env %s <%s>" % (vname, string, env.__class__, str(env)))
|
||||||
|
diff --git a/buildtools/wafsamba/symbols.py b/buildtools/wafsamba/symbols.py
|
||||||
|
index 3eca3d46bd71cf0780b3c8e36a26b96bd3aa3b83..73e8ca8ce53ef5d956ac58e14a2403dd49f01109 100644
|
||||||
|
--- a/buildtools/wafsamba/symbols.py
|
||||||
|
+++ b/buildtools/wafsamba/symbols.py
|
||||||
|
@@ -119,9 +119,9 @@ def find_ldd_path(bld, libname, binary):
|
||||||
|
|
||||||
|
|
||||||
|
# some regular expressions for parsing readelf output
|
||||||
|
-re_sharedlib = re.compile(b'Shared library: \[(.*)\]')
|
||||||
|
+re_sharedlib = re.compile(r'Shared library: \[(.*)\]')
|
||||||
|
# output from readelf could be `Library rpath` or `Libray runpath`
|
||||||
|
-re_rpath = re.compile(b'Library (rpath|runpath): \[(.*)\]')
|
||||||
|
+re_rpath = re.compile(r'Library (rpath|runpath): \[(.*)\]')
|
||||||
|
|
||||||
|
def get_libs(bld, binname):
|
||||||
|
'''find the list of linked libraries for any binary or library
|
||||||
|
--
|
||||||
|
2.22.0
|
||||||
|
|
361
libtdb.spec
Normal file
361
libtdb.spec
Normal file
@ -0,0 +1,361 @@
|
|||||||
|
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||||
|
%global with_python3 1
|
||||||
|
%endif
|
||||||
|
|
||||||
|
Name: libtdb
|
||||||
|
Version: 1.4.3
|
||||||
|
Release: 5%{?dist}
|
||||||
|
Summary: The tdb library
|
||||||
|
License: LGPLv3+
|
||||||
|
URL: http://tdb.samba.org/
|
||||||
|
Source0: http://samba.org/ftp/tdb/tdb-%{version}.tar.gz
|
||||||
|
Source1: http://samba.org/ftp/tdb/tdb-%{version}.tar.asc
|
||||||
|
# gpg2 --no-default-keyring --keyring ./tdb.keyring --recv-keys 9147A339719518EE9011BCB54793916113084025
|
||||||
|
Source2: tdb.keyring
|
||||||
|
|
||||||
|
# Patches
|
||||||
|
Patch0001: 0003-wafsamba-Fix-few-SyntaxWarnings-caused-by-regular-ex.patch
|
||||||
|
|
||||||
|
BuildRequires: gcc
|
||||||
|
BuildRequires: gnupg2
|
||||||
|
BuildRequires: libxslt
|
||||||
|
BuildRequires: docbook-style-xsl
|
||||||
|
%if 0%{?with_python3}
|
||||||
|
BuildRequires: python3-devel
|
||||||
|
%endif
|
||||||
|
|
||||||
|
Provides: bundled(libreplace)
|
||||||
|
Obsoletes: python2-tdb < 1.4.2-1
|
||||||
|
|
||||||
|
%description
|
||||||
|
A library that implements a trivial database.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Header files need to link the Tdb library
|
||||||
|
Requires: libtdb = %{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Header files needed to develop programs that link against the Tdb library.
|
||||||
|
|
||||||
|
%package -n tdb-tools
|
||||||
|
Summary: Developer tools for the Tdb library
|
||||||
|
Requires: libtdb = %{version}-%{release}
|
||||||
|
|
||||||
|
%description -n tdb-tools
|
||||||
|
Tools to manage Tdb files
|
||||||
|
|
||||||
|
%if 0%{?with_python3}
|
||||||
|
%package -n python3-tdb
|
||||||
|
Summary: Python3 bindings for the Tdb library
|
||||||
|
Requires: libtdb = %{version}-%{release}
|
||||||
|
%{?python_provide:%python_provide python3-tdb}
|
||||||
|
|
||||||
|
%description -n python3-tdb
|
||||||
|
Python3 bindings for libtdb
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n tdb-%{version} -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
zcat %{SOURCE0} | gpgv2 --quiet --keyring %{SOURCE2} %{SOURCE1} -
|
||||||
|
%configure --disable-rpath \
|
||||||
|
--bundled-libraries=NONE \
|
||||||
|
--builtin-libraries=replace
|
||||||
|
|
||||||
|
%make_build
|
||||||
|
|
||||||
|
%check
|
||||||
|
%make_build check
|
||||||
|
|
||||||
|
%install
|
||||||
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
%files
|
||||||
|
%{_libdir}/libtdb.so.*
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%doc docs/README
|
||||||
|
%{_includedir}/tdb.h
|
||||||
|
%{_libdir}/libtdb.so
|
||||||
|
%{_libdir}/pkgconfig/tdb.pc
|
||||||
|
|
||||||
|
%files -n tdb-tools
|
||||||
|
%{_bindir}/tdbbackup
|
||||||
|
%{_bindir}/tdbdump
|
||||||
|
%{_bindir}/tdbtool
|
||||||
|
%{_bindir}/tdbrestore
|
||||||
|
%{_mandir}/man8/tdbbackup.8*
|
||||||
|
%{_mandir}/man8/tdbdump.8*
|
||||||
|
%{_mandir}/man8/tdbtool.8*
|
||||||
|
%{_mandir}/man8/tdbrestore.8*
|
||||||
|
|
||||||
|
%if 0%{?with_python3}
|
||||||
|
%files -n python3-tdb
|
||||||
|
%{python3_sitearch}/__pycache__/_tdb_text.cpython*.py[co]
|
||||||
|
%{python3_sitearch}/tdb.cpython*.so
|
||||||
|
%{python3_sitearch}/_tdb_text.py
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%ldconfig_scriptlets
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.3-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jul 13 2020 Tom Stellard <tstellar@redhat.com> - 1.4.3-4
|
||||||
|
- Use make macros
|
||||||
|
- https://fedoraproject.org/wiki/Changes/UseMakeBuildInstallMacro
|
||||||
|
|
||||||
|
* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 1.4.3-3
|
||||||
|
- Rebuilt for Python 3.9
|
||||||
|
|
||||||
|
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.3-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 22 2020 Lukas Slebodnik <lslebodn@fedoraproject.org> - 1.4.3-1
|
||||||
|
- rhbz#1783927 - libtdb-1.4.3 is available
|
||||||
|
|
||||||
|
* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 1.4.2-2
|
||||||
|
- Rebuilt for Python 3.8.0rc1 (#1748018)
|
||||||
|
|
||||||
|
* Mon Aug 26 2019 Lukas Slebodnik <lslebodn@fedoraproject.org> - 1.4.2-1
|
||||||
|
- rhbz#1691299 - libtdb-1.4.2 is available
|
||||||
|
- rhbz#1737644 - libldb, libtalloc, libtevent, libtdb: Remove Python 2 subpackages from Fedora 31+
|
||||||
|
|
||||||
|
* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 1.3.18-5
|
||||||
|
- Rebuilt for Python 3.8
|
||||||
|
|
||||||
|
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.18-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jun 14 2019 Lukas Slebodnik <lslebodn@fedoraproject.org> - 1.3.18-3
|
||||||
|
- rhbz#1718113 - samba fail to build with Python 3.8
|
||||||
|
AttributeError: module 'time' has no attribute 'clock'
|
||||||
|
|
||||||
|
* Mon Jun 03 2019 Lukas Slebodnik <lslebodn@fedoraproject.org> - 1.3.18-2
|
||||||
|
- rhbz#1711638 - fails to build with Python 3.8.0a4
|
||||||
|
|
||||||
|
* Tue Feb 26 2019 Lukas Slebodnik <lslebodn@fedoraproject.org> - 1.3.18-1
|
||||||
|
- rhbz#1683185 - libtdb-1.3.18 is available
|
||||||
|
|
||||||
|
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.17-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jan 17 2019 Lukas Slebodnik <lslebodn@fedoraproject.org> - 1.3.17-1
|
||||||
|
- rhbz#1667472 - libtdb-1.3.17 is available
|
||||||
|
|
||||||
|
* Fri Jul 13 2018 Jakub Hrozek <jhrozek@redhat.com> - 1.3.16-2
|
||||||
|
- Drop the unneeded ABI hide patch
|
||||||
|
- Use pathfix.py instead of a local patch to munge the python path
|
||||||
|
|
||||||
|
* Thu Jul 12 2018 Jakub Hrozek <jhrozek@redhat.com> - 1.3.16-1
|
||||||
|
- New upstream release 1.3.16
|
||||||
|
- Apply a patch to hide local ABI symbols to avoid issues with new binutils
|
||||||
|
- Patch the waf script to explicitly call python2 as "env python" doesn't
|
||||||
|
yield py2 anymore
|
||||||
|
|
||||||
|
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 1.3.15-5
|
||||||
|
- Rebuilt for Python 3.7
|
||||||
|
|
||||||
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.15-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 1.3.15-3
|
||||||
|
- Rebuilt for switch to libxcrypt
|
||||||
|
|
||||||
|
* Thu Nov 30 2017 Lukas Slebodnik <lslebodn@fedoraproject.org> - 1.3.15-2
|
||||||
|
- Update spec file conditionals
|
||||||
|
|
||||||
|
* Sat Aug 26 2017 Lukas Slebodnik <lslebodn@redhat.com> - 1.3.15-1
|
||||||
|
- New upstream release 1.3.15
|
||||||
|
|
||||||
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.14-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.14-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jul 3 2017 Lukas Slebodnik <lslebodn@redhat.com> - 1.3.14-1
|
||||||
|
- New upstream release 1.3.14
|
||||||
|
- run unittests
|
||||||
|
|
||||||
|
* Fri Apr 28 2017 Lukas Slebodnik <lslebodn@redhat.com> - 1.3.13-1
|
||||||
|
- New upstream release 1.3.13
|
||||||
|
- removed Group fields (new packaging policy)
|
||||||
|
- %%defattr() is no longer needed
|
||||||
|
|
||||||
|
* Tue Feb 14 2017 Lukas Slebodnik <lslebodn@redhat.com> - 1.3.12-5
|
||||||
|
- rhbz#1401175 - Missing symbol versioning provided by libtdb.so
|
||||||
|
- Fix configure time detection with -Werror=implicit-function-declaration
|
||||||
|
-Werror=implicit-int
|
||||||
|
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
|
||||||
|
|
||||||
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.12-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 1.3.12-3
|
||||||
|
- Rebuild for Python 3.6
|
||||||
|
|
||||||
|
* Tue Dec 6 2016 Adam Williamson <awilliam@redhat.com> - 1.3.12-2
|
||||||
|
- rebuild with reverted redhat-rpm-config to fix missing library symbols
|
||||||
|
|
||||||
|
* Fri Dec 2 2016 Jakub Hrozek <jhrozek@redhat.com> - 1.3.12-1
|
||||||
|
- New upstream release 1.3.12
|
||||||
|
|
||||||
|
* Tue Aug 30 2016 Jakub Hrozek <jhrozek@redhat.com> - 1.3.11-1
|
||||||
|
- New upstream release 1.3.11
|
||||||
|
|
||||||
|
* Thu Jul 28 2016 Jakub Hrozek <jhrozek@redhat.com> - 1.3.10-1
|
||||||
|
- New upstream release 1.3.10
|
||||||
|
|
||||||
|
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.9-2
|
||||||
|
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
|
||||||
|
|
||||||
|
* Wed Apr 27 2016 Jakub Hrozek <jhrozek@redhat.com> - 1.3.9-1
|
||||||
|
- New upstream release 1.3.9
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.8-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Nov 11 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.8-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
|
||||||
|
|
||||||
|
* Wed Nov 11 2015 Jakub Hrozek <jhrozek@redhat.com> - 1.3.8-1
|
||||||
|
- New upstream release 1.3.8
|
||||||
|
|
||||||
|
* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.7-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
|
||||||
|
|
||||||
|
* Wed Jul 22 2015 Jakub Hrozek <jhrozek@redhat.com> - 1.3.7-1
|
||||||
|
- New upstream release 1.3.7
|
||||||
|
- Build Python3 bindings
|
||||||
|
|
||||||
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.6-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Jun 14 2015 Jakub Hrozek <jhrozek@redhat.com> - 1.3.6-1
|
||||||
|
- New upstream release 1.3.6
|
||||||
|
|
||||||
|
* Wed Apr 29 2015 Jakub Hrozek <jhrozek@redhat.com> - 1.3.5-1
|
||||||
|
- New upstream release 1.3.5
|
||||||
|
|
||||||
|
* Mon Jan 5 2015 Jakub Hrozek <jhrozek@redhat.com> - 1.3.4-1
|
||||||
|
- New upstream release 1.3.4
|
||||||
|
|
||||||
|
* Fri Dec 5 2014 Jakub Hrozek <jhrozek@redhat.com> - 1.3.3-1
|
||||||
|
- New upstream release 1.3.3
|
||||||
|
|
||||||
|
* Thu Sep 18 2014 Jakub Hrozek <jhrozek@redhat.com> - 1.3.1-1
|
||||||
|
- New upstream release 1.3.1
|
||||||
|
|
||||||
|
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri May 23 2014 Adam Williamson <awilliam@redhat.com> - 1.3.0-2
|
||||||
|
- add a missing include to tdb.h (fixes builds against libtdb) (BSO #10625)
|
||||||
|
|
||||||
|
* Fri May 23 2014 Jakub Hrozek <jhrozek@redhat.com> - 1.3.0-1
|
||||||
|
- New upstream release 1.3.0
|
||||||
|
|
||||||
|
* Thu Mar 20 2014 Jakub Hrozek <jhrozek@redhat.com> - 1.2.13-1
|
||||||
|
- New upstream release 1.2.13
|
||||||
|
|
||||||
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.12-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jun 04 2013 Jakub Hrozek <jhrozek@redhat.com> - 1.2.12-1
|
||||||
|
- New upstream release 1.2.12
|
||||||
|
|
||||||
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.11-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Dec 01 2012 Jakub Hrozek <jhrozek@redhat.com> - 1.2.11-1
|
||||||
|
- New upstream release 1.2.11
|
||||||
|
|
||||||
|
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.10-16
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue May 22 2012 Stephen Gallagher <sgallagh@redhat.com> - 1.2.10-15
|
||||||
|
- New upstream release 1.2.10
|
||||||
|
- Remove upstreamed patches
|
||||||
|
- Provides functionality for the upcoming Samba 4 beta
|
||||||
|
|
||||||
|
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.9-14
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Dec 01 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-13
|
||||||
|
- Add patch to ignore --disable-silent-rules
|
||||||
|
- Include README documentation
|
||||||
|
|
||||||
|
* Wed Nov 23 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-12
|
||||||
|
- Add explicit mention of the bundled libreplace
|
||||||
|
- https://fedorahosted.org/fpc/ticket/120
|
||||||
|
|
||||||
|
|
||||||
|
* Wed Nov 09 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-11
|
||||||
|
- Rebuild for F17 due to bz#744766
|
||||||
|
|
||||||
|
* Tue Apr 5 2011 Simo Sorce <ssorce@redhat.com> - 1.2.9-9
|
||||||
|
- Add patch to limit database expansion, was causing OOMs in SSSD in some
|
||||||
|
extreme situations.
|
||||||
|
|
||||||
|
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.9-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 14 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-8
|
||||||
|
- Actually fix the verbosity
|
||||||
|
|
||||||
|
* Fri Jan 14 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-7
|
||||||
|
- Let rpmbuild strip binaries, make build more verbose.
|
||||||
|
- Original patch by Ville Skyttä <ville.skytta@iki.fi>
|
||||||
|
|
||||||
|
* Wed Jan 12 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-6
|
||||||
|
- Install python bindings into the correct location
|
||||||
|
|
||||||
|
* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-5
|
||||||
|
- Run ldconfig on python-tdb
|
||||||
|
|
||||||
|
* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-4
|
||||||
|
- Do not delete a necessary file during %%install
|
||||||
|
|
||||||
|
* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-3
|
||||||
|
- Bump release to rebuild with the correct sources in place
|
||||||
|
|
||||||
|
* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-2
|
||||||
|
- Bump build to rebuild with sources in place
|
||||||
|
|
||||||
|
* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.2.9-1
|
||||||
|
- New upstream bugfix release
|
||||||
|
- Adds a new tdbrestore utility
|
||||||
|
- Convert to new WAF build-system
|
||||||
|
- Add python bindings in new python-tdb subpackage
|
||||||
|
|
||||||
|
* Wed Feb 24 2010 Simo Sorce <ssorce@redhat.com> - 1.2.1-3
|
||||||
|
- add missing build require
|
||||||
|
|
||||||
|
* Wed Feb 24 2010 Simo Sorce <ssorce@redhat.com> - 1.2.1-2
|
||||||
|
- Fix spec file
|
||||||
|
- Package manpages too
|
||||||
|
|
||||||
|
* Wed Feb 24 2010 Simo Sorce <ssorce@redhat.com> - 1.2.1-1
|
||||||
|
- New upstream bugfix release
|
||||||
|
|
||||||
|
* Tue Dec 15 2009 Simo Sorce <ssorce@redhat.com> - 1.2.0-1
|
||||||
|
- New upstream release
|
||||||
|
|
||||||
|
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.5-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 17 2009 Simo Sorce <ssorce@redhat.com> - 1.1.5-1
|
||||||
|
- Original tarballs had a screw-up, rebuild with new fixed tarballs from
|
||||||
|
upstream.
|
||||||
|
|
||||||
|
* Tue Jun 16 2009 Simo Sorce <ssorce@redhat.com> - 1.1.5-0
|
||||||
|
- New upstream release
|
||||||
|
|
||||||
|
* Wed May 6 2009 Simo Sorce <ssorce@redhat.com> - 1.1.3-15
|
||||||
|
- First public independent release from upstream
|
3
sources
Normal file
3
sources
Normal file
@ -0,0 +1,3 @@
|
|||||||
|
SHA512 (tdb.keyring) = 9dd3ad33a29f2f8484b80f6a41db1ef0551d6fe1a265b9100e2d7e71085d010c944fb830cb752a9964e5a58e45ac33920927140b839da21a5ca5ef05ad903f4a
|
||||||
|
SHA512 (tdb-1.4.3.tar.asc) = d384fbdb6ba11fb34077b49d47c26da04fd5c6046c3234cf35d83143c1ac41a25ed772bb41e3a36978cc29c425f7b47576b3ac92e59a5e8095e4e335758de8af
|
||||||
|
SHA512 (tdb-1.4.3.tar.gz) = 99488839e7da396f04df60412d21a7d3e09efeab52772d6cb5e9470a3dfd585d73ef2422c51cd0d8ccc123a65d455de400d5d6b24a21a2a50d3da60d9a70e67a
|
Loading…
Reference in New Issue
Block a user