RHEL 9.0.0 Alpha bootstrap
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/libtalloc#dba3f54ff1bcdb6f4d3a944e80519b3cfd4e4973
This commit is contained in:
parent
e837b0edd0
commit
f417e2afd8
25
.gitignore
vendored
25
.gitignore
vendored
@ -0,0 +1,25 @@
|
||||
/talloc-2.0.6.tar.gz
|
||||
/talloc-2.0.7.tar.gz
|
||||
/talloc-2.0.8.tar.gz
|
||||
/talloc-2.1.0.tar.gz
|
||||
/talloc-2.1.1.tar.gz
|
||||
/talloc-2.1.2.tar.gz
|
||||
/talloc-2.1.3.tar.gz
|
||||
/talloc-2.1.4.tar.gz
|
||||
/talloc-2.1.5.tar.gz
|
||||
/talloc-2.1.6.tar.gz
|
||||
/talloc-2.1.7.tar.gz
|
||||
/talloc-2.1.8.tar.gz
|
||||
/talloc-2.1.9.tar.gz
|
||||
/talloc-2.1.10.tar.gz
|
||||
/talloc-2.1.11.tar.gz
|
||||
/talloc-2.1.12.tar.gz
|
||||
/talloc-2.1.13.tar.gz
|
||||
/talloc-2.1.14.tar.gz
|
||||
/talloc-2.1.15.tar.gz
|
||||
/talloc-2.1.16.tar.gz
|
||||
/talloc-2.2.0.tar.gz
|
||||
/talloc-2.3.0.tar.gz
|
||||
/talloc-2.3.0.tar.asc
|
||||
/talloc-2.3.1.tar.gz
|
||||
/talloc-2.3.1.tar.asc
|
195
0003-wafsamba-Fix-few-SyntaxWarnings-caused-by-regular-ex.patch
Normal file
195
0003-wafsamba-Fix-few-SyntaxWarnings-caused-by-regular-ex.patch
Normal file
@ -0,0 +1,195 @@
|
||||
From 87dfb0ce329447625050771fd83dae1841ece1b8 Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Slebodnik <lslebodn@fedoraproject.org>
|
||||
Date: Wed, 12 Jun 2019 13:38:17 +0200
|
||||
Subject: [PATCH] wafsamba: Fix few SyntaxWarnings caused by regular
|
||||
expressions
|
||||
|
||||
./buildtools/wafsamba/samba_utils.py:258: SyntaxWarning: invalid escape sequence \$
|
||||
lst = re.split('(\$\{\w+\})', string)
|
||||
./buildtools/wafsamba/samba_utils.py:261: SyntaxWarning: invalid escape sequence \$
|
||||
if re.match('\$\{\w+\}', v):
|
||||
./buildtools/wafsamba/samba_cross.py:80: SyntaxWarning: invalid escape sequence \(
|
||||
m = re.match('\(\s*(-?\d+)\s*,\s*\"(.*)\"\s*\)', ans)
|
||||
./buildtools/wafsamba/samba_conftests.py:400: SyntaxWarning: invalid escape sequence \s
|
||||
m = re.search('MAN%sEXT\s+=\s+(\w+)' % section, man)
|
||||
./buildtools/wafsamba/samba_abi.py:24: SyntaxWarning: invalid escape sequence \$
|
||||
sig = re.sub('^\$[0-9]+\s=\s\{(.+)\}$', r'\1', sig)
|
||||
./buildtools/wafsamba/samba_abi.py:25: SyntaxWarning: invalid escape sequence \$
|
||||
sig = re.sub('^\$[0-9]+\s=\s\{(.+)\}(\s0x[0-9a-f]+\s<\w+>)+$', r'\1', sig)
|
||||
./buildtools/wafsamba/samba_abi.py:26: SyntaxWarning: invalid escape sequence \$
|
||||
sig = re.sub('^\$[0-9]+\s=\s(0x[0-9a-f]+)\s?(<\w+>)?$', r'\1', sig)
|
||||
./buildtools/wafsamba/samba_abi.py:33: SyntaxWarning: invalid escape sequence \*
|
||||
m = m.replace('*', '\*')
|
||||
./buildtools/wafsamba/samba_abi.py:44: SyntaxWarning: invalid escape sequence \s
|
||||
sig = re.sub(',\s\.\.\.', '', sig)
|
||||
./buildtools/wafsamba/samba_headers.py:22: SyntaxWarning: invalid escape sequence \s
|
||||
re_header = re.compile('^\s*#\s*include[ \t]*"([^"]+)"', re.I | re.M)
|
||||
./buildtools/wafsamba/symbols.py:122: SyntaxWarning: invalid escape sequence \[
|
||||
re_sharedlib = re.compile(b'Shared library: \[(.*)\]')
|
||||
./buildtools/wafsamba/symbols.py:124: SyntaxWarning: invalid escape sequence \[
|
||||
re_rpath = re.compile(b'Library (rpath|runpath): \[(.*)\]')
|
||||
./buildtools/wafsamba/pkgconfig.py:12: SyntaxWarning: invalid escape sequence \w
|
||||
a = re.split('(@\w+@)', s)
|
||||
./buildtools/wafsamba/pkgconfig.py:17: SyntaxWarning: invalid escape sequence \w
|
||||
if re.match('@\w+@', v):
|
||||
./buildtools/wafsamba/configure_file.py:16: SyntaxWarning: invalid escape sequence \w
|
||||
a = re.split('(@\w+@)', s)
|
||||
./buildtools/wafsamba/configure_file.py:19: SyntaxWarning: invalid escape sequence \w
|
||||
if re.match('@\w+@', v):
|
||||
---
|
||||
buildtools/wafsamba/configure_file.py | 4 ++--
|
||||
buildtools/wafsamba/pkgconfig.py | 4 ++--
|
||||
buildtools/wafsamba/samba_abi.py | 12 ++++++------
|
||||
buildtools/wafsamba/samba_conftests.py | 2 +-
|
||||
buildtools/wafsamba/samba_cross.py | 2 +-
|
||||
buildtools/wafsamba/samba_headers.py | 2 +-
|
||||
buildtools/wafsamba/samba_utils.py | 4 ++--
|
||||
buildtools/wafsamba/symbols.py | 4 ++--
|
||||
8 files changed, 17 insertions(+), 17 deletions(-)
|
||||
|
||||
diff --git a/buildtools/wafsamba/configure_file.py b/buildtools/wafsamba/configure_file.py
|
||||
index 6ad43546249fba7b4c0a037035e8574e7a9d2753..98a58a4604513e3633317e73299c1c9280c250d2 100644
|
||||
--- a/buildtools/wafsamba/configure_file.py
|
||||
+++ b/buildtools/wafsamba/configure_file.py
|
||||
@@ -13,10 +13,10 @@ def subst_at_vars(task):
|
||||
s = task.inputs[0].read()
|
||||
|
||||
# split on the vars
|
||||
- a = re.split('(@\w+@)', s)
|
||||
+ a = re.split(r'(@\w+@)', s)
|
||||
out = []
|
||||
for v in a:
|
||||
- if re.match('@\w+@', v):
|
||||
+ if re.match(r'@\w+@', v):
|
||||
vname = v[1:-1]
|
||||
if not vname in task.env and vname.upper() in task.env:
|
||||
vname = vname.upper()
|
||||
diff --git a/buildtools/wafsamba/pkgconfig.py b/buildtools/wafsamba/pkgconfig.py
|
||||
index b83d5f382a58352bb3318b594aa2b45fc02d87d5..b77bd618c8903789c7ba9e64a6972a4e080f1821 100644
|
||||
--- a/buildtools/wafsamba/pkgconfig.py
|
||||
+++ b/buildtools/wafsamba/pkgconfig.py
|
||||
@@ -9,12 +9,12 @@ def subst_at_vars(task):
|
||||
|
||||
s = task.inputs[0].read()
|
||||
# split on the vars
|
||||
- a = re.split('(@\w+@)', s)
|
||||
+ a = re.split(r'(@\w+@)', s)
|
||||
out = []
|
||||
done_var = {}
|
||||
back_sub = [ ('PREFIX', '${prefix}'), ('EXEC_PREFIX', '${exec_prefix}')]
|
||||
for v in a:
|
||||
- if re.match('@\w+@', v):
|
||||
+ if re.match(r'@\w+@', v):
|
||||
vname = v[1:-1]
|
||||
if not vname in task.env and vname.upper() in task.env:
|
||||
vname = vname.upper()
|
||||
diff --git a/buildtools/wafsamba/samba_abi.py b/buildtools/wafsamba/samba_abi.py
|
||||
index 5e7686da3d68b1ebcd842b8a319a5997fa9cf600..761667fcfe1f3937be22c8261b45dcb3979ae4cd 100644
|
||||
--- a/buildtools/wafsamba/samba_abi.py
|
||||
+++ b/buildtools/wafsamba/samba_abi.py
|
||||
@@ -21,16 +21,16 @@ version_key = lambda x: list(map(int, x.split(".")))
|
||||
def normalise_signature(sig):
|
||||
'''normalise a signature from gdb'''
|
||||
sig = sig.strip()
|
||||
- sig = re.sub('^\$[0-9]+\s=\s\{(.+)\}$', r'\1', sig)
|
||||
- sig = re.sub('^\$[0-9]+\s=\s\{(.+)\}(\s0x[0-9a-f]+\s<\w+>)+$', r'\1', sig)
|
||||
- sig = re.sub('^\$[0-9]+\s=\s(0x[0-9a-f]+)\s?(<\w+>)?$', r'\1', sig)
|
||||
- sig = re.sub('0x[0-9a-f]+', '0xXXXX', sig)
|
||||
+ sig = re.sub(r'^\$[0-9]+\s=\s\{(.+)\}$', r'\1', sig)
|
||||
+ sig = re.sub(r'^\$[0-9]+\s=\s\{(.+)\}(\s0x[0-9a-f]+\s<\w+>)+$', r'\1', sig)
|
||||
+ sig = re.sub(r'^\$[0-9]+\s=\s(0x[0-9a-f]+)\s?(<\w+>)?$', r'\1', sig)
|
||||
+ sig = re.sub(r'0x[0-9a-f]+', '0xXXXX', sig)
|
||||
sig = re.sub('", <incomplete sequence (\\\\[a-z0-9]+)>', r'\1"', sig)
|
||||
|
||||
for t in abi_type_maps:
|
||||
# we need to cope with non-word characters in mapped types
|
||||
m = t
|
||||
- m = m.replace('*', '\*')
|
||||
+ m = m.replace('*', r'\*')
|
||||
if m[-1].isalnum() or m[-1] == '_':
|
||||
m += '\\b'
|
||||
if m[0].isalnum() or m[0] == '_':
|
||||
@@ -41,7 +41,7 @@ def normalise_signature(sig):
|
||||
|
||||
def normalise_varargs(sig):
|
||||
'''cope with older versions of gdb'''
|
||||
- sig = re.sub(',\s\.\.\.', '', sig)
|
||||
+ sig = re.sub(r',\s\.\.\.', '', sig)
|
||||
return sig
|
||||
|
||||
|
||||
diff --git a/buildtools/wafsamba/samba_conftests.py b/buildtools/wafsamba/samba_conftests.py
|
||||
index ef632ba903369e4211991f17a3b204bcd96c3a2f..63e50567860ff890b00b0ce6c7607c917b7329d1 100644
|
||||
--- a/buildtools/wafsamba/samba_conftests.py
|
||||
+++ b/buildtools/wafsamba/samba_conftests.py
|
||||
@@ -397,7 +397,7 @@ WriteMakefile(
|
||||
|
||||
if section:
|
||||
man = Utils.readf(os.path.join(bdir,'Makefile'))
|
||||
- m = re.search('MAN%sEXT\s+=\s+(\w+)' % section, man)
|
||||
+ m = re.search(r'MAN%sEXT\s+=\s+(\w+)' % section, man)
|
||||
if not m:
|
||||
conf.end_msg('not found', color='YELLOW')
|
||||
return
|
||||
diff --git a/buildtools/wafsamba/samba_cross.py b/buildtools/wafsamba/samba_cross.py
|
||||
index 8863c2c53e7d7dd9317c9233f0085ffd0eea6b2f..34793902fba884cf2d8358bf4315dc98027266b6 100644
|
||||
--- a/buildtools/wafsamba/samba_cross.py
|
||||
+++ b/buildtools/wafsamba/samba_cross.py
|
||||
@@ -77,7 +77,7 @@ def cross_answer(ca_file, msg):
|
||||
f.close()
|
||||
return (0, ans.strip("'"))
|
||||
else:
|
||||
- m = re.match('\(\s*(-?\d+)\s*,\s*\"(.*)\"\s*\)', ans)
|
||||
+ m = re.match(r'\(\s*(-?\d+)\s*,\s*\"(.*)\"\s*\)', ans)
|
||||
if m:
|
||||
f.close()
|
||||
return (int(m.group(1)), m.group(2))
|
||||
diff --git a/buildtools/wafsamba/samba_headers.py b/buildtools/wafsamba/samba_headers.py
|
||||
index a268c011c5d8e406e0d763554c55668cfb5388bc..c8bee19010978a04460b0637fcc8fd484a699ea8 100644
|
||||
--- a/buildtools/wafsamba/samba_headers.py
|
||||
+++ b/buildtools/wafsamba/samba_headers.py
|
||||
@@ -19,7 +19,7 @@ def header_install_path(header, header_path):
|
||||
return ''
|
||||
|
||||
|
||||
-re_header = re.compile('^\s*#\s*include[ \t]*"([^"]+)"', re.I | re.M)
|
||||
+re_header = re.compile(r'^\s*#\s*include[ \t]*"([^"]+)"', re.I | re.M)
|
||||
|
||||
# a dictionary mapping source header paths to public header paths
|
||||
header_map = {}
|
||||
diff --git a/buildtools/wafsamba/samba_utils.py b/buildtools/wafsamba/samba_utils.py
|
||||
index ad97de1859ba24c4afd5106b4f9694b0dc855643..75c9794ec40f327ef8ccf9aa33fafd6ed6181e3b 100644
|
||||
--- a/buildtools/wafsamba/samba_utils.py
|
||||
+++ b/buildtools/wafsamba/samba_utils.py
|
||||
@@ -255,10 +255,10 @@ def TO_LIST(str, delimiter=None):
|
||||
|
||||
def subst_vars_error(string, env):
|
||||
'''substitute vars, throw an error if a variable is not defined'''
|
||||
- lst = re.split('(\$\{\w+\})', string)
|
||||
+ lst = re.split(r'(\$\{\w+\})', string)
|
||||
out = []
|
||||
for v in lst:
|
||||
- if re.match('\$\{\w+\}', v):
|
||||
+ if re.match(r'\$\{\w+\}', v):
|
||||
vname = v[2:-1]
|
||||
if not vname in env:
|
||||
raise KeyError("Failed to find variable %s in %s in env %s <%s>" % (vname, string, env.__class__, str(env)))
|
||||
diff --git a/buildtools/wafsamba/symbols.py b/buildtools/wafsamba/symbols.py
|
||||
index 3eca3d46bd71cf0780b3c8e36a26b96bd3aa3b83..73e8ca8ce53ef5d956ac58e14a2403dd49f01109 100644
|
||||
--- a/buildtools/wafsamba/symbols.py
|
||||
+++ b/buildtools/wafsamba/symbols.py
|
||||
@@ -119,9 +119,9 @@ def find_ldd_path(bld, libname, binary):
|
||||
|
||||
|
||||
# some regular expressions for parsing readelf output
|
||||
-re_sharedlib = re.compile(b'Shared library: \[(.*)\]')
|
||||
+re_sharedlib = re.compile(r'Shared library: \[(.*)\]')
|
||||
# output from readelf could be `Library rpath` or `Libray runpath`
|
||||
-re_rpath = re.compile(b'Library (rpath|runpath): \[(.*)\]')
|
||||
+re_rpath = re.compile(r'Library (rpath|runpath): \[(.*)\]')
|
||||
|
||||
def get_libs(bld, binname):
|
||||
'''find the list of linked libraries for any binary or library
|
||||
--
|
||||
2.22.0
|
||||
|
356
libtalloc.spec
Normal file
356
libtalloc.spec
Normal file
@ -0,0 +1,356 @@
|
||||
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||
%global with_python3 1
|
||||
%endif
|
||||
|
||||
Name: libtalloc
|
||||
Version: 2.3.1
|
||||
Release: 5%{?dist}
|
||||
Summary: The talloc library
|
||||
License: LGPLv3+
|
||||
URL: https://talloc.samba.org/
|
||||
|
||||
Source0: https://www.samba.org/ftp/talloc/talloc-%{version}.tar.gz
|
||||
Source1: https://www.samba.org/ftp/talloc/talloc-%{version}.tar.asc
|
||||
Source2: https://download.samba.org/pub/samba/samba-pubkey.asc#/talloc.keyring
|
||||
|
||||
# Patches
|
||||
Patch0001: 0003-wafsamba-Fix-few-SyntaxWarnings-caused-by-regular-ex.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: libxslt
|
||||
BuildRequires: docbook-style-xsl
|
||||
%if 0%{?with_python3}
|
||||
BuildRequires: python3-devel
|
||||
%endif
|
||||
BuildRequires: doxygen
|
||||
BuildRequires: gnupg2
|
||||
|
||||
Provides: bundled(libreplace)
|
||||
Obsoletes: python2-talloc < 2.2.0-1
|
||||
Obsoletes: python2-talloc-devel < 2.2.0-1
|
||||
|
||||
%description
|
||||
A library that implements a hierarchical allocator with destructors.
|
||||
|
||||
%package devel
|
||||
Summary: Developer tools for the Talloc library
|
||||
Requires: libtalloc = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
Header files needed to develop programs that link against the Talloc library.
|
||||
|
||||
%if 0%{?with_python3}
|
||||
%package -n python3-talloc
|
||||
Summary: Python bindings for the Talloc library
|
||||
Requires: libtalloc = %{version}-%{release}
|
||||
%{?python_provide:%python_provide python3-talloc}
|
||||
|
||||
%description -n python3-talloc
|
||||
Python 3 libraries for creating bindings using talloc
|
||||
|
||||
%package -n python3-talloc-devel
|
||||
Summary: Development libraries for python3-talloc
|
||||
Requires: python3-talloc = %{version}-%{release}
|
||||
%{?python_provide:%python_provide python3-talloc-devel}
|
||||
|
||||
%description -n python3-talloc-devel
|
||||
Development libraries for python3-talloc
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%autosetup -n talloc-%{version} -p1
|
||||
|
||||
%build
|
||||
zcat %{SOURCE0} | gpgv2 --quiet --keyring %{SOURCE2} %{SOURCE1} -
|
||||
# workaround for https://bugzilla.redhat.com/show_bug.cgi?id=1217376
|
||||
export python_LDFLAGS=""
|
||||
|
||||
%configure --disable-rpath \
|
||||
--disable-rpath-install \
|
||||
--bundled-libraries=NONE \
|
||||
--builtin-libraries=replace \
|
||||
--disable-silent-rules
|
||||
|
||||
%make_build
|
||||
doxygen doxy.config
|
||||
|
||||
%check
|
||||
%make_build check
|
||||
|
||||
%install
|
||||
%make_install
|
||||
|
||||
# Install API docs
|
||||
cp -a doc/man/* $RPM_BUILD_ROOT/%{_mandir}
|
||||
|
||||
%files
|
||||
%{_libdir}/libtalloc.so.*
|
||||
|
||||
%files devel
|
||||
%{_includedir}/talloc.h
|
||||
%{_libdir}/libtalloc.so
|
||||
%{_libdir}/pkgconfig/talloc.pc
|
||||
%{_mandir}/man3/talloc*.3.gz
|
||||
%{_mandir}/man3/libtalloc*.3.gz
|
||||
|
||||
%if 0%{?with_python3}
|
||||
%files -n python3-talloc
|
||||
%{_libdir}/libpytalloc-util.cpython*.so.*
|
||||
%{python3_sitearch}/talloc.cpython*.so
|
||||
|
||||
%files -n python3-talloc-devel
|
||||
%{_includedir}/pytalloc.h
|
||||
%{_libdir}/pkgconfig/pytalloc-util.cpython-*.pc
|
||||
%{_libdir}/libpytalloc-util.cpython*.so
|
||||
%endif
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
%if 0%{?with_python3}
|
||||
%ldconfig_scriptlets -n python3-talloc
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Mon Jul 13 2020 Tom Stellard <tstellar@redhat.com> - 2.3.1-4
|
||||
- Use make macros
|
||||
- https://fedoraproject.org/wiki/Changes/UseMakeBuildInstallMacro
|
||||
|
||||
* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 2.3.1-3
|
||||
- Rebuilt for Python 3.9
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Wed Jan 22 2020 Lukas Slebodnik <lslebodn@fedoraproject.org> - 2.3.1-1
|
||||
- rhbz#1748815 - libtalloc-2.3.1 is available
|
||||
|
||||
* Wed Sep 11 2019 Lukas Slebodnik <lslebodn@fedoraproject.org> - 2.3.0-1
|
||||
- rhbz#1748815 - libtalloc-2.3.0 is available
|
||||
|
||||
* Mon Aug 26 2019 Lukas Slebodnik <lslebodn@fedoraproject.org> - 2.2.0-1
|
||||
- rhbz#1691297 - libtalloc-2.2.0 is available
|
||||
- rhbz#1737644 - libldb, libtalloc, libtevent, libtdb: Remove Python 2 subpackages from Fedora 31+
|
||||
|
||||
* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 2.1.16-5
|
||||
- Rebuilt for Python 3.8
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.16-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri Jun 14 2019 Lukas Slebodnik <lslebodn@fedoraproject.org> - 2.1.16-3
|
||||
- rhbz#1718113 - samba fail to build with Python 3.8
|
||||
AttributeError: module 'time' has no attribute 'clock'
|
||||
|
||||
* Mon Jun 03 2019 Lukas Slebodnik <lslebodn@fedoraproject.org> - 2.1.16-2
|
||||
- rhbz#1711638 - fails to build with Python 3.8.0a4
|
||||
|
||||
* Tue Feb 26 2019 Lukas Slebodnik <lslebodn@fedoraproject.org> - 2.1.16-1
|
||||
- rhbz#1683211 - libtalloc-2.1.16 is available
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.15-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Thu Jan 17 2019 Lukas Slebodnik <lslebodn@fedoraproject.org> - 2.1.15-1
|
||||
- rhbz#1667471 - libtalloc-2.1.15 is available
|
||||
|
||||
* Fri Jul 13 2018 Jakub Hrozek <jhrozek@redhat.com> - 2.1.14-2
|
||||
- Drop the unneeded ABI hide patch
|
||||
- Use pathfix.py instead of a local patch to munge the python path
|
||||
|
||||
* Thu Jul 12 2018 Jakub Hrozek <jhrozek@redhat.com> - 2.1.14-1
|
||||
- New upstream release - 2.1.14
|
||||
- Apply a patch to hide local ABI symbols to avoid issues with new binutils
|
||||
- Patch the waf script to explicitly call python2 as "env python" doesn't
|
||||
yield py2 anymore
|
||||
|
||||
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 2.1.13-2
|
||||
- Rebuilt for Python 3.7
|
||||
|
||||
* Fri Apr 06 2018 Lukas Slebodnik <lslebodn@fedoraproject.org> - 2.1.13-1
|
||||
- rhbz#1564323 New upstream release - 2.1.13
|
||||
|
||||
* Thu Mar 22 2018 Lukas Slebodnik <lslebodn@fedoraproject.org> - 2.1.12-1
|
||||
- rhbz#1559378 New upstream release - 2.1.12
|
||||
|
||||
* Fri Mar 02 2018 Lukas Slebodnik <lslebodn@fedoraproject.org> - 2.1.11-6
|
||||
- Disable link time optimisation for python3 related libs
|
||||
- Workaround for rhbz#1548823
|
||||
|
||||
* Mon Feb 26 2018 Lukas Slebodnik <lslebodn@fedoraproject.org> - 2.1.11-5
|
||||
- Add gcc to Buildroot
|
||||
- https://fedoraproject.org/wiki/Changes/Remove_GCC_from_BuildRoot
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.11-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Sat Feb 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.1.11-3
|
||||
- Switch to %%ldconfig_scriptlets
|
||||
|
||||
* Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 2.1.11-2
|
||||
- Rebuilt for switch to libxcrypt
|
||||
|
||||
* Sat Jan 13 2018 Lukas Slebodnik <lslebodn@fedoraproject.org> - 2.1.11-1
|
||||
- rhbz#1534136 New upstream release - 2.1.11
|
||||
|
||||
* Wed Nov 29 2017 Merlin Mathesius <mmathesi@redhat.com> - 2.1.10-5
|
||||
- Cleanup spec file conditionals
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.10-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.10-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Mon Jul 24 2017 Lukas Slebodnik <lslebodn@redhat.com> - 2.1.10-2
|
||||
- fix location of pkgconfig files for libpytalloc*
|
||||
|
||||
* Mon Jul 24 2017 Lukas Slebodnik <lslebodn@redhat.com> - 2.1.10-1
|
||||
- rhbz#1473997 New upstream release - 2.1.10
|
||||
- enable unit tests
|
||||
|
||||
* Thu Jul 06 2017 Andreas Schneider <asn@redhat.com> - 2.1.9-2
|
||||
- Install pytalloc-util for python3 as well
|
||||
|
||||
* Tue Feb 28 2017 Lukas Slebodnik <lslebodn@redhat.com> - 2.1.9-1
|
||||
- rhbz#1427352 New upstream release - 2.1.9
|
||||
- rhbz#1401225 - Rename python packages to match packaging guidelines
|
||||
https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.8-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 2.1.8-2
|
||||
- Rebuild for Python 3.6
|
||||
|
||||
* Thu Jul 28 2016 Jakub Hrozek <jhrozek@redhat.com> - 2.1.8-1
|
||||
- New upstream release - 2.1.8
|
||||
|
||||
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.7-2
|
||||
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
|
||||
|
||||
* Fri May 6 2016 Jakub Hrozek <jhrozek@redhat.com> - 2.1.7-1
|
||||
- New upstream release - 2.1.7
|
||||
- Resolves: rhbz#1333790 - libtalloc-2.1.7 is available
|
||||
|
||||
* Wed Mar 9 2016 Jakub Hrozek <jhrozek@redhat.com> - 2.1.6-1
|
||||
- New upstream release - 2.1.6
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.5-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Wed Nov 11 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.5-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
|
||||
|
||||
* Wed Nov 11 2015 Jakub Hrozek <jhrozek@redhat.com> - 2.1.5-1
|
||||
- New upstream release - 2.1.5
|
||||
|
||||
* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
|
||||
|
||||
* Wed Oct 14 2015 Jakub Hrozek <jhrozek@redhat.com> - 2.1.4-1
|
||||
- New upstream release - 2.1.4
|
||||
|
||||
* Wed Jul 22 2015 Jakub Hrozek <jhrozek@redhat.com> - 2.1.3-1
|
||||
- New upstream release - 2.1.3
|
||||
- Resolves: rhbz#1241928 - Switch libtalloc to use python3
|
||||
- Rename pytalloc to python-talloc (Miro Hrončok <mhroncok@redhat.com>)
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Fri Mar 13 2015 Jakub Hrozek <jhrozek@redhat.com> - 2.1.2-1
|
||||
- New upstream release - 2.1.2
|
||||
|
||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Fri May 23 2014 Jakub Hrozek <jhrozek@redhat.com> - 2.1.1-1
|
||||
- New upstream release
|
||||
|
||||
* Sun Dec 15 2013 Jakub Hrozek <jhrozek@redhat.com> - 2.1.0-3
|
||||
- Bump NVR in order to tag a build
|
||||
|
||||
* Tue Sep 10 2013 Jakub Hrozek <jhrozek@redhat.com> - 2.1.0-2
|
||||
- New upstream release
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.8-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.8-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Sat Dec 01 2012 Jakub Hrozek <jhrozek@redhat.com> - 2.0.8-1
|
||||
- New upstream release
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.7-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.7-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Thu Dec 01 2011 Stephen Gallagher <sgallagh@redhat.com> - 2.0.7-3
|
||||
- Add patch to ignore --disable-silent-rules
|
||||
- Package API docs into libtalloc-devel
|
||||
|
||||
* Wed Nov 23 2011 Stephen Gallagher <sgallagh@redhat.com> - 2.0.7-2
|
||||
- Add explicit mention of the bundled libreplace
|
||||
- https://fedorahosted.org/fpc/ticket/120
|
||||
|
||||
* Fri Nov 04 2011 Stephen Gallagher <sgallagh@redhat.com> - 2.0.7-1
|
||||
- New upstream release
|
||||
- Required for new Samba 4 alpha builds
|
||||
|
||||
* Mon Aug 08 2011 Simo Sorce <ssorce@redhat.com> - 2.0.6-1
|
||||
- New upstream release
|
||||
- Fixes various bugs with talloc_free_children and freeing complex
|
||||
hierarchies with many siblinbgs.
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.5-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Fri Jan 14 2011 Stephen Gallagher <sgallagh@redhat.com> - 2.0.5-7
|
||||
- Let rpmbuild strip binaries, make build more verbose.
|
||||
- Resolves rhbz#669477 - libtalloc 2.0.5-6 binaries not stripped,
|
||||
- empty -debuginfo
|
||||
- Original patch by Ville Skyttä <ville.skytta@iki.fi>
|
||||
|
||||
* Wed Jan 12 2011 Stephen Gallagher <sgallagh@redhat.com> - 2.0.5-6
|
||||
- Install python bindings in the correct location
|
||||
|
||||
* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 2.0.5-5
|
||||
- Run ldconfig on pytalloc
|
||||
|
||||
* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 2.0.5-4
|
||||
- Fix build failure on 32-bit platforms
|
||||
|
||||
* Tue Jan 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 2.0.5-3
|
||||
- New version from upstream
|
||||
- Add support for pytalloc
|
||||
- Convert to new WAF build-system
|
||||
|
||||
* Tue Dec 15 2009 Simo Sorce <ssorce@redhat.com> - 2.0.1-1
|
||||
- New version from upstream
|
||||
- Also stop building the compat lib, it is not necessary anymore
|
||||
|
||||
* Tue Sep 8 2009 Simo Sorce <ssorce@redhat.com> - 2.0.0-0
|
||||
- New version from upstream.
|
||||
- Build also sover 1 compat library to ease packages migration
|
||||
|
||||
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Wed Jun 17 2009 Simo Sorce <ssorce@redhat.com> - 1.3.1-1
|
||||
- Original tarballs had a screw-up, rebuild with new fixed tarballs from
|
||||
upstream.
|
||||
|
||||
* Tue Jun 16 2009 Simo Sorce <ssorce@redhat.com> - 1.3.1-0
|
||||
- New Upstream release.
|
||||
|
||||
* Wed May 6 2009 Simo Sorce <ssorce@redhat.com> - 1.3.0-0
|
||||
- First public independent release from upstream
|
2
sources
Normal file
2
sources
Normal file
@ -0,0 +1,2 @@
|
||||
SHA512 (talloc-2.3.1.tar.asc) = 1774981d745197ace0b79c95fc63fffd220c2a3ed2686943af9cd95f696d396e6d65602f83ed72be3c63864c45e36ade2b10d171f2000f8fbe83e184191857c3
|
||||
SHA512 (talloc-2.3.1.tar.gz) = 064fc39a9aaace6e0209f3251c8ff198d8a318b4cf4198006ff9892ca6e15e7d817b2fda43e0444fbbf04d2c3e70d06523dff5d57cbb796d27317ef4759e062e
|
BIN
talloc.keyring
Normal file
BIN
talloc.keyring
Normal file
Binary file not shown.
Loading…
Reference in New Issue
Block a user