2.3.0
This commit is contained in:
parent
c21697a920
commit
c19c1d14fb
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
|||||||
/srtp-1.4.4-20101004cvs.tar.bz2
|
/srtp-1.4.4-20101004cvs.tar.bz2
|
||||||
/v1.5.0.tar.gz
|
/v1.5.0.tar.gz
|
||||||
/v1.5.4.tar.gz
|
/v1.5.4.tar.gz
|
||||||
|
/v2.3.0.tar.gz
|
||||||
|
36
libsrtp-2.3.0-shared-fix.patch
Normal file
36
libsrtp-2.3.0-shared-fix.patch
Normal file
@ -0,0 +1,36 @@
|
|||||||
|
diff -up libsrtp-2.3.0/Makefile.in.sharedfix libsrtp-2.3.0/Makefile.in
|
||||||
|
--- libsrtp-2.3.0/Makefile.in.sharedfix 2020-01-07 09:48:36.004217062 -0500
|
||||||
|
+++ libsrtp-2.3.0/Makefile.in 2020-01-07 09:53:08.117725096 -0500
|
||||||
|
@@ -106,12 +106,14 @@ bindir = @bindir@
|
||||||
|
pkgconfigdir = $(libdir)/pkgconfig
|
||||||
|
pkgconfig_DATA = libsrtp2.pc
|
||||||
|
|
||||||
|
-SHAREDLIBVERSION = 1
|
||||||
|
+SHAREDLIBMINIVER = 1
|
||||||
|
+SHAREDLIBVERSION = $(SHAREDLIBMINIVER).0.0
|
||||||
|
ifneq (,$(or $(findstring linux,@host@), $(findstring gnu,@host@)))
|
||||||
|
SHAREDLIB_DIR = $(libdir)
|
||||||
|
-SHAREDLIB_LDFLAGS = -shared -Wl,-soname,$@
|
||||||
|
SHAREDLIBSUFFIXNOVER = so
|
||||||
|
+SHAREDLIBMINISUFFIX = $(SHAREDLIBSUFFIXNOVER).$(SHAREDLIBMINIVER)
|
||||||
|
SHAREDLIBSUFFIX = $(SHAREDLIBSUFFIXNOVER).$(SHAREDLIBVERSION)
|
||||||
|
+SHAREDLIB_LDFLAGS = -shared -Wl,-soname,libsrtp2.$(SHAREDLIBMINISUFFIX)
|
||||||
|
else ifneq (,$(or $(findstring cygwin,@host@), $(findstring mingw,@host@)))
|
||||||
|
SHAREDLIB_DIR = $(bindir)
|
||||||
|
SHAREDLIB_LDFLAGS = -shared -Wl,--out-implib,libsrtp2.dll.a
|
||||||
|
@@ -166,6 +168,7 @@ libsrtp2.$(SHAREDLIBSUFFIX): $(srtpobj)
|
||||||
|
$(CC) -shared -o $@ $(SHAREDLIB_LDFLAGS) \
|
||||||
|
$^ $(LDFLAGS) $(LIBS)
|
||||||
|
if [ -n "$(SHAREDLIBVERSION)" ]; then \
|
||||||
|
+ ln -sfn $@ libsrtp2.$(SHAREDLIBMINISUFFIX); \
|
||||||
|
ln -sfn $@ libsrtp2.$(SHAREDLIBSUFFIXNOVER); \
|
||||||
|
fi
|
||||||
|
|
||||||
|
@@ -288,6 +291,7 @@ install:
|
||||||
|
cp libsrtp2.$(SHAREDLIBSUFFIXNOVER) $(DESTDIR)$(SHAREDLIB_DIR)/; \
|
||||||
|
if [ -n "$(SHAREDLIBVERSION)" ]; then \
|
||||||
|
ln -sfn libsrtp2.$(SHAREDLIBSUFFIX) $(DESTDIR)$(SHAREDLIB_DIR)/libsrtp2.$(SHAREDLIBSUFFIXNOVER); \
|
||||||
|
+ ln -sfn libsrtp2.$(SHAREDLIBSUFFIX) $(DESTDIR)$(SHAREDLIB_DIR)/libsrtp2.$(SHAREDLIBMINISUFFIX); \
|
||||||
|
fi; \
|
||||||
|
fi
|
||||||
|
$(INSTALL) -d $(DESTDIR)$(pkgconfigdir)
|
31
libsrtp.spec
31
libsrtp.spec
@ -1,20 +1,15 @@
|
|||||||
%global shortname srtp
|
%global shortname srtp
|
||||||
|
|
||||||
Name: libsrtp
|
Name: libsrtp
|
||||||
Version: 1.5.4
|
Version: 2.3.0
|
||||||
Release: 11%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: An implementation of the Secure Real-time Transport Protocol (SRTP)
|
Summary: An implementation of the Secure Real-time Transport Protocol (SRTP)
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: https://github.com/cisco/libsrtp
|
URL: https://github.com/cisco/libsrtp
|
||||||
Source0: https://github.com/cisco/libsrtp/archive/v%{version}.tar.gz
|
Source0: https://github.com/cisco/libsrtp/archive/v%{version}.tar.gz
|
||||||
# Universal config.h
|
BuildRequires: gcc, nss-devel, libpcap-devel
|
||||||
Source2: config.h
|
|
||||||
BuildRequires: gcc
|
|
||||||
# Fix shared lib so ldconfig doesn't complain
|
# Fix shared lib so ldconfig doesn't complain
|
||||||
Patch0: libsrtp-1.5.4-shared-fix.patch
|
Patch0: libsrtp-2.3.0-shared-fix.patch
|
||||||
Patch1: libsrtp-srtp_aes_encrypt.patch
|
|
||||||
Patch2: libsrtp-sha1-name-fix.patch
|
|
||||||
Patch3: libsrtp-fix-name-collision-on-MIPS.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
This package provides an implementation of the Secure Real-time
|
This package provides an implementation of the Secure Real-time
|
||||||
@ -33,9 +28,6 @@ developing applications that use %{name}.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}
|
%setup -q -n %{name}-%{version}
|
||||||
%patch0 -p1 -b .sharedfix
|
%patch0 -p1 -b .sharedfix
|
||||||
%patch1 -p1 -b .srtp_aes_encrypt
|
|
||||||
%patch2 -p1 -b .sha1-name-fix
|
|
||||||
%patch3 -p1 -b .mips-name-fix
|
|
||||||
|
|
||||||
%if 0%{?rhel} > 0
|
%if 0%{?rhel} > 0
|
||||||
%ifarch ppc64
|
%ifarch ppc64
|
||||||
@ -45,30 +37,29 @@ sed -i 's/-z noexecstack//' Makefile.in
|
|||||||
|
|
||||||
%build
|
%build
|
||||||
export CFLAGS="%{optflags} -fPIC"
|
export CFLAGS="%{optflags} -fPIC"
|
||||||
%configure
|
%configure --enable-nss
|
||||||
make %{?_smp_mflags} shared_library
|
make %{?_smp_mflags} shared_library
|
||||||
|
|
||||||
%install
|
%install
|
||||||
make install DESTDIR=%{buildroot}
|
make install DESTDIR=%{buildroot}
|
||||||
find %{buildroot} -name '*.la' -exec rm -f {} ';'
|
find %{buildroot} -name '*.la' -exec rm -f {} ';'
|
||||||
|
|
||||||
# Handle multilib issues with config.h
|
|
||||||
mv %{buildroot}%{_includedir}/%{shortname}/config.h %{buildroot}%{_includedir}/%{shortname}/config-%{__isa_bits}.h
|
|
||||||
cp -a %{SOURCE2} %{buildroot}%{_includedir}/%{shortname}/config.h
|
|
||||||
|
|
||||||
%ldconfig_scriptlets
|
%ldconfig_scriptlets
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%license LICENSE
|
%license LICENSE
|
||||||
%doc CHANGES README TODO VERSION doc/*.txt doc/*.pdf
|
%doc CHANGES README.md
|
||||||
%{_libdir}/*.so.*
|
%{_libdir}/*.so.*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_includedir}/%{shortname}/
|
%{_includedir}/%{shortname}2/
|
||||||
%{_libdir}/pkgconfig/libsrtp.pc
|
%{_libdir}/pkgconfig/libsrtp2.pc
|
||||||
%{_libdir}/*.so
|
%{_libdir}/*.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 7 2020 Tom Callaway <spot@fedoraproject.org> - 2.3.0-1
|
||||||
|
- update to 2.3.0
|
||||||
|
|
||||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.4-11
|
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.4-11
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user