1.5.4 + MIPS fix
This commit is contained in:
parent
09bd1ae31d
commit
528a92e8ba
55
libsrtp-fix-name-collision-on-MIPS.patch
Normal file
55
libsrtp-fix-name-collision-on-MIPS.patch
Normal file
@ -0,0 +1,55 @@
|
||||
diff -urp libsrtp-1.5.0/test/srtp_driver.c l/test/srtp_driver.c
|
||||
--- libsrtp-1.5.0/test/srtp_driver.c 2014-10-13 16:35:33.000000000 +0200
|
||||
+++ libsrtp-1.5.4/test/srtp_driver.c 2015-09-18 06:41:50.740727805 +0200
|
||||
@@ -341,7 +341,7 @@ main (int argc, char *argv[]) {
|
||||
if (do_codec_timing) {
|
||||
srtp_policy_t policy;
|
||||
int ignore;
|
||||
- double mips = mips_estimate(1000000000, &ignore);
|
||||
+ double mips_est = mips_estimate(1000000000, &ignore);
|
||||
|
||||
crypto_policy_set_rtp_default(&policy.rtp);
|
||||
crypto_policy_set_rtcp_default(&policy.rtcp);
|
||||
@@ -353,33 +353,33 @@ main (int argc, char *argv[]) {
|
||||
policy.allow_repeat_tx = 0;
|
||||
policy.next = NULL;
|
||||
|
||||
- printf("mips estimate: %e\n", mips);
|
||||
+ printf("mips estimate: %e\n", mips_est);
|
||||
|
||||
printf("testing srtp processing time for voice codecs:\n");
|
||||
printf("codec\t\tlength (octets)\t\tsrtp instructions/second\n");
|
||||
printf("G.711\t\t%d\t\t\t%e\n", 80,
|
||||
- (double) mips * (80 * 8) /
|
||||
+ (double) mips_est * (80 * 8) /
|
||||
srtp_bits_per_second(80, &policy) / .01 );
|
||||
printf("G.711\t\t%d\t\t\t%e\n", 160,
|
||||
- (double) mips * (160 * 8) /
|
||||
+ (double) mips_est * (160 * 8) /
|
||||
srtp_bits_per_second(160, &policy) / .02);
|
||||
printf("G.726-32\t%d\t\t\t%e\n", 40,
|
||||
- (double) mips * (40 * 8) /
|
||||
+ (double) mips_est * (40 * 8) /
|
||||
srtp_bits_per_second(40, &policy) / .01 );
|
||||
printf("G.726-32\t%d\t\t\t%e\n", 80,
|
||||
- (double) mips * (80 * 8) /
|
||||
+ (double) mips_est * (80 * 8) /
|
||||
srtp_bits_per_second(80, &policy) / .02);
|
||||
printf("G.729\t\t%d\t\t\t%e\n", 10,
|
||||
- (double) mips * (10 * 8) /
|
||||
+ (double) mips_est * (10 * 8) /
|
||||
srtp_bits_per_second(10, &policy) / .01 );
|
||||
printf("G.729\t\t%d\t\t\t%e\n", 20,
|
||||
- (double) mips * (20 * 8) /
|
||||
+ (double) mips_est * (20 * 8) /
|
||||
srtp_bits_per_second(20, &policy) / .02 );
|
||||
printf("Wideband\t%d\t\t\t%e\n", 320,
|
||||
- (double) mips * (320 * 8) /
|
||||
+ (double) mips_est * (320 * 8) /
|
||||
srtp_bits_per_second(320, &policy) / .01 );
|
||||
printf("Wideband\t%d\t\t\t%e\n", 640,
|
||||
- (double) mips * (640 * 8) /
|
||||
+ (double) mips_est * (640 * 8) /
|
||||
srtp_bits_per_second(640, &policy) / .02 );
|
||||
}
|
||||
|
32
libsrtp.spec
32
libsrtp.spec
@ -1,8 +1,8 @@
|
||||
%global shortname srtp
|
||||
|
||||
Name: libsrtp
|
||||
Version: 1.5.0
|
||||
Release: 4%{?dist}
|
||||
Version: 1.5.4
|
||||
Release: 1%{?dist}
|
||||
Summary: An implementation of the Secure Real-time Transport Protocol (SRTP)
|
||||
Group: System Environment/Libraries
|
||||
License: BSD
|
||||
@ -12,12 +12,9 @@ Source0: https://github.com/cisco/libsrtp/archive/v%{version}.tar.gz
|
||||
Source1: libsrtp.pc
|
||||
# Universal config.h
|
||||
Source2: config.h
|
||||
|
||||
# Seriously. Who doesn't do shared libs these days?
|
||||
# And how does Chromium always manage to find these projects and use them?
|
||||
Patch0: libsrtp-1.5.0-shared.patch
|
||||
Patch1: libsrtp-srtp_aes_encrypt.patch
|
||||
Patch2: libsrtp-sha1-name-fix.patch
|
||||
Patch3: libsrtp-fix-name-collision-on-MIPS.patch
|
||||
|
||||
%description
|
||||
This package provides an implementation of the Secure Real-time
|
||||
@ -27,7 +24,7 @@ a supporting cryptographic kernel.
|
||||
%package devel
|
||||
Summary: Development files for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Requires: pkgconfig
|
||||
|
||||
%description devel
|
||||
@ -36,12 +33,9 @@ developing applications that use %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch0 -p1 -b .shared
|
||||
%patch1 -p1 -b .srtp_aes_encrypt
|
||||
%patch2 -p1 -b .sha1-name-fix
|
||||
|
||||
# Fix end-of-line encoding
|
||||
sed -i 's/\r//g' doc/draft-irtf-cfrg-icm-00.txt
|
||||
%patch3 -p1 -b .mips-name-fix
|
||||
|
||||
%if 0%{?rhel} > 0
|
||||
%ifarch ppc64
|
||||
@ -52,16 +46,11 @@ sed -i 's/-z noexecstack//' Makefile.in
|
||||
%build
|
||||
export CFLAGS="%{optflags} -fPIC"
|
||||
%configure
|
||||
make %{?_smp_mflags}
|
||||
make %{?_smp_mflags} shared_library
|
||||
|
||||
%install
|
||||
make install DESTDIR=%{buildroot}
|
||||
find %{buildroot} -name '*.la' -exec rm -f {} ';'
|
||||
pushd %{buildroot}%{_libdir}
|
||||
mv libsrtp.so libsrtp.so.1.0.0
|
||||
ln -sf libsrtp.so.1.0.0 libsrtp.so
|
||||
ln -sf libsrtp.so.1.0.0 libsrtp.so.1
|
||||
popd
|
||||
|
||||
# Install the pkg-config file
|
||||
mkdir -p %{buildroot}%{_libdir}/pkgconfig/
|
||||
@ -79,17 +68,20 @@ cp -a %{SOURCE2} %{buildroot}%{_includedir}/%{shortname}/config.h
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc CHANGES LICENSE README TODO VERSION doc/*.txt doc/*.pdf
|
||||
%license LICENSE
|
||||
%doc CHANGES README TODO VERSION doc/*.txt doc/*.pdf
|
||||
%{_libdir}/*.so.*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
%{_includedir}/%{shortname}/
|
||||
%{_libdir}/pkgconfig/libsrtp.pc
|
||||
%{_libdir}/*.so
|
||||
|
||||
%changelog
|
||||
* Thu Feb 11 2016 Tom Callaway <spot@fedoraproject.org> - 1.5.4-1
|
||||
- update to 1.5.4
|
||||
- fix MIPS name collision (bz1305950 ) Thanks to Michal Toman
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user