Update to 2.54.1
This commit is contained in:
parent
9248e13e1d
commit
bc69d11250
1
.gitignore
vendored
1
.gitignore
vendored
@ -77,3 +77,4 @@ libsoup-2.31.6.tar.bz2
|
||||
/libsoup-2.53.92.tar.xz
|
||||
/libsoup-2.54.0.tar.xz
|
||||
/libsoup-2.54.0.1.tar.xz
|
||||
/libsoup-2.54.1.tar.xz
|
||||
|
11
libsoup.spec
11
libsoup.spec
@ -3,8 +3,8 @@
|
||||
### Abstract ###
|
||||
|
||||
Name: libsoup
|
||||
Version: 2.54.0.1
|
||||
Release: 3%{?dist}
|
||||
Version: 2.54.1
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2
|
||||
Group: Development/Libraries
|
||||
Summary: Soup, an HTTP library implementation
|
||||
@ -12,8 +12,6 @@ URL: https://wiki.gnome.org/Projects/libsoup
|
||||
#VCS: git:git://git.gnome.org/libsoup
|
||||
Source: https://download.gnome.org/sources/%{name}/2.54/%{name}-%{version}.tar.xz
|
||||
|
||||
Patch01: rh1327072-ntlm-auth-failure.patch
|
||||
|
||||
### Build Dependencies ###
|
||||
|
||||
BuildRequires: glib2-devel >= %{glib2_version}
|
||||
@ -50,7 +48,6 @@ you to develop applications that use the libsoup library.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch01 -p1 -b .ntlm-auth-failure
|
||||
|
||||
%build
|
||||
%configure --disable-static
|
||||
@ -90,6 +87,10 @@ rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
|
||||
%{_datadir}/vala/vapi/libsoup-2.4.vapi
|
||||
|
||||
%changelog
|
||||
* Tue Apr 26 2016 Milan Crha <mcrha@redhat.com> - 2.54.1-1
|
||||
- Update to 2.54.1
|
||||
- Remove patch for NTLM auth failure with latest samba (fixed upstream)
|
||||
|
||||
* Fri Apr 22 2016 Milan Crha <mcrha@redhat.com> - 2.54.0.1-3
|
||||
- Add 'BuildRequires: krb5-devel', to support WWW-Authenticate: Negotiate in runtime
|
||||
|
||||
|
@ -1,30 +0,0 @@
|
||||
diff --git a/libsoup/soup-auth-ntlm.c b/libsoup/soup-auth-ntlm.c
|
||||
index 926fd4a..68029ae 100644
|
||||
--- a/libsoup/soup-auth-ntlm.c
|
||||
+++ b/libsoup/soup-auth-ntlm.c
|
||||
@@ -359,6 +359,7 @@ soup_auth_ntlm_update_connection (SoupConnectionAuth *auth, SoupMessage *msg,
|
||||
conn->state = SOUP_NTLM_SSO_FAILED;
|
||||
success = FALSE;
|
||||
} else if (!g_ascii_strcasecmp (response, "PW")) {
|
||||
+ conn->state = SOUP_NTLM_SSO_FAILED;
|
||||
priv->sso_available = FALSE;
|
||||
g_free (response);
|
||||
} else {
|
||||
@@ -489,7 +490,7 @@ soup_auth_ntlm_get_connection_authorization (SoupConnectionAuth *auth,
|
||||
priv->sso_available = FALSE;
|
||||
}
|
||||
} else {
|
||||
- g_warning ("NTLM single-sign-on using %s failed", NTLM_AUTH);
|
||||
+ g_debug ("NTLM single-sign-on using %s failed", NTLM_AUTH);
|
||||
}
|
||||
}
|
||||
/* If NTLM single-sign-on fails, go back to original
|
||||
@@ -525,7 +526,7 @@ soup_auth_ntlm_get_connection_authorization (SoupConnectionAuth *auth,
|
||||
#ifdef USE_NTLM_AUTH
|
||||
case SOUP_NTLM_SSO_FAILED:
|
||||
/* Restart request without SSO */
|
||||
- g_warning ("NTLM single-sign-on by using %s failed", NTLM_AUTH);
|
||||
+ g_debug ("NTLM single-sign-on by using %s failed", NTLM_AUTH);
|
||||
priv->sso_available = FALSE;
|
||||
header = soup_ntlm_request ();
|
||||
conn->state = SOUP_NTLM_SENT_REQUEST;
|
Loading…
Reference in New Issue
Block a user