Update to 2.58.1
This commit is contained in:
parent
6a34e67c97
commit
1eb47d2e6b
1
.gitignore
vendored
1
.gitignore
vendored
@ -82,3 +82,4 @@ libsoup-2.31.6.tar.bz2
|
||||
/libsoup-2.56.0.tar.xz
|
||||
/libsoup-2.57.1.tar.xz
|
||||
/libsoup-2.58.0.tar.xz
|
||||
/libsoup-2.58.1.tar.xz
|
||||
|
@ -1,49 +0,0 @@
|
||||
From 8d337030bd7b4c7a9c141765cc5bcedbffe3d7e0 Mon Sep 17 00:00:00 2001
|
||||
From: Dan Winship <danw@gnome.org>
|
||||
Date: Sun, 30 Apr 2017 14:23:37 -0400
|
||||
Subject: Revert "Abort session after a new proxy resolver is set"
|
||||
|
||||
This reverts commit 28849060f5b8d8829bc4fc6d208d22f15e869f46.
|
||||
|
||||
There was no compelling need for the change, just consistency, but it
|
||||
apparently broke things.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=781590
|
||||
---
|
||||
libsoup/soup-session.c | 6 ++----
|
||||
1 file changed, 2 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/libsoup/soup-session.c b/libsoup/soup-session.c
|
||||
index 20054f3..f7aef68 100644
|
||||
--- a/libsoup/soup-session.c
|
||||
+++ b/libsoup/soup-session.c
|
||||
@@ -623,8 +623,6 @@ set_proxy_resolver (SoupSession *session, SoupURI *uri,
|
||||
G_GNUC_END_IGNORE_DEPRECATIONS;
|
||||
} else if (g_resolver)
|
||||
priv->proxy_resolver = g_object_ref (g_resolver);
|
||||
-
|
||||
- soup_session_abort (session);
|
||||
}
|
||||
|
||||
static void
|
||||
@@ -646,6 +644,7 @@ soup_session_set_property (GObject *object, guint prop_id,
|
||||
case PROP_PROXY_URI:
|
||||
set_proxy_resolver (session, g_value_get_boxed (value),
|
||||
NULL, NULL);
|
||||
+ soup_session_abort (session);
|
||||
socket_props_changed = TRUE;
|
||||
break;
|
||||
case PROP_PROXY_RESOLVER:
|
||||
@@ -3218,8 +3217,7 @@ soup_session_class_init (SoupSessionClass *session_class)
|
||||
* A #GProxyResolver to use with this session. Setting this
|
||||
* will clear the #SoupSession:proxy-uri property, and remove
|
||||
* any <type>SoupProxyURIResolver</type> features that have
|
||||
- * been added to the session. Setting this property will also
|
||||
- * cancel all currently pending messages.
|
||||
+ * been added to the session.
|
||||
*
|
||||
* By default, in a plain #SoupSession, this is set to the
|
||||
* default #GProxyResolver, but you can set it to %NULL if you
|
||||
--
|
||||
cgit v0.12
|
||||
|
10
libsoup.spec
10
libsoup.spec
@ -1,16 +1,14 @@
|
||||
%define glib2_version 2.38.0
|
||||
|
||||
Name: libsoup
|
||||
Version: 2.58.0
|
||||
Release: 2%{?dist}
|
||||
Version: 2.58.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Soup, an HTTP library implementation
|
||||
|
||||
License: LGPLv2
|
||||
URL: https://wiki.gnome.org/Projects/libsoup
|
||||
Source0: https://download.gnome.org/sources/%{name}/2.58/%{name}-%{version}.tar.xz
|
||||
|
||||
Patch01: libsoup-2.58.0-request-cancel.patch
|
||||
|
||||
BuildRequires: glib2-devel >= %{glib2_version}
|
||||
BuildRequires: glib-networking
|
||||
BuildRequires: intltool
|
||||
@ -44,7 +42,6 @@ you to develop applications that use the libsoup library.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch01 -p1 -b .request-cancel
|
||||
|
||||
%build
|
||||
%configure --disable-static
|
||||
@ -84,6 +81,9 @@ rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
|
||||
%{_datadir}/vala/vapi/libsoup-2.4.vapi
|
||||
|
||||
%changelog
|
||||
* Tue May 09 2017 Kalev Lember <klember@redhat.com> - 2.58.1-1
|
||||
- Update to 2.58.1
|
||||
|
||||
* Wed May 03 2017 Milan Crha <mcrha@redhat.com> - 2.58.0-2
|
||||
- Add patch for GNONE bug #781590 (Fails to connect to server due to request cancel)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libsoup-2.58.0.tar.xz) = 2d041a36f49e1a271d206eb75b09f8786f0674a884caf97cdb9175cfe1bfaa71abf41de2fb3b0eabb53f0917d6b7ff1957981c40b69d63369dddd6907d1431a9
|
||||
SHA512 (libsoup-2.58.1.tar.xz) = 9181771197a8ed700a80e449ad9b39e697d1b4f470a8d33c227a037322b2a81c8e68bcfdfdab062a97e2b71172b77397facba2ab000be5d388e7ae2f1d6c4d3a
|
||||
|
Loading…
Reference in New Issue
Block a user