rebase to af1465a2.
also libsolv-repo_add_solv_without_stub.patch.
This commit is contained in:
parent
fe1dd0f5cc
commit
f4c7379d23
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
|||||||
/libsolv-857fe28.tar.xz
|
/libsolv-857fe28.tar.xz
|
||||||
/libsolv-80afaf7.tar.xz
|
/libsolv-80afaf7.tar.xz
|
||||||
|
/libsolv-af1465a2.tar.xz
|
||||||
|
30
libsolv-repo_add_solv_without_stub.patch
Normal file
30
libsolv-repo_add_solv_without_stub.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
From 6b63ea994945195f02d8a04d2786959ed438f484 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Ales Kozumplik <akozumpl@redhat.com>
|
||||||
|
Date: Thu, 12 Apr 2012 10:29:28 +0200
|
||||||
|
Subject: [PATCH] make repo_add_solv() work without stub repodata.
|
||||||
|
|
||||||
|
---
|
||||||
|
src/repo_solv.c | 7 ++++++-
|
||||||
|
1 files changed, 6 insertions(+), 1 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/repo_solv.c b/src/repo_solv.c
|
||||||
|
index 3f391ef..4e632ae 100644
|
||||||
|
--- a/src/repo_solv.c
|
||||||
|
+++ b/src/repo_solv.c
|
||||||
|
@@ -514,7 +514,12 @@ repo_add_solv(Repo *repo, FILE *fp, int flags)
|
||||||
|
extendstart = repo->start;
|
||||||
|
extendend = repo->end;
|
||||||
|
}
|
||||||
|
-
|
||||||
|
+ else if ((flags & REPO_EXTEND_SOLVABLES) != 0)
|
||||||
|
+ {
|
||||||
|
+ parent = repo_add_repodata(repo, flags);
|
||||||
|
+ repodata_extend_block(parent, repo->start, repo->nsolvables);
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
memset(&data, 0, sizeof(data));
|
||||||
|
data.repo = repo;
|
||||||
|
data.fp = fp;
|
||||||
|
--
|
||||||
|
1.7.7.3
|
||||||
|
|
14
libsolv.spec
14
libsolv.spec
@ -1,4 +1,4 @@
|
|||||||
%global gitrev 80afaf7
|
%global gitrev af1465a2
|
||||||
%{!?ruby_sitearch: %global ruby_sitearch %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"] ')}
|
%{!?ruby_sitearch: %global ruby_sitearch %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"] ')}
|
||||||
%filter_provides_in %{perl_vendorarch}/.*\.so$
|
%filter_provides_in %{perl_vendorarch}/.*\.so$
|
||||||
%filter_provides_in %{python_sitearch}/.*\.so$
|
%filter_provides_in %{python_sitearch}/.*\.so$
|
||||||
@ -7,7 +7,7 @@
|
|||||||
|
|
||||||
Name: libsolv
|
Name: libsolv
|
||||||
Version: 0.0.0
|
Version: 0.0.0
|
||||||
Release: 6.git%{gitrev}%{?dist}
|
Release: 7.git%{gitrev}%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Url: https://github.com/openSUSE/libsolv
|
Url: https://github.com/openSUSE/libsolv
|
||||||
# git clone https://github.com/openSUSE/libsolv.git
|
# git clone https://github.com/openSUSE/libsolv.git
|
||||||
@ -15,6 +15,7 @@ Url: https://github.com/openSUSE/libsolv
|
|||||||
Source: libsolv-%{gitrev}.tar.xz
|
Source: libsolv-%{gitrev}.tar.xz
|
||||||
Patch0: libsolv-rubyinclude.patch
|
Patch0: libsolv-rubyinclude.patch
|
||||||
Patch1: libsolv-newruby.patch
|
Patch1: libsolv-newruby.patch
|
||||||
|
Patch2: libsolv-repo_add_solv_without_stub.patch
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Summary: Package dependency solver
|
Summary: Package dependency solver
|
||||||
BuildRequires: cmake libdb-devel expat-devel rpm-devel zlib-devel
|
BuildRequires: cmake libdb-devel expat-devel rpm-devel zlib-devel
|
||||||
@ -83,6 +84,7 @@ Perl bindings for sat solver.
|
|||||||
%setup -q -n libsolv
|
%setup -q -n libsolv
|
||||||
%patch0 -p1 -b .rubyinclude
|
%patch0 -p1 -b .rubyinclude
|
||||||
%patch1 -p1 -b .newruby
|
%patch1 -p1 -b .newruby
|
||||||
|
%patch2 -p1 -b .withoutstub
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
%cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
||||||
@ -142,16 +144,20 @@ rm $RPM_BUILD_ROOT/usr/bin/testsolv
|
|||||||
%{python_sitearch}/*
|
%{python_sitearch}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 12 2012 Aleš Kozumplik <akozumpl@redhat.com> - 0.0.0-7.gitaf1465a2%{?dist}
|
||||||
|
- Rebase to the upstream.
|
||||||
|
- Make repo_add_solv() work without stub repodata.
|
||||||
|
|
||||||
* Thu Apr 5 2012 Karel Klíč <kklic@redhat.com> - 0.0.0-6.git80afaf7%{?dist}
|
* Thu Apr 5 2012 Karel Klíč <kklic@redhat.com> - 0.0.0-6.git80afaf7%{?dist}
|
||||||
- Rebuild for the new libdb package.
|
- Rebuild for the new libdb package.
|
||||||
|
|
||||||
* Mon Apr 2 2012 Karel Klíč <kklic@redhat.com> - 0.0.0-5.git80afaf7%{?dist}
|
* Mon Apr 2 2012 Karel Klíč <kklic@redhat.com> - 0.0.0-5.git80afaf7%{?dist}
|
||||||
- Rebuild for the new rpm package.
|
- Rebuild for the new rpm package.
|
||||||
|
|
||||||
* Wed Mar 21 2012 Aleš Kozumplík <akozumpl@redhat.com> - 0.0.0-4.git%{gitrev}%{?dist}
|
* Wed Mar 21 2012 Aleš Kozumplík <akozumpl@redhat.com> - 0.0.0-4.git80afaf7%{?dist}
|
||||||
- New upstream version, fix the .rpm release number.
|
- New upstream version, fix the .rpm release number.
|
||||||
|
|
||||||
* Wed Mar 21 2012 Aleš Kozumplík <akozumpl@redhat.com> - 0.0.0-3.git%{gitrev}%{?dist}
|
* Wed Mar 21 2012 Aleš Kozumplík <akozumpl@redhat.com> - 0.0.0-3.git80afaf7%{?dist}
|
||||||
- New upstream version.
|
- New upstream version.
|
||||||
|
|
||||||
* Tue Feb 7 2012 Karel Klíč <kklic@redhat.com> - 0.0.0-2.git857fe28%{?dist}
|
* Tue Feb 7 2012 Karel Klíč <kklic@redhat.com> - 0.0.0-2.git857fe28%{?dist}
|
||||||
|
Loading…
Reference in New Issue
Block a user