Update to 0.7.6
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
parent
46f897c4ad
commit
b3cd3bae2e
1
.gitignore
vendored
1
.gitignore
vendored
@ -48,3 +48,4 @@
|
|||||||
/libsolv-0.7.3.tar.gz
|
/libsolv-0.7.3.tar.gz
|
||||||
/libsolv-0.7.4.tar.gz
|
/libsolv-0.7.4.tar.gz
|
||||||
/libsolv-0.7.5.tar.gz
|
/libsolv-0.7.5.tar.gz
|
||||||
|
/libsolv-0.7.6.tar.gz
|
||||||
|
@ -1,30 +0,0 @@
|
|||||||
From 69439fe4eea683200aa6449ac6632f4283997e49 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Michael Schroeder <mls@suse.de>
|
|
||||||
Date: Mon, 1 Jul 2019 14:52:24 +0200
|
|
||||||
Subject: [PATCH] Always do nevr check for src rpms, even if there are provides
|
|
||||||
|
|
||||||
Newer rpm versions add a "rpmlib(DynamicBuildRequires)" provides
|
|
||||||
to source rpms in some cases. Sigh.
|
|
||||||
---
|
|
||||||
src/pool.c | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/pool.c b/src/pool.c
|
|
||||||
index a5544531..5651f85a 100644
|
|
||||||
--- a/src/pool.c
|
|
||||||
+++ b/src/pool.c
|
|
||||||
@@ -1355,9 +1355,9 @@ pool_addrelproviders(Pool *pool, Id d)
|
|
||||||
continue;
|
|
||||||
}
|
|
||||||
}
|
|
||||||
- if (!s->provides)
|
|
||||||
+ if (!s->provides || s->arch == ARCH_SRC || s->arch == ARCH_NOSRC)
|
|
||||||
{
|
|
||||||
- /* no provides - check nevr */
|
|
||||||
+ /* no provides or src rpm - check nevr */
|
|
||||||
if (pool_match_nevr_rel(pool, s, MAKERELDEP(d)))
|
|
||||||
queue_push(&plist, p);
|
|
||||||
continue;
|
|
||||||
--
|
|
||||||
2.22.0
|
|
||||||
|
|
10
libsolv.spec
10
libsolv.spec
@ -20,17 +20,14 @@
|
|||||||
%bcond_without zstd
|
%bcond_without zstd
|
||||||
|
|
||||||
Name: lib%{libname}
|
Name: lib%{libname}
|
||||||
Version: 0.7.5
|
Version: 0.7.6
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Package dependency solver
|
Summary: Package dependency solver
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: https://github.com/openSUSE/libsolv
|
URL: https://github.com/openSUSE/libsolv
|
||||||
Source: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
Source: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
# https://github.com/openSUSE/libsolv/commit/69439fe4eea683200aa6449ac6632f4283997e49
|
|
||||||
Patch0001: 0001-Always-do-nevr-check-for-src-rpms-even-if-there-are-.patch
|
|
||||||
|
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
BuildRequires: ninja-build
|
BuildRequires: ninja-build
|
||||||
@ -279,6 +276,9 @@ Python 3 version.
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Aug 30 09:08:03 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.6-1
|
||||||
|
- Update to 0.7.6
|
||||||
|
|
||||||
* Sun Aug 18 2019 Miro Hrončok <mhroncok@redhat.com> - 0.7.5-4
|
* Sun Aug 18 2019 Miro Hrončok <mhroncok@redhat.com> - 0.7.5-4
|
||||||
- Rebuilt for Python 3.8
|
- Rebuilt for Python 3.8
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (libsolv-0.7.5.tar.gz) = 41564a9ebde1156a74ea963b08ea032c91bb4b717d27292ef6d0c64c7d9f67daa50472b8e4a395277de966c3eb60ee32b5b23305c359a7f25920f8bfa0958506
|
SHA512 (libsolv-0.7.6.tar.gz) = f275545cab73fa7fcf3a4547a0a0ebd21184efccfee176e9f311023d0bf4f979efc1d2882bf6b328fd42493ca724dd8d2ff2d5fb10d1f648723910a50019eadd
|
||||||
|
Loading…
Reference in New Issue
Block a user