Update to 0.7.0
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
parent
0a5679dd34
commit
a51205b291
1
.gitignore
vendored
1
.gitignore
vendored
@ -42,3 +42,4 @@
|
|||||||
/libsolv-0.6.33.tar.gz
|
/libsolv-0.6.33.tar.gz
|
||||||
/libsolv-0.6.34.tar.gz
|
/libsolv-0.6.34.tar.gz
|
||||||
/libsolv-0.6.35.tar.gz
|
/libsolv-0.6.35.tar.gz
|
||||||
|
/libsolv-0.7.0.tar.gz
|
||||||
|
@ -1,61 +0,0 @@
|
|||||||
From 0e29e1188c19609e117478a0df1cb995a2f9e745 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Michael Schroeder <mls@suse.de>
|
|
||||||
Date: Fri, 28 Sep 2018 14:48:14 +0200
|
|
||||||
Subject: [PATCH] Make sure that targeted updates don't do reinstalls
|
|
||||||
|
|
||||||
---
|
|
||||||
src/solver.c | 16 +++++++++++++---
|
|
||||||
1 file changed, 13 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/solver.c b/src/solver.c
|
|
||||||
index 6405f4a..a4e0c4b 100644
|
|
||||||
--- a/src/solver.c
|
|
||||||
+++ b/src/solver.c
|
|
||||||
@@ -2957,7 +2957,9 @@ add_update_target(Solver *solv, Id p, Id how)
|
|
||||||
Pool *pool = solv->pool;
|
|
||||||
Solvable *s = pool->solvables + p;
|
|
||||||
Repo *installed = solv->installed;
|
|
||||||
- Id pi, pip;
|
|
||||||
+ Id pi, pip, identicalp;
|
|
||||||
+ int startcnt, endcnt;
|
|
||||||
+
|
|
||||||
if (!solv->update_targets)
|
|
||||||
{
|
|
||||||
solv->update_targets = solv_calloc(1, sizeof(Queue));
|
|
||||||
@@ -2968,6 +2970,8 @@ add_update_target(Solver *solv, Id p, Id how)
|
|
||||||
queue_push2(solv->update_targets, p, p);
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
+ identicalp = 0;
|
|
||||||
+ startcnt = solv->update_targets->count;
|
|
||||||
FOR_PROVIDES(pi, pip, s->name)
|
|
||||||
{
|
|
||||||
Solvable *si = pool->solvables + pi;
|
|
||||||
@@ -2982,9 +2986,9 @@ add_update_target(Solver *solv, Id p, Id how)
|
|
||||||
if (how & SOLVER_CLEANDEPS)
|
|
||||||
add_cleandeps_updatepkg(solv, pi);
|
|
||||||
queue_push2(solv->update_targets, pi, p);
|
|
||||||
- /* check if it's ok to keep the installed package */
|
|
||||||
+ /* remember an installed package that is identical to p */
|
|
||||||
if (s->evr == si->evr && solvable_identical(s, si))
|
|
||||||
- queue_push2(solv->update_targets, pi, pi);
|
|
||||||
+ identicalp = pi;
|
|
||||||
}
|
|
||||||
if (s->obsoletes)
|
|
||||||
{
|
|
||||||
@@ -3014,6 +3018,12 @@ add_update_target(Solver *solv, Id p, Id how)
|
|
||||||
}
|
|
||||||
}
|
|
||||||
}
|
|
||||||
+ /* also allow upgrading to an identical installed package */
|
|
||||||
+ if (identicalp)
|
|
||||||
+ {
|
|
||||||
+ for (endcnt = solv->update_targets->count; startcnt < endcnt; startcnt += 2)
|
|
||||||
+ queue_push2(solv->update_targets, solv->update_targets->elements[startcnt], identicalp);
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
|
|
||||||
static int
|
|
||||||
--
|
|
||||||
libgit2 0.26.6
|
|
||||||
|
|
82
libsolv.spec
82
libsolv.spec
@ -27,6 +27,7 @@
|
|||||||
%bcond_with arch_repo
|
%bcond_with arch_repo
|
||||||
# For handling deb + rpm at the same time
|
# For handling deb + rpm at the same time
|
||||||
%bcond_with multi_semantics
|
%bcond_with multi_semantics
|
||||||
|
%bcond_with zchunk
|
||||||
%else
|
%else
|
||||||
%bcond_without helix_repo
|
%bcond_without helix_repo
|
||||||
%bcond_without suse_repo
|
%bcond_without suse_repo
|
||||||
@ -34,6 +35,7 @@
|
|||||||
%bcond_without arch_repo
|
%bcond_without arch_repo
|
||||||
# For handling deb + rpm at the same time
|
# For handling deb + rpm at the same time
|
||||||
%bcond_without multi_semantics
|
%bcond_without multi_semantics
|
||||||
|
%bcond_without zchunk
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
#global commitnum 2901
|
#global commitnum 2901
|
||||||
@ -41,8 +43,8 @@
|
|||||||
#global shortcommit %(c=%{commit}; echo ${c:0:7})
|
#global shortcommit %(c=%{commit}; echo ${c:0:7})
|
||||||
|
|
||||||
Name: lib%{libname}
|
Name: lib%{libname}
|
||||||
Version: 0.6.35
|
Version: 0.7.0
|
||||||
Release: 3%{?commit:.git.%{commitnum}.%{?shortcommit}}%{?dist}
|
Release: 1%{?commit:.git.%{commitnum}.%{?shortcommit}}%{?dist}
|
||||||
Summary: Package dependency solver
|
Summary: Package dependency solver
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -52,7 +54,6 @@ Source: %{url}/archive/%{commit}/%{name}-%{shortcommit}.tar.gz
|
|||||||
%else
|
%else
|
||||||
Source: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
Source: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||||
%endif
|
%endif
|
||||||
Patch0: 0001-Make-sure-that-targeted-updates-dont-do-reinstalls.patch
|
|
||||||
|
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
@ -67,6 +68,10 @@ BuildRequires: xz-devel
|
|||||||
BuildRequires: bzip2-devel
|
BuildRequires: bzip2-devel
|
||||||
# -DENABLE_ZSTD_COMPRESSION=ON
|
# -DENABLE_ZSTD_COMPRESSION=ON
|
||||||
BuildRequires: libzstd-devel
|
BuildRequires: libzstd-devel
|
||||||
|
%if %{with zchunk}
|
||||||
|
# -DENABLE_ZCHUNK_COMPRESSION=ON
|
||||||
|
BuildRequires: pkgconfig(zck)
|
||||||
|
%endif
|
||||||
|
|
||||||
%description
|
%description
|
||||||
A free package dependency solver using a satisfiability algorithm. The
|
A free package dependency solver using a satisfiability algorithm. The
|
||||||
@ -89,12 +94,7 @@ Development files for %{name}.
|
|||||||
%package tools
|
%package tools
|
||||||
Summary: Package dependency solver tools
|
Summary: Package dependency solver tools
|
||||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
# repo2solv dependencies. All of those are used in shell-script.
|
# repo2solv dependencies. Used as execl()
|
||||||
Requires: %{_bindir}/gzip
|
|
||||||
Requires: %{_bindir}/bzip2
|
|
||||||
Requires: %{_bindir}/lzma
|
|
||||||
Requires: %{_bindir}/xz
|
|
||||||
Requires: %{_bindir}/cat
|
|
||||||
Requires: %{_bindir}/find
|
Requires: %{_bindir}/find
|
||||||
|
|
||||||
%description tools
|
%description tools
|
||||||
@ -165,41 +165,42 @@ Python 3 version.
|
|||||||
%autosetup -p1 %{?commit:-n %{name}-%{commit}}
|
%autosetup -p1 %{?commit:-n %{name}-%{commit}}
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake . -B"%{_vpath_builddir}" -GNinja \
|
%cmake . -B"%{_vpath_builddir}" -GNinja \
|
||||||
-DFEDORA=1 \
|
-DFEDORA=1 \
|
||||||
-DENABLE_RPMDB=ON \
|
-DENABLE_RPMDB=ON \
|
||||||
-DENABLE_RPMDB_BYRPMHEADER=ON \
|
-DENABLE_RPMDB_BYRPMHEADER=ON \
|
||||||
-DENABLE_RPMDB_LIBRPM=ON \
|
-DENABLE_RPMDB_LIBRPM=ON \
|
||||||
-DENABLE_RPMPKG_LIBRPM=ON \
|
-DENABLE_RPMPKG_LIBRPM=ON \
|
||||||
-DENABLE_RPMMD=ON \
|
-DENABLE_RPMMD=ON \
|
||||||
%{?with_comps:-DENABLE_COMPS=ON} \
|
%{?with_comps:-DENABLE_COMPS=ON} \
|
||||||
%{?with_appdata:-DENABLE_APPDATA=ON} \
|
%{?with_appdata:-DENABLE_APPDATA=ON} \
|
||||||
-DUSE_VENDORDIRS=ON \
|
-DUSE_VENDORDIRS=ON \
|
||||||
-DWITH_LIBXML2=ON \
|
-DWITH_LIBXML2=ON \
|
||||||
-DENABLE_LZMA_COMPRESSION=ON \
|
-DENABLE_LZMA_COMPRESSION=ON \
|
||||||
-DENABLE_BZIP2_COMPRESSION=ON \
|
-DENABLE_BZIP2_COMPRESSION=ON \
|
||||||
-DENABLE_ZSTD_COMPRESSION=ON \
|
-DENABLE_ZSTD_COMPRESSION=ON \
|
||||||
-DENABLE_ZCHUNK_COMPRESSION=OFF \
|
%if %{with zchunk}
|
||||||
%{?with_helix_repo:-DENABLE_HELIXREPO=ON} \
|
-DENABLE_ZCHUNK_COMPRESSION=ON \
|
||||||
%{?with_suse_repo:-DENABLE_SUSEREPO=ON} \
|
-DWITH_SYSTEM_ZCHUNK=ON \
|
||||||
%{?with_debian_repo:-DENABLE_DEBIAN=ON} \
|
%endif
|
||||||
%{?with_arch_repo:-DENABLE_ARCHREPO=ON} \
|
%{?with_helix_repo:-DENABLE_HELIXREPO=ON} \
|
||||||
%{?with_multi_semantics:-DMULTI_SEMANTICS=ON} \
|
%{?with_suse_repo:-DENABLE_SUSEREPO=ON} \
|
||||||
%{?with_complex_deps:-DENABLE_COMPLEX_DEPS=1} \
|
%{?with_debian_repo:-DENABLE_DEBIAN=ON} \
|
||||||
%{?with_perl_bindings:-DENABLE_PERL=ON} \
|
%{?with_arch_repo:-DENABLE_ARCHREPO=ON} \
|
||||||
%{?with_ruby_bindings:-DENABLE_RUBY=ON} \
|
%{?with_multi_semantics:-DMULTI_SEMANTICS=ON} \
|
||||||
|
%{?with_complex_deps:-DENABLE_COMPLEX_DEPS=1} \
|
||||||
|
%{?with_perl_bindings:-DENABLE_PERL=ON} \
|
||||||
|
%{?with_ruby_bindings:-DENABLE_RUBY=ON} \
|
||||||
%if %{with python2_bindings} || %{with python3_bindings}
|
%if %{with python2_bindings} || %{with python3_bindings}
|
||||||
-DENABLE_PYTHON=ON \
|
-DENABLE_PYTHON=ON \
|
||||||
%if %{with python2_bindings}
|
%if %{with python2_bindings}
|
||||||
-DPythonLibs_FIND_VERSION=%{python2_version} \
|
-DPYTHON_EXECUTABLE=%{__python2} \
|
||||||
-DPythonLibs_FIND_VERSION_MAJOR=2 \
|
|
||||||
%if %{with python3_bindings}
|
%if %{with python3_bindings}
|
||||||
-DENABLE_PYTHON3=ON \
|
-DENABLE_PYTHON3=ON \
|
||||||
-DPYTHON3_EXECUTABLE=%{__python3} \
|
-DPYTHON3_EXECUTABLE=%{__python3} \
|
||||||
%endif
|
%endif
|
||||||
%else
|
%else
|
||||||
-DPythonLibs_FIND_VERSION=%{python3_version} \
|
-DPYTHON_EXECUTABLE=%{__python3} \
|
||||||
-DPythonLibs_FIND_VERSION_MAJOR=3 \
|
|
||||||
%endif
|
%endif
|
||||||
%endif
|
%endif
|
||||||
%{nil}
|
%{nil}
|
||||||
@ -295,6 +296,9 @@ Python 3 version.
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Oct 28 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.0-1
|
||||||
|
- Update to 0.7.0
|
||||||
|
|
||||||
* Mon Oct 01 2018 Jaroslav Rohel <jrohel@redhat.org> - 0.6.35-3
|
* Mon Oct 01 2018 Jaroslav Rohel <jrohel@redhat.org> - 0.6.35-3
|
||||||
- Backport patch: Make sure that targeted updates don't do reinstalls
|
- Backport patch: Make sure that targeted updates don't do reinstalls
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (libsolv-0.6.35.tar.gz) = 48f5666618bbb145c648159d0a60bfc9047d58e958c83f805024eecc491572359badaee20317acf3c3d0d0ce8b1497ae251343f9cdaa570e36828856361763f7
|
SHA512 (libsolv-0.7.0.tar.gz) = 0e4047b972519cce14eca3df9c3693789139469a720e252eb1a7702bdb44d0a809177ace970fdbe9d03c812642f663d5aa9defe3c1550979b66f892255a39072
|
||||||
|
Loading…
Reference in New Issue
Block a user