Rebuilt for https://fedoraproject.org/wiki/Changes/Ruby_2.2
This commit is contained in:
parent
ef41a38963
commit
a30f8a0205
20
libsolv-ruby22-rbconfig.patch
Normal file
20
libsolv-ruby22-rbconfig.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
--- a/cmake/modules/FindRuby.cmake
|
||||||
|
+++ b/cmake/modules/FindRuby.cmake
|
||||||
|
@@ -86,7 +86,7 @@
|
||||||
|
OUTPUT_VARIABLE _RUBY_OUTPUT
|
||||||
|
ERROR_QUIET)
|
||||||
|
IF(_RUBY_SUCCESS OR NOT _RUBY_OUTPUT)
|
||||||
|
- EXECUTE_PROCESS(COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "print Config::CONFIG['${RBVAR}']"
|
||||||
|
+ EXECUTE_PROCESS(COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "print RbConfig::CONFIG['${RBVAR}']"
|
||||||
|
RESULT_VARIABLE _RUBY_SUCCESS
|
||||||
|
OUTPUT_VARIABLE _RUBY_OUTPUT
|
||||||
|
ERROR_QUIET)
|
||||||
|
@@ -112,7 +112,7 @@
|
||||||
|
_RUBY_CONFIG_VAR("sitelibdir" RUBY_SITELIB_DIR)
|
||||||
|
|
||||||
|
# vendor_ruby available ?
|
||||||
|
- EXECUTE_PROCESS(COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "print 'true' unless Config::CONFIG['vendorarchdir'].nil?"
|
||||||
|
+ EXECUTE_PROCESS(COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "print 'true' unless RbConfig::CONFIG['vendorarchdir'].nil?"
|
||||||
|
OUTPUT_VARIABLE RUBY_HAS_VENDOR_RUBY ERROR_QUIET)
|
||||||
|
|
||||||
|
IF(RUBY_HAS_VENDOR_RUBY)
|
@ -5,7 +5,7 @@ diff -up libsolv/bindings/ruby/CMakeLists.txt.rubyinclude libsolv/bindings/ruby/
|
|||||||
SET (RUBY_INSTALL_DIR ${RUBY_SITEARCH_DIR})
|
SET (RUBY_INSTALL_DIR ${RUBY_SITEARCH_DIR})
|
||||||
ENDIF (USE_VENDORDIRS AND RUBY_VENDORARCH_DIR)
|
ENDIF (USE_VENDORDIRS AND RUBY_VENDORARCH_DIR)
|
||||||
|
|
||||||
+EXECUTE_PROCESS(COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "print Config::CONFIG['arch']"
|
+EXECUTE_PROCESS(COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "print RbConfig::CONFIG['arch']"
|
||||||
+ OUTPUT_VARIABLE RUBY_ARCH)
|
+ OUTPUT_VARIABLE RUBY_ARCH)
|
||||||
+
|
+
|
||||||
+EXECUTE_PROCESS(COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "print RbConfig::CONFIG['rubyhdrdir']"
|
+EXECUTE_PROCESS(COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "print RbConfig::CONFIG['rubyhdrdir']"
|
||||||
|
@ -6,11 +6,12 @@
|
|||||||
|
|
||||||
Name: libsolv
|
Name: libsolv
|
||||||
Version: 0.6.8
|
Version: 0.6.8
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Url: https://github.com/openSUSE/libsolv
|
Url: https://github.com/openSUSE/libsolv
|
||||||
Source: https://github.com/openSUSE/libsolv/archive/%{version}.tar.gz
|
Source: https://github.com/openSUSE/libsolv/archive/%{version}.tar.gz
|
||||||
Patch0: libsolv-rubyinclude.patch
|
Patch0: libsolv-rubyinclude.patch
|
||||||
|
Patch1: libsolv-ruby22-rbconfig.patch
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Summary: Package dependency solver
|
Summary: Package dependency solver
|
||||||
BuildRequires: cmake libdb-devel expat-devel rpm-devel zlib-devel
|
BuildRequires: cmake libdb-devel expat-devel rpm-devel zlib-devel
|
||||||
@ -80,6 +81,7 @@ Perl bindings for sat solver.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n libsolv-%{version}
|
%setup -q -n libsolv-%{version}
|
||||||
%patch0 -p1 -b .rubyinclude
|
%patch0 -p1 -b .rubyinclude
|
||||||
|
%patch1 -p1 -b .ruby-rbconfig
|
||||||
|
|
||||||
%check
|
%check
|
||||||
make ARGS="-V" test
|
make ARGS="-V" test
|
||||||
@ -150,6 +152,9 @@ rm $RPM_BUILD_ROOT/usr/bin/testsolv
|
|||||||
%{python_sitearch}/*
|
%{python_sitearch}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 19 2015 Vít Ondruch <vondruch@redhat.com> - 0.6.8-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Changes/Ruby_2.2
|
||||||
|
|
||||||
* Fri Jan 16 2015 Richard Hughes <richard@hughsie.com> - 0.6.8-2
|
* Fri Jan 16 2015 Richard Hughes <richard@hughsie.com> - 0.6.8-2
|
||||||
- Update to latest upstream release to fix a crash in PackageKit.
|
- Update to latest upstream release to fix a crash in PackageKit.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user