Rebase to upstream 8cf7650.
Also fix -devel and -tools dependencies. Fix USE_VENDORDIRS for ruby bindings in Fedora.
This commit is contained in:
parent
f4c7379d23
commit
a22d1f674b
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
/libsolv-857fe28.tar.xz
|
||||
/libsolv-80afaf7.tar.xz
|
||||
/libsolv-af1465a2.tar.xz
|
||||
/libsolv-8cf7650.tar.xz
|
||||
|
@ -1,30 +0,0 @@
|
||||
From 6b63ea994945195f02d8a04d2786959ed438f484 Mon Sep 17 00:00:00 2001
|
||||
From: Ales Kozumplik <akozumpl@redhat.com>
|
||||
Date: Thu, 12 Apr 2012 10:29:28 +0200
|
||||
Subject: [PATCH] make repo_add_solv() work without stub repodata.
|
||||
|
||||
---
|
||||
src/repo_solv.c | 7 ++++++-
|
||||
1 files changed, 6 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/src/repo_solv.c b/src/repo_solv.c
|
||||
index 3f391ef..4e632ae 100644
|
||||
--- a/src/repo_solv.c
|
||||
+++ b/src/repo_solv.c
|
||||
@@ -514,7 +514,12 @@ repo_add_solv(Repo *repo, FILE *fp, int flags)
|
||||
extendstart = repo->start;
|
||||
extendend = repo->end;
|
||||
}
|
||||
-
|
||||
+ else if ((flags & REPO_EXTEND_SOLVABLES) != 0)
|
||||
+ {
|
||||
+ parent = repo_add_repodata(repo, flags);
|
||||
+ repodata_extend_block(parent, repo->start, repo->nsolvables);
|
||||
+ }
|
||||
+
|
||||
memset(&data, 0, sizeof(data));
|
||||
data.repo = repo;
|
||||
data.fp = fp;
|
||||
--
|
||||
1.7.7.3
|
||||
|
15
libsolv-ruby-usevendordirs.patch
Normal file
15
libsolv-ruby-usevendordirs.patch
Normal file
@ -0,0 +1,15 @@
|
||||
diff -up libsolv/bindings/ruby/CMakeLists.txt.ruby-usevendordirs libsolv/bindings/ruby/CMakeLists.txt
|
||||
--- libsolv/bindings/ruby/CMakeLists.txt.ruby-usevendordirs 2012-05-18 12:54:34.483906092 +0200
|
||||
+++ libsolv/bindings/ruby/CMakeLists.txt 2012-05-18 12:55:11.108000512 +0200
|
||||
@@ -1,10 +1,6 @@
|
||||
FIND_PACKAGE (Ruby)
|
||||
|
||||
-IF (USE_VENDORDIRS)
|
||||
- SET (RUBY_INSTALL_DIR ${RUBY_VENDORARCH_DIR})
|
||||
-ELSE (USE_VENDORDIRS)
|
||||
- SET (RUBY_INSTALL_DIR ${RUBY_SITEARCH_DIR})
|
||||
-ENDIF (USE_VENDORDIRS)
|
||||
+SET (RUBY_INSTALL_DIR ${RUBY_SITEARCH_DIR})
|
||||
|
||||
EXECUTE_PROCESS(COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "print Config::CONFIG['arch']"
|
||||
OUTPUT_VARIABLE RUBY_ARCH)
|
17
libsolv.spec
17
libsolv.spec
@ -1,4 +1,4 @@
|
||||
%global gitrev af1465a2
|
||||
%global gitrev 8cf7650
|
||||
%{!?ruby_sitearch: %global ruby_sitearch %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"] ')}
|
||||
%filter_provides_in %{perl_vendorarch}/.*\.so$
|
||||
%filter_provides_in %{python_sitearch}/.*\.so$
|
||||
@ -7,7 +7,7 @@
|
||||
|
||||
Name: libsolv
|
||||
Version: 0.0.0
|
||||
Release: 7.git%{gitrev}%{?dist}
|
||||
Release: 9.git%{gitrev}%{?dist}
|
||||
License: BSD
|
||||
Url: https://github.com/openSUSE/libsolv
|
||||
# git clone https://github.com/openSUSE/libsolv.git
|
||||
@ -15,7 +15,7 @@ Url: https://github.com/openSUSE/libsolv
|
||||
Source: libsolv-%{gitrev}.tar.xz
|
||||
Patch0: libsolv-rubyinclude.patch
|
||||
Patch1: libsolv-newruby.patch
|
||||
Patch2: libsolv-repo_add_solv_without_stub.patch
|
||||
Patch2: libsolv-ruby-usevendordirs.patch
|
||||
Group: Development/Libraries
|
||||
Summary: Package dependency solver
|
||||
BuildRequires: cmake libdb-devel expat-devel rpm-devel zlib-devel
|
||||
@ -33,8 +33,8 @@ library is based on two major, but independent, blocks:
|
||||
%package devel
|
||||
Summary: A new approach to package dependency solving
|
||||
Group: Development/Libraries
|
||||
Requires: libsolv-tools%{?_isa} = %version
|
||||
Requires: libsolv%{?_isa} = %version
|
||||
Requires: libsolv-tools%{?_isa} = %{epoch}:%{version}-%{release}
|
||||
Requires: libsolv%{?_isa} = %{epoch}:%{version}-%{release}
|
||||
Requires: rpm-devel%{?_isa}
|
||||
Requires: cmake
|
||||
|
||||
@ -45,6 +45,7 @@ Development files for libsolv,
|
||||
Summary: A new approach to package dependency solving
|
||||
Group: Development/Libraries
|
||||
Requires: gzip bzip2 coreutils
|
||||
Requires: libsolv%{?_isa} = %{epoch}:%{version}-%{release}
|
||||
|
||||
%description tools
|
||||
Package dependency solver tools.
|
||||
@ -84,7 +85,7 @@ Perl bindings for sat solver.
|
||||
%setup -q -n libsolv
|
||||
%patch0 -p1 -b .rubyinclude
|
||||
%patch1 -p1 -b .newruby
|
||||
%patch2 -p1 -b .withoutstub
|
||||
%patch2 -p1 -b .ruby-usevendordirs
|
||||
|
||||
%build
|
||||
%cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
||||
@ -144,6 +145,10 @@ rm $RPM_BUILD_ROOT/usr/bin/testsolv
|
||||
%{python_sitearch}/*
|
||||
|
||||
%changelog
|
||||
* Thu May 17 2012 Aleš Kozumplik <akozumpl@redhat.com> - 0.0.0-9.git8cf7650%{?dist}
|
||||
- Rebase to upstream 8cf7650.
|
||||
- ruby bindings: fix USE_VENDORDIRS for Fedora.
|
||||
|
||||
* Thu Apr 12 2012 Aleš Kozumplik <akozumpl@redhat.com> - 0.0.0-7.gitaf1465a2%{?dist}
|
||||
- Rebase to the upstream.
|
||||
- Make repo_add_solv() work without stub repodata.
|
||||
|
Loading…
Reference in New Issue
Block a user