Update to 0.7.5
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
parent
4a800aab8f
commit
977b5f4c0c
1
.gitignore
vendored
1
.gitignore
vendored
@ -47,3 +47,4 @@
|
|||||||
/libsolv-0.7.2.tar.gz
|
/libsolv-0.7.2.tar.gz
|
||||||
/libsolv-0.7.3.tar.gz
|
/libsolv-0.7.3.tar.gz
|
||||||
/libsolv-0.7.4.tar.gz
|
/libsolv-0.7.4.tar.gz
|
||||||
|
/libsolv-0.7.5.tar.gz
|
||||||
|
@ -1,29 +0,0 @@
|
|||||||
From 6c9ffb5938ed81c35df04f1c7ab4082a65e39173 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
||||||
Date: Tue, 2 Apr 2019 14:22:08 +0200
|
|
||||||
Subject: [PATCH] solver: Free favorq when running solver_solve()
|
|
||||||
|
|
||||||
Otherwise, favorq leaks from previous executions.
|
|
||||||
|
|
||||||
Fixes: https://github.com/openSUSE/libsolv/issues/312
|
|
||||||
Fixes: 2645bc64b322460ac77d0d051de63434d4a90a0a
|
|
||||||
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
||||||
---
|
|
||||||
src/solver.c | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/src/solver.c b/src/solver.c
|
|
||||||
index b335e6af..7957373e 100644
|
|
||||||
--- a/src/solver.c
|
|
||||||
+++ b/src/solver.c
|
|
||||||
@@ -3389,6 +3389,7 @@ solver_solve(Solver *solv, Queue *job)
|
|
||||||
map_zerosize(&solv->cleandepsmap);
|
|
||||||
map_zerosize(&solv->weakrulemap);
|
|
||||||
solv->favormap = solv_free(solv->favormap);
|
|
||||||
+ queuep_free(&solv->favorq);
|
|
||||||
queue_empty(&solv->weakruleq);
|
|
||||||
solv->watches = solv_free(solv->watches);
|
|
||||||
queue_empty(&solv->ruletojob);
|
|
||||||
--
|
|
||||||
2.21.0
|
|
||||||
|
|
@ -1,29 +0,0 @@
|
|||||||
From 78e2076be0969bddf599f805985ae7bd39298c62 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Michael Schroeder <mls@suse.de>
|
|
||||||
Date: Tue, 14 May 2019 11:48:28 +0200
|
|
||||||
Subject: [PATCH] Make peace with swig-4.0.0
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
Patch by Jitka Plesníková, thanks!
|
|
||||||
---
|
|
||||||
bindings/solv.i | 4 +++-
|
|
||||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/bindings/solv.i b/bindings/solv.i
|
|
||||||
index 0289adb5..107192ff 100644
|
|
||||||
--- a/bindings/solv.i
|
|
||||||
+++ b/bindings/solv.i
|
|
||||||
@@ -629,8 +629,10 @@ SWIG_AsValDepId(void *obj, int *val) {
|
|
||||||
%typemap(out) disown_helper {
|
|
||||||
#if defined(SWIGRUBY)
|
|
||||||
SWIG_ConvertPtr(self, &argp1,SWIGTYPE_p_Pool, SWIG_POINTER_DISOWN | 0 );
|
|
||||||
-#elif defined(SWIGPYTHON)
|
|
||||||
+#elif defined(SWIGPYTHON) && SWIG_VERSION < 0x040000
|
|
||||||
SWIG_ConvertPtr(obj0, &argp1,SWIGTYPE_p_Pool, SWIG_POINTER_DISOWN | 0 );
|
|
||||||
+#elif defined(SWIGPYTHON)
|
|
||||||
+ SWIG_ConvertPtr(swig_obj[0], &argp1,SWIGTYPE_p_Pool, SWIG_POINTER_DISOWN | 0 );
|
|
||||||
#elif defined(SWIGPERL)
|
|
||||||
SWIG_ConvertPtr(ST(0), &argp1,SWIGTYPE_p_Pool, SWIG_POINTER_DISOWN | 0 );
|
|
||||||
#elif defined(SWIGTCL)
|
|
14
libsolv.spec
14
libsolv.spec
@ -41,21 +41,14 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: lib%{libname}
|
Name: lib%{libname}
|
||||||
Version: 0.7.4
|
Version: 0.7.5
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Package dependency solver
|
Summary: Package dependency solver
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: https://github.com/openSUSE/libsolv
|
URL: https://github.com/openSUSE/libsolv
|
||||||
Source: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
Source: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
# https://github.com/openSUSE/libsolv/issues/312
|
|
||||||
# https://github.com/openSUSE/libsolv/pull/313
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1695069
|
|
||||||
Patch0001: 0001-solver-Free-favorq-when-running-solver_solve.patch
|
|
||||||
# https://github.com/openSUSE/libsolv/issues/325
|
|
||||||
Patch0002: libsolv-0.7.4-fix-for-swig-4.patch
|
|
||||||
|
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
BuildRequires: ninja-build
|
BuildRequires: ninja-build
|
||||||
@ -304,6 +297,9 @@ Python 3 version.
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jun 12 15:58:49 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.5-1
|
||||||
|
- Update to 0.7.5
|
||||||
|
|
||||||
* Mon Jun 10 22:13:20 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.4-5
|
* Mon Jun 10 22:13:20 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.4-5
|
||||||
- Rebuild for RPM 4.15
|
- Rebuild for RPM 4.15
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (libsolv-0.7.4.tar.gz) = 74507b131bf9341d9ed9ff113cb01ccd2bc0e0315e6f2361fd23939de5ef051ba6e4bf1df494989569881849b7dd8cefbefe09fba5f9774f5435cfa8ab25512d
|
SHA512 (libsolv-0.7.5.tar.gz) = 41564a9ebde1156a74ea963b08ea032c91bb4b717d27292ef6d0c64c7d9f67daa50472b8e4a395277de966c3eb60ee32b5b23305c359a7f25920f8bfa0958506
|
||||||
|
Loading…
Reference in New Issue
Block a user