Update to 0.7.17
Signed-off-by: Igor Raits <ignatenkobrain@fedoraproject.org>
This commit is contained in:
parent
ecfbab2928
commit
5b033775e0
1
.gitignore
vendored
1
.gitignore
vendored
@ -56,3 +56,4 @@
|
||||
/libsolv-0.7.12.tar.gz
|
||||
/libsolv-0.7.14.tar.gz
|
||||
/libsolv-0.7.15.tar.gz
|
||||
/libsolv-0.7.17.tar.gz
|
||||
|
12
libsolv.spec
12
libsolv.spec
@ -21,19 +21,14 @@
|
||||
%define __cmake_switch(b:) %[%{expand:%%{?with_%{-b*}}} ? "ON" : "OFF"]
|
||||
|
||||
Name: lib%{libname}
|
||||
Version: 0.7.15
|
||||
Release: 3%{?dist}
|
||||
Version: 0.7.17
|
||||
Release: 1%{?dist}
|
||||
Summary: Package dependency solver
|
||||
|
||||
License: BSD
|
||||
URL: https://github.com/openSUSE/libsolv
|
||||
Source: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||
|
||||
# Python 3.10 compatibility backport:
|
||||
# https://github.com/openSUSE/libsolv/commit/170f8550
|
||||
# https://github.com/openSUSE/libsolv/commit/e258226c
|
||||
Patch1: python3.10.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: ninja-build
|
||||
@ -254,6 +249,9 @@ export LD_LIBRARY_PATH=%{buildroot}%{_libdir}
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Jan 21 2021 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.7.17-1
|
||||
- Update to 0.7.17
|
||||
|
||||
* Thu Jan 7 2021 Vít Ondruch <vondruch@redhat.com> - 0.7.15-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Changes/Ruby_3.0
|
||||
|
||||
|
@ -1,63 +0,0 @@
|
||||
From 170f8550b89c6c9e61b40e782cd75148825c2e89 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Schroeder <mls@suse.de>
|
||||
Date: Mon, 16 Nov 2020 13:45:13 +0100
|
||||
Subject: [PATCH] Use PyBytes_AsStringAndSize() instead of
|
||||
PyObject_AsReadBuffer() for python3
|
||||
|
||||
PyObject_AsReadBuffer was deprecated since python-3.0 and has
|
||||
now been removed in python-3.10.
|
||||
|
||||
Fixes issue #410
|
||||
---
|
||||
bindings/solv.i | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/bindings/solv.i b/bindings/solv.i
|
||||
index 48d3f1fb..0a8389a2 100644
|
||||
--- a/bindings/solv.i
|
||||
+++ b/bindings/solv.i
|
||||
@@ -44,7 +44,11 @@ typedef struct {
|
||||
#if defined(SWIGPYTHON)
|
||||
const void *pybuf = 0;
|
||||
Py_ssize_t pysize = 0;
|
||||
+#if PY_VERSION_HEX >= 0x03000000
|
||||
+ res = PyBytes_AsStringAndSize($input, &pybuf, &pysize);
|
||||
+#else
|
||||
res = PyObject_AsReadBuffer($input, &pybuf, &pysize);
|
||||
+#endif
|
||||
if (res < 0) {
|
||||
%argument_fail(res, "BinaryBlob", $symname, $argnum);
|
||||
} else {
|
||||
|
||||
From e258226c2430db4f37a34c71e72b2d909fa407fe Mon Sep 17 00:00:00 2001
|
||||
From: Michael Schroeder <mls@suse.de>
|
||||
Date: Mon, 16 Nov 2020 15:11:14 +0100
|
||||
Subject: [PATCH] Properly escape preprocessor directives
|
||||
|
||||
Otherwise swig will process them instead of the compiler
|
||||
|
||||
Should have been in commit 170f8550b89c6c9e61b40e782cd75148825c2e89
|
||||
---
|
||||
bindings/solv.i | 8 ++++----
|
||||
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/bindings/solv.i b/bindings/solv.i
|
||||
index 0a8389a2..1882b135 100644
|
||||
--- a/bindings/solv.i
|
||||
+++ b/bindings/solv.i
|
||||
@@ -44,11 +44,11 @@ typedef struct {
|
||||
#if defined(SWIGPYTHON)
|
||||
const void *pybuf = 0;
|
||||
Py_ssize_t pysize = 0;
|
||||
-#if PY_VERSION_HEX >= 0x03000000
|
||||
- res = PyBytes_AsStringAndSize($input, &pybuf, &pysize);
|
||||
-#else
|
||||
+%#if PY_VERSION_HEX >= 0x03000000
|
||||
+ res = PyBytes_AsStringAndSize($input, (char **)&pybuf, &pysize);
|
||||
+%#else
|
||||
res = PyObject_AsReadBuffer($input, &pybuf, &pysize);
|
||||
-#endif
|
||||
+%#endif
|
||||
if (res < 0) {
|
||||
%argument_fail(res, "BinaryBlob", $symname, $argnum);
|
||||
} else {
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libsolv-0.7.15.tar.gz) = 34c8d6ad6b978d857b1f7825ad79f18bbcca9f00cde26c9ce9a0384bb1c0ad0b29f5c996de52cc18725943cb1f95a115103053a01d6a61f64e28f183562000e7
|
||||
SHA512 (libsolv-0.7.17.tar.gz) = 82c8d4ab02f9aabeb620a70c1cae427c1e74ad2ee8c79d5b08840478f63dee74439dc903fd63ab63fe9ab7763024a3ce52498f1b9ab6d76c1ad47423e9f6386b
|
||||
|
Loading…
Reference in New Issue
Block a user