Backport patch for fixing yumobs
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
parent
ba9ff5fd0f
commit
4426b6752a
26
0001-yumobs-remove-bogus-queue_empty-call.patch
Normal file
26
0001-yumobs-remove-bogus-queue_empty-call.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
From fe64933a5c9125401f0ae3e928c406d19075c202 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Michael Schroeder <mls@suse.de>
|
||||||
|
Date: Fri, 21 Jul 2017 13:38:15 +0200
|
||||||
|
Subject: [PATCH] yumobs: remove bogus queue_empty() call
|
||||||
|
|
||||||
|
The queue_empty made the code only create yumobs rules for one
|
||||||
|
dependency. It's surprising that nobody ran into this bug until now.
|
||||||
|
---
|
||||||
|
src/rules.c | 1 -
|
||||||
|
1 file changed, 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/rules.c b/src/rules.c
|
||||||
|
index 26b93ea..6c28cdd 100644
|
||||||
|
--- a/src/rules.c
|
||||||
|
+++ b/src/rules.c
|
||||||
|
@@ -3720,7 +3720,6 @@ solver_addyumobsrules(Solver *solv)
|
||||||
|
#if 0
|
||||||
|
printf("checking yumobs for %s\n", pool_solvable2str(pool, s));
|
||||||
|
#endif
|
||||||
|
- queue_empty(&qo);
|
||||||
|
for (opp = solv->obsoletes_data + solv->obsoletes[p - installed->start]; (op = *opp++) != 0;)
|
||||||
|
{
|
||||||
|
Solvable *os = pool->solvables + op;
|
||||||
|
--
|
||||||
|
2.13.2
|
||||||
|
|
17
libsolv.spec
17
libsolv.spec
@ -39,13 +39,17 @@
|
|||||||
|
|
||||||
Name: lib%{libname}
|
Name: lib%{libname}
|
||||||
Version: 0.6.28
|
Version: 0.6.28
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Package dependency solver
|
Summary: Package dependency solver
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: https://github.com/openSUSE/libsolv
|
URL: https://github.com/openSUSE/libsolv
|
||||||
Source: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
Source: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
|
# https://github.com/openSUSE/libsolv/commit/fe64933a5c9125401f0ae3e928c406d19075c202
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1470922
|
||||||
|
Patch0001: 0001-yumobs-remove-bogus-queue_empty-call.patch
|
||||||
|
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
BuildRequires: pkgconfig(rpm)
|
BuildRequires: pkgconfig(rpm)
|
||||||
@ -287,16 +291,19 @@ popd
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Sat Jul 01 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.6.28-1
|
* Fri Jul 21 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.28-2
|
||||||
|
- Backport patch for fixing yumobs
|
||||||
|
|
||||||
|
* Sat Jul 01 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.28-1
|
||||||
- Update to 0.6.28
|
- Update to 0.6.28
|
||||||
|
|
||||||
* Mon May 29 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.6.27-2
|
* Mon May 29 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.27-2
|
||||||
- Backport few fixes for bindings
|
- Backport few fixes for bindings
|
||||||
|
|
||||||
* Thu May 04 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.6.27-1
|
* Thu May 04 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.27-1
|
||||||
- Update to 0.6.27
|
- Update to 0.6.27
|
||||||
|
|
||||||
* Mon Mar 27 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.6.26-5.git.20.668e249
|
* Mon Mar 27 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.26-5.git.20.668e249
|
||||||
- Update to latest snapshot
|
- Update to latest snapshot
|
||||||
|
|
||||||
* Sat Mar 18 2017 Neal Gompa <ngompa13@gmail.com> - 0.6.26-4.git.19.2262346
|
* Sat Mar 18 2017 Neal Gompa <ngompa13@gmail.com> - 0.6.26-4.git.19.2262346
|
||||||
|
Loading…
Reference in New Issue
Block a user