Set x86_64 arch as exchangeable to x86_64_v2
This commit is contained in:
parent
b38493eda4
commit
3ffd606a04
42
0001-Set-x86_64-arch-as-exchangeable-to-x86_64_v2.patch
Normal file
42
0001-Set-x86_64-arch-as-exchangeable-to-x86_64_v2.patch
Normal file
@ -0,0 +1,42 @@
|
||||
From d63dfdba8f97ea42e1e3661de6bbaf273ccb790a Mon Sep 17 00:00:00 2001
|
||||
From: eabdullin <ed.abdullin.1@gmail.com>
|
||||
Date: Wed, 10 Jul 2024 15:36:47 +0300
|
||||
Subject: [PATCH] Set x86_64 arch as exchangeable to x86_64_v2
|
||||
|
||||
---
|
||||
src/poolarch.c | 9 +++++----
|
||||
1 file changed, 5 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/poolarch.c b/src/poolarch.c
|
||||
index bc4582f..3b5a893 100644
|
||||
--- a/src/poolarch.c
|
||||
+++ b/src/poolarch.c
|
||||
@@ -24,13 +24,13 @@ static const char *archpolicies[] = {
|
||||
#if defined(FEDORA) || defined(MAGEIA)
|
||||
"x86_64_v4", "x86_64_v4:x86_64_v3:x86_64_v2:x86_64:athlon:i686:i586:i486:i386",
|
||||
"x86_64_v3", "x86_64_v3:x86_64_v2:x86_64:athlon:i686:i586:i486:i386",
|
||||
- "x86_64_v2", "x86_64_v2:x86_64:athlon:i686:i586:i486:i386",
|
||||
- "x86_64", "x86_64:athlon:i686:i586:i486:i386",
|
||||
+ "x86_64_v2", "x86_64_v2=x86_64:athlon:i686:i586:i486:i386",
|
||||
+ "x86_64", "x86_64=x86_64_v2:athlon:i686:i586:i486:i386",
|
||||
#else
|
||||
"x86_64_v4", "x86_64_v4:x86_64_v3:x86_64_v2:x86_64:i686:i586:i486:i386",
|
||||
"x86_64_v3", "x86_64_v3:x86_64_v2:x86_64:i686:i586:i486:i386",
|
||||
- "x86_64_v2", "x86_64_v2:x86_64:i686:i586:i486:i386",
|
||||
- "x86_64", "x86_64:i686:i586:i486:i386",
|
||||
+ "x86_64_v2", "x86_64_v2=x86_64:i686:i586:i486:i386",
|
||||
+ "x86_64", "x86_64=x86_64_v2:i686:i586:i486:i386",
|
||||
#endif
|
||||
"i686", "i686:i586:i486:i386",
|
||||
"i586", "i586:i486:i386",
|
||||
@@ -70,6 +70,7 @@ static const char *archpolicies[] = {
|
||||
0
|
||||
};
|
||||
|
||||
+
|
||||
void
|
||||
pool_setarch(Pool *pool, const char *arch)
|
||||
{
|
||||
--
|
||||
2.39.3 (Apple Git-146)
|
||||
|
75
libsolv.spec
75
libsolv.spec
@ -27,7 +27,7 @@
|
||||
|
||||
Name: lib%{libname}
|
||||
Version: 0.7.29
|
||||
Release: %autorelease
|
||||
Release: 7%{?dist}.alma.1
|
||||
Summary: Package dependency solver
|
||||
|
||||
License: BSD-3-Clause
|
||||
@ -36,6 +36,9 @@ Source: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||
# Downstream-only, RHEL-41048
|
||||
Patch0: 0001-Add-support-for-computing-hashes-using-OpenSSL.patch
|
||||
|
||||
# AlmaLinux patches
|
||||
Patch1000: 0001-Set-x86_64-arch-as-exchangeable-to-x86_64_v2.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: ninja-build
|
||||
@ -274,4 +277,72 @@ export LD_LIBRARY_PATH=%{buildroot}%{_libdir}
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
||||
* Fri Sep 06 2024 Eduard Abdullin <eabdullin@almalinux.org> - 0.7.29-7.alma.1
|
||||
- Set x86_64 arch as exchangeable to x86_64_v2
|
||||
|
||||
* Thu Aug 08 2024 Troy Dawson <tdawson@redhat.com> - 0.7.29-7
|
||||
- Bump release for Aug 2024 perl mass rebuild
|
||||
|
||||
* Tue Jul 09 2024 Petr Písař <ppisar@redhat.com> - 0.7.29-6
|
||||
- Use digest functions from OpenSSL
|
||||
|
||||
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 0.7.29-5
|
||||
- Bump release for June 2024 mass rebuild
|
||||
|
||||
* Fri May 31 2024 Petr Písař <ppisar@redhat.com> - 0.7.29-4
|
||||
- Stricten dependencies between libsolv subpackages (RHEL-38831)
|
||||
|
||||
* Fri May 31 2024 Petr Písař <ppisar@redhat.com> - 0.7.29-2
|
||||
- Configure gating
|
||||
|
||||
* Thu May 30 2024 Petr Písař <ppisar@redhat.com> - 0.7.29-1
|
||||
- Update to 0.7.29 (RHEL-32212)
|
||||
|
||||
* Fri Feb 09 2024 Jan Kolarik <jkolarik@redhat.com> - 0.7.28-1
|
||||
- Update to 0.7.28
|
||||
|
||||
* Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.27-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Sun Jan 21 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.27-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Wed Jan 03 2024 Vít Ondruch <vondruch@redhat.com> - 0.7.27-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Changes/Ruby_3.3
|
||||
|
||||
* Tue Dec 05 2023 Jan Kolarik <jkolarik@redhat.com> - 0.7.27-1
|
||||
- Update to 0.7.27
|
||||
|
||||
* Tue Oct 03 2023 Jan Kolarik <jkolarik@redhat.com> - 0.7.25-1
|
||||
- Update to 0.7.25
|
||||
|
||||
* Mon Aug 28 2023 Yaakov Selkowitz <yselkowi@redhat.com> - 0.7.24-9
|
||||
- Disable zchunk in RHEL builds
|
||||
|
||||
* Fri Jul 21 2023 Neal Gompa <ngompa@fedoraproject.org> - 0.7.24-8
|
||||
- Backport fix to lower memory usage of updateinfo processing
|
||||
(rhbz#2214520)
|
||||
|
||||
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.24-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Tue Jul 11 2023 Jitka Plesnikova <jplesnik@redhat.com> - 0.7.24-6
|
||||
- Perl 5.38 rebuild
|
||||
|
||||
* Thu Jun 15 2023 Python Maint <python-maint@redhat.com> - 0.7.24-5
|
||||
- Rebuilt for Python 3.12
|
||||
|
||||
* Wed May 17 2023 Jan Kolarik <jkolarik@redhat.com> - 0.7.24-4
|
||||
- Rebuild for rpm-4.18.90-4
|
||||
|
||||
* Tue May 16 2023 Jan Kolarik <jkolarik@redhat.com> - 0.7.24-3
|
||||
- Rebuild for rpm-4.18.90
|
||||
|
||||
* Mon May 15 2023 Igor Raits <igor.raits@gmail.com> - 0.7.24-2
|
||||
- Upload sources
|
||||
|
||||
* Mon May 15 2023 Igor Raits <igor.raits@gmail.com> - 0.7.24-1
|
||||
- Update to 0.7.24
|
||||
|
||||
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.22-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
Loading…
Reference in New Issue
Block a user