Rebase to 6c9d3eb.
This commit is contained in:
parent
739fa315eb
commit
3dde16b1a0
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@
|
|||||||
/libsolv-d39a42b.tar.xz
|
/libsolv-d39a42b.tar.xz
|
||||||
/libsolv-1617994.tar.xz
|
/libsolv-1617994.tar.xz
|
||||||
/libsolv-1617994.tar.xz
|
/libsolv-1617994.tar.xz
|
||||||
|
/libsolv-6c9d3eb.tar.xz
|
||||||
|
@ -1,29 +0,0 @@
|
|||||||
From 021e309f4f32642b8f53e3c8a162c4af150e269e Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ales Kozumplik <ales@redhat.com>
|
|
||||||
Date: Tue, 10 Jul 2012 14:07:02 +0200
|
|
||||||
Subject: [PATCH] preliminary fix for JOB resons in
|
|
||||||
solver_describe_decision().
|
|
||||||
|
|
||||||
This makes the function return SOLVER_REASON_RESOLVE_JOB for some unit
|
|
||||||
rules too. Discussion is ongoing with the libsolv upstream whether this is
|
|
||||||
a good solution.
|
|
||||||
---
|
|
||||||
src/solver.c | 2 ++
|
|
||||||
1 file changed, 2 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/src/solver.c b/src/solver.c
|
|
||||||
index 68ff49f..16a0ff8 100644
|
|
||||||
--- a/src/solver.c
|
|
||||||
+++ b/src/solver.c
|
|
||||||
@@ -3437,6 +3437,8 @@ solver_describe_decision(Solver *solv, Id p, Id *infop)
|
|
||||||
{
|
|
||||||
if (infop)
|
|
||||||
*infop = why;
|
|
||||||
+ if (why >= solv->jobrules && why < solv->jobrules_end)
|
|
||||||
+ return SOLVER_REASON_RESOLVE_JOB;
|
|
||||||
return SOLVER_REASON_UNIT_RULE;
|
|
||||||
}
|
|
||||||
why = -why;
|
|
||||||
--
|
|
||||||
1.7.10.2
|
|
||||||
|
|
@ -1,44 +0,0 @@
|
|||||||
From 307a43cf501f6b0b9fcb258a6753afcaf05e59c7 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ales Kozumplik <ales@redhat.com>
|
|
||||||
Date: Mon, 23 Jul 2012 10:44:24 +0200
|
|
||||||
Subject: [PATCH] solv.i: new perl includes <stdbool.h> and the custom
|
|
||||||
typedefs cause gcc errors.
|
|
||||||
|
|
||||||
Use <stdbool.h> as the default instead.
|
|
||||||
---
|
|
||||||
bindings/solv.i | 5 +----
|
|
||||||
1 file changed, 1 insertion(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/bindings/solv.i b/bindings/solv.i
|
|
||||||
index a5b9552..618401c 100644
|
|
||||||
--- a/bindings/solv.i
|
|
||||||
+++ b/bindings/solv.i
|
|
||||||
@@ -331,6 +331,7 @@ typedef VALUE AppObjectPtr;
|
|
||||||
%include "typemaps.i"
|
|
||||||
|
|
||||||
%{
|
|
||||||
+#include <stdbool.h>
|
|
||||||
#include <stdio.h>
|
|
||||||
#include <sys/stat.h>
|
|
||||||
#include <sys/types.h>
|
|
||||||
@@ -378,9 +379,6 @@ typedef VALUE AppObjectPtr;
|
|
||||||
#define RARRAY_LEN(ary) (RARRAY(ary)->len)
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-#define true 1
|
|
||||||
-#define false 1
|
|
||||||
-
|
|
||||||
#define SOLVER_SOLUTION_ERASE -100
|
|
||||||
#define SOLVER_SOLUTION_REPLACE -101
|
|
||||||
#define SOLVER_SOLUTION_REPLACE_DOWNGRADE -102
|
|
||||||
@@ -388,7 +386,6 @@ typedef VALUE AppObjectPtr;
|
|
||||||
#define SOLVER_SOLUTION_REPLACE_VENDORCHANGE -104
|
|
||||||
|
|
||||||
typedef struct chksum Chksum;
|
|
||||||
-typedef int bool;
|
|
||||||
typedef void *AppObjectPtr;
|
|
||||||
|
|
||||||
typedef struct {
|
|
||||||
--
|
|
||||||
1.7.10.2
|
|
||||||
|
|
13
libsolv.spec
13
libsolv.spec
@ -1,4 +1,4 @@
|
|||||||
%global gitrev 1617994
|
%global gitrev 6c9d3eb
|
||||||
%{!?ruby_vendorarch: %global ruby_vendorarch %(ruby -rrbconfig -e 'puts Config::CONFIG["vendorarchdir"] ')}
|
%{!?ruby_vendorarch: %global ruby_vendorarch %(ruby -rrbconfig -e 'puts Config::CONFIG["vendorarchdir"] ')}
|
||||||
%filter_provides_in %{perl_vendorarch}/.*\.so$
|
%filter_provides_in %{perl_vendorarch}/.*\.so$
|
||||||
%filter_provides_in %{python_sitearch}/.*\.so$
|
%filter_provides_in %{python_sitearch}/.*\.so$
|
||||||
@ -7,15 +7,13 @@
|
|||||||
|
|
||||||
Name: libsolv
|
Name: libsolv
|
||||||
Version: 0.0.0
|
Version: 0.0.0
|
||||||
Release: 16.git%{gitrev}%{?dist}
|
Release: 17.git%{gitrev}%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Url: https://github.com/openSUSE/libsolv
|
Url: https://github.com/openSUSE/libsolv
|
||||||
# git clone https://github.com/openSUSE/libsolv.git
|
# git clone https://github.com/openSUSE/libsolv.git
|
||||||
# git archive %{gitrev} --prefix=libsolv/ | xz > libsolv-%{gitrev}.tar.xz
|
# git archive %{gitrev} --prefix=libsolv/ | xz > libsolv-%{gitrev}.tar.xz
|
||||||
Source: libsolv-%{gitrev}.tar.xz
|
Source: libsolv-%{gitrev}.tar.xz
|
||||||
Patch0: libsolv-rubyinclude.patch
|
Patch0: libsolv-rubyinclude.patch
|
||||||
Patch1: libsolv-job-reasons.patch
|
|
||||||
Patch2: libsolv-solvi-stdbool.patch
|
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Summary: Package dependency solver
|
Summary: Package dependency solver
|
||||||
BuildRequires: cmake libdb-devel expat-devel rpm-devel zlib-devel
|
BuildRequires: cmake libdb-devel expat-devel rpm-devel zlib-devel
|
||||||
@ -84,8 +82,6 @@ Perl bindings for sat solver.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n libsolv
|
%setup -q -n libsolv
|
||||||
%patch0 -p1 -b .rubyinclude
|
%patch0 -p1 -b .rubyinclude
|
||||||
%patch1 -p1 -b .jobreasons
|
|
||||||
%patch2 -p1 -b .solvistdbool
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
%cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
||||||
@ -145,6 +141,11 @@ rm $RPM_BUILD_ROOT/usr/bin/testsolv
|
|||||||
%{python_sitearch}/*
|
%{python_sitearch}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Aug 23 2012 Aleš Kozumplík <akozumpl@redhat.com> - 0.0.0-17.git6c9d3eb
|
||||||
|
- Rebase to upstream 6c9d3eb.
|
||||||
|
- Drop the solv.i stdbool.h fix integrated upstream.
|
||||||
|
- Dropped the job reasons fix.
|
||||||
|
|
||||||
* Mon Jul 23 2012 Aleš Kozumplík <akozumpl@redhat.com> - 0.0.0-16.git1617994
|
* Mon Jul 23 2012 Aleš Kozumplík <akozumpl@redhat.com> - 0.0.0-16.git1617994
|
||||||
- Fix build problems with Perl bindings.
|
- Fix build problems with Perl bindings.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user