import UBI libsolv-0.7.24-2.el9
This commit is contained in:
parent
44fb312c8c
commit
2bfa0bfde7
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/libsolv-0.7.22.tar.gz
|
||||
SOURCES/libsolv-0.7.24.tar.gz
|
||||
|
@ -1 +1 @@
|
||||
d58e6030f2ee6ffaf34642e1da841708ab21eefc SOURCES/libsolv-0.7.22.tar.gz
|
||||
d5bcae967154dd1e904fd90cc17f5dce3da646f8 SOURCES/libsolv-0.7.24.tar.gz
|
||||
|
@ -1,22 +1,20 @@
|
||||
From 11eab76046e2df31248d358ab85bdbcf366d2c78 Mon Sep 17 00:00:00 2001
|
||||
From: Nicola Sella <nsella@redhat.com>
|
||||
Date: Wed, 11 Nov 2020 14:52:14 +0100
|
||||
Subject: [PATCH 1/1] Add support for computing hashes using OpenSSL
|
||||
From 49859c1ad32487de6adb65eedf4b81f021e1b0e8 Mon Sep 17 00:00:00 2001
|
||||
From: Jaroslav Rohel <jrohel@redhat.com>
|
||||
Date: Fri, 25 Oct 2019 14:33:22 +0200
|
||||
Subject: [PATCH] Add support for computing hashes using OpenSSL
|
||||
|
||||
It adds WITH_OPENSSL build option.
|
||||
If it is ON, OpenSSL will be used instead of internal implementation
|
||||
of computing hashes (MD5, SHA1, SHA224, SHA256, SHA384, SHA512).
|
||||
|
||||
Rebase of https://github.com/openSUSE/libsolv/commit/9839a88e4fda23b46015170b201c98da7bcdd55e
|
||||
---
|
||||
CMakeLists.txt | 13 +++++++++++--
|
||||
src/CMakeLists.txt | 16 +++++++++++-----
|
||||
src/CMakeLists.txt | 13 ++++++++++---
|
||||
src/chksum.c | 32 ++++++++++++++++++++++++++++++++
|
||||
tools/CMakeLists.txt | 2 +-
|
||||
4 files changed, 55 insertions(+), 8 deletions(-)
|
||||
4 files changed, 54 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 3541f496..e73dc552 100644
|
||||
index f899c49..23615bd 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -40,6 +40,7 @@ OPTION (ENABLE_ZCHUNK_COMPRESSION "Build with zchunk compression support?" OFF)
|
||||
@ -61,22 +59,23 @@ index 3541f496..e73dc552 100644
|
||||
SET (SYSTEM_LIBRARIES ${RPMDB_LIBRARY} ${SYSTEM_LIBRARIES})
|
||||
ENDIF (ENABLE_RPMDB)
|
||||
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
|
||||
index bbf30bac..ece870ee 100644
|
||||
index ca04b39..a0ce267 100644
|
||||
--- a/src/CMakeLists.txt
|
||||
+++ b/src/CMakeLists.txt
|
||||
@@ -18,9 +18,8 @@ SET (libsolv_SRCS
|
||||
@@ -18,9 +18,9 @@ SET (libsolv_SRCS
|
||||
solver.c solverdebug.c repo_solv.c repo_write.c evr.c pool.c
|
||||
queue.c repo.c repodata.c repopage.c util.c policy.c solvable.c
|
||||
transaction.c order.c rules.c problems.c linkedpkg.c cplxdeps.c
|
||||
- chksum.c md5.c sha1.c sha2.c solvversion.c selection.c
|
||||
- fileprovides.c diskusage.c suse.c solver_util.c cleandeps.c
|
||||
- userinstalled.c filelistfilter.c)
|
||||
- userinstalled.c filelistfilter.c decision.c)
|
||||
+ chksum.c solvversion.c selection.c fileprovides.c diskusage.c
|
||||
+ suse.c solver_util.c cleandeps.c userinstalled.c filelistfilter.c)
|
||||
+ suse.c solver_util.c cleandeps.c userinstalled.c
|
||||
+ filelistfilter.c decision.c)
|
||||
|
||||
SET (libsolv_HEADERS
|
||||
bitmap.h evr.h hash.h policy.h poolarch.h poolvendor.h pool.h
|
||||
@@ -43,14 +42,21 @@ IF (WIN32)
|
||||
@@ -43,14 +43,21 @@ IF (WIN32)
|
||||
LIST (APPEND libsolv_SRCS ${WIN32_COMPAT_SOURCES})
|
||||
ENDIF (WIN32)
|
||||
|
||||
@ -89,19 +88,17 @@ index bbf30bac..ece870ee 100644
|
||||
ENDIF (HAVE_LINKER_VERSION_SCRIPT)
|
||||
|
||||
IF (DISABLE_SHARED)
|
||||
- ADD_LIBRARY (libsolv STATIC ${libsolv_SRCS})
|
||||
+ ADD_LIBRARY (libsolv STATIC ${libsolv_SRCS})
|
||||
ADD_LIBRARY (libsolv STATIC ${libsolv_SRCS})
|
||||
ELSE (DISABLE_SHARED)
|
||||
- ADD_LIBRARY (libsolv SHARED ${libsolv_SRCS})
|
||||
+ ADD_LIBRARY (libsolv SHARED ${libsolv_SRCS})
|
||||
+ IF (WITH_OPENSSL)
|
||||
+ TARGET_LINK_LIBRARIES (libsolv ${OPENSSL_CRYPTO_LIBRARY})
|
||||
+ ENDIF (WITH_OPENSSL)
|
||||
ADD_LIBRARY (libsolv SHARED ${libsolv_SRCS})
|
||||
+ IF (WITH_OPENSSL)
|
||||
+ TARGET_LINK_LIBRARIES (libsolv ${OPENSSL_CRYPTO_LIBRARY})
|
||||
+ ENDIF (WITH_OPENSSL)
|
||||
ENDIF (DISABLE_SHARED)
|
||||
|
||||
IF (WIN32)
|
||||
diff --git a/src/chksum.c b/src/chksum.c
|
||||
index 1f8ab471..9189b744 100644
|
||||
index 1f8ab47..9189b74 100644
|
||||
--- a/src/chksum.c
|
||||
+++ b/src/chksum.c
|
||||
@@ -15,10 +15,42 @@
|
||||
@ -148,7 +145,7 @@ index 1f8ab471..9189b744 100644
|
||||
#include "strfncs.h"
|
||||
#endif
|
||||
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
|
||||
index f19030eb..d477e195 100644
|
||||
index f19030e..d477e19 100644
|
||||
--- a/tools/CMakeLists.txt
|
||||
+++ b/tools/CMakeLists.txt
|
||||
@@ -116,7 +116,7 @@ SET(tools_list ${tools_list} repo2solv)
|
||||
@ -160,6 +157,6 @@ index f19030eb..d477e195 100644
|
||||
|
||||
ADD_EXECUTABLE (mergesolv mergesolv.c )
|
||||
TARGET_LINK_LIBRARIES (mergesolv toolstuff libsolvext libsolv ${SYSTEM_LIBRARIES})
|
||||
--
|
||||
2.26.2
|
||||
--
|
||||
libgit2 1.3.2
|
||||
|
||||
|
@ -0,0 +1,60 @@
|
||||
From 9a3f2a2e161c7bcd2da94f6878b2b1470afc09b2 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Schroeder <mls@suse.de>
|
||||
Date: Tue, 18 Apr 2023 11:57:50 +0200
|
||||
Subject: [PATCH] Treat condition both as positive and negative literal in
|
||||
pool_add_pos_literals_complex_dep
|
||||
|
||||
That's because (A IF B ELSE C) gets rewritten to (A OR ~B) AND (C OR B) and
|
||||
(A UNLESS B ELSE C) gets rewritten to (A AND ~B) OR (C AND B). In both
|
||||
cases we have A, B, ~B, C.
|
||||
|
||||
This resolves issue #527
|
||||
---
|
||||
src/cplxdeps.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/cplxdeps.c b/src/cplxdeps.c
|
||||
index 6c40752e..26e754d9 100644
|
||||
--- a/src/cplxdeps.c
|
||||
+++ b/src/cplxdeps.c
|
||||
@@ -405,6 +405,7 @@ pool_add_pos_literals_complex_dep(Pool *pool, Id dep, Queue *q, Map *m, int neg)
|
||||
Reldep *rd2 = GETRELDEP(pool, rd->evr);
|
||||
if (rd2->flags == REL_ELSE)
|
||||
{
|
||||
+ pool_add_pos_literals_complex_dep(pool, rd2->name, q, m, !neg);
|
||||
pool_add_pos_literals_complex_dep(pool, rd2->evr, q, m, !neg);
|
||||
dep = rd2->name;
|
||||
}
|
||||
--
|
||||
2.40.1
|
||||
|
||||
|
||||
From 2c55198fb476e616ac29a45befe2746be09b7547 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Schroeder <mls@suse.de>
|
||||
Date: Tue, 18 Apr 2023 12:36:40 +0200
|
||||
Subject: [PATCH] Add testcase for last commit
|
||||
|
||||
---
|
||||
test/testcases/cplxdeps/ifelse_rec.t | 10 ++++++++++
|
||||
1 file changed, 10 insertions(+)
|
||||
create mode 100644 test/testcases/cplxdeps/ifelse_rec.t
|
||||
|
||||
diff --git a/test/testcases/cplxdeps/ifelse_rec.t b/test/testcases/cplxdeps/ifelse_rec.t
|
||||
new file mode 100644
|
||||
index 00000000..ea467027
|
||||
--- /dev/null
|
||||
+++ b/test/testcases/cplxdeps/ifelse_rec.t
|
||||
@@ -0,0 +1,10 @@
|
||||
+repo appstream 0 testtags <inline>
|
||||
+#>=Pkg: xorg-x11-server-Xorg 1.20.11 18.el9 noarch
|
||||
+#>=Req: missing-req
|
||||
+#>=Pkg: pass 1.7.4 6.el9 noarch
|
||||
+#>=Rec: xclip <IF> (xorg-x11-server-Xorg <ELSE> wl-clipboard)
|
||||
+repo @System 0 empty
|
||||
+system unset * @System
|
||||
+job install pkg pass-1.7.4-6.el9.noarch@appstream
|
||||
+result transaction,problems <inline>
|
||||
+#>install pass-1.7.4-6.el9.noarch@appstream
|
||||
--
|
||||
2.40.1
|
||||
|
125
SOURCES/0006-Allow_break_arch_lock_step_on_erase.patch
Normal file
125
SOURCES/0006-Allow_break_arch_lock_step_on_erase.patch
Normal file
@ -0,0 +1,125 @@
|
||||
From ab2ca3eb281c7be17ac23d28c3a57f357555ea04 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Schroeder <mls@suse.de>
|
||||
Date: Wed, 19 Apr 2023 13:09:10 +0200
|
||||
Subject: [PATCH] Allow to break arch lock-step on erase operations
|
||||
|
||||
We allow it if SOLVER_SETARCH is (auto-)set in the erase job.
|
||||
---
|
||||
src/rules.c | 26 ++++++++++++++++++++++++++
|
||||
1 file changed, 26 insertions(+)
|
||||
|
||||
diff --git a/src/rules.c b/src/rules.c
|
||||
index 008d5940..6dee4c64 100644
|
||||
--- a/src/rules.c
|
||||
+++ b/src/rules.c
|
||||
@@ -1672,6 +1672,16 @@ solver_addinfarchrules(Solver *solv, Map *addedmap)
|
||||
if (first)
|
||||
continue; /* not the first in the group */
|
||||
|
||||
+ if (!bestscore && allowedarchs.count > 1 && pool->implicitobsoleteusescolors)
|
||||
+ {
|
||||
+ for (j = 0; j < allowedarchs.count; j++)
|
||||
+ {
|
||||
+ a = pool_arch2score(pool, allowedarchs.elements[j]);
|
||||
+ if (a && a != 1 && (!bestscore || a < bestscore))
|
||||
+ bestscore = a;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
if (!bestscore)
|
||||
continue; /* did not find a score for this group */
|
||||
|
||||
@@ -2578,6 +2588,20 @@ jobtodisablelist(Solver *solv, Id how, Id what, Queue *q)
|
||||
case SOLVER_ERASE:
|
||||
if (!installed)
|
||||
break;
|
||||
+ set = how & SOLVER_SETMASK;
|
||||
+ if (!(set & (SOLVER_NOAUTOSET | SOLVER_SETARCH)) && pool->implicitobsoleteusescolors && solv->infarchrules != solv->infarchrules_end)
|
||||
+ {
|
||||
+ if (select == SOLVER_SOLVABLE)
|
||||
+ set |= SOLVER_SETARCH;
|
||||
+ else if ((select == SOLVER_SOLVABLE_NAME || select == SOLVER_SOLVABLE_PROVIDES) && ISRELDEP(what))
|
||||
+ {
|
||||
+ Reldep *rd = GETRELDEP(pool, what);
|
||||
+ if (rd->flags <= 7 && ISRELDEP(rd->name))
|
||||
+ rd = GETRELDEP(pool, rd->name);
|
||||
+ if (rd->flags == REL_ARCH)
|
||||
+ set |= SOLVER_SETARCH;
|
||||
+ }
|
||||
+ }
|
||||
if (select == SOLVER_SOLVABLE_ALL || (select == SOLVER_SOLVABLE_REPO && what == installed->repoid))
|
||||
{
|
||||
FOR_REPO_SOLVABLES(installed, p, s)
|
||||
@@ -2587,6 +2611,8 @@ jobtodisablelist(Solver *solv, Id how, Id what, Queue *q)
|
||||
if (pool->solvables[p].repo == installed)
|
||||
{
|
||||
queue_push2(q, DISABLE_UPDATE, p);
|
||||
+ if ((set & SOLVER_SETARCH) != 0 && pool->implicitobsoleteusescolors && solv->infarchrules != solv->infarchrules_end)
|
||||
+ queue_push2(q, DISABLE_INFARCH, pool->solvables[p].name); /* allow to break the lock-step */
|
||||
#ifdef ENABLE_LINKED_PKGS
|
||||
if (solv->instbuddy && solv->instbuddy[p - installed->start] > 1)
|
||||
queue_push2(q, DISABLE_UPDATE, solv->instbuddy[p - installed->start]);
|
||||
--
|
||||
2.40.1
|
||||
|
||||
|
||||
From 847f3f1b21f8c396c831564f849981a450c67dbf Mon Sep 17 00:00:00 2001
|
||||
From: Michael Schroeder <mls@suse.de>
|
||||
Date: Fri, 21 Apr 2023 16:15:10 +0200
|
||||
Subject: [PATCH] Only disable infarch rules on erase if the package was in
|
||||
lock-step
|
||||
|
||||
Fiexes issue #528
|
||||
---
|
||||
src/rules.c | 28 +++++++++++++++++++++++++++-
|
||||
1 file changed, 27 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/rules.c b/src/rules.c
|
||||
index 6dee4c64..54fefcb8 100644
|
||||
--- a/src/rules.c
|
||||
+++ b/src/rules.c
|
||||
@@ -2367,6 +2367,31 @@ reenablerepopriorule(Solver *solv, Id name)
|
||||
#define DISABLE_BLACK 4
|
||||
#define DISABLE_REPOPRIO 5
|
||||
|
||||
+/* check if installed package p is in lock-step with another installed package */
|
||||
+static int
|
||||
+installed_is_in_lockstep(Solver *solv, Id p)
|
||||
+{
|
||||
+ Pool *pool = solv->pool;
|
||||
+ Repo *installed = solv->installed;
|
||||
+ int rid;
|
||||
+ Id pp, l;
|
||||
+ Rule *r;
|
||||
+
|
||||
+ if (!installed)
|
||||
+ return 0;
|
||||
+ for (rid = solv->infarchrules, r = solv->rules + rid; rid < solv->infarchrules_end; rid++, r++)
|
||||
+ {
|
||||
+ if (r->p >= 0)
|
||||
+ continue;
|
||||
+ if (pool->solvables[-r->p].repo != installed)
|
||||
+ continue;
|
||||
+ FOR_RULELITERALS(l, pp, r)
|
||||
+ if (l == p)
|
||||
+ return 1;
|
||||
+ }
|
||||
+ return 0;
|
||||
+}
|
||||
+
|
||||
static void
|
||||
jobtodisablelist(Solver *solv, Id how, Id what, Queue *q)
|
||||
{
|
||||
@@ -2612,7 +2637,8 @@ jobtodisablelist(Solver *solv, Id how, Id what, Queue *q)
|
||||
{
|
||||
queue_push2(q, DISABLE_UPDATE, p);
|
||||
if ((set & SOLVER_SETARCH) != 0 && pool->implicitobsoleteusescolors && solv->infarchrules != solv->infarchrules_end)
|
||||
- queue_push2(q, DISABLE_INFARCH, pool->solvables[p].name); /* allow to break the lock-step */
|
||||
+ if (installed_is_in_lockstep(solv, p))
|
||||
+ queue_push2(q, DISABLE_INFARCH, pool->solvables[p].name); /* allow to break the lock-step */
|
||||
#ifdef ENABLE_LINKED_PKGS
|
||||
if (solv->instbuddy && solv->instbuddy[p - installed->start] > 1)
|
||||
queue_push2(q, DISABLE_UPDATE, solv->instbuddy[p - installed->start]);
|
||||
--
|
||||
2.40.1
|
||||
|
@ -22,8 +22,8 @@
|
||||
%define __cmake_switch(b:) %[%{expand:%%{?with_%{-b*}}} ? "ON" : "OFF"]
|
||||
|
||||
Name: lib%{libname}
|
||||
Version: 0.7.22
|
||||
Release: 4%{?dist}
|
||||
Version: 0.7.24
|
||||
Release: 2%{?dist}
|
||||
Summary: Package dependency solver
|
||||
|
||||
License: BSD
|
||||
@ -34,6 +34,8 @@ Patch1: 0001-Add-support-for-computing-hashes-using-OpenSSL.patch
|
||||
Patch2: 0002-Revert-Improve-choice-rule-generation.patch
|
||||
Patch3: 0003-Revert-Add-complex_deps-requirement-to-choice1b-test.patch
|
||||
Patch4: 0004-Revert-Add-more-choicerules-tests.patch
|
||||
Patch5: 0005-Treat-condition-both-as-positive-and-negative-litera.patch
|
||||
Patch6: 0006-Allow_break_arch_lock_step_on_erase.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gcc-c++
|
||||
@ -260,6 +262,14 @@ export LD_LIBRARY_PATH=%{buildroot}%{_libdir}
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jun 21 2023 Jaroslav Rohel <jrohel@redhat.com> - 0.7.24-2
|
||||
- Backport Allow to break arch lock-step on erase operations (RhBug:2172288,2172292)
|
||||
|
||||
* Tue May 16 2023 Jaroslav Rohel <jrohel@redhat.com> - 0.7.24-1
|
||||
- Update to 0.7.24
|
||||
- Backport Treat condition both as positive and negative literal in pool_add_pos_literals_complex_dep
|
||||
(RhBug:2185061,2190136)
|
||||
|
||||
* Thu Dec 15 2022 Nicola Sella <nsella@redhat.com> - 0.7.22-4
|
||||
- Delete patch "Move OpenSSL functions" to fix ABI change
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user