Update to 0.7.20
Resolves: rhbz#2006672
This commit is contained in:
parent
6d2ff015c5
commit
134bbd0f87
1
.gitignore
vendored
1
.gitignore
vendored
@ -58,3 +58,4 @@
|
||||
/libsolv-0.7.15.tar.gz
|
||||
/libsolv-0.7.17.tar.gz
|
||||
/libsolv-0.7.19.tar.gz
|
||||
/libsolv-0.7.20.tar.gz
|
||||
|
@ -1,30 +0,0 @@
|
||||
From 8615575144e6fd3d708a30983ed2415db479ef4c Mon Sep 17 00:00:00 2001
|
||||
From: Jaroslav Rohel <jrohel@redhat.com>
|
||||
Date: Thu, 8 Apr 2021 12:17:09 +0200
|
||||
Subject: [PATCH] Fix: Memory leaks in SWIG generated code (for Python)
|
||||
|
||||
There were memory leaks in the `Chksum_from_bin`, `Chksum_add`,
|
||||
`SolvFp_write` functions wrapper for Python.
|
||||
|
||||
The problem was in "freearg" typemap argument defined in "solv.i".
|
||||
Therefore, the typemap was not applied.
|
||||
---
|
||||
bindings/solv.i | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/bindings/solv.i b/bindings/solv.i
|
||||
index 1882b13..3bbeca0 100644
|
||||
--- a/bindings/solv.i
|
||||
+++ b/bindings/solv.i
|
||||
@@ -63,7 +63,7 @@ typedef struct {
|
||||
$2 = size;
|
||||
}
|
||||
|
||||
-%typemap(freearg,noblock=1,match="in") (const unsigned char *str, int len) {
|
||||
+%typemap(freearg,noblock=1,match="in") (const unsigned char *str, size_t len) {
|
||||
if (alloc$argnum == SWIG_NEWOBJ) %delete_array(buf$argnum);
|
||||
}
|
||||
|
||||
--
|
||||
libgit2 1.0.1
|
||||
|
15
libsolv.spec
15
libsolv.spec
@ -22,16 +22,15 @@
|
||||
%define __cmake_switch(b:) %[%{expand:%%{?with_%{-b*}}} ? "ON" : "OFF"]
|
||||
|
||||
Name: lib%{libname}
|
||||
Version: 0.7.19
|
||||
Release: 3%{?dist}
|
||||
Version: 0.7.20
|
||||
Release: 1%{?dist}
|
||||
Summary: Package dependency solver
|
||||
|
||||
License: BSD
|
||||
URL: https://github.com/openSUSE/libsolv
|
||||
Source: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||
Patch1: 0001-Fix-Memory-leaks-in-SWIG-generated-code-for-Python.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1993126
|
||||
Patch2: 0002-Add-support-for-computing-hashes-using-OpenSSL.patch
|
||||
Patch1: 0001-Add-support-for-computing-hashes-using-OpenSSL.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gcc-c++
|
||||
@ -258,6 +257,14 @@ export LD_LIBRARY_PATH=%{buildroot}%{_libdir}
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Oct 25 2021 Pavla Kratochvilova <pkratoch@redhat.com> - 0.7.20-1
|
||||
- Update to 0.7.20
|
||||
- new SOLVER_EXCLUDEFROMWEAK job to ignore pkgs for weak dependencies
|
||||
- support for environments in comps parser
|
||||
- fix misparsing of '&' in attributes with libxml2
|
||||
- choice rules: treat orphaned packages as newest
|
||||
- fix compatibility with Python 3.10
|
||||
|
||||
* Thu Aug 12 2021 Pavla Kratochvilova <pkratoch@redhat.com> - 0.7.19-3
|
||||
- Use OpenSSL for computing hashes (RhBug:1993126)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libsolv-0.7.19.tar.gz) = dfcebea314d549a15bf5af19db775ff1b1850bfc6fb147b68fe094e43bf1541fcfe22d2f6c6607a6393e01905a086cea606d0b25da2e3ce376d100c4ef4fee00
|
||||
SHA512 (libsolv-0.7.20.tar.gz) = be810a78543509c60fe9be9310cc84b6c75e671b77929a1f914f51d4b3b2364e68398794d4648da46691cde7e5aab3cf57d18969c31f1003692080dc1982e955
|
||||
|
Loading…
Reference in New Issue
Block a user